<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />


<title>What is a project roadmap: Overview and how-to (with template) - LogRocket Blog</title>
<meta name="description" content="In this post, I will explain what a project roadmap is and how we can improve our monitoring process with templates and examples." />
<link rel="canonical" href="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="What is a project roadmap: Overview and how-to (with template) - LogRocket Blog" />
<meta property="og:description" content="In this post, I will explain what a project roadmap is and how we can improve our monitoring process with templates and examples." />
<meta property="og:url" content="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2022-12-16T14:00:21+00:00" />
<meta property="article:modified_time" content="2022-12-14T14:48:40+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="487" />
<meta property="og:image:type" content="image/png" />
<meta name="author" content="Zeynep Cansu Yildirim" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Zeynep Cansu Yildirim" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="10 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/","url":"https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/","name":"What is a project roadmap: Overview and how-to (with template) - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/#primaryimage"},"image":{"@id":"https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/#primaryimage"},"thumbnailUrl":"https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png","datePublished":"2022-12-16T14:00:21+00:00","dateModified":"2022-12-14T14:48:40+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/f327497ee822aa7db06322e8c15f179d"},"description":"In this post, I will explain what a project roadmap is and how we can improve our monitoring process with templates and examples.","breadcrumb":{"@id":"https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/#primaryimage","url":"https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png","contentUrl":"https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png","width":730,"height":487,"caption":"What Is A Project Roadmap Overview How-To With Template"},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://blog.logrocket.com/"},{"@type":"ListItem","position":2,"name":"What is a project roadmap: Overview and how-to (with template)"}]},{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://blog.logrocket.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/f327497ee822aa7db06322e8c15f179d","name":"Zeynep Cansu Yildirim","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blog.logrocket.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/fe1a55c148700361478fa4914ca5ccb3?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/fe1a55c148700361478fa4914ca5ccb3?s=96&d=mm&r=g","caption":"Zeynep Cansu Yildirim"},"description":"I am an experienced PM of 5+ years with 9+ years of analyst and leadership experience in software companies, currently working as a PM in an e-commerce company. I am an Electric and Electronic Engineer with a Masters in Engineering Management. In my social life, I like skiing, kitesurfing, boxing, and am a professional horse rider in show jumping competitions.","sameAs":["https://www.linkedin.com/in/zeynepcansuyildirim/"],"url":"https://blog.logrocket.com/author/zeynepcansuyildirim/"}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; What is a project roadmap: Overview and how-to (with template) Comments Feed" href="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=6.1.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-audio{margin:0 0 1em}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.wp-block-embed{margin:0 0 1em}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-image{margin:0 0 1em}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-search__button{border:1px solid #ccc;padding:.375em .625em}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table{margin:"0 0 1em 0"}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video{margin:0 0 1em}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.17' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://blog.logrocket.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/6.0.0-beta2/css/all.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=11.7-a.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.7-a.3' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/148298" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-CzU' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<script src="//geoip-js.com/js/apis/geoip2/v2.1/geoip2.js" type="text/javascript"></script>
<script src="https://storage.googleapis.com/lr-marketing-js/lr-web-analytics/script/4.js"></script>
<script>
    function geoipCountry() {
      return new Promise((resolve, reject) => {
        window.geoip2.country(resolve, reject);
      });
    }
</script>
<script>
  // Setup as much as we can early on, before we enter the async portion
  window.lr_analytics.init({
    analyticsProxy: {
        enabled: true,
      },
      segment: {
        enabled: true,
        writeKey: 'hn3yvJCms37nkkjrwDQ08PuKJKydGtAZ',
        load: true,
      },
      redditPixel: {
        enabled: true,
        accountId: 't2_3xdvtyx2',
      },
      vwo: {
        enabled: true,
        accountId: 338524
      },
      utmMediumHash: {
        enabled: true,
      }
  });

  // Async portion of the script
  // There is no guarantee on when this function will finish executing.
  // Once we hit the first `await` execution will be suspended
  (async function () {
    let geoipResponse;
    try {
      geoipResponse = await geoipCountry();
    } catch (err) {
      // Geoip potentially got blocked.
      // TODO: add this to the analytics proxy
      console.error('geoip blocked');
    }

    window.lr_analytics.init({
      sixSense: {
        enabled: () => {
          if (!geoipResponse) {
            return false;
          }
          if (geoipResponse.country.iso_code === 'US') {
            return true;
          } else if (geoipResponse.continent.code === 'NA' || geoipResponse.continent.code === 'EU') {
            return false;
          } else {
            return true;
          }
        },
        apiKey: 'd5fbd2e5f08cba3d3d417f7a67cd8d1f',
        companyDetails: {
          enabled: () => geoipResponse.country.iso_code === 'US',
          apiKey: 'a2d1a28025c555de9af13fd94f96f9044dbb8331',
          callback: async (sixSenseResponse) => {
            // send to segment
            window.lr_analytics.sixSenseCallbacks.sendSegmentEvents(sixSenseResponse);
            
            // try to personalize the page
            const data = JSON.parse(sixSenseResponse);

            if (data?.company?.domain && !window.location.href.includes('product-management')) {
              try {
                // Get the custom demo and image links
                const custom = await window.lr_analytics.fetchOutreachAccountCustomFields({
                  domain: data.company.domain,
                  fields: [17, 18]
                });

                window.lr_analytics.personalizePage({
                  items: [
                    {
                      selector: "#blog-personalized-demo-link",
                      source: custom['custom17'],
                      attribute: 'href'
                    },
                    {
                      selector: "#blog-personalized-demo-thumbnail",
                      source: custom['custom18'],
                      attribute: 'src'
                    },
                    {
                      selector: "#personalized-company-account-name",
                      source: data.company.name,
                      attribute: 'innerHTML'
                    }
                  ]
                });

                window.analytics.track('Personalization-deployed-blog', {
                  Domain: data.company.domain,
                });
              } catch (err) {
                window.analytics.track('personalization-failed');
                throw err;
              }
            }
          }
        },
      },
    });

    analytics.page();
  })()

</script>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://a39e555ed62c408792586c55bbb2ce3b@e.logrocket.com/9').install()
    </script> <style>img#wpstats{display:none}</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=467c4e7327" /><style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-148298 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="nav-left">

 <a class="blog-logo" href='https://logrocket.com' rel='home'><img src='https://blog.logrocket.com/wp-content/uploads/2022/09/logrocket-logo-frontend-analytics.png' alt='LogRocket Blog'></a>
<div class="col-lg-4 col-md-4 mr-auto col-xs-12 text-right searcharea">
</div>

<div class="navarea">
<nav class="navbar navbar-toggleable-sm">
<button class="navbar-toggler navbar-toggler-right" type="button" data-toggle="collapse" data-target="#bs4navbar" aria-controls="bs4navbar" aria-expanded="false" aria-label="Toggle navigation">
<span class="navbar-toggler-icon"></span>
</button>
<div id="bs4navbar" class="collapse navbar-collapse"><ul id="menu-primary" class="navbar-nav col-md-12 justify-content-center"><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6 nav-item dropdown"><a href="#" class="nav-link dropdown-toggle">Blog</a>
<div class="dropdown-menu">
<a href="/" class="dropdown-item">Dev</a><a href="https://blog.logrocket.com/product-management" class="dropdown-item">Product Management</a></div>
<li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">Podcast</a><li id="menu-item-72923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72923 nav-item"><a href="https://blog.logrocket.com/tech-meetups/" class="nav-link">Meetups</a></ul></div> </nav>
</div>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Start monitoring for free</a></li>
</ul></div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container container-first-lr">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=What%20is%20a%20project%20roadmap:%20Overview%20and%20how-to%20(with%20template)&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png&amp;description=What%20is%20a%20project%20roadmap:%20Overview%20and%20how-to%20(with%20template)">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template%2F&amp;title=What%20is%20a%20project%20roadmap:%20Overview%20and%20how-to%20(with%20template)">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-148298 post type-post status-publish format-standard has-post-thumbnail hentry category-product-management tag-product-management" id="post-148298">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/zeynepcansuyildirim/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/12/zeynepcansuyildirim-150x150.jpeg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/12/zeynepcansuyildirim-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/12/zeynepcansuyildirim-150x150.jpeg?crop=1' class='avatar avatar-72 photo' height='72' width='72'  /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/zeynepcansuyildirim/">
Zeynep Cansu Yildirim <span class="btn follow">Follow</span></a>
<span class="author-description d-block">I am an experienced PM of 5+ years with 9+ years of analyst and leadership experience in software companies, currently working as a PM in an e-commerce company. I am an Electric and Electronic Engineer with a Masters in Engineering Management. In my social life, I like skiing, kitesurfing, boxing, and am a professional horse rider in show jumping competitions.</span>
</div>
</div>
<h1 class="posttitle">What is a project roadmap: Overview and how-to (with template)</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
December 16, 2022 </time></span>
<span class="dot"></span>
<span class="readingtime">6 min read</span>
<span class="wordcount">1950</span>
</p>
</div>
<img width="730" height="487" src="https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="What Is A Project Roadmap Overview How-To With Template" decoding="async" data-attachment-id="148411" data-permalink="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/attachment/what-is-a-project-roadmap-overview-how-to-template-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="What is a project roadmap overview how to template" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template-300x200.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template-300x200.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/12/what-is-a-project-roadmap-overview-how-to-template.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> <article class="article-post">
<p>As a product manager, I know that we call everything a “product.” My product has this many users, my product is in the first line in this market, etc. I sometimes see my cat as a well-published product with iterative improvements. 😊</p>
<p>There is a misunderstanding, though — not everything we are working on is a product. According to the company&#8217;s structure, we build projects for serving a specific customer need. As a summary, we can say that a project has a goal to achieve with a series of tasks and a certain timeline.</p>
<p>In this post, I will explain what a project roadmap is and how we can improve our monitoring process with templates and examples.</p>
<hr />
<h2>Table of contents</h2>
<ul>
<li><a href="#what-project-roadmap">What is a project roadmap?</a></li>
<li><a href="#when-need-project-roadmap">When do you need a project roadmap?</a></li>
<li><a href="#what-benefits-using-project-roadmap">What are the benefits of using a project roadmap?</a>
<ul style="margin-bottom: 0px; padding-bottom: 0px;">
<li><a href="#easy-monitor">Easy to monitor</a></li>
<li><a href="#fast-communication">Fast communication</a></li>
<li><a href="#ready-present">Ready to present</a></li>
<li><a href="#hard-miss-important-points">It’s hard to miss the important points</a></li>
<li><a href="#helps-prioritize-tasks">Helps prioritize tasks</a></li>
<li><a href="#visualizes-task-statuses">Visualizes task statuses</a></li>
</ul>
</li>
<li><a href="#how-create-project-roadmap">How can you create a project roadmap?</a>
<ul style="margin-bottom: 0px; padding-bottom: 0px;">
<li><a href="#mandatory-fields">Mandatory fields</a></li>
<li><a href="#nice-have-fields">Nice to have fields</a></li>
</ul>
</li>
<li><a href="#project-roadmap-vs-project-plan-vs-project-charter">Project roadmap vs. project plan vs. project charter</a>
<ul style="margin-bottom: 0px; padding-bottom: 0px;">
<li><a href="#project-plan">Project plan</a></li>
<li><a href="#project-charter">Project charter</a></li>
</ul>
</li>
<li><a href="#project-roadmap-template-download">Project roadmap template for download</a></li>
</ul>
<hr />
<h2 id="what-project-roadmap">What is a project roadmap?</h2>
<p>A project roadmap is a simple table that monitors all departments&#8217; tasks and their statuses. It shows a timeline for each task, subtask, and feature.</p>
<p>Every role in the company can access this documentation and understand the project status at a high level. A project roadmap has a similar goal as a product roadmap: it is used for visualizing. The main difference is that we are adding project tasks into project roadmaps, not product goals.</p>
<p>Project roadmaps should be clear and informative with shorter descriptions. Stakeholders should be able to see the overall picture without scrolling or shifting needs. That’s why we never exceed one line rule in roadmaps. Try to avoid long explanations and unnecessary fields.</p>
<h2 id="when-need-project-roadmap">When do you need a project roadmap?</h2>
<p>We can decide if and when we need a project roadmap if we have more than one initiative. Let’s ask a series of questions to make sure we understand our needs.</p>
<p>Firstly, do we need to monitor every step of the project? Because the motivation of a project roadmap is to be a visual follow-up requirement for tasks.</p>
<p>Second, we need to evaluate size, risk, and complexity. Do we have more than one department included and do they indirectly give us the required project timeline?</p>
<p>An additional motivation of the project roadmap can be monitoring for phasing. Some projects require different timeline requirements and this document makes our monitoring easy.</p>
<h2 id="what-benefits-using-project-roadmap">What are the benefits of using a project roadmap?</h2>
<p>Project roadmaps have a lot of benefits to offer, let’s go over them in depth below.</p>
<h3 id="easy-monitor">Easy to monitor</h3>
<p>There is no easier way to monitor the project with many teams than by using a project roadmap. <a href="https://blog.logrocket.com/product-management/what-stakeholder-management-tools-techniques/">Every stakeholder adds their tasks</a> into the roadmap and updates its status. You will have update meetings for each project and you can use these documents for alignment. You can go through the tasks for each domain/team and discuss further steps.</p>
<h3 id="fast-communication">Fast communication</h3>
<p>You can see the person responsible for your task/question and discuss it with them.</p>
<h3 id="ready-present">Ready to present</h3>
<p>You don’t need to create meeting documents for updates. You can add every detail into this document with new sheets: meeting notes, timeline, project chart, project plan, decisions, agenda, and more.</p>
<h3 id="hard-miss-important-points">It’s hard to miss the important points</h3>
<p>You can see tasks with statuses and timeline. It’s easy to see the overall picture and discuss each required task according to their priority.</p>
<h3 id="helps-prioritize-tasks">Helps prioritize tasks</h3>
<p>With size and impact columns, <a href="https://blog.logrocket.com/product-management/what-prioritization-matrix-definition-examples-template/">you will be able to prioritize the tasks</a> and add possible delivery dates.</p>
<h3 id="visualizes-task-statuses">Visualizes tasks statuses</h3>
<p>You don’t have to check too much documentation or the Jira board to know how many open tasks remain for the project or what’s not started, in progress, done, etc. With a basic filter, you can visualize task status percentages for upper management meetings.</p>
<h2 id="how-create-project-roadmap">How can you create a project roadmap?</h2>
<p>There is a long field list we can add for follow-up to the project details. As the list gets longer, the document will become harder to understand.</p>
<p>To be able to create a clean and readable document, you can use the mandatory fields and select “if” requirements from the “nice to have” categories below.</p>
<h3 id="mandatory-fields">Mandatory fields</h3>
<p>The first aspect to a project roadmap are the mandatory fields. The most common ones are:</p>
<h4 id="domain">Domain</h4>
<p>If you are managing the project with more than one department, you should have a field for differentiating task ownership easily. We can use team or department names in this field.</p>
<h4 id="tasks">Tasks</h4>
<p>This field should include enough information for the job you will provide. You need to be specific and keep the field as short as possible. You can name the field things like to-dos, features, or processes.</p>
<h4 id="estimated-delivery">Estimated delivery date</h4>
<p>Delivery dates should not be vague, but we should be careful about giving a certain or exact date. This field is important to create deployment plans and alignment with other teams. For blocker tasks, we should always provide date information as soon as possible.</p>
<h4 id="product-owner-manager">Product owner/manager</h4>
<p>There may be more than one name here. If the task requires a different follow-up, you can add the responsible person here.</p>
<h4 id="impact">Impact</h4>
<p>This field indicates the task’s priority and business value. You can differentiate the importance of the task according to its impact. Each company should create their own impact analysis matrix to be able to enter a realistic impact.</p>
<p>If you don’t have an impact matrix, you should create one before starting a project roadmap. Most teams use XS, S, M, L, and XL terminology. For those who don&#8217;t have one, you can use the below legend. I also added it as a table inside the example template:</p>
<p id="gdcalert1"><img data-attachment-id="148348" data-permalink="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/attachment/impact-table/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table.png" data-orig-size="730,116" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Impact table" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table-300x48.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table.png" decoding="async" class="aligncenter size-full wp-image-148348 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table.png" alt="Impact Table" width="730" height="116" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table-300x48.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="148348" data-permalink="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/attachment/impact-table/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table.png" data-orig-size="730,116" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Impact table" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table-300x48.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table.png" decoding="async" loading="lazy" class="aligncenter size-full wp-image-148348" src="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table.png" alt="Impact Table" width="730" height="116" srcset="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/12/impact-table-300x48.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<h4 id="size-risk">Size/risk</h4>
<p>We use this field in combination with the impact column while prioritizing tasks. High impact, small size mostly wins.</p>
<p>This field indicates the tech legend of a task. We can select size/risk according to resource requirement, execution risk, planning requirement, complexity, effects of more than one departments, change in management requirements, data migration needs, etc.</p>
<p>To be able to have the same structure, you can also use XS, S, M, L, XL terminology in this field:</p>
<p id="gdcalert2"><img data-attachment-id="148350" data-permalink="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/attachment/size-table-xl-sizing/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing.png" data-orig-size="730,161" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Size table xl sizing" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing-300x66.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing.png" decoding="async" class="aligncenter size-full wp-image-148350 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing.png" alt="Size Table With XL Sizing" width="730" height="161" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing-300x66.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="148350" data-permalink="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/attachment/size-table-xl-sizing/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing.png" data-orig-size="730,161" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Size table xl sizing" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing-300x66.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing.png" decoding="async" loading="lazy" class="aligncenter size-full wp-image-148350" src="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing.png" alt="Size Table With XL Sizing" width="730" height="161" srcset="https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/12/size-table-xl-sizing-300x66.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<h4 id="status">Status</h4>
<p>This field makes our roadmap easily readable to be able to differentiate on-going tasks. We prefer to use color codes for each status and I think this helps us to differentiate tasks more easily.</p>
<p>You can use idea, new, not started, in progress, canceled, or done statuses. A summary visual for impact ,size, and status will look like this:</p>
<p id="gdcalert3"><img data-attachment-id="148352" data-permalink="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/attachment/impact-status/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status.png" data-orig-size="616,226" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Impact status" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status-300x110.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status.png" decoding="async" class="aligncenter size-full wp-image-148352 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status.png" alt="Impact Status" width="616" height="226" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status.png 616w, https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status-300x110.png 300w" data-lazy-sizes="(max-width: 616px) 100vw, 616px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="148352" data-permalink="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/attachment/impact-status/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status.png" data-orig-size="616,226" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Impact status" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status-300x110.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status.png" decoding="async" loading="lazy" class="aligncenter size-full wp-image-148352" src="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status.png" alt="Impact Status" width="616" height="226" srcset="https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status.png 616w, https://blog.logrocket.com/wp-content/uploads/2022/12/impact-status-300x110.png 300w" sizes="(max-width: 616px) 100vw, 616px"  /></noscript></p>
<h3 id="nice-have-fields">Nice to have fields</h3>
<p>Next, we have fields that aren’t necessary but nice to have.</p>
<h4 id="start-dates">Start date</h4>
<p>We can use this field to understand monthly tasks we are starting and monitor the tasks backtrack. I prefer to keep this field for months. We don’t need to know specific dates, only the month name will be enough.</p>
<h4 id="task-file">Task file</h4>
<p>You can use this field to add the link for any documentation which you think may help for watchers.</p>
<h4 id="description-notes">Description/notes</h4>
<p>Some tasks require more definitions or discussion points for making follow-up easy. If the file link is not used, I recommend you add this field. You can link documents or add more information here.</p>
<h4 id="business-owner">Business owner</h4>
<p>We use this field to easily reach business owners. Your organization can have different roles for analyzing tasks or customer needs. You can add a responsible department or watcher name to ask clarifying questions.</p>
<h4 id="business-delivery-expectation">Business delivery expectation</h4>
<p>This field shows us the delivery time expectation of the customer (or business owner). We use this field to see which feature has a promised delivery date to the user. You can also use it to track alignment for multi-team development.</p>
<p>This document will be open to every role inside the company and you may not want to share the promised date with everyone. Be aware of that before adding the document.</p>
<h4 id="phasing">Phasing</h4>
<p>If the project has more than one expected delivery phase, we can use the phasing field for prioritization.</p>
<h4 id="project">Project</h4>
<p>If the project roadmap includes more than one project inside, you can even add this as a follow-up field.</p>
<h2 id="project-roadmap-vs-project-plan-vs-project-charter">Project roadmap vs. project plan vs. project charter</h2>
<p>These three terms all seem to get confused, so let’s quickly clarify the difference between these documents.</p>
<h3 id="project-plan">Project plan</h3>
<p>A project plan is a formal way to show every step of a project, such as resource management, risk management, go live plan, cost, scope, and more.</p>
<p><a href="https://blog.logrocket.com/product-management/product-manager-vs-project-manager/">Project plans are mostly prepared by a project manager</a>. They include charts, detailed plans, and are created with tools to be able to achieve the timeline. I can say that a project roadmap and plan documents have the same purpose — controlling the execution timeline and visualizing the status.</p>
<p>As I said, a project plan is more formal because it includes costs, planned hours, actual hours, and executes a price at the end of the project. This document is applicable for project-based companies that are providing plans according to budget, salary, cost, materials, schedule.</p>
<p>For product-based Agile companies, this structure can be hard to apply because of its waterfall nature. We use project plans inside our project roadmap as a visual part for deliverable tasks. We create a monthly basis to easily prepare Excel sheets and show finished, in progress, not started, and delayed tasks with colors. We can see the delivery plan and control the execution process without formal calculations.</p>
<p>You can also add a project plan into your roadmap document as an additional sheet to monitor your process from kick-off to closure. I added the below plan sheet inside the example template:</p>
<p id="gdcalert4"><img data-attachment-id="148354" data-permalink="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/attachment/project-plan/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan.png" data-orig-size="730,170" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Project plan" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan-300x70.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan.png" decoding="async" class="aligncenter size-full wp-image-148354 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan.png" alt="Project Plan" width="730" height="170" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan-300x70.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="148354" data-permalink="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/attachment/project-plan/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan.png" data-orig-size="730,170" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Project plan" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan-300x70.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan.png" decoding="async" loading="lazy" class="aligncenter size-full wp-image-148354" src="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan.png" alt="Project Plan" width="730" height="170" srcset="https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/12/project-plan-300x70.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<h3 id="project-charter">Project charter</h3>
<p>A project charter is a description page for explaining your motivation for the project. It is in one-page format and indicates your objectives, risks, advantages, and key stakeholders before starting the project. We always add a charter page into our project roadmaps.</p>
<p>You should know and be able to explain every step of the charter to your team before dividing the problem into tasks. I believe the charter feeds the project roadmap and the project roadmap feeds the project plan. I will share the project charter, the fields it should have, and a detailed example template in my next post.</p>
<h2 id="using-project-roadmaps-plans-charters-together">Using project roadmaps, plans, and charters together</h2>
<p>Contrary to most resources, I like to use these three types of project management documents to monitor my projects. I believe they all feed the project and every team member.</p>
<p>I recommend you start your project with a charter, continue with a well-prepared roadmap, and after you list your tasks, start to update your timeline. These three concepts will make your day easy and you will deliver your project on time.</p>
<h2 id="project-roadmap-template-download">Project roadmap template for download</h2>
<p>Finally, there are a lot of roadmap templates out there, but many of them require you to sign-up for a service or enter your information. Instead, I created a free <a href="https://docs.google.com/spreadsheets/d/1QN9Yn0l-ie4baF4aPDcrEw9i_5xEcgdkQ3VXAalBig8/edit#gid=58607616">project roadmap document template</a> for you to apply into your projects.</p>
<p>The template here is in Google Sheets, so you can make a copy or download it locally for your use. Feel free to ask any questions in the comments of this blog, I would be very happy to help you build your own!</p>
<h2 id="conclusion">Conclusion</h2>
<p>In this post, we learned all about project roadmaps. We discussed when you need them, their benefits, what goes into a project roadmap, and key differences between roadmaps and other project documents. Thank you for reading, take care!</p>
<p style="font-size: 14px;"><em>Featured image source: <a href="URL OF IMAGE">IconScout</a></em></p><div class='code-block code-block-31' style='margin: 8px 0; clear: both;'>
<div class="blog-plug inline-plug product-plug">
<h2><a href="https://lp.logrocket.com/blg/pm-signup" target="_blank">LogRocket</a> generates product insights that lead to meaningful action</h2>
<a href="https://lp.logrocket.com/blg/pm-signup" target="_blank"><img src="https://firebasestorage.googleapis.com/v0/b/logrocket-com.appspot.com/o/0df879ea96ac05188c8d39ba5cb7de315d34e3f7-3727x3569.svg?alt=media&amp;token=86fd1118-d1a4-41c9-bacf-279f3fb8d784" data-lazy-src="https://firebasestorage.googleapis.com/v0/b/logrocket-com.appspot.com/o/0df879ea96ac05188c8d39ba5cb7de315d34e3f7-3727x3569.svg?alt=media&amp;token=86fd1118-d1a4-41c9-bacf-279f3fb8d784&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img data-lazy-fallback="1"
        src="https://firebasestorage.googleapis.com/v0/b/logrocket-com.appspot.com/o/0df879ea96ac05188c8d39ba5cb7de315d34e3f7-3727x3569.svg?alt=media&token=86fd1118-d1a4-41c9-bacf-279f3fb8d784" /></noscript></a>
<p style="margin-top: -30px;"><a href="https://lp.logrocket.com/blg/pm-signup" target="_blank">LogRocket</a> identifies friction points in the user experience so you can make informed decisions about product and design changes that must happen to hit your goals.<br> <br>With LogRocket, you can understand the scope of the issues affecting your product and prioritize the changes that need to be made. LogRocket simplifies workflows by allowing Engineering and Design teams to work from the same data as you, eliminating any confusion about what needs to be done.<p>Get your teams on the same page — try <a class="signup" href="https://lp.logrocket.com/blg/pm-signup" target="_blank" rel="noopener noreferrer">LogRocket</a> today.</p>
</p></div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-148298" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-148298" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-148298" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/product-management/what-is-a-project-roadmap-overview-how-to-template/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/12/zeynepcansuyildirim-150x150.jpeg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/12/zeynepcansuyildirim-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/12/zeynepcansuyildirim-150x150.jpeg?crop=1' class='avatar avatar-72 photo' height='72' width='72'  /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/zeynepcansuyildirim/">
Zeynep Cansu Yildirim <span class="btn follow">Follow</span></a>
<span class="author-description d-block">I am an experienced PM of 5+ years with 9+ years of analyst and leadership experience in software companies, currently working as a PM in an e-commerce company. I am an Electric and Electronic Engineer with a Masters in Engineering Management. In my social life, I like skiing, kitesurfing, boxing, and am a professional horse rider in show jumping competitions.</span>
</div>
</div>
<div class="after-post-tags">
<ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/product-management/" rel="category tag">Product Management</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/product-management/">#product-management</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/phoenix-authentication/" rel="prev">Authentication with Phoenix</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/build-rust-api-builder-pattern/" rel="next">How to build a Rust API with the builder pattern</a> &raquo;</div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/product-management/freemium-model-how-to-know-right-for-your-business/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/12/freemium-model-how-to-know-right-for-your-business.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/product-management/freemium-model-how-to-know-right-for-your-business/">The freemium model: How to know if it’s right&hellip;</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/bartkrawczyk/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/08/bart-krawczyk-150x150.jpeg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/08/bart-krawczyk-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/08/bart-krawczyk-150x150.jpeg?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/bartkrawczyk/">Bart Krawczyk</a></span><br>
<span class="post-date">Dec 15, 2022</span>
<span class="dot"></span>
<span class="readingtime">5 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/product-management/freemium-model-how-to-know-right-for-your-business/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/product-management/guide-to-creating-sharing-public-product-roadmaps/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/12/guide-to-creating-sharing-public-product-roadmaps.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/product-management/guide-to-creating-sharing-public-product-roadmaps/">A guide to creating and sharing public product roadmaps</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/danielschwarz/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/12/icon-512x512-1-150x150.png?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/12/icon-512x512-1-150x150.png?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/12/icon-512x512-1-150x150.png?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/danielschwarz/">Daniel Schwarz</a></span><br>
<span class="post-date">Dec 15, 2022</span>
<span class="dot"></span>
<span class="readingtime">7 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/product-management/guide-to-creating-sharing-public-product-roadmaps/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/product-management/cohort-analysis-how-to-reduce-churn-improve-retention/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/12/cohort-analysis-how-to-reduce-churn-and-improve-retention.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/product-management/cohort-analysis-how-to-reduce-churn-improve-retention/">Cohort analysis: How to reduce churn and improve retention</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/monicadhiman/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/06/monica-dhiman-150x150.jpeg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/06/monica-dhiman-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/06/monica-dhiman-150x150.jpeg?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/monicadhiman/">Monica Dhiman</a></span><br>
<span class="post-date">Dec 14, 2022</span>
<span class="dot"></span>
<span class="readingtime">8 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/product-management/cohort-analysis-how-to-reduce-churn-improve-retention/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/product-management/what-is-a-project-roadmap-overview-how-to-template#respond" style="display:none;">Cancel reply</a></small>
 </h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=148298&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;jetpack_comments_nonce=529c5be40c&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=11.7-a.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=9ffde9cc825194b14582b8736806f9e4d8a26cc7#parent=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="footerRight"><form role="search" method="get" action="https://blog.logrocket.com/" class="wp-block-search__button-outside wp-block-search__text-button alignright wp-block-search"><label for="wp-block-search__input-1" class="wp-block-search__label screen-reader-text">Search</label><div class="wp-block-search__inside-wrapper " style="width: 100%"><input type="search" id="wp-block-search__input-1" class="wp-block-search__input wp-block-search__input" name="s" value="" placeholder="" required /><button type="submit" class="wp-block-search__button has-text-color wp-element-button" style="color: #764abc">Search</button></div></form></div> <div class="clearfix"></div>
<a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script defer id="bilmur" data-provider="wordpress.com" data-service="atomic" src="https://s0.wp.com/wp-content/js/bilmur.min.js?m=202250"></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length && document.location.href.indexOf('product-management') === -1) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text(),
	postAuthor: jQuery("meta[name='twitter:data1']").attr("content"),
	id: jQuery(".mainheading").closest(".col-md-8").attr("id").replace('post-','')
  });
}
jQuery(".aretags li a:contains('archive')").parent('li').hide();
jQuery(".aretags li a:contains('86919')").parent('li').hide();
jQuery(".aretags li a:contains('72293')").parent('li').hide();
};</script> <div style="display:none">
<div class="grofile-hash-map-fe1a55c148700361478fa4914ca5ccb3">
</div>
<div class="grofile-hash-map-a37b3f6974b9b904366cf8246bfd4fda">
</div>
<div class="grofile-hash-map-7ba2dc4a8a6c5c08b49bf00a55f322d7">
</div>
<div class="grofile-hash-map-4ed92c544e9e814fae95b0cab8465570">
</div>
</div>
<div id="jp-carousel-loading-overlay">
<div id="jp-carousel-loading-wrapper">
<span id="jp-carousel-library-loading">&nbsp;</span>
</div>
</div>
<div class="jp-carousel-overlay" style="display: none;">
<div class="jp-carousel-container">

<div class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions" itemscope itemtype="https://schema.org/ImageGallery">
<div class="jp-carousel swiper-wrapper"></div>
<div class="jp-swiper-button-prev swiper-button-prev">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white" />
</mask>
<g mask="url(#maskPrev)">
<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
<div class="jp-swiper-button-next swiper-button-next">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white" />
</mask>
<g mask="url(#maskNext)">
<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
</div>

<div class="jp-carousel-close-hint">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white" />
</mask>
<g mask="url(#maskClose)">
<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>

<div class="jp-carousel-info">
<div class="jp-carousel-info-footer">
<div class="jp-carousel-pagination-container">
<div class="jp-swiper-pagination swiper-pagination"></div>
<div class="jp-carousel-pagination"></div>
</div>
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-caption"></h2>
</div>
<div class="jp-carousel-photo-icons-container">
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white" />
</mask>
<g mask="url(#maskInfo)">
<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</span>
</a>
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
 <mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white" />
</mask>
<g mask="url(#maskComments)">
<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
</span>
</a>
</div>
</div>
<div class="jp-carousel-info-extra">
<div class="jp-carousel-info-content-wrapper">
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-title"></h2>
</div>
<div class="jp-carousel-comments-wrapper">
<div id="jp-carousel-comments-loading">
<span>Loading Comments...</span>
</div>
<div class="jp-carousel-comments"></div>
<div id="jp-carousel-comment-form-container">
<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
<div id="jp-carousel-comment-post-results"></div>
<form id="jp-carousel-comment-form">
<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
<textarea name="comment" class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea" id="jp-carousel-comment-form-comment-field" placeholder="Write a Comment..."></textarea>
<div id="jp-carousel-comment-form-submit-and-info-wrapper">
<div id="jp-carousel-comment-form-commenting-as">
<fieldset>
<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-url-field">Website</label>
<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
</fieldset>
</div>
<input type="submit" name="submit" class="jp-carousel-comment-form-button" id="jp-carousel-comment-form-button-submit" value="Post Comment" />
</div>
</form>
</div>
</div>
<div class="jp-carousel-image-meta">
<div class="jp-carousel-title-and-caption">
<div class="jp-carousel-photo-info">
<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
</div>
<div class="jp-carousel-photo-description"></div>
</div>
<ul class="jp-carousel-image-exif" style="display: none;"></ul>
<a class="jp-carousel-image-download" target="_blank" style="display: none;">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white" />
</mask>
<g mask="url(#mask0)">
<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-download-text"></span>
</a>
<div class="jp-carousel-image-map" style="display: none;"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/product-management\/what-is-a-project-roadmap-overview-how-to-template\/":148298};
	</script>
<link rel='stylesheet' id='dashicons-css' href='https://blog.logrocket.com/wp-includes/css/dashicons.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='nf-display-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/display-opinions-light.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='nf-font-awesome-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/font-awesome.min.css?ver=6.1.1' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-before'>
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=6.1.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=83ec8aa758f883d6da14' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=8767d0da914b289bd862' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/blog.logrocket.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"c687f7ab43","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=11.7-a.3' id='jetpack-carousel-js'></script>
<script defer type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1666634240' id='akismet-frontend-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/underscore.min.js?ver=1.13.4' id='underscore-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/backbone.min.js?ver=1.4.1' id='backbone-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end-deps.js?ver=3.6.14' id='nf-front-end-deps-js'></script>
<script type='text/javascript' id='nf-front-end-js-extra'>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</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end.js?ver=3.6.14' id='nf-front-end-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.7-a.3' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=148298&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=529c5be40c&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.7-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=9ffde9cc825194b14582b8736806f9e4d8a26cc7#parent=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=148298&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=529c5be40c&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.7-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=9ffde9cc825194b14582b8736806f9e4d8a26cc7#parent=https%3A%2F%2Fblog.logrocket.com%2Fproduct-management%2Fwhat-is-a-project-roadmap-overview-how-to-template";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202250.js' defer></script>
<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'161333275',post:'148298',tz:'-5',srv:'blog.logrocket.com',hp:'atomic',ac:'2',amp:'0',j:'1:11.7-a.3'} ]);
		_stq.push([ 'clickTrackerInit', '161333275', '148298' ]);
	</script><script id="tmpl-nf-layout" type="text/template">
	<span id="nf-form-title-{{{ data.id }}}" class="nf-form-title">
		{{{ ( 1 == data.settings.show_title ) ? '<h3>' + data.settings.title + '</h3>' : '' }}}
	</span>
	<div class="nf-form-wrap ninja-forms-form-wrap">
		<div class="nf-response-msg"></div>
		<div class="nf-debug-msg"></div>
		<div class="nf-before-form"></div>
		<div class="nf-form-layout"></div>
		<div class="nf-after-form"></div>
	</div>
</script>
<script id="tmpl-nf-empty" type="text/template">

</script>
<script id="tmpl-nf-before-form" type="text/template">
	{{{ data.beforeForm }}}
</script><script id="tmpl-nf-after-form" type="text/template">
	{{{ data.afterForm }}}
</script><script id="tmpl-nf-before-fields" type="text/template">
    <div class="nf-form-fields-required">{{{ data.renderFieldsMarkedRequired() }}}</div>
    {{{ data.beforeFields }}}
</script><script id="tmpl-nf-after-fields" type="text/template">
    {{{ data.afterFields }}}
    <div id="nf-form-errors-{{{ data.id }}}" class="nf-form-errors" role="alert"></div>
    <div class="nf-form-hp"></div>
</script>
<script id="tmpl-nf-before-field" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-after-field" type="text/template">
    {{{ data.afterField }}}
</script><script id="tmpl-nf-form-layout" type="text/template">
	<form>
		<div>
			<div class="nf-before-form-content"></div>
			<div class="nf-form-content {{{ data.element_class }}}"></div>
			<div class="nf-after-form-content"></div>
		</div>
	</form>
</script><script id="tmpl-nf-form-hp" type="text/template">
	<label for="nf-field-hp-{{{ data.id }}}" aria-hidden="true">
		{{{ nfi18n.formHoneypot }}}
		<input id="nf-field-hp-{{{ data.id }}}" name="nf-field-hp" class="nf-element nf-field-hp" type="text" value=""/>
	</label>
</script>
<script id="tmpl-nf-field-layout" type="text/template">
    <div id="nf-field-{{{ data.id }}}-container" class="nf-field-container {{{ data.type }}}-container {{{ data.renderContainerClass() }}}">
        <div class="nf-before-field"></div>
        <div class="nf-field"></div>
        <div class="nf-after-field"></div>
    </div>
</script>
<script id="tmpl-nf-field-before" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-field-after" type="text/template">
    <#
    /*
     * Render our input limit section if that setting exists.
     */
    #>
    <div class="nf-input-limit"></div>
    <#
    /*
     * Render our error section if we have an error.
     */
    #>
    <div id="nf-error-{{{ data.id }}}" class="nf-error-wrap nf-error" role="alert"></div>
    <#
    /*
     * Render any custom HTML after our field.
     */
    #>
    {{{ data.afterField }}}
</script>
<script id="tmpl-nf-field-wrap" type="text/template">
	<div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
		<#
		/*
		 * This is our main field template. It's called for every field type.
		 * Note that must have ONE top-level, wrapping element. i.e. a div/span/etc that wraps all of the template.
		 */
        #>
		<#
		/*
		 * Render our label.
		 */
        #>
		{{{ data.renderLabel() }}}
		<#
		/*
		 * Render our field element. Uses the template for the field being rendered.
		 */
        #>
		<div class="nf-field-element">{{{ data.renderElement() }}}</div>
		<#
		/*
		 * Render our Description Text.
		 */
        #>
		{{{ data.renderDescText() }}}
	</div>
</script>
<script id="tmpl-nf-field-wrap-no-label" type="text/template">
    <div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
        <div class="nf-field-label"></div>
        <div class="nf-field-element">{{{ data.renderElement() }}}</div>
        <div class="nf-error-wrap"></div>
    </div>
</script>
<script id="tmpl-nf-field-wrap-no-container" type="text/template">

        {{{ data.renderElement() }}}

        <div class="nf-error-wrap"></div>
</script>
<script id="tmpl-nf-field-label" type="text/template">
	<div class="nf-field-label"><label for="nf-field-{{{ data.id }}}"
	                                   id="nf-label-field-{{{ data.id }}}"
	                                   class="{{{ data.renderLabelClasses() }}}">{{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}} {{{ ( 'undefined' != typeof data.required && 1 == data.required ) ? '<span class="ninja-forms-req-symbol">*</span>' : '' }}} {{{ data.maybeRenderHelp() }}}</label></div>
</script>
<script id="tmpl-nf-field-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-form-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-field-input-limit" type="text/template">
    {{{ data.currentCount() }}} {{{ nfi18n.of }}} {{{ data.input_limit }}} {{{ data.input_limit_msg }}}
</script><script id="tmpl-nf-field-null" type="text/template">
</script><script id="tmpl-nf-field-listradio" type="text/template">
    <ul aria-describedby="nf-error-{{{ data.id }}}">
        {{{ data.renderOptions() }}}
    </ul>
</script>
<script id='tmpl-nf-field-listradio-option' type='text/template'>
    <# if ( ! data.visible ) { return '' } #>
    <li>
        <input type="radio"
               id="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               name="nf-field-{{{ data.fieldID }}}"
               class="{{{ data.classes }}} nf-element {{{ ( data.value == data.currentValue  || 1 == data.selected ) ? 'nf-checked' : '' }}}" value="{{{ data.value }}}" {{{ ( data.value == data.currentValue  || 1 == data.selected ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-class-field-{{{ data.fieldID }}}-{{{ data.index }}}"
            <# if( data.required ) { #>
			required
			<# } #>
        >
        <label for="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               id="nf-label-class-field-{{{ data.fieldID }}}-{{{ data.index }}}" class="{{{ ( data.value == data.currentValue  || 1
                       ==
               data.selected ) ? 'nf-checked-label' : '' }}}">{{{ data.label }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listradio-other' type='text/template'>
    <li>
        <input type="radio" name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element" value="nf-other" {{{ ( ! data.valueFound ) ? 'checked="checked"' : '' }}}> <label>Other {{{ data.renderOtherText() }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listradio-other-text' type='text/template'>
    <input type="text" name="nf-field-{{{ data.fieldID }}}" class="nf-element" value="{{{ data.currentValue }}}">
</script>
<script id='tmpl-nf-field-input' type='text/template'>
    <input id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" aria-invalid="false" aria-describedby="nf-error-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element" type="text" value="{{{ _.escape( data.value ) }}}" {{{ data.renderPlaceholder() }}} {{{ data.maybeDisabled() }}}
           aria-labelledby="nf-label-field-{{{ data.id }}}"

            {{{ data.maybeRequired() }}}
    >
</script>
<script id="tmpl-nf-field-submit" type="text/template">
	<input id="nf-field-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element " type="button" value="{{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}}" {{{ ( data.disabled ) ? 'disabled' : '' }}}>
</script><script id='tmpl-nf-field-button' type='text/template'>
    <button id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" class="{{{ data.classes }}} nf-element">
        {{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}}
    </button>
</script><script>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</script>
</body>
</html>
