<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v15.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Build a reusable React component to export arrays to Excel - LogRocket Blog</title>
	<meta name="description" content="In this article, you can learn how to export an array of objects to an Excel file using a reusable React component." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Build a reusable React component to export arrays to Excel - LogRocket Blog" />
	<meta property="og:description" content="In this article, you can learn how to export an array of objects to an Excel file using a reusable React component." />
	<meta property="og:url" content="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/" />
	<meta property="og:site_name" content="LogRocket Blog" />
	<meta property="article:published_time" content="2021-02-19T14:00:49+00:00" />
	<meta property="article:modified_time" content="2021-02-19T13:56:08+00:00" />
	<meta property="og:image" content="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?fit=730%2C487&#038;ssl=1" />
	<meta property="og:image:width" content="730" />
	<meta property="og:image:height" content="487" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Linda Ikechukwu">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="10 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/reusable-react-component-export-arrays-excel/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?fit=730%2C487&ssl=1","width":730,"height":487,"caption":"React Logo"},{"@type":"WebPage","@id":"https://blog.logrocket.com/reusable-react-component-export-arrays-excel/#webpage","url":"https://blog.logrocket.com/reusable-react-component-export-arrays-excel/","name":"Build a reusable React component to export arrays to Excel - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/reusable-react-component-export-arrays-excel/#primaryimage"},"datePublished":"2021-02-19T14:00:49+00:00","dateModified":"2021-02-19T13:56:08+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/ca84276865e285009a8d489d76c339a3"},"description":"In this article, you can learn how to export an array of objects to an Excel file using a reusable React component.","breadcrumb":{"@id":"https://blog.logrocket.com/reusable-react-component-export-arrays-excel/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/reusable-react-component-export-arrays-excel/"]}]},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/reusable-react-component-export-arrays-excel/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://blog.logrocket.com/","url":"https://blog.logrocket.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://blog.logrocket.com/reusable-react-component-export-arrays-excel/","url":"https://blog.logrocket.com/reusable-react-component-export-arrays-excel/","name":"Build a reusable React component to export arrays to Excel"}}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/ca84276865e285009a8d489d76c339a3","name":"Linda Ikechukwu","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/b12ebc301b41cd08402e95641fd3be46?s=96&d=mm&r=g","caption":"Linda Ikechukwu"},"description":"Frontend Developer. Writer. Community Strategist. Building web interfaces that connect products to their target users."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Build a reusable React component to export arrays to Excel Comments Feed" href="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.6.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.6.1/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css'  href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/9.4.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.4.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/34634" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/paUW9B-90C' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
    <script>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</script>


    <script>
    window.Raven && window.Raven.config('https://98e0ea7c6f2e492d94439ad5aaea48dd@e.logrocket.com/4').install()
    </script>
    <script type="text/javascript">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</script>

    <script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
    <script>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</script><style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=270%2C270&#038;ssl=1" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=de679bb724" />
		<style id="kirki-inline-styles">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</style></head>

<body class="post-template-default single single-post postid-34634 single-format-standard">

<style>
    </style>


<header class="navbar-light bg-white fixed-top mediumnavigation">

    <div class="container">



        <div class="navarea">

<div class="nav-left">

  <a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>

<nav class="menu-container">

        <div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a><li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">PodRocket</a></ul></div></nav>

</div>

<div class="nav-right">

  <div class="menu-container">
    <div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Free Trial</a></li>
</ul></div>  </div>

</div>

        </div>

    </div>

</header>


        <!-- Begin site-content
		================================================== -->
        <div class="site-content">


<div class="container"> 
    <div class="row">         
        <div class=" col-md-2 ">           
            <div class="share">
                
                <div class="sidebarapplause">
                                </div>
                
                				<p class="sharecolour">
					Share				</p>
                
<ul class="shareitnow"><li>
        <a target="_blank" href="https://twitter.com/intent/tweet?text=Build%20a%20reusable%20React%20component%20to%20export%20arrays%20to%20Excel&amp;url=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F">
        <i class="fa fa-twitter"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F">
        <i class="fa fa-facebook"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F">
        <i class="fa fa-google"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F&amp;media=https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?fit=730%2C487&ssl=1&amp;description=Build%20a%20reusable%20React%20component%20to%20export%20arrays%20to%20Excel">
        <i class="fa fa-pinterest"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F&amp;title=Build%20a%20reusable%20React%20component%20to%20export%20arrays%20to%20Excel">
        <i class="fa fa-linkedin"></i>
        </a>
    </li></ul>                		        
                
                                <div class="sep"></div>
                <div class="hidden-xs-down">      

                    <p>
                        Reply                    </p>
                    <ul>
                        <li>
                        <a class="smoothscroll" href="#comments">0<br/>
                        <svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
                        </a>
                        </li>
                    </ul>
                </div>
                            </div>			                                
        </div>
        
                    			                <div class="col-md-8 flex-first flex-md-unordered post-34634 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-create-react-app tag-react" id="post-34634"> 
                    <div class="mainheading">
                       
                                                <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-md-down"> 
                            <div class="col-md-2 col-xs-12"> 
                                <a href="https://blog.logrocket.com/author/lindaikechukwu/">
                                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lindaikechukwu.png?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lindaikechukwu.png?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lindaikechukwu.png?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                                </a>
                            </div>                                         
                            <div class="col-md-10 col-xs-12"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/lindaikechukwu/">
                                Linda Ikechukwu <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">Frontend Developer. Writer. Community Strategist. Building web interfaces that connect products to their target users.</span> 
                            </div>                                         
                        </div>
                                                 
                                                
                        <h1 class="posttitle">Build a reusable React component to export arrays to Excel</h1>
					    <h2 class="post-subtitle"></h2>

                        <p>
                                                        <span class="post-date"><time class="post-date">
                            February 19, 2021                            </time></span>
                                                        
                                                        <span class="dot"></span>
                            <span class="readingtime">8 min read</span>
						    <span class="wordcount">2272</span>

                                                    </p> 
                    </div>
                    
                  <img width="730" height="487" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?fit=730%2C487&amp;ssl=1" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="React Logo" loading="lazy" data-attachment-id="34637" data-permalink="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/buildareusablereactcomponenttoexporttoexcel/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?fit=730%2C487&amp;ssl=1" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Build a reusable React component to export to Excel" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?fit=300%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?fit=730%2C487&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?w=730&amp;ssl=1 730w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/buildareusablereactcomponenttoexporttoexcel.png?fit=730%2C487&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    <article class="article-post">
                                                <p>Not so long ago, I was tasked with adding an export-array-to-excel button to some pages of a React application. The criteria given for this button was:</p>
<ul>
<li>It had to be reusable, so it can be imported into any page and used as needed</li>
<li>When clicked, it should open up a modal that lets users choose between downloading all columns (all properties from each individual object of the array) or selected columns (only selected properties from individual objects of the array)</li>
<li>The modal should contain a download button that will download a JSON API response array directly into a spreadsheet file based on the columns selected</li>
</ul>
<figure id="attachment_34644" aria-describedby="caption-attachment-34644" style="width: 730px" class="wp-caption aligncenter"><img loading="lazy" class="wp-image-34644 size-full jetpack-lazy-image" src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=730%2C417&#038;ssl=1" alt="A Screenshot of the export-array-to-excel Component" width="730" height="417" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?w=730&amp;ssl=1 730w, https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=300%2C171&amp;ssl=1 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=730%2C417&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="wp-image-34644 size-full" src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=730%2C417&#038;ssl=1" alt="A Screenshot of the export-array-to-excel Component" width="730" height="417" srcset="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?w=730&amp;ssl=1 730w, https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=300%2C171&amp;ssl=1 300w" sizes="(max-width: 730px) 100vw, 730px" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-34644" class="wp-caption-text">A screenshot of the export-array-to-excel component.</figcaption></figure>
<p>I found out that this is a common feature request (maybe with a little variation) given to developers, especially those who work on admin dashboard-like projects, and that is why I’m writing this article.</p>
<p>This article assumes that you have a fair knowledge of JavaScript and React. In this article, I will first show you the fundamental concepts involved in exporting an array of objects into an Excel sheet. Then, based on that, create the reusable export-array-to-excel component shown above, using Chakra UI as the component library of choice.</p>
<p>The first thing that needs to be figured out is how to prompt a download on the browser.</p>
<p>In plain HTML, creating a button to prompt a download in the browser is pretty straightforward using an anchor tag and its download attribute. Simply pass the URL or file path of the file to be downloaded to the <code>href</code> attribute:</p>
<pre>&lt;a href="/files/excel-sheet-to-download.xls" download=”customer-list”&gt;
       &lt;button&gt; Download to excel &lt;/button&gt;
&lt;/a&gt;
</pre>
<p>The <code>download</code> attribute is part of the HTML5 spec, and it specifies that the target should be downloaded when the link is clicked. The value passed to the <code>download</code> attribute specifies the filename for the downloaded file.</p>
<p>Unfortunately, the solution above won’t exactly work for our use case because there isn’t a pre-existing Excel file to link to.</p>
<p>We’ll have to perform four tasks spontaneously when the download button is clicked:</p>
<ol>
<li>Get the API response array and convert it to a table</li>
<li>Embed the table into a spreadsheet XML template</li>
<li>Programmatically create a file URL for the spreadsheet template using the <code>Blob</code> and <code>URL.createObjectURL()</code> methods</li>
<li>Finally, assign the created URL to the <code>href</code> of an anchor tag with a download attribute, then programmatically click the anchor tag to prompt a download</li>
</ol>
<p>Let’s go over each step and write the necessary code for it. But first, we need to set up a React app and Chakra UI.</p>
<h2>Setting up a React application</h2>
<p>To set up a demo React app, use <a href="https://github.com/facebook/create-react-app" target="_blank" rel="noopener">Create React App</a>. Make sure you have <a href="https://nodejs.org/en/" target="_blank" rel="noopener">Node &gt;= 8.10 and npm &gt;= 5.6</a> installed:</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br/>No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>

<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>

<pre>npx create-react-app export-array-demo
cd export-array-demo
npm start
</pre>
<p>Next, install Chakra UI:</p>
<pre>npm i @chakra-ui/react @emotion/react @emotion/styled framer-motion
npm i @chakra-ui/icons
</pre>
<p><a href="https://chakra-ui.com/docs/getting-started" target="_blank" rel="noopener">Chakra UI</a> is an open-source component library for React that provides a set of simple, modular, and accessible components that make it easier to build the UI of applications. It will be used to quickly assemble UI elements that will be needed.</p>
<p>For Chakra UI to work correctly, you need to set up the <code>ChakraProvider</code> (which is the library’s context provider <a href="https://www.codewithlinda.com/blog/dark-mode-with-react-context/" target="_blank" rel="noopener">using the React Context API</a>) in <code>index.js</code>:</p>
<pre>import React from 'react';
…………
import {ChakraProvider} from "@chakra-ui/react"

ReactDOM.render(
  &lt;React.StrictMode&gt;
    &lt;ChakraProvider&gt;
      &lt;App /&gt;
    &lt;/ChakraProvider&gt;
  &lt;/React.StrictMode&gt;,
  document.getElementById('root')
);
</pre>
<p>That’s all the initial setup needed. Next up, is to write functions to take care of the array to Excel export.</p>
<h2>Write <code>ArrayToExcel</code></h2>
<p>To keep the core array-to-excel logic separated, create a <code>Components/ArrayToExcel</code> folder in <code>src</code>. Inside this folder, create two files <code>ArrayToExcel.js</code> which will contain the function that’ll take care of the conversion and download, and <code>ArrayToExcelButton.js</code>, which will house the button, modal, and other necessary UI elements.</p>
<p>In <code>ArrayToExcel.js</code>, copy the code <a href="https://github.com/Linda-Ikechukwu/Blog-Posts-Demo-Apps/blob/master/export-array-demo/src/Components/ArrayToExcel/ArrayToExcel.js" target="_blank" rel="noopener">here</a>, which I’ll now go over in bits:</p>
<pre>export const arrayToExcel = (function () {
....
})();
</pre>
<p>First, all functions are wrapped in an <a href="https://medium.com/@vvkchandra/essential-javascript-mastering-immediately-invoked-function-expressions-67791338ddc6" target="_blank" rel="noopener">IIFE</a> to make sure that variables scoping will always be protected.</p>
<p>Then there is the <code>convertArrayToTable</code> method returned from the <code>arrayToExcel</code> function:</p>
<pre>convertArrayToTable : async (apiArray, fileName) =&gt; {
   //use keys from the first array object to form table column headers
   const tableHeaders = `&lt;tr&gt;${Object.keys(apiArray[0]).map(key =&gt;   `&lt;td&gt;${key}&lt;/td&gt;`).join('')}&lt;/tr&gt;`;
   //now loop through all array objects to form table rows
   const tableRows = apiArray.map(obj =&gt;
      [`&lt;tr&gt;
         ${Object.keys(obj).map(key =&gt; `&lt;td&gt;${obj[key] === null ||    obj[key] === '' ? '' : obj[key]}&lt;/td&gt;`).join('')}
      &lt;tr/&gt;`]).join('');
   const table = `&lt;table&gt;${tableHeaders}${tableRows}&lt;/table&gt;`.trim();


   const xmlTable = createXMLTable(table, fileName);
   const downloadURL = createFileUrl(xmlTable);
   downloadFile(downloadURL, fileName);
}
</pre>
<p>The <code>convertArrayToTable</code> function receives a JSON API response array (which is an array of objects) as a parameter and loops through the keys of the first object to form the first row, which will represent the table headers or columns. It also loops through each object and uses its values to create rows. Every <code>map</code> function returns an array, which then <code>join</code> method that converts into a string. Then using template literals, concatenate <code>tableHeader</code> and <code>tableRows</code> to form a complete table and pass it into <code>createXMLTable</code>:</p>
<pre>const createXMLTable = (table, fileName) =&gt; {
  const xmlTable = `
        &lt;html xmlns:o="urn:schemas-microsoft-com:office:office xmlns:x="urn:schemas-microsoft-com:office:excel"
       xmlns="http://www.w3.org/TR/REC-html40"
        &gt;
           &lt;meta http-equiv="content-type" content="application/vnd.ms-excel; charset=UTF-8"/&gt;
           &lt;head&gt;
              &lt;xml&gt;
                &lt;x:ExcelWorkbook&gt;
                    &lt;x:ExcelWorksheets&gt;
                        &lt;x:ExcelWorksheet&gt;
                            &lt;x:Name&gt;${fileName}&lt;/x:Name&gt;
                            &lt;x:WorksheetOptions&gt;&lt;x:DisplayGridlines/&gt;&lt;/x:WorksheetOptions&gt;
                        &lt;/x:ExcelWorksheet&gt;
                    &lt;/x:ExcelWorksheets&gt;
                &lt;/x:ExcelWorkbook&gt;
              &lt;/xml&gt;
           &lt;/head&gt;
           &lt;body&gt;
             ${table}
           &lt;/body&gt;
        &lt;/html&gt; `
        return xmlTable;
    }
</pre>
<p>The <code>createXMLTable</code> function uses the <a href="https://docs.microsoft.com/en-us/office/open-xml/structure-of-a-spreadsheetml-document" target="_blank" rel="noopener">SpreadsheetDataXML</a> specification by Microsoft to describe how a spreadsheet file should be structured. In the XML template, you’re instructing that the file should be a workbook with worksheets and that the particular worksheet which displays the table should have a title of whatever the <code>fileName</code> parameter is, and should display grid lines.</p>
<p>XML is a markup language mainly used to transfer data between different programs. In our case, between the web and a .xls (file extension for spreadsheet files) file.</p>
<blockquote><p>
  <em>You can write inline CSS here to style how the exported spreadsheet table should look.</em>
</p></blockquote>
<p>Next is the <code>createXMLTable</code> function which returns an Excel file template that is passed to <code>createFileUrl</code>:</p>
<pre>const createFileUrl = (xmlTable) =&gt; {
        const tableBlob = new Blob([xmlTable], {type: 'application/vnd.ms-excel;base64,' });
        const downloadURL = URL.createObjectURL(tableBlob);
        return downloadURL;
    }
</pre>
<p>To programmatically create a file URL for the Excel template, you’ll need to convert it into a file or a file-like object using the <a href="https://developer.mozilla.org/en-US/docs/Web/API/Blob" target="_blank" rel="noopener">blob</a> method. The <code>blob</code> method takes in an array and a <a href="https://developer.mozilla.org/en-US/docs/Web/HTTP/Basics_of_HTTP/MIME_types" target="_blank" rel="noopener">MIME type</a> as arguments. The <code>blob</code> method returns a blob object, which is passed into the <code>createObjectURL</code> method to create a unique file URL which can then be passed to an <code>a</code> tag.</p>
<p>The <code>downloadFile</code> function takes in the resulting URL from <code>createFileUrl,</code> and finally starts the download:</p>
<pre>const downloadFile = (downloadURL, fileName) =&gt; {
        const downloadLink = document.createElement('a');
        document.body.appendChild(downloadLink);
        downloadLink.download = fileName;
        downloadLink.href = downloadURL;
        downloadLink.click();
    }
</pre>
<p>The <code>downloadFile</code> function passes the file URL to the <code>href</code> of the anchor tag which is created programmatically, and then invokes the click method on the link to trigger the download process. The <code>fileName</code> parameter assigned to the download will be the name of the file.</p>
<p>And that’s all you need to do, to take care of downloading an array of objects into an Excel file.</p>
<p>Next, let’s set up our array-to-excel component with UI elements from Chakra UI and also import <code>arrayToExcel</code>.</p>
<h2>Assembling UI elements with Chakra UI</h2>
<p>To build out the export-array-to-excel component as shown in the beginning, you’ll need a button, modal, select input, and checkbox UI elements.</p>
<p>In <code>ArrayToExcelButton.js</code> import these elements from Chakra UI:</p>
<pre>import React, { useState } from "react";
import {
    Button,
    Modal,
    ModalOverlay,
    ModalContent,
    ModalHeader,
    ModalFooter,
    ModalBody,
    ModalCloseButton,
    Select,
    Checkbox,
} from "@chakra-ui/react"
import { DownloadIcon } from '@chakra-ui/icons'
</pre>
<p>Chakra exports those <a href="https://chakra-ui.com/docs/overlay/modal#import" target="_blank" rel="noopener">seven modal-based components</a> to help you create any type of modal dialog.</p>
<p>Remember, from the workflow stated in the beginning, when the main button is clicked, it should open up a modal that lets users choose between downloading all columns or some selected columns (i.e. select properties from each object of the array):</p>
<pre>const ArrayToExcelButton = ({ apiArray, fileName, buttonTitle }) =&gt; {

    const [showDownloadModal, setShowDownloadModal] = useState(false);
    const [columnsType, setColumnsType] = useState("1");
    const [selectedColumns, setSelectedColumns] = useState([]);

    return (
        &lt;&gt;
            &lt;Button leftIcon={&lt;DownloadIcon /&gt;} colorScheme="teal" onClick={() =&gt; setShowDownloadModal(true)}&gt;
                {buttonTitle}
            &lt;/Button&gt;
            {showDownloadModal &amp;&amp;
                &lt;Modal isOpen={showDownloadModal} onClose={() =&gt;    setShowDownloadModal(false)}&gt;
                    &lt;ModalOverlay /&gt;
                    &lt;ModalContent&gt;
                        &lt;ModalHeader&gt;{buttonTitle}&lt;/ModalHeader&gt;
                        &lt;ModalCloseButton /&gt;
                        &lt;ModalBody&gt;
                            &lt;p style={{marginBottom:"10px" }}&gt;
                              Select Download Type: 
                            &lt;/p&gt;
                            &lt;Select onChange={(e) =&gt; setColumnsType(e.target.value)}&gt;
                                &lt;option value="1"&gt;All Columns&lt;/option&gt;
                                &lt;option value="2"&gt;Custom&lt;/option&gt;
                            &lt;/Select&gt;
                            {columnsType === "1" &amp;&amp;
                                &lt;p style={{marginTop:"20px" }}&gt;
                                    {Object.keys(apiArray[0]).map((key, index) =&gt; {
                                        return (
                                            &lt;span key={index}&gt;{(key)}, &lt;/span&gt;
                                        )
                                    })}
                                &lt;/p&gt;
                            }
                            {columnsType === "2" &amp;&amp;
                                &lt;div style={{ display: "flex", flexWrap: "wrap", width: "100%", marginTop:"20px" }}&gt;
                                    {Object.keys(apiArray[0]).map((key, index) =&gt; {
                                        return (
                                            &lt;div key={index} style={{ display: "flex", alignItems: "center", width:"33.3%"}}&gt;
                                                &lt;Checkbox
                                                    id={key}
                                                    onChange={(e) =&gt;       updateSelectedColumns(e, key)}
                                                &gt;
                                                   {key}
                                                &lt;/Checkbox&gt;

                                            &lt;/div&gt;
                                        )
                                    })}
                                &lt;/div&gt;
                            }

                        &lt;/ModalBody&gt;

                        &lt;ModalFooter&gt;
                            &lt;Button variant="ghost" mr={3} onClick={() =&gt; setShowDownloadModal(false)}&gt;
                                Cancel
                            &lt;/Button&gt;
                            &lt;Button colorScheme="teal" onClick={() =&gt; apiArrayToExcel()}&gt;
                                Download
                            &lt;/Button&gt;
                        &lt;/ModalFooter&gt;
                    &lt;/ModalContent&gt;
                &lt;/Modal&gt;
            }
        &lt;/&gt;
    )
}

export default ArrayToExcelButton;
</pre>
<p>The main button which receives a <code>buttonTitle</code> prop, toggles opening, and closing of the download modal using the <code>showDownloadModal</code> state.</p>
<p>Inside <code>ModalBody</code>, there is a <code>Select</code> element that toggles the type of download to perform, “All Columns” or “Custom” using <code>setColumnsType</code>. If “All Column” is selected, loop through the first object of <code>apiArray</code> and list out all object properties in a paragraph. If “Columns” is selected, also loop through the first object of <code>apiArray</code> and list out each object properties alongside a checkbox.</p>
<p>To keep track of checked checkboxes we’ll use the <code>updateSelectedColumns</code> function:</p>
<pre>const ArrayToExcelButton = ({ apiArray, fileName, buttonTitle }) =&gt; {

   ...

    const updateSelectedColumns = (e, column) =&gt; {
        if (e.target.checked) {
            setSelectedColumns([...selectedColumns, column]);
        } else {
            setSelectedColumns(selectedColumns.filter(value =&gt; value !== column));
        }
    }

   ...
</pre>
<p>When a checkbox is clicked, <code>updateSelectedColumns</code> either adds or removes the target object property from the <code>selectedColumns</code> state array.</p>
<p>Lastly, clicking on the modal’s download button triggers the array-to-excel download with the <code>apiArrayToExcel</code> function:</p>
<pre>import React, { useState } from "react";
...
import {arrayToExcel} from "./ArrayToExcel";
import cloneDeep from "lodash.clonedeep";

const ArrayToExcelButton = ({ apiArray, fileName, buttonTitle }) =&gt; {

   ....
    const apiArrayToExcel = () =&gt; {
        if (columnsType === "1") {
           arrayToExcel.convertArrayToTable(apiArray, fileName)
        } else {
            const customArray = cloneDeep(apiArray);
            customArray.map(obj =&gt; Object.keys(obj).forEach((key) =&gt; {
                if (!selectedColumns.includes(key)) {
                    delete obj[key];
                }
            }))
            arrayToExcel.convertArrayToTable(customArray, fileName)
            setSelectedColumns([]);
        }
    }

....
</pre>
<p>If the value of the download type selected is “All Columns”, the <code>apiArrayToExcel</code> function simply calls the <code>convertArrayToTable</code> method from <code>arrayToExcel</code> passing in <code>apiArray</code> and fileName props as arguments. Else, if the value is <code>Custom</code>, it duplicates the <code>apiArray</code> array using <code>cloneDeep </code>from lodash, and loops through individual objects in <code>customArray</code> deleting object keys (alongside their corresponding values) that are not present in the <code>selectedColumns</code> array.</p>
<p>Because JavaScript arrays are reference types, simply assigning <code>apiArray</code> to a new variable will only create a shallow copy and any changes made to <code>customArray</code> will affect <code>apiArray</code>. To avoid that, <a href="https://dev.to/samanthaming/how-to-deep-clone-an-array-in-javascript-3cig" target="_blank" rel="noopener">deep clone the array</a> using <code>cloneDeep</code>. The lodash <code>cloneDeep</code> method creates a deep clone of an array:</p>
<pre> npm i --save lodash.clonedeep
</pre>
<p>With that, the export-array-to-excel component is ready!</p>
<p><em>Note, I added some inline styling to keep things simple and together. Ideally, you should keep styles separate.</em></p>
<p>To test our array-to-excel component, let’s make a mock API fetch call in <code>App.js</code>:</p>
<pre>import React, { useState, useEffect } from "react";
import ArrayToExcelButton from "./Components/ArrayToExcel/ArrayToExcelButton"

const App =()=&gt; {

  const [userData, setUserData] = useState([]);
  const [loading, setLoading] = useState(true);

  const fetchJsonArray = async () =&gt; {
    try {
      const response = await fetch('https://jsonfy.com/users');
      let jsonArray = await response.json();
      setUserData(jsonArray);
      setLoading(false);
    } catch (error) {
      console.log(error.message);
      setLoading(false);
    }
  }

  useEffect(() =&gt; {
    fetchJsonArray();
  }, [])

  return (
    &lt;div className="App"&gt;
      {loading ?
        &lt;p&gt;Loading&lt;/p&gt; :
        &lt;ArrayToExcelButton apiArray={userData} fileName={"UserData.xls"} buttonTitle={"Download User Data"} /&gt;
      }
    &lt;/div&gt;
  );
}

export default App;
</pre>
<p>Import <code>ArrayToExcelButton</code> and pass <code>userData</code> into it as props. Start up the application with <code>npm run start</code> and check that the button works fine.</p>
<p><img data-attachment-id="34644" data-permalink="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/export-array-to-excel-component/" data-orig-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?fit=730%2C417&amp;ssl=1" data-orig-size="730,417" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="A screenshot of the export-array-to-excel component" data-image-description data-medium-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?fit=300%2C171&amp;ssl=1" data-large-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?fit=730%2C417&amp;ssl=1" loading="lazy" class="aligncenter size-full wp-image-34644 jetpack-lazy-image" src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=730%2C417&#038;ssl=1" alt="A Screenshot of the export-array-to-excel Component" width="730" height="417" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?w=730&amp;ssl=1 730w, https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=300%2C171&amp;ssl=1 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=730%2C417&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="34644" data-permalink="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/export-array-to-excel-component/" data-orig-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?fit=730%2C417&amp;ssl=1" data-orig-size="730,417" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="A screenshot of the export-array-to-excel component" data-image-description="" data-medium-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?fit=300%2C171&amp;ssl=1" data-large-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?fit=730%2C417&amp;ssl=1" loading="lazy" class="aligncenter size-full wp-image-34644" src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=730%2C417&#038;ssl=1" alt="A Screenshot of the export-array-to-excel Component" width="730" height="417" srcset="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?w=730&amp;ssl=1 730w, https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/export-array-to-excel-component.png?resize=300%2C171&amp;ssl=1 300w" sizes="(max-width: 730px) 100vw, 730px" data-recalc-dims="1" /></noscript></p>
<p>The full code for this demo project can be found on my <a href="https://github.com/Linda-Ikechukwu/Blog-Posts-Demo-Apps/tree/master/export-array-demo" target="_blank" rel="noopener">GitHub</a>.</p>
<h2>Conclusion</h2>
<p>Congratulations! You’ve just learned how to export an array of objects to an Excel file using a reusable React component. As I mentioned before, this is a feature request you’re likely to encounter occasionally as a developer especially if you’re working on admin dashboard projects. Now, go on and build something great 🙂</p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<div class="blog-plug inline-plug react-plug"><h2>Full visibility into production React apps</h2> Debugging React applications can be difficult, especially when users experience issues that are difficult to reproduce. If you’re interested in monitoring and tracking Redux state, automatically surfacing JavaScript errors, and tracking slow network requests and component load time, <a href="https://www2.logrocket.com/react-performance-monitoring" target="_blank">try LogRocket</a>. <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i2.wp.com/files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?ssl=1" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i2.wp.com/files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?ssl=1" data-recalc-dims="1" /></noscript></a><a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" /></noscript></a><p style="margin-top: 15px;"><a href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web apps, recording literally everything that happens on your React app. Instead of guessing why problems happen, you can aggregate and report on what state your application was in when an issue occurred. LogRocket also monitors your app's performance, reporting with metrics like client CPU load, client memory usage, and more.</p><p>The LogRocket Redux middleware package adds an extra layer of visibility into your user sessions. LogRocket logs all actions and state from your Redux stores. </p><p>Modernize how you debug your React apps — <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">start monitoring for free</a>.</p></div>

<style>
.plug-poll {margin-bottom: 2rem;}
.code-block-3 .fadeIn {
    opacity:1 !important;
    height:auto !important;
}

.code-block-3 .fadeOut {
    opacity:0 !important;
}

.code-block-3 .wpcf7-email {margin: 15px 0;}

#plug-survey-errors, #plug-survey-help, #plug-survey-email  {opacity:0; height:1px; transition: all 1s;overflow:hidden; width: 100%;}

</style>

<script>
  jQuery("#plug-survey-framework input").click(function() {
  analytics.track('footer-poll', {
      'footer-poll-framework': jQuery(this).val()
    });
    jQuery('#plug-survey-framework').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-errors').delay(800).addClass('fadeIn');
  });
    jQuery("#plug-survey-errors input").click(function() {
    jQuery('#plug-survey-errors').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-help').delay(800).addClass('fadeIn');
  });
  
      jQuery("#plug-survey-help input").click(function() {
        analytics.track('footer-poll', {
      'footer-poll-help': jQuery(this).val()
    });
    jQuery('#plug-survey-help').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-email').delay(800).addClass('fadeIn');
  });
  
  </script>

</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-34634" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-34634" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-34634" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/reusable-react-component-export-arrays-excel/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><!-- AI CONTENT END 1 -->
                        <div class="clearfix"></div>
                                                <div class="clearfix"></div>
                    </article>
                            
                                             <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-lg-up"> 
                            <div class="col-md-2 col-xs-4"> 
                                <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lindaikechukwu.png?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lindaikechukwu.png?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lindaikechukwu.png?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                            </div>                                         
                            <div class="col-md-10 col-xs-8"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/lindaikechukwu/">
                                Linda Ikechukwu <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">Frontend Developer. Writer. Community Strategist. Building web interfaces that connect products to their target users.</span> 
                            </div>                                         
                        </div>
                                         
                    <div class="after-post-tags">
                                                    <ul class="post-categories">
	<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul>                                                                            <ul class="post-categories aretags">
                            <li><a href="https://blog.logrocket.com/tag/create-react-app/">#create-react-app</a></li> <li><a href="https://blog.logrocket.com/tag/react/">#react</a></li>                             </ul>
                                            </div>
                    
                  
                    <div class="row mb-5 prevnextlinks justify-content-center align-items-center"> 
                       <div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/mirage-js-tutorial-mocking-apis-in-react/" rel="prev">Mirage JS tutorial: Mocking APIs in React</a></div></div>
                       <div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/creative-text-styling-with-the-css-mix-blend-mode-property/" rel="next">Creative text styling with the CSS <code>mix-blend-mode</code> property</a> &raquo;</div></div>
                    </div>
                    
                </div>
        
                    
         
        
        
    </div>                 
</div>             
          
<div class="hideshare"></div>

    <div class="graybg"> 
        <div class="container"> 
                <div class="row justify-content-center listrecent listrelated">
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/uploading-files-using-multer-and-node-js/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-05-at-11.39.15-AM.png?fit=730%2C485&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/uploading-files-using-multer-and-node-js/">Uploading files using Node.js and Multer</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/dillion-megida/">
                    <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/dillion.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/dillion.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/dillion.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/dillion-megida/">Dillion Megida</a></span><br>
                    <span class="post-date">Feb 19, 2021</span>
                    <span class="dot"></span>
                    <span class="readingtime">6 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/uploading-files-using-multer-and-node-js/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/creative-text-styling-with-the-css-mix-blend-mode-property/" style="background-image:url(https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/Text-Styling-CSS-Mix-Blend-Mode.png?fit=730%2C488&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/creative-text-styling-with-the-css-mix-blend-mode-property/">Creative text styling with the CSS mix-blend-mode property</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/davidaji/">
                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/david.jpeg?resize=48%2C48&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/david.jpeg?resize=48%2C48&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/david.jpeg?resize=48%2C48&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/davidaji/">David Aji</a></span><br>
                    <span class="post-date">Feb 19, 2021</span>
                    <span class="dot"></span>
                    <span class="readingtime">4 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/creative-text-styling-with-the-css-mix-blend-mode-property/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/mirage-js-tutorial-mocking-apis-in-react/" style="background-image:url(https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/02/miragejs-tutorial-mocking-apis-react.png?fit=730%2C481&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/mirage-js-tutorial-mocking-apis-in-react/">Mirage JS tutorial: Mocking APIs in React</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/samailabala/">
                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/samaila-bala.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/samaila-bala.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/samaila-bala.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/samailabala/">Samaila Bala</a></span><br>
                    <span class="post-date">Feb 18, 2021</span>
                    <span class="dot"></span>
                    <span class="readingtime">9 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/mirage-js-tutorial-mocking-apis-in-react/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
            </div>
    <div class="clearfix"></div>
                
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/reusable-react-component-export-arrays-excel/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=34634&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.4.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=873fb9ba28fdbad239e9703a9cfc4c7adf4eafb3#parent=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
</div>
</div>        </div>                 
    </div>

    <div class="alertbar"> 
        <div class="container text-center"> 
                    </div>
    </div>

</div><!-- /.site-content -->
        
        <div class="container">
            <footer class="footer"> 
                <div class="pull-left"> Does something seem off? Email <a>support@logrocket.com</a> </div> 
                <div class="pull-right"> <div class = "footerRight">			<div id="jetpack-search-filters-2-wrapper" >
		<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field"
placeholder="Search..."
value="" name="s"
title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>   
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div>  </div> 
                <div class="clearfix"></div>
                <a href="" class="back-to-top hidden-md-down"> 
                <i class="fa fa-angle-up"></i>
                </a>
            </footer>
        </div>
        

<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202107'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text()
  });
}
};</script>	<div style="display:none">
	<div class="grofile-hash-map-b12ebc301b41cd08402e95641fd3be46">
	</div>
	<div class="grofile-hash-map-652384877690a5781ffa6746493a484c">
	</div>
	<div class="grofile-hash-map-bbab31ce6688bcacf37fbab2964ad3ab">
	</div>
	<div class="grofile-hash-map-e591191b9141482414beeafb2907b9aa">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/reusable-react-component-export-arrays-excel\/":34634};
	</script>
				<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.4.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blog.logrocket.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.6.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.4.1/modules/widgets/search/js/search-widget.js' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.6.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"ad7fb4861d","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.4.1/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.8' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.4.1/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target && (
					event.target.matches && event.target.matches( 'a.share-twitter' ) ||
					event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-twitter' )
				) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
					return false;
				}
			} );
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target && (
					event.target.matches && event.target.matches( 'a.share-linkedin' ) ||
					event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-linkedin' )
				) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
					return false;
				}
			} );
var windowOpen;
			document.body.addEventListener( 'click', function ( event ) {
				if ( event.target && (
					event.target.matches && event.target.matches( 'a.share-facebook' ) ||
					event.target.msMatchesSelector && event.target.msMatchesSelector( 'a.share-facebook' )
				) ) {
					// If there's another sharing window open, close it.
					if ( typeof windowOpen !== 'undefined' ) {
						windowOpen.close();
					}
					windowOpen = window.open( event.target.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
					return false;
				}
			} );
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=34634&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.4.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=873fb9ba28fdbad239e9703a9cfc4c7adf4eafb3#parent=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=34634&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.4.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=873fb9ba28fdbad239e9703a9cfc4c7adf4eafb3#parent=https%3A%2F%2Fblog.logrocket.com%2Freusable-react-component-export-arrays-excel%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202107.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'161333275',post:'34634',tz:'-5',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '34634' ]);
</script>
<script>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</script>
            </body>     
</html>
