<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v15.7 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>GraphQL Modules tutorial: How to modularize GraphQL schema - LogRocket Blog</title>
	<meta name="description" content="Use GraphQL Modules to break your GraphQL application into simple, reusable, feature-based modules and maintain easily scalable code." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="GraphQL Modules tutorial: How to modularize GraphQL schema - LogRocket Blog" />
	<meta property="og:description" content="Use GraphQL Modules to break your GraphQL application into simple, reusable, feature-based modules and maintain easily scalable code." />
	<meta property="og:url" content="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/" />
	<meta property="og:site_name" content="LogRocket Blog" />
	<meta property="article:published_time" content="2021-01-29T14:00:56+00:00" />
	<meta property="article:modified_time" content="2021-01-28T16:17:56+00:00" />
	<meta property="og:image" content="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?fit=730%2C484&#038;ssl=1" />
	<meta property="og:image:width" content="730" />
	<meta property="og:image:height" content="484" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Godwin Ekuma">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="9 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?fit=730%2C484&ssl=1","width":730,"height":484,"caption":"graphql modules schema modularization"},{"@type":"WebPage","@id":"https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/#webpage","url":"https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/","name":"GraphQL Modules tutorial: How to modularize GraphQL schema - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/#primaryimage"},"datePublished":"2021-01-29T14:00:56+00:00","dateModified":"2021-01-28T16:17:56+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/3a7c1eccfc2ca172684040209557a376"},"description":"Use GraphQL Modules to break your GraphQL application into simple, reusable, feature-based modules and maintain easily scalable code.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/"]}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/3a7c1eccfc2ca172684040209557a376","name":"Godwin Ekuma","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a3ab6e9a9e6c1a0a28090753f6d41853?s=96&d=mm&r=g","caption":"Godwin Ekuma"},"description":"I learn so that I can solve problems"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; GraphQL Modules tutorial: How to modularize GraphQL schema Comments Feed" href="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.6/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.6/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css'  href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/9.3.2/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.3.2/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/33501" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/paUW9B-8Il' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
    <script>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</script>


    <script>
    window.Raven && window.Raven.config('https://98e0ea7c6f2e492d94439ad5aaea48dd@e.logrocket.com/4').install()
    </script>
    <script type="text/javascript">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</script>

    <script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
    <script>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</script><style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=270%2C270&#038;ssl=1" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=de679bb724" />
		<style id="kirki-inline-styles">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</style><style>
.ai-viewports                 {--ai: 1;}
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
</head>

<body class="post-template-default single single-post postid-33501 single-format-standard">

<style>
    </style>


<header class="navbar-light bg-white fixed-top mediumnavigation">

    <div class="container">



        <div class="navarea">

<div class="nav-left">

  <a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>

<nav class="menu-container">

        <div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a><li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">PodRocket</a></ul></div></nav>

</div>

<div class="nav-right">

  <div class="menu-container">
    <div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Free Trial</a></li>
</ul></div>  </div>

</div>

        </div>

    </div>

</header>


        <!-- Begin site-content
		================================================== -->
        <div class="site-content">


<div class="container"> 
    <div class="row">         
        <div class=" col-md-2 ">           
            <div class="share">
                
                <div class="sidebarapplause">
                                </div>
                
                				<p class="sharecolour">
					Share				</p>
                
<ul class="shareitnow"><li>
        <a target="_blank" href="https://twitter.com/intent/tweet?text=GraphQL%20Modules%20tutorial:%20How%20to%20modularize%20GraphQL%20schema&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F">
        <i class="fa fa-twitter"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F">
        <i class="fa fa-facebook"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F">
        <i class="fa fa-google"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F&amp;media=https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?fit=730%2C484&ssl=1&amp;description=GraphQL%20Modules%20tutorial:%20How%20to%20modularize%20GraphQL%20schema">
        <i class="fa fa-pinterest"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F&amp;title=GraphQL%20Modules%20tutorial:%20How%20to%20modularize%20GraphQL%20schema">
        <i class="fa fa-linkedin"></i>
        </a>
    </li></ul>                		        
                
                                <div class="sep"></div>
                <div class="hidden-xs-down">      

                    <p>
                        Reply                    </p>
                    <ul>
                        <li>
                        <a class="smoothscroll" href="#comments">0<br/>
                        <svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
                        </a>
                        </li>
                    </ul>
                </div>
                            </div>			                                
        </div>
        
                    			                <div class="col-md-8 flex-first flex-md-unordered post-33501 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-graphql" id="post-33501"> 
                    <div class="mainheading">
                       
                                                <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-md-down"> 
                            <div class="col-md-2 col-xs-12"> 
                                <a href="https://blog.logrocket.com/author/godwinekuma/">
                                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/09/godwinekuma.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/09/godwinekuma.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/09/godwinekuma.jpg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                                </a>
                            </div>                                         
                            <div class="col-md-10 col-xs-12"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/godwinekuma/">
                                Godwin Ekuma <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">I learn so that I can solve problems</span> 
                            </div>                                         
                        </div>
                                                 
                                                
                        <h1 class="posttitle">GraphQL Modules tutorial: How to modularize GraphQL schema</h1>
					    <h2 class="post-subtitle"></h2>

                        <p>
                                                        <span class="post-date"><time class="post-date">
                            January 29, 2021                            </time></span>
                                                        
                                                        <span class="dot"></span>
                            <span class="readingtime">6 min read</span>
						    <span class="wordcount">1898</span>

                                                    </p> 
                    </div>
                    
                  <img width="730" height="484" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?fit=730%2C484&amp;ssl=1" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="graphql modules schema modularization" loading="lazy" data-attachment-id="33516" data-permalink="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/screen-shot-2021-01-28-at-10-37-23-am/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?fit=730%2C484&amp;ssl=1" data-orig-size="730,484" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="graphql modules schema modularization" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?fit=300%2C199&amp;ssl=1" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?fit=730%2C484&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?w=730&amp;ssl=1 730w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?resize=300%2C199&amp;ssl=1 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-28-at-10.37.23-AM.png?fit=730%2C484&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    <article class="article-post">
                                                <p>In this tutorial, we’ll show you how to use GraphQL Modules to break your GraphQL application into simple, reusable, feature-based modules.</p>
<p>We’ll cover the following:</p>
<ul>
<li><a href="#WhatareGraphQLModules">What are GraphQL Modules?</a></li>
<li><a href="#WhyUseGraphQLModules">Why use GraphQL Modules?</a></li>
<li><a href="#HowGraphQLModulesWork">How GraphQL Modules work</a></li>
<li><a href="#MergingschemaswithGraphQLModules">Merging schemas with GraphQL Modules</a></li>
<li><a href="#Dependencyinjection">Dependency injection</a></li>
</ul>
<h2 id="WhatareGraphQLModules">What are GraphQL Modules?</h2>
<p><a href="https://graphql-modules.com/">GraphQL Modules</a> is a set of libraries and guidelines designed to help you create reusable, maintainable, testable, and extendable modules. The basic concept behind GraphQL Modules is to separate your GraphQL server into smaller, independent, feature-based modules.</p>
<p>GraphQL Modules help you implement the <a href="https://deviq.com/principles/separation-of-concerns">separation of concerns</a> <a href="https://deviq.com/principles/separation-of-concerns">design pattern</a> in GraphQL, enabling you to write simple modules that only do what they need to. This makes your code easier to write, test, and maintain.</p>
<p>The structure of an initial, basic implementation of a GraphQL server would look something like this:</p>
<figure id="attachment_33512" aria-describedby="caption-attachment-33512" style="width: 174px" class="wp-caption aligncenter"><img data-attachment-id="33512" data-permalink="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/graphql-server-basic-implementation-example/" data-orig-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?fit=174%2C421&amp;ssl=1" data-orig-size="174,421" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="GraphQL Server Basic Implementation Example" data-image-description data-medium-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?fit=124%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?fit=174%2C421&amp;ssl=1" loading="lazy" class="wp-image-33512 size-full jetpack-lazy-image" src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?resize=174%2C421&#038;ssl=1" alt="GraphQL Server Basic Implementation Example" width="174" height="421" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?w=174&amp;ssl=1 174w, https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?resize=124%2C300&amp;ssl=1 124w" data-lazy-sizes="(max-width: 174px) 100vw, 174px" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?resize=174%2C421&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="33512" data-permalink="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/graphql-server-basic-implementation-example/" data-orig-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?fit=174%2C421&amp;ssl=1" data-orig-size="174,421" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="GraphQL Server Basic Implementation Example" data-image-description="" data-medium-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?fit=124%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?fit=174%2C421&amp;ssl=1" loading="lazy" class="wp-image-33512 size-full" src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?resize=174%2C421&#038;ssl=1" alt="GraphQL Server Basic Implementation Example" width="174" height="421" srcset="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?w=174&amp;ssl=1 174w, https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQL-Server-Basic-Implementation-Example-.png?resize=124%2C300&amp;ssl=1 124w" sizes="(max-width: 174px) 100vw, 174px" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-33512" class="wp-caption-text">Basic GraphQL implementation</figcaption></figure>
<p>As your GraphQL application grows, so will the complexity of your schema and resolvers, which can make schema maintenance difficult. To organize your code, you’ll want to separate your schema types and their associated resolvers into multiple files or modules and add anything related to a specific part of the app under a module. The graphql-modules library helps facilitate this gradual process.</p>
<p>With <code>graphql-modules</code>, your app would be structured as follows:</p>
<p><img data-attachment-id="33513" data-permalink="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/graphql-modules-library-app-structure/" data-orig-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?fit=496%2C601&amp;ssl=1" data-orig-size="496,601" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="GraphQL-Modules Library App Structure" data-image-description data-medium-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?fit=248%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?fit=496%2C601&amp;ssl=1" loading="lazy" class="aligncenter wp-image-33513 size-full jetpack-lazy-image" src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?resize=496%2C601&#038;ssl=1" alt="GraphQL-Modules Library App Structure" width="496" height="601" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?w=496&amp;ssl=1 496w, https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?resize=248%2C300&amp;ssl=1 248w" data-lazy-sizes="(max-width: 496px) 100vw, 496px" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?resize=496%2C601&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="33513" data-permalink="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/graphql-modules-library-app-structure/" data-orig-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?fit=496%2C601&amp;ssl=1" data-orig-size="496,601" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="GraphQL-Modules Library App Structure" data-image-description="" data-medium-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?fit=248%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?fit=496%2C601&amp;ssl=1" loading="lazy" class="aligncenter wp-image-33513 size-full" src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?resize=496%2C601&#038;ssl=1" alt="GraphQL-Modules Library App Structure" width="496" height="601" srcset="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?w=496&amp;ssl=1 496w, https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/GraphQl-Modules-Library-App-Structure.png?resize=248%2C300&amp;ssl=1 248w" sizes="(max-width: 496px) 100vw, 496px" data-recalc-dims="1" /></noscript></p>
<h2 id="WhyUseGraphQLModules">Why use GraphQL Modules?</h2>
<p>Most developers who use GraphQL Modules select the toolset for its reusable modules, scalable structure, clear path to growth, and testability. Let’s take a closer look at some of the reasons why developers turn to GraphQL Modules to write reusable, extendable modules for their GraphQL apps.</p>
<ul>
<li><strong>Reusable modules</strong>: Modules are defined by their GraphQL schema in smaller pieces, which you can later move and reuse</li>
<li><strong>Scalable structure</strong>: Each module has a clearly defined boundary, which makes managing multiple teams and features, multiple microservices, and servers a lot easier. Modules can communicate between each other using custom messages</li>
<li><strong>Clear path to growth</strong>: By separating features into modules, it’s easy to see how your application can grow from a very simple, fast, single-file modules to scalable, multi-file, -team, -repo and -server modules</li>
<li><strong>Testability</strong>: Testing small pieces of code is easier than testing larger chunks of code. GraphQL Modules provides a rich toolset for testing and mocking your application</li>
</ul>
<h2 id="HowGraphQLModulesWork">How GraphQL Modules work</h2>
<p>We’ll use a simple library application to show how to break your GraphQL application into modules. The application will have <code>Book,</code> <code>Author</code>, and <code>Genre</code> modules and each module will be composed of type definitions and resolver functions.</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br/>No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>

<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>

<h3>Creating a GraphQL module</h3>
<p>To start using <code>graphql-modules</code>, all you need is to install its package and <code>graphql</code>:</p>
<pre>// NPM
npm install --save graphql graphql-modules

//Yarn 

yarn add graphql graphql-modules
</pre>
<p>To create a module, use <code>createModule</code>:</p>
<pre>import { createModule } from 'graphql-modules';

export const myModule = createModule({
  id: 'my-module',
  dirname: __dirname,
  typeDefs: [
    `type Query {
      hello: String!
    }`,
  ],
  resolvers: {
    Query: {
      hello: () =&amp;gt; 'world',
    },
  },
});
</pre>
<p>Adding a unique <code>id</code> to the module is important because it will help you locate issues in your type definition. The <code>dirname</code>, though optional, makes it simpler to match the correct file when an exception occurs.</p>
<h3>Type definitions and resolvers</h3>
<p>For defining schemas, GraphQL Modules uses Schema Definition Language (SDL), just like GraphQL Schema.</p>
<p>GraphQL Modules also implements resolvers in the same manner as any other GraphQL implementation. According to the <a href="https://graphql-modules.com/docs/essentials/resolvers/">GraphQL Modules documentation</a>, modules created by GraphQL Modules can detect duplicate, incorrect, or old resolvers (e.g., resolvers that don&#8217;t match type definitions or extensions).</p>
<h3>Creating the book module</h3>
<p>Here’s how to create a book module for our GraphQL app:</p>
<pre>// book.type.graphql
import { gql } from 'graphql-modules';

export const Book = gql`
  type Query {
      book(id: ID!): Book
  }
  type Book {
    id: String
    title: String
    author: Author
    summary: String
    isbn: String
    genre: [Genre]
    url: String
  }
`;


// book.resolver.graphql

export const BookResolver = {
    Query: {
      book(root, { id }) {
        return {
          _id: id,
          title: "To The Lighthouse",
          author: "Virginia Woolf",
          summary:"Book summary",
          isbn: "12345678EDB"
          genre: ["ficton"],
          url: "http://lighouse.com"
        };
      },
    },
    Book: {
      id(book) {
        return book._id;
      },
      title(book) {
        return book.title;
      },
      author(book) {
        return book.author;
      },
      summary(book) {
        return book.summary;
      },
      isbn(book) {
        return book.isbn;
      },
      genre(book) {
        return book.genre;
      },
      url(book) {
        return book.url;
      },
    },
  },



// book.module.graphql.ts
import{ Book } from './book.type.graphql';
import { BookResolver } '.book.resolver.graphql';
import { createModule } from 'graphql-modules';

export const BookModule = createModule({
  id: 'book-module',
  dirname: __dirname,
  typeDefs: [Book],
  resolvers: [BookResolvers]
});
</pre>
<h3>Other modules</h3>
<p>To create the author and genre modules for our example GraphQL library app, follow the steps below:</p>
<pre>// author.module.graphql.ts
import{ Author } from './author.type.graphql';
import { AuthorResolver } '.author.resolver.graphql';
import { createModule } from 'graphql-modules';

export const AuthorModule = createModule({
  id: 'book-module',
  dirname: __dirname,
  typeDefs: [Author],
  resolvers: [AuthorResolvers]
});


// genre.module.graphql.ts
import{ Genre } from './genre.type.graphql';
import { GenreResolver } '.genre.resolver.graphql';
import { createModule } from 'graphql-modules';

export const GenreModule = createModule({
  id: 'book-module',
  dirname: __dirname,
  typeDefs: [Genre],
  resolvers: [GenreResolvers]
});
</pre>
<h2 id="MergingschemaswithGraphQLModules">Merging schemas with GraphQL Modules</h2>
<p>Each of the modules we defined contributes to a small part of the entire schema.</p>
<p>To merge the schemas together, create an <code>application</code> using GraphQL Modules’ <code>createApplication</code>:</p>
<pre>import { createApplication } from 'graphql-modules';
import { GenreModule } from './genre/genre.module.graphql';
import { BookModule } from './book/book.module.graphql';
import { AuthorModule } from './author/author.module.graphql';

export const application = createApplication({
  modules: [BookModule, AuthorModule, GenreModule],
});
</pre>
<p>The <code>application</code> contains your GraphQL schema and the implementation of it. We need to make it consumable by a GraphQL server.</p>
<p>GraphQL Modules have various implementations for popular GraphQL servers, such as <a href="https://www.apollographql.com/">Apollo</a>, <a href="https://graphql.org/graphql-js/running-an-express-graphql-server/">Express GraphQL</a>, and <a href="https://github.com/contrawork/graphql-helix">GraphQL</a> <a href="https://github.com/contrawork/graphql-helix">Helix</a>. If you’re using <a href="https://www.apollographql.com/docs/apollo-server/">Apollo</a> <a href="https://www.apollographql.com/docs/apollo-server/">Server</a>, you can use <code>createSchemaForApollo</code> to get a schema that is adapted for this server and integrates with it perfectly:</p>
<pre>import { ApolloServer } from 'apollo-server';
import { application } from './application';

const schema = application.createSchemaForApollo();

const server = new ApolloServer({
  schema,
});

server.listen().then(({ url }) =&amp;gt; {
  console.log(`🚀 Server ready at ${url}`);
});
</pre>
<h2 id="GraphQLContext">GraphQL <code>context</code></h2>
<p>In GraphQL, the <code><a href="https://www.apollographql.com/docs/apollo-server/data/resolvers/#the-context-argument">context</a></code><a href="https://www.apollographql.com/docs/apollo-server/data/resolvers/#the-context-argument">argument </a>is shared across all resolvers that are executing for a particular operation. You can use <code>context</code> to share per-operation state, including authentication data, dataloader instances, etc.</p>
<p>In GraphQL Modules, <code>context</code> is available as the third argument to each resolver and is shared across modules:</p>
<pre>const resolvers = {
  Query: {
    myQuery(root, args, context, info) {
      // ...
    },
  },
};
</pre>
<h2 id="Dependencyinjection">Dependency injection</h2>
<p>As your application expands, you may need to separate certain business logic from the resolver into a service. GraphQL Modules supports dependency injection (DI), which helps you make your services available to the resolvers.</p>
<p>Dependencies are services or objects that a resolvers needs to perform its function. So rather creating a service, a resolver requests it from an external resource.</p>
<p>It’s important to note that dependency injection makes sense only when your codebase is quite large and you need to move fast.</p>
<p>To use GraphQL Modules’ DI, there are few terms you should understand:</p>
<ul>
<li><code>injector</code> is an object in in the DI system that can find a named dependency in its cache or create a dependency using a configured provider and then make it available to a module or the entire application depending on its scope</li>
<li><code>InjectionToken</code> is a symbol (token) or class (service class) that represents an object or any value in the dependency injection space</li>
<li><code>provider</code> is a way to define a value and match it with a <code>Token</code> or a <code>Service</code> class. It provides the value of a specific injection token. Providers are injected into resolvers or other services.</li>
</ul>
<p>There are three kinds of providers: class providers, value providers, and factory providers. Let’s take a closer look at each.</p>
<h3>Class provider</h3>
<p>A class provider creates an instance of a class and makes it available to the injector. For a service class to be used as a provider, it has to be decorated with the <code>@Injectable()</code> decorator:</p>
<pre>// book.service.ts
import { Injectable } from 'graphql-modules';

@Injectable()
export class BookService {}


// book.module.graphql.ts
import{ Book } from './book.type.graphql';
import { BookResolver } '.book.resolver.graphql';
import { createModule } from 'graphql-modules';

export const BookModule = createModule({
  id: 'book-module',
  dirname: __dirname,
  typeDefs: [Book],
  resolvers: [BookResolvers],
  providers: [BookService]
});
</pre>
<p>The <code>context</code> object is available in every resolver. This <code>context</code> object contains another object, <code>injector</code>, which can be used to access a provided service class in a resolver.</p>
<pre>// book.resolver.graphql
import { BookService } from './book.service.ts'
export const BookResolver = {
    Query: {
      book(root, { id }, context) {
        const bookService = context.injector.get(BookService);
        return {
          _id: id,
         // ...
        };
      },
    },
    Book: {
      id(book) {
        return book._id;
      },
      // ...
    },
  },
</pre>
<p>To use it in a class, simply ask for it in the constructor.</p>
<pre>import { Injectable } from 'graphql-modules';
import { BookService } from './book';

@Injectable()
class AuthorService {
  constructor(private bookService: BookService) {}

  allbooks(authorId) {
     return this.bookService.books(authorId)
  }
}
</pre>
<h3>Value provider</h3>
<p>The value provider provides a ready-to-use value. It requires a token that represents a value, either <code>InjectionToken</code> or a class.</p>
<pre>import { InjectionToken } from 'graphql-modules';
const ApiKey = new InjectionToken&amp;lt;string&amp;gt;('api-key');
import { createModule } from 'graphql-modules';

export const BookModule = createModule({
  id: 'book-module',
  /* ... */
  providers: [
    {
      provide: ApiKey,
      useValue: 'my-api-key',
    },
  ],
});
</pre>
<h3>Factory provider</h3>
<p>The factory provider is a function that provides a value. It comes in handy when you need to create a dependent value dynamically based on information that would not be available until run time. You can make an informed decision on which value to return based on certain conditions of the application state.</p>
<p>The factory provider is also useful for creating an instance of a class, such as when using third-party libraries. The factory function can have an optional argument with dependencies, if any.</p>
<pre>import { InjectionToken } from 'graphql-modules';
const ApiKey = new InjectionToken&amp;lt;string&amp;gt;('api-key');
import { createModule } from 'graphql-modules';

export const BookModule = createModule({
  id: 'book-module',
  /* ... */
  providers: [
    {
      provide: ApiKey,
      useFactory(config: Config) {
        if (context.environment) {
          return 'my-api-key';
        }

        return null;
      },
      deps: [Config],
    },
  ],
});
</pre>
<p>Accessing a token in a resolver is similar to accessing a service. The <code>@Inject</code> decorator is used to access a token in a constructor.</p>
<pre>import { Injectable } from 'graphql-modules';
import { BookService } from './book';

@Injectable()
class AuthorService {
  constructor(@Inject(ApiKey) private key: string, private bookService: BookService) {}

  allbooks(authorId) {
     return this.bookService.books(authorId)
  }
}
</pre>
<h3>GraphQL scopes</h3>
<p>Each token or provider has a scope that is used to define its lifecycle. <code>Scope</code> can either be a singleton or an operation. Every provider or token defined as a singleton is created once and the same instance is available for all incoming GraphQL operations. A singleton provider lives throughout the lifecycle of the application and is the default and recommended scope for GraphQL Modules.</p>
<p>Operation providers, on the other hand, are created per execution context or for each GraphQL operation that requires it. An operation provider lives only the lifecycle of the GraphQL operation that instantiated it.</p>
<pre>// genre.service.ts
import { Injectable, Scope } from 'graphql-modules';

@Injectable({
  scope: Scope.Operation,
})
export class GenreService {}


// genre.module.graphql.ts
import{ Genre } from './genre.type.graphql';
import { GenreResolver } '.genre.resolver.graphql';
import { createModule } from 'graphql-modules';
import { GenreService } from './genre.service.ts'

export const GenreModule = createModule({
  id: 'book-module',
  dirname: __dirname,
  typeDefs: [Genre],
  resolvers: [GenreResolvers],
  providers: [GenreService]
});
</pre>
<p>When <code>GenreService</code> is not called by resolvers, the service is not created.</p>
<h2 id="conclusion">Conclusion</h2>
<p>Maintainable code is easily scalable, and GraphQL Modules aim to help you achieve just that.</p>
<p>It’s worth nothing that code separation or modularization only happens during development. However, at runtime, a unified schema is still served.</p>
<p>You should now have everything you need to get started using GraphQL Modules. To learn about other advanced concepts, such as subscription, middleware, execution context, and lifecycle hooks, you can check out <a href="https://graphql-modules.com/">GraphQL</a> <a href="https://graphql-modules.com/">Module</a><a href="https://graphql-modules.com/">s</a> <a href="https://graphql-modules.com/">documentation</a>.</p><div class='code-block code-block-25' style='margin: 8px 0; clear: both;'>
<div class="blog-plug inline-plug graphql-plug"><h2>Monitor failed and slow GraphQL requests in production</h2>While GraphQL has some features for debugging requests and responses, making sure GraphQL reliably serves resources to your production app is where things get tougher. If you’re interested in ensuring network requests to the backend or third party services are successful, <a href="https://logrocket.com/signup" target="_blank">try LogRocket</a>.<a class="signup" href="https://logrocket.com/signup" target="_blank" rel="noopener noreferrer"><img src="https://i1.wp.com/files.readme.io/69aa835-Image_2019-11-09_at_1.28.05_PM.png?ssl=1" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/files.readme.io/69aa835-Image_2019-11-09_at_1.28.05_PM.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i1.wp.com/files.readme.io/69aa835-Image_2019-11-09_at_1.28.05_PM.png?ssl=1" data-recalc-dims="1"></noscript><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" /></noscript></a><a href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">https://logrocket.com/signup/</a><p style="margin-top: 15px;"><a href="https://logrocket.com/signup" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web apps, recording literally everything that happens on your site. Instead of guessing why problems happen, you can aggregate and report on problematic GraphQL requests to quickly understand the root cause. In addition, you can track Apollo client state and inspect GraphQL queries' key-value pairs.</p>LogRocket instruments your app to record baseline performance timings such as page load time, time to first byte, slow network requests, and also logs Redux, NgRx, and Vuex actions/state. <a class="signup" href="https://logrocket.com/signup" target="_blank" rel="noopener noreferrer">Start monitoring for free</a>.</div>

<style>
.plug-poll {margin-bottom: 2rem;}
.code-block-25 .fadeIn {
    opacity:1 !important;
    height:auto !important;
}

.code-block-25 .fadeOut {
    opacity:0 !important;
}

.code-block-25 .wpcf7-email {margin: 15px 0;}

#plug-survey-errors, #plug-survey-help, #plug-survey-email  {opacity:0; height:1px; transition: all 1s;overflow:hidden; width: 100%;}

</style>

<script>
  jQuery("#plug-survey-framework input").click(function() {
  analytics.track('footer-poll', {
      'footer-poll-framework': jQuery(this).val()
    });
    jQuery('#plug-survey-framework').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-errors').delay(800).addClass('fadeIn');
  });
    jQuery("#plug-survey-errors input").click(function() {
    jQuery('#plug-survey-errors').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-help').delay(800).addClass('fadeIn');
  });
  
      jQuery("#plug-survey-help input").click(function() {
        analytics.track('footer-poll', {
      'footer-poll-help': jQuery(this).val()
    });
    jQuery('#plug-survey-help').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-email').delay(800).addClass('fadeIn');
  });
  
  </script>

</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-33501" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-33501" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-33501" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/graphql-modules-tutorial-how-to-modularize-graphql-schema/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><!-- AI CONTENT END 1 -->
                        <div class="clearfix"></div>
                                                <div class="clearfix"></div>
                    </article>
                            
                                             <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-lg-up"> 
                            <div class="col-md-2 col-xs-4"> 
                                <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/09/godwinekuma.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/09/godwinekuma.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/09/godwinekuma.jpg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                            </div>                                         
                            <div class="col-md-10 col-xs-8"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/godwinekuma/">
                                Godwin Ekuma <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">I learn so that I can solve problems</span> 
                            </div>                                         
                        </div>
                                         
                    <div class="after-post-tags">
                                                    <ul class="post-categories">
	<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul>                                                                            <ul class="post-categories aretags">
                            <li><a href="https://blog.logrocket.com/tag/graphql/">#graphql</a></li>                             </ul>
                                            </div>
                    
                  
                    <div class="row mb-5 prevnextlinks justify-content-center align-items-center"> 
                       <div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/zero-downtime-deploys-with-digitalocean-github-and-docker/" rel="prev">Zero-downtime deploys with DigitalOcean, GitHub, and Docker</a></div></div>
                       <div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"></div></div>
                    </div>
                    
                </div>
        
                    
         
        
        
    </div>                 
</div>             
          
<div class="hideshare"></div>

    <div class="graybg"> 
        <div class="container"> 
                <div class="row justify-content-center listrecent listrelated">
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/zero-downtime-deploys-with-digitalocean-github-and-docker/" style="background-image:url(https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/Screen-Shot-2021-01-22-at-1.15.13-PM.png?fit=730%2C489&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/zero-downtime-deploys-with-digitalocean-github-and-docker/">Zero-downtime deploys with DigitalOcean, GitHub, and Docker</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/thomashunter/">
                    <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/04/thomashuntr.png?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/04/thomashuntr.png?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/04/thomashuntr.png?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/thomashunter/">Thomas Hunter</a></span><br>
                    <span class="post-date">Jan 28, 2021</span>
                    <span class="dot"></span>
                    <span class="readingtime">14 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/zero-downtime-deploys-with-digitalocean-github-and-docker/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/best-practices-for-managing-and-storing-secrets-in-frontend-development/" style="background-image:url(https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/secureapikeys.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/best-practices-for-managing-and-storing-secrets-in-frontend-development/">Best practices for managing and storing secrets in frontend&hellip;</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/patienceadajah/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/patienceadajah.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/patienceadajah.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/patienceadajah.jpg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/patienceadajah/">Patience Adajah</a></span><br>
                    <span class="post-date">Jan 28, 2021</span>
                    <span class="dot"></span>
                    <span class="readingtime">6 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/best-practices-for-managing-and-storing-secrets-in-frontend-development/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/why-is-rust-popular/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2021/01/why-is-rust-popular.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/why-is-rust-popular/">Why is Rust so popular?</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/fortuneikechi/">
                    <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/FortuneIkechi.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/FortuneIkechi.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/FortuneIkechi.jpg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/fortuneikechi/">Fortune Ikechi</a></span><br>
                    <span class="post-date">Jan 28, 2021</span>
                    <span class="dot"></span>
                    <span class="readingtime">4 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/why-is-rust-popular/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
            </div>
    <div class="clearfix"></div>
                
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/graphql-modules-tutorial-how-to-modularize-graphql-schema/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=33501&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.3.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=070100885b11c2f14ebdcf83770a5ae448d5f4a4#parent=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
</div>
</div>        </div>                 
    </div>

    <div class="alertbar"> 
        <div class="container text-center"> 
                    </div>
    </div>

</div><!-- /.site-content -->
        
        <div class="container">
            <footer class="footer"> 
                <div class="pull-left"> Does something seem off? Email <a>support@logrocket.com</a> </div> 
                <div class="pull-right"> <div class = "footerRight">			<div id="jetpack-search-filters-2-wrapper" >
		<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field"
placeholder="Search..."
value="" name="s"
title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>   
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div>  </div> 
                <div class="clearfix"></div>
                <a href="" class="back-to-top hidden-md-down"> 
                <i class="fa fa-angle-up"></i>
                </a>
            </footer>
        </div>
        


<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202104'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text()
  });
}
};</script>	<div style="display:none">
	<div class="grofile-hash-map-a3ab6e9a9e6c1a0a28090753f6d41853">
	</div>
	<div class="grofile-hash-map-c0e344ddcbabb383f94b1bd3486e55ba">
	</div>
	<div class="grofile-hash-map-b5e6e698ade627aa446971c2415fc1f3">
	</div>
	<div class="grofile-hash-map-8d1d8eeb485465ffbf259208dc267d88">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/graphql-modules-tutorial-how-to-modularize-graphql-schema\/":33501};
	</script>
				<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.3.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blog.logrocket.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.6/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.3.2/modules/widgets/search/js/search-widget.js' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.6/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"acb834e384","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.3.2/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.8' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.3.2/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=33501&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.3.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=070100885b11c2f14ebdcf83770a5ae448d5f4a4#parent=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=33501&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.3.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=070100885b11c2f14ebdcf83770a5ae448d5f4a4#parent=https%3A%2F%2Fblog.logrocket.com%2Fgraphql-modules-tutorial-how-to-modularize-graphql-schema%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202104.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.3.2',blog:'161333275',post:'33501',tz:'-5',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '33501' ]);
</script>
<script>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</script>
            </body>     
</html>
