<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />


<title>Build an API with Next.js Lambda functions - LogRocket Blog</title>
<meta name="description" content="In this blog, we’ll learn about Next.js serverless functions. We&#039;ll discuss page and dynamic routes, as well as API and dynamic API routes." />
<link rel="canonical" href="https://blog.logrocket.com/build-api-next-js-lambda-functions/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Build an API with Next.js Lambda functions - LogRocket Blog" />
<meta property="og:description" content="In this blog, we’ll learn about Next.js serverless functions. We&#039;ll discuss page and dynamic routes, as well as API and dynamic API routes." />
<meta property="og:url" content="https://blog.logrocket.com/build-api-next-js-lambda-functions/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2022-09-21T16:00:49+00:00" />
<meta property="article:modified_time" content="2022-09-20T16:04:25+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="487" />
<meta property="og:image:type" content="image/png" />
<meta name="author" content="Lawrence Eagles" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Lawrence Eagles" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="9 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://blog.logrocket.com/build-api-next-js-lambda-functions/","url":"https://blog.logrocket.com/build-api-next-js-lambda-functions/","name":"Build an API with Next.js Lambda functions - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/build-api-next-js-lambda-functions/#primaryimage"},"image":{"@id":"https://blog.logrocket.com/build-api-next-js-lambda-functions/#primaryimage"},"thumbnailUrl":"https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png","datePublished":"2022-09-21T16:00:49+00:00","dateModified":"2022-09-20T16:04:25+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/b37bfea2c52f4db66ae789722e0853ae"},"description":"In this blog, we’ll learn about Next.js serverless functions. We'll discuss page and dynamic routes, as well as API and dynamic API routes.","breadcrumb":{"@id":"https://blog.logrocket.com/build-api-next-js-lambda-functions/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/build-api-next-js-lambda-functions/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blog.logrocket.com/build-api-next-js-lambda-functions/#primaryimage","url":"https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png","contentUrl":"https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png","width":730,"height":487,"caption":"Build An Api With Next.js Lambda Functions"},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/build-api-next-js-lambda-functions/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://blog.logrocket.com/"},{"@type":"ListItem","position":2,"name":"Build an API with Next.js Lambda functions"}]},{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://blog.logrocket.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/b37bfea2c52f4db66ae789722e0853ae","name":"Lawrence Eagles","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blog.logrocket.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/37e15aae62c51e948e2d56b2820c49a7?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/37e15aae62c51e948e2d56b2820c49a7?s=96&d=mm&r=g","caption":"Lawrence Eagles"},"description":"Senior full-stack developer, writer, and instructor.","url":"https://blog.logrocket.com/author/lawrenceoputa/"}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Build an API with Next.js Lambda functions Comments Feed" href="https://blog.logrocket.com/build-api-next-js-lambda-functions/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/6.0.0-beta2/css/all.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=11.4-a.5' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.4-a.5' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/132891" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-yzp' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<script src="//geoip-js.com/js/apis/geoip2/v2.1/geoip2.js" type="text/javascript"></script>
<script src="https://storage.googleapis.com/lr-marketing-js/lr-web-analytics/script/4.js"></script>
<script>
    function geoipCountry() {
      return new Promise((resolve, reject) => {
        window.geoip2.country(resolve, reject);
      });
    }
</script>
<script>
  (async function () {
    let geoipResponse;
    try {
      geoipResponse = await geoipCountry();
    } catch (err) {
      // Geoip potentially got blocked.
      // TODO: add this to the analytics proxy
      console.error('geoip blocked');
    }

    window.lr_analytics.init({
      analyticsProxy: {
        enabled: true,
      },
      segment: {
        enabled: true,
        writeKey: 'hn3yvJCms37nkkjrwDQ08PuKJKydGtAZ',
        load: true,
      },
      sixSense: {
        enabled: () => {
          if (!geoipResponse) {
            return false;
          }

          if (geoipResponse.country.iso_code === 'US') {
            return true;
          } else if (geoipResponse.continent.code === 'NA' || geoipResponse.continent.code === 'EU') {
            return false;
          } else {
            return true;
          }
        },
        apiKey: 'd5fbd2e5f08cba3d3d417f7a67cd8d1f',
        companyDetails: {
          enabled: () => geoipResponse.country.iso_code === 'US',
          apiKey: 'a2d1a28025c555de9af13fd94f96f9044dbb8331',
          callback: window.lr_analytics.sixSenseCallbacks.personalizeBlogPost
        },
      },
      redditPixel: {
        enabled: true,
        accountId: 't2_3xdvtyx2',
      },
      vwo: {
        enabled: true,
        accountId: 338524
      },
      utmMediumHash: {
        enabled: true,
      }
    });

    analytics.page();
  })()

</script>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://a39e555ed62c408792586c55bbb2ce3b@e.logrocket.com/9').install()
    </script><style>img#wpstats{display:none}</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=4ebfe50e4a" /><style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-132891 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="nav-left">

<a class="blog-logo" href='https://logrocket.com' rel='home'><img src='https://blog.logrocket.com/wp-content/uploads/2022/09/logrocket-logo-frontend-analytics.png' alt='LogRocket Blog'></a>
<div class="col-lg-4 col-md-4 mr-auto col-xs-12 text-right searcharea">
</div>

<div class="navarea">
<nav class="navbar navbar-toggleable-sm">
<button class="navbar-toggler navbar-toggler-right" type="button" data-toggle="collapse" data-target="#bs4navbar" aria-controls="bs4navbar" aria-expanded="false" aria-label="Toggle navigation">
<span class="navbar-toggler-icon"></span>
</button>
<div id="bs4navbar" class="collapse navbar-collapse"><ul id="menu-primary" class="navbar-nav col-md-12 justify-content-center"><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6 nav-item dropdown"><a href="#" class="nav-link dropdown-toggle">Blog</a>
<div class="dropdown-menu">
<a href="/" class="dropdown-item">Dev</a><a href="https://blog.logrocket.com/product-management" class="dropdown-item">Product Management</a></div>
<li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">Podcast</a><li id="menu-item-72923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72923 nav-item"><a href="https://blog.logrocket.com/tech-meetups/" class="nav-link">Meetups</a></ul></div> </nav>
</div>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Start monitoring for free</a></li>
</ul></div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container container-first-lr">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Build%20an%20API%20with%20Next.js%20Lambda%20functions&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png&amp;description=Build%20an%20API%20with%20Next.js%20Lambda%20functions">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions%2F&amp;title=Build%20an%20API%20with%20Next.js%20Lambda%20functions">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-132891 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-nextjs" id="post-132891">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/lawrenceoputa/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/08/lawrenceo-150x150.jpg" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/08/lawrenceo-150x150.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/08/lawrenceo-150x150.jpg' class='avatar avatar-72 photo' height='72' width='72'  /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/lawrenceoputa/">
Lawrence Eagles <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Senior full-stack developer, writer, and instructor.</span>
</div>
</div>
<h1 class="posttitle">Build an API with Next.js Lambda functions</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
September 21, 2022 </time></span>
<span class="dot"></span>
<span class="readingtime">6 min read</span>
<span class="wordcount">1698</span>
</p>
</div>
<img width="730" height="487" src="https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="Build An Api With Next.js Lambda Functions" data-attachment-id="132936" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/build-api-next-js-lambda-functions-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Build api nextjs lambda functions" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions-300x200.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions-300x200.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/09/build-api-next-js-lambda-functions.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> <article class="article-post">
<p>Next.js is a React framework for creating prerendered React websites. This is all done via server-side rendering or static site generation.</p>
<p>In server-side rendering, or SSR, Next.js renders React components into HTML pages on the server after a page request comes from the browser. While in static site generation, or SSG, Next.js renders React components into HTML pages at build time. We simply deploy the web pages and JavaScript bundles to the server.</p>
<p>Whether you are using SSR or SSG in Next.js, your React components are already rendered into HTML pages by the time they reach the browser. Consequently, all routing is handled in the browser and the app behaves like a single-page application (SPA). In contrast to this, React renders components in the browser through client-side rendering.</p>
<p>With Next.js, we get both SSG and SSR benefits, such as improved performance and better SEO.</p>
<p>In this article, we’ll learn about another great feature of Next.js — serverless functions. We will begin by discussing Next.js page routes and dynamic routes and later build on our knowledge to learn about Next.js API and dynamic API routes.</p>
<ul>
<li><a href="#introduction-lambda-functions-next-js">Introduction to Lambda functions in Next.js</a></li>
<li><a href="#prerequisites">Prerequisites</a></li>
<li><a href="#setting-up-application">Setting up our application</a></li>
<li><a href="#page-routes-next-js">Page routes in Next.js</a></li>
<li><a href="#dynamic-routes-next-js">Dynamic routes in Next.js</a></li>
<li><a href="#api-routing-next-js-lambda-functions">API routing with Next.js Lambda functions</a>
<ul style="margin-bottom: 0px; padding-bottom: 0px;">
<li><a href="#request-handler-function">The request handler function</a></li>
</ul>
</li>
<li><a href="#dynamic-api-routes">Dynamic API routes</a></li>
<li><a href="#advantages-api-routes">Advantages of API routes</a></li>
</ul>
<h2 id="introduction-lambda-functions-next-js">Introduction to Lambda functions in Next.js</h2>
<p>Lambda functions are just a naming convention. AWS calls them Lambda functions but Vercel calls them serverless functions — they&#8217;re the same thing.</p>
<p>Serverless functions are not directly a part of the Next.js API. However, Next.js provides developers with <a href="https://blog.logrocket.com/serverless-deployments-vercel-node-js/" target="_blank" rel="noopener">API routes that can be deployed on Vercel as serverless functions</a>. And this is the crux of this article.</p>
<h2 id="prerequisites">Prerequisites</h2>
<p>To benefit the most from this article, the following prerequisites are required:</p>
<ul>
<li>Basic understanding of JavaScript</li>
<li>Basic understanding of Next.js</li>
<li>Basic understanding of API design</li>
<li>The latest Node.js version installed on your system</li>
</ul>
<h2 id="setting-up-application">Setting up our application</h2>
<p>We will start by bootstrapping a Next.js application and use <code>create-next-app</code> to automatically set everything up. To create a Next.js project, run the following command:</p>
<pre class="language-bash hljs">yarn create next-app
</pre>
<p>After the installation is complete, start your app by running <code>yarn dev</code>. When you visit <code>localhost:3000</code>, you will get:</p><div class='code-block code-block-57' style='margin: 8px 0; clear: both;'>
<hr>
<div style="display:block; margin-bottom: 20px;">
<a href="https://lp.logrocket.com/blg/learn-more" class="embed-link">
<div class="tweet-embed-container">
<div class="single-tweet">
<img src="https://blog.logrocket.com/wp-content/uploads/2022/08/tweet-embed.png" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/08/tweet-embed.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img data-lazy-fallback="1" src="https://blog.logrocket.com/wp-content/uploads/2022/08/tweet-embed.png" /></noscript>
</div>
<div class="embed-tweet-right">
<h2>Over 200k developers use LogRocket to create better digital experiences</h2>
<div class="embed-btn"><img src="https://blog.logrocket.com/wp-content/uploads/2022/08/rocket-button-icon.png" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/08/rocket-button-icon.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img data-lazy-fallback="1" src="https://blog.logrocket.com/wp-content/uploads/2022/08/rocket-button-icon.png" /></noscript>Learn more →</div>
</div>
</div></a></div>
<hr>
<style>
@media all and (max-width: 800px){
    .tweet-embed-container {flex-direction: column !important;}
    .single-tweet, .embed-tweet-right {width: 100% !important;}
}
.embed-link {text-decoration: none;}
.embed-link:hover {text-decoration: none;}
.tweet-embed-container {border-radius: 20px;
  background: radial-gradient(79.69% 102.24% at 100% 100.11%, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0)), radial-gradient(89.7% 115.09% at 3.43% 2.75%, rgba(255, 255, 255, 0.7), rgba(255, 255, 255, 0)), #764ABC;
background-blend-mode: overlay, overlay, normal;
  box-shadow: 0 4px 0 #d5d5d5;
  width: auto;
  padding: 10px 15px;
  display: flex;
  flex-direction: row;
  justify-content: space-evenly;
  align-items: center;
  margin: 0 auto;
  gap: 3%;
}
.single-tweet {width: 50%;}
.single-tweet img {max-width: 100%;height: auto;}
.embed-tweet-right {width: 46%;}
.embed-tweet-right h2 {padding-top: 20px;font-family: 'Avenir';
font-style: normal;
font-weight: 500;
font-size: 16px;
line-height: 28px;
color: #FFFFFF;}
.embed-btn {
  display: flex;
  flex-direction: row;
  justify-content: left;
  width: 170px;
  gap: 5px;
  align-items: center;
  padding: 0px 10px;
  font-family: 'Avenir';
font-style: normal;
font-weight: 900;
font-size: 16px;
line-height: 16px;
color: #764ABC;
height: 48px;
/* White */
background: #FFFFFF;
mix-blend-mode: normal;
box-shadow: 0px 24px 30px rgba(0, 0, 0, 0.11);
border-radius: 80px;
  border: none;
}</style></div>
<p><img data-attachment-id="132900" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/next-welcome-screen/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen.png" data-orig-size="730,382" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="next-welcome-screen" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen.png" class="aligncenter size-full wp-image-132900 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen.png" alt="Next.js Welcome Screen" width="730" height="382" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen-300x157.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="132900" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/next-welcome-screen/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen.png" data-orig-size="730,382" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="next-welcome-screen" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen.png" loading="lazy" class="aligncenter size-full wp-image-132900" src="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen.png" alt="Next.js Welcome Screen" width="730" height="382" srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/next-welcome-screen-300x157.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<h2 id="page-routes-next-js">Page routes in Next.js</h2>
<p>Before talking about API Routes, <a href="https://blog.logrocket.com/what-you-need-know-new-next-js-router/" target="_blank" rel="noopener">let&#8217;s learn about page routes</a>.</p>
<p>In Next.js, each page is driven by a component. For example, an “About” page will have an <code>About</code> component and a “Contact” page will have a <code>Contact</code> component. Each page component has a file inside the <code>pages</code> folder, thus, the file name and location of each page component are tied to the particular page’s route.</p>
<p>To elaborate on this, navigate your browser to <code>localhost:3000/about</code> and you will get:</p>
<p><img data-attachment-id="132902" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/about-page-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page.png" data-orig-size="730,383" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="about-page" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page.png" class="aligncenter size-full wp-image-132902 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page.png" alt="About Page With Error" width="730" height="383" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-300x157.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="132902" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/about-page-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page.png" data-orig-size="730,383" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="about-page" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page.png" loading="lazy" class="aligncenter size-full wp-image-132902" src="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page.png" alt="About Page With Error" width="730" height="383" srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-300x157.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>The <code>404</code> page shown above simply means that Next.js cannot find a component in the <code>page</code> folder called <code>about</code>. This is because we have not created an <code>about</code> component in the <code>pages</code> folder.</p>
<p>To resolve this, create an <code>about.js</code> file inside the <code>pages</code> directory and add the following code:</p><div class='code-block code-block-54' style='margin: 8px 0; clear: both;'>
<hr>
<h3>More great articles from LogRocket:</h3>
<ul>
<li>Don't miss a moment with <a href="https://lp.logrocket.com/subscribe-thereplay">The Replay</a>, a curated newsletter from LogRocket</li>
<li>Use React's useEffect <a href="https://blog.logrocket.com/understanding-react-useeffect-cleanup-function/">to optimize your application's performance</a></li>
<li>Switch between <a href="https://blog.logrocket.com/switching-between-node-versions-during-development/">multiple versions of Node</a></li>
<li><a href="https://blog.logrocket.com/animate-react-app-animxyz/">Learn how to animate</a> your React app with AnimXYZ</li>
<li><a href="https://blog.logrocket.com/rust-solid-js-tauri-desktop-app/">Explore Tauri</a>, a new framework for building binaries</li>
<li>Compare <a href="https://blog.logrocket.com/nestjs-vs-express-js/">NestJS vs. Express.js</a></li>
<li><a href="https://blog.logrocket.com/best-typescript-orms/">Discover</a> popular ORMs used in the TypeScript landscape</li>
</ul>
<hr></div>
<pre class="language-javascript hljs">const About = () =&gt; {
    return (
        &lt;div&gt;
            &lt;h1&gt;Hello World!&lt;/h1&gt;
        &lt;/div&gt;
    )
};
export default About;
</pre>
<p>Now, revisit <code>localhost:3000/about</code> and you get:</p>
<p><img data-attachment-id="132904" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/about-page-working/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working.png" data-orig-size="730,382" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="about-page-working" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working.png" class="aligncenter size-full wp-image-132904 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working.png" alt="About Page Working" width="730" height="382" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working-300x157.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="132904" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/about-page-working/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working.png" data-orig-size="730,382" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="about-page-working" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working.png" loading="lazy" class="aligncenter size-full wp-image-132904" src="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working.png" alt="About Page Working" width="730" height="382" srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/about-page-working-300x157.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>When we created the <code>About</code> component in the <code>pages</code> folder, Next.js automatically created a route to serve the <code>About</code> component. Thus, the route name is tied to the file name.</p>
<h2 id="dynamic-routes-next-js">Dynamic routes in Next.js</h2>
<p>Next.js pages support <a href="https://nextjs.org/docs/routing/dynamic-routes" target="_blank" rel="noopener">dynamic routes</a>. This is useful because complex applications require more than just defining routes by using predefined paths.</p>
<p>In Next.js, you can add brackets to a page component name, <code>[param].js</code>, to create a dynamic route for example. The page can be accessed via its dynamic route: <code>pages/users/[param].js</code>. Here, <code>[param]</code> is the page’s id, slug, pretty URLs, etc. Any route like <code>/users/1</code> or <code>/users/abcdef</code> can be matched.</p>
<p>Next.js will send the matched path parameter as a query parameter to the page. And if there are other query parameters, Next.js will link the matched path parameter with them.</p>
<p>To elaborate on this, the matched route <code>/users/abcdef</code> of a dynamic route <code>pages/users/[param].js</code>, will have the query object:</p>
<pre class="language-javascript hljs">{ "param": "abcdef" }
</pre>
<p>Similarly, the matched route <code>/users/abcdef?foo=bar</code> of a dynamic route, <code>pages/users/[param].js</code>, will have the following <code>query</code> object:</p>
<pre class="language-javascript hljs">{ "foo": "bar", "pid": "abc" } 
</pre>
<p>In your application, create a <code>user</code> folder, and inside it create a component named <code>[username.js</code>. Add the following code to the component:</p>
<pre class="language-javascript hljs">import { useRouter } from "next/router";
const User = () =&gt; {
    const router = useRouter();
    const username = router.query["username"];
    return (
        &lt;div&gt;
            &lt;h1&gt;Hello! Welcome {username} &lt;/h1&gt;
        &lt;/div&gt;
    );
};
export default User;
</pre>
<p>Now, when you visit <code><a href="http://localhost:3000/users/lawrenceagles" rel="nofollow">http://localhost:3000/users/lawrenceagles</a></code>, you get:</p>
<p><img data-attachment-id="132908" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/users-lawrenceeagles-screen/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen.png" data-orig-size="730,385" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Users lawrenceeagles screen" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen-300x158.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen.png" class="aligncenter size-full wp-image-132908 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen.png" alt="Users Lawrence Eagles Screen" width="730" height="385" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen-300x158.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="132908" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/users-lawrenceeagles-screen/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen.png" data-orig-size="730,385" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Users lawrenceeagles screen" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen-300x158.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen.png" loading="lazy" class="aligncenter size-full wp-image-132908" src="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen.png" alt="Users Lawrence Eagles Screen" width="730" height="385" srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/users-lawrenceeagles-screen-300x158.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>From our demonstration above, you see that Next automatically matched <code>/users/lawrenceagles</code> with the dynamic route <code>pages/users/[username].js</code>. Thus, whatever <code>username</code> is passed in the route will be displayed on the page. You can try out different usernames.</p>
<p>In addition to creating and serving pages with the page routes, Next.js can create APIs with the API routes. Building upon our knowledge so far, let’s learn about Next.js API routes in the next section.</p>
<h2 id="api-routing-next-js-lambda-functions">API routing with Next.js Lambda functions</h2>
<p><a href="https://nextjs.org/blog/next-9" target="_blank" rel="noopener">API routes were introduced in Next.js v9</a>. They enable us to build backend application endpoints, leveraging hot reloading and a unified build pipeline in the process.</p>
<p>What this means is that Next ≥v9 encapsulates both the frontend and backend. We can rapidly develop full-stack React and Node.js applications that scale effortlessly.</p>
<p>While the page routes serve Next.js pages as web pages, Next.js API routes are treated as an endpoint. The API routes live inside the <code>/pages/api</code> folder and Next.js maps any file inside that folder to <code>/api/*</code> as an endpoint.</p>
<p>This feature is very interesting because it enables Next.js to render data on the frontend that is stored in the Next.js app or render data that is fetched using Next.js API routes.</p>
<p>By bootstrapping your application with <code>create-next-app</code>, Next.js automatically creates an example API route, the <code>/pages/api/hello.js</code> file, for you. Inside <code>/pages/api/hello.js</code>, Next.js creates and exports a function named <code>handler</code> that returns a JSON object.</p>
<p>You can access this endpoint via the browser by navigating to <code><a href="http://localhost:3000/api/hello" rel="nofollow">http://localhost:3000/api/hello</a></code> and the following JSON is returned:</p>
<pre class="language-javascript hljs">{
  "name": "John Doe"
}
</pre>
<h3 id="request-handler-function">The request handler function</h3>
<p>As seen above, to create a Next.js API route, you need to export a request handler function as default. The request handler function receives two parameters:</p>
<ul>
<li><code>req</code>: an object that is an instance of <code><a href="https://nodejs.org/api/http.html#class-httpincomingmessage" target="_blank" rel="noopener">http.IncomingMessage</a></code>, and some <a href="https://nextjs.org/docs/api-routes/request-helpers" target="_blank" rel="noopener">prebuilt middlewares</a></li>
<li><code>res</code>: an object that is an instance of <code><a href="https://nodejs.org/api/http.html#class-httpserverresponse" target="_blank" rel="noopener">http.ServerResponse</a></code>, plus some <a href="https://nextjs.org/docs/api-routes/response-helpers" target="_blank" rel="noopener">helper functions</a></li>
</ul>
<p>To build an API with the API route, create a folder called <code>data</code> in the root directory. Create a <code>post.json</code> file inside the <code>data</code> folder with the following code:</p>
<pre class="language-javascript hljs">[
    {
        "Title": "I am title 1",
        "Body": "Hello from post 1"
    },
    {
        "Title": "I am title 2",
        "Body": "Hello from post 2"
    },
    {
        "Title": "I am title 3",
        "Body": "Hello from post 3"
    },
    {
        "Title": "I am title 4",
        "Body": "Hello from post 4"
    },
    {
        "Title": "I am title 5",
        "Body": "Hello from post 5"
    }
]
</pre>
<p>Now, in the <code>pages/api/</code> folder, create a new file called <code>posts.js</code> with the following code:</p>
<pre class="language-javascript hljs">// Next.js API route support: https://nextjs.org/docs/api-routes/introduction
import posts from "../../data/posts.json"
export default function handler(req, res) {
    res.status(200).json(posts)
}
</pre>
<p>In the API route above, the handler function imports the JSON data, <code>posts</code>, and returns it as a response to a <code>GET</code> request. When you query for this data by visiting <code><a href="http://localhost:3000/api/posts" rel="nofollow">http://localhost:3000/api/posts</a></code> from the browser, you get:</p>
<p><img data-attachment-id="132910" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/posts-results-page/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page.png" data-orig-size="730,381" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Posts results page" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page.png" class="aligncenter size-full wp-image-132910 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page.png" alt="Posts Results Page" width="730" height="381" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page-300x157.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="132910" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/posts-results-page/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page.png" data-orig-size="730,381" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Posts results page" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page.png" loading="lazy" class="aligncenter size-full wp-image-132910" src="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page.png" alt="Posts Results Page" width="730" height="381" srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/posts-results-page-300x157.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>You can use the <code>request.method</code> object as seen below to handle other HTTP requests:</p>
<pre class="language-javascript hljs">export default (req, res) =&gt; {
  switch (req.method) {
    case 'GET':
      //...
      break
    case 'POST':
      //...
      break
    case 'PUT':
      //...
      break
    case 'DELETE':
      //...
      break
    default:
      res.status(405).end() // Method not allowed
      break
  }
}
</pre>
<h2 id="dynamic-api-routes">Dynamic API routes</h2>
<p>Like page routes, Next API routes support <a href="https://nextjs.org/docs/routing/dynamic-routes" target="_blank" rel="noopener">dynamic routes</a>. And <a href="https://nextjs.org/docs/api-routes/dynamic-api-routes" target="_blank" rel="noopener">dynamic API routes</a> follow the same file naming rules used for page routes.</p>
<p>To elaborate on this, create a <code>posts</code> folder inside the <code>pages/api/</code> folder. Create a file named <code>[postid.js]</code> inside the <code>posts</code> folder and the following code to it:</p>
<pre class="language-javascript hljs">// Next.js API route support: https://nextjs.org/docs/api-routes/introduction
import posts from "../../../data/posts.json"
export default function handler(req, res) {
    const { postid } = req.query;
    const post = posts.find((post =&gt; post.id === parseInt(postid)));
    res.status(200).json(post)
}
</pre>
<p>In the code above, Next automatically matched the <code>/posts/1</code> path with the dynamic route <code>pages/posts/[postid].js</code>. Whichever post <code>id</code> is passed to the route <code>/posts/[postid]</code>: <code>/post/2</code>, <code>/post/3</code>, <code>/post/4</code>, etc. will be available in the <code>req.query</code> object.</p>
<p>The request handler function above retrieves the passed post <code>id</code> from the <code>req.query</code> object, finds the post in the <code>posts</code> array, and sends it to the client.</p>
<p>So to get the post with an <code>id</code> of <code>1</code>, navigate your browser to <code><a href="http://localhost:3000/api/posts/1" rel="nofollow">http://localhost:3000/api/posts/1</a></code>. You will get:</p>
<p><img data-attachment-id="132913" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/posts-1-results/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results.png" data-orig-size="730,382" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Posts 1 results" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results.png" class="aligncenter size-full wp-image-132913 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results.png" alt="Posts With Id 1 Results" width="730" height="382" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results-300x157.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="132913" data-permalink="https://blog.logrocket.com/build-api-next-js-lambda-functions/attachment/posts-1-results/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results.png" data-orig-size="730,382" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Posts 1 results" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results-300x157.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results.png" loading="lazy" class="aligncenter size-full wp-image-132913" src="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results.png" alt="Posts With Id 1 Results" width="730" height="382" srcset="https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/09/posts-1-results-300x157.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<h2 id="advantages-api-routes">Advantages of API routes</h2>
<p>Next.js API routes are deployed as serverless functions in Vercel. This means they can be deployed to <a href="https://vercel.com/docs/concepts/functions/serverless-functions/regions#multiple-regions" target="_blank" rel="noopener">many regions across the world</a> to improve latency and availability.</p>
<p>Also, as serverless functions, they are cost-effective and enable you to run your code on demand. This removes the need to manage infrastructure, provision servers, or upgrade hardware.</p>
<p>Another benefit of API routes is that they scale very well. Finally, they do not specify CORS by default because they are <code>same-origin</code>, however, you can customize this behavior by using the <a href="https://github.com/vercel/next.js/blob/canary/examples/api-routes-cors/pages/api/cors.ts" target="_blank" rel="noopener">CORS request helper</a>.</p>
<h2 id="conclusion">Conclusion</h2>
<p>In this article, we learned about an interesting and powerful Next.js feature — API routes. We began by learning about the Next.js page route and delved into API routes. We also learned how to build an API using Next API routes, deployed as Vercel’s serverless function.</p>
<p>I do hope that at the end of this article, you can build APIs using Next.js APIs Route!</p><div class='code-block code-block-30' style='margin: 8px 0; clear: both;'>
<div class="blog-plug inline-plug next-plug"><h2><a href="https://lp.logrocket.com/blg/signup" target="_blank">LogRocket</a>: Full visibility into production Next.js apps</h2> Debugging Next applications can be difficult, especially when users experience issues that are difficult to reproduce. If you’re interested in monitoring and tracking state, automatically surfacing JavaScript errors, and tracking slow network requests and component load time, <a href="https://lp.logrocket.com/blg/signup" target="_blank">try LogRocket</a>. <a class="signup" href="https://lp.logrocket.com/blg/signup" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png" data-lazy-src="https://files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" class="alignnone size-full wp-image-46" src="https://files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png"  /></noscript></a><a class="signup" href="https://lp.logrocket.com/blg/signup" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" class="alignnone size-full wp-image-46" src="https://blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677"  /></noscript></a><p style="margin-top: 15px;"><a href="https://lp.logrocket.com/blg/signup" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web and mobile apps, recording literally everything that happens on your Next app. Instead of guessing why problems happen, you can aggregate and report on what state your application was in when an issue occurred. LogRocket also monitors your app's performance, reporting with metrics like client CPU load, client memory usage, and more.</p><p>The LogRocket Redux middleware package adds an extra layer of visibility into your user sessions. LogRocket logs all actions and state from your Redux stores. </p><p>Modernize how you debug your Next.js apps — <a class="signup" href="https://lp.logrocket.com/blg/signup" target="_blank" rel="noopener noreferrer">start monitoring for free</a>.</p></div></div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-132891" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/build-api-next-js-lambda-functions/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/build-api-next-js-lambda-functions/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-132891" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/build-api-next-js-lambda-functions/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-132891" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/build-api-next-js-lambda-functions/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/08/lawrenceo-150x150.jpg" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/08/lawrenceo-150x150.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/08/lawrenceo-150x150.jpg' class='avatar avatar-72 photo' height='72' width='72'  /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/lawrenceoputa/">
Lawrence Eagles <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Senior full-stack developer, writer, and instructor.</span>
</div>
</div>
<div class="after-post-tags">
<ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/nextjs/">#nextjs</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/5-mantine-hooks-simplifying-ui-management-react/" rel="prev">5 Mantine Hooks for simplifying UI management in React</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/lighting-basics-unity/" rel="next">The basics of lighting in Unity</a> &raquo;</div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/lighting-basics-unity/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/09/lighting-basics-unity.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/lighting-basics-unity/">The basics of lighting in Unity</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/fimberelemuwa/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/06/fimber-elemuwa-150x150.png?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/06/fimber-elemuwa-150x150.png?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/06/fimber-elemuwa-150x150.png?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/fimberelemuwa/">Fimber Elemuwa</a></span><br>
<span class="post-date">Sep 21, 2022</span>
<span class="dot"></span>
<span class="readingtime">4 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/lighting-basics-unity/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/5-mantine-hooks-simplifying-ui-management-react/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/09/5-mantine-hooks-simplifying-ui-management-react.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/5-mantine-hooks-simplifying-ui-management-react/">5 Mantine Hooks for simplifying UI management in React</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/chinwikemaduabuchi/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/11/chinwike.jpeg" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/11/chinwike.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/11/chinwike.jpeg' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/chinwikemaduabuchi/">Chinwike Maduabuchi</a></span><br>
<span class="post-date">Sep 21, 2022</span>
<span class="dot"></span>
<span class="readingtime">5 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/5-mantine-hooks-simplifying-ui-management-react/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/using-convex-for-state-management/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/09/guide-using-convex-state-management-nocdn.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/using-convex-for-state-management/">A guide to using Convex for state management</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/anshumanbhardwaj/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/09/anshuman-bhardwaj-150x150.jpeg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/09/anshuman-bhardwaj-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/09/anshuman-bhardwaj-150x150.jpeg?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/anshumanbhardwaj/">Anshuman Bhardwaj</a></span><br>
<span class="post-date">Sep 21, 2022</span>
<span class="dot"></span>
<span class="readingtime">9 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/using-convex-for-state-management/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/build-api-next-js-lambda-functions#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=132891&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;jetpack_comments_nonce=77c1ffa14e&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=11.4-a.5&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=0481dff35021915f1488f7165762a43ac2f3bdc1#parent=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="footerRight"><form role="search" method="get" action="https://blog.logrocket.com/" class="wp-block-search__button-outside wp-block-search__text-button alignright wp-block-search"><label for="wp-block-search__input-1" class="wp-block-search__label screen-reader-text">Search</label><div class="wp-block-search__inside-wrapper " style="width: 100%"><input type="search" id="wp-block-search__input-1" class="wp-block-search__input " name="s" value="" placeholder="" required /><button type="submit" class="wp-block-search__button has-text-color " style="color: #764abc">Search</button></div></form></div> <div class="clearfix"></div>
<a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script defer id="bilmur" data-provider="wordpress.com" data-service="atomic" src="https://s0.wp.com/wp-content/js/bilmur.min.js?m=202238"></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length && document.location.href.indexOf('product-management') === -1) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text(),
	postAuthor: jQuery("meta[name='twitter:data1']").attr("content"),
	id: jQuery(".mainheading").closest(".col-md-8").attr("id").replace('post-','')
  });
}
jQuery(".aretags li a:contains('archive')").parent('li').hide();
jQuery(".aretags li a:contains('86919')").parent('li').hide();
jQuery(".aretags li a:contains('72293')").parent('li').hide();
};</script> <div style="display:none">
<div class="grofile-hash-map-37e15aae62c51e948e2d56b2820c49a7">
</div>
<div class="grofile-hash-map-6ac7af8ca4963133c43a0803450c8a4a">
</div>
<div class="grofile-hash-map-4ee46e80e195619f24b562b2ca75af0d">
</div>
<div class="grofile-hash-map-91438a5ee02e487a0920191a257e0127">
</div>
</div>
<div id="jp-carousel-loading-overlay">
<div id="jp-carousel-loading-wrapper">
<span id="jp-carousel-library-loading">&nbsp;</span>
</div>
</div>
<div class="jp-carousel-overlay" style="display: none;">
<div class="jp-carousel-container">

<div class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions" itemscope itemtype="https://schema.org/ImageGallery">
<div class="jp-carousel swiper-wrapper"></div>
<div class="jp-swiper-button-prev swiper-button-prev">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white" />
</mask>
<g mask="url(#maskPrev)">
<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
<div class="jp-swiper-button-next swiper-button-next">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white" />
</mask>
<g mask="url(#maskNext)">
<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
</div>

<div class="jp-carousel-close-hint">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white" />
 </mask>
<g mask="url(#maskClose)">
<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>

<div class="jp-carousel-info">
<div class="jp-carousel-info-footer">
<div class="jp-carousel-pagination-container">
<div class="jp-swiper-pagination swiper-pagination"></div>
<div class="jp-carousel-pagination"></div>
</div>
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-caption"></h2>
</div>
<div class="jp-carousel-photo-icons-container">
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white" />
</mask>
<g mask="url(#maskInfo)">
<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</span>
</a>
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white" />
</mask>
<g mask="url(#maskComments)">
<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
</span>
</a>
</div>
</div>
<div class="jp-carousel-info-extra">
<div class="jp-carousel-info-content-wrapper">
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-title"></h2>
</div>
<div class="jp-carousel-comments-wrapper">
<div id="jp-carousel-comments-loading">
<span>Loading Comments...</span>
</div>
<div class="jp-carousel-comments"></div>
<div id="jp-carousel-comment-form-container">
<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
<div id="jp-carousel-comment-post-results"></div>
<form id="jp-carousel-comment-form">
<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
<textarea name="comment" class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea" id="jp-carousel-comment-form-comment-field" placeholder="Write a Comment..."></textarea>
<div id="jp-carousel-comment-form-submit-and-info-wrapper">
<div id="jp-carousel-comment-form-commenting-as">
<fieldset>
<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
</fieldset>
<fieldset>
 <label for="jp-carousel-comment-form-author-field">Name (Required)</label>
<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-url-field">Website</label>
<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
</fieldset>
</div>
<input type="submit" name="submit" class="jp-carousel-comment-form-button" id="jp-carousel-comment-form-button-submit" value="Post Comment" />
</div>
</form>
</div>
</div>
<div class="jp-carousel-image-meta">
<div class="jp-carousel-title-and-caption">
<div class="jp-carousel-photo-info">
<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
</div>
<div class="jp-carousel-photo-description"></div>
</div>
<ul class="jp-carousel-image-exif" style="display: none;"></ul>
<a class="jp-carousel-image-download" target="_blank" style="display: none;">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white" />
</mask>
<g mask="url(#mask0)">
<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-download-text"></span>
</a>
<div class="jp-carousel-image-map" style="display: none;"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/build-api-next-js-lambda-functions\/":132891};
	</script>
<link rel='stylesheet' id='dashicons-css' href='https://blog.logrocket.com/wp-includes/css/dashicons.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='nf-display-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/display-opinions-light.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='nf-font-awesome-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/font-awesome.min.css?ver=6.0.2' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-before'>
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=6.0.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=83ec8aa758f883d6da14' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=8767d0da914b289bd862' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/blog.logrocket.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"82d960f862","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=11.4-a.5' id='jetpack-carousel-js'></script>
<script defer type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1658852030' id='akismet-frontend-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/backbone.min.js?ver=1.4.1' id='backbone-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end-deps.js?ver=3.6.14' id='nf-front-end-deps-js'></script>
<script type='text/javascript' id='nf-front-end-js-extra'>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</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end.js?ver=3.6.14' id='nf-front-end-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.4-a.5' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=132891&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=77c1ffa14e&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.4-a.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0481dff35021915f1488f7165762a43ac2f3bdc1#parent=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=132891&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=77c1ffa14e&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.4-a.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0481dff35021915f1488f7165762a43ac2f3bdc1#parent=https%3A%2F%2Fblog.logrocket.com%2Fbuild-api-next-js-lambda-functions";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202238.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.4-a.5',blog:'161333275',post:'132891',tz:'-4',srv:'blog.logrocket.com',hp:'atomic',ac:'2',amp:'0'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '132891' ]);
</script>
<script id="tmpl-nf-layout" type="text/template">
	<span id="nf-form-title-{{{ data.id }}}" class="nf-form-title">
		{{{ ( 1 == data.settings.show_title ) ? '<h3>' + data.settings.title + '</h3>' : '' }}}
	</span>
	<div class="nf-form-wrap ninja-forms-form-wrap">
		<div class="nf-response-msg"></div>
		<div class="nf-debug-msg"></div>
		<div class="nf-before-form"></div>
		<div class="nf-form-layout"></div>
		<div class="nf-after-form"></div>
	</div>
</script>
<script id="tmpl-nf-empty" type="text/template">

</script>
<script id="tmpl-nf-before-form" type="text/template">
	{{{ data.beforeForm }}}
</script><script id="tmpl-nf-after-form" type="text/template">
	{{{ data.afterForm }}}
</script><script id="tmpl-nf-before-fields" type="text/template">
    <div class="nf-form-fields-required">{{{ data.renderFieldsMarkedRequired() }}}</div>
    {{{ data.beforeFields }}}
</script><script id="tmpl-nf-after-fields" type="text/template">
    {{{ data.afterFields }}}
    <div id="nf-form-errors-{{{ data.id }}}" class="nf-form-errors" role="alert"></div>
    <div class="nf-form-hp"></div>
</script>
<script id="tmpl-nf-before-field" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-after-field" type="text/template">
    {{{ data.afterField }}}
</script><script id="tmpl-nf-form-layout" type="text/template">
	<form>
		<div>
			<div class="nf-before-form-content"></div>
			<div class="nf-form-content {{{ data.element_class }}}"></div>
			<div class="nf-after-form-content"></div>
		</div>
	</form>
</script><script id="tmpl-nf-form-hp" type="text/template">
	<label for="nf-field-hp-{{{ data.id }}}" aria-hidden="true">
		{{{ nfi18n.formHoneypot }}}
		<input id="nf-field-hp-{{{ data.id }}}" name="nf-field-hp" class="nf-element nf-field-hp" type="text" value=""/>
	</label>
</script>
<script id="tmpl-nf-field-layout" type="text/template">
    <div id="nf-field-{{{ data.id }}}-container" class="nf-field-container {{{ data.type }}}-container {{{ data.renderContainerClass() }}}">
        <div class="nf-before-field"></div>
        <div class="nf-field"></div>
        <div class="nf-after-field"></div>
    </div>
</script>
<script id="tmpl-nf-field-before" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-field-after" type="text/template">
    <#
    /*
     * Render our input limit section if that setting exists.
     */
    #>
    <div class="nf-input-limit"></div>
    <#
    /*
     * Render our error section if we have an error.
     */
    #>
    <div id="nf-error-{{{ data.id }}}" class="nf-error-wrap nf-error" role="alert"></div>
    <#
    /*
     * Render any custom HTML after our field.
     */
    #>
    {{{ data.afterField }}}
</script>
<script id="tmpl-nf-field-wrap" type="text/template">
	<div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
		<#
		/*
		 * This is our main field template. It's called for every field type.
		 * Note that must have ONE top-level, wrapping element. i.e. a div/span/etc that wraps all of the template.
		 */
        #>
		<#
		/*
		 * Render our label.
		 */
        #>
		{{{ data.renderLabel() }}}
		<#
		/*
		 * Render our field element. Uses the template for the field being rendered.
		 */
        #>
		<div class="nf-field-element">{{{ data.renderElement() }}}</div>
		<#
		/*
		 * Render our Description Text.
		 */
        #>
		{{{ data.renderDescText() }}}
	</div>
</script>
<script id="tmpl-nf-field-wrap-no-label" type="text/template">
    <div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
        <div class="nf-field-label"></div>
        <div class="nf-field-element">{{{ data.renderElement() }}}</div>
        <div class="nf-error-wrap"></div>
    </div>
</script>
<script id="tmpl-nf-field-wrap-no-container" type="text/template">

        {{{ data.renderElement() }}}

        <div class="nf-error-wrap"></div>
</script>
<script id="tmpl-nf-field-label" type="text/template">
	<div class="nf-field-label"><label for="nf-field-{{{ data.id }}}"
	                                   id="nf-label-field-{{{ data.id }}}"
	                                   class="{{{ data.renderLabelClasses() }}}">{{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}} {{{ ( 'undefined' != typeof data.required && 1 == data.required ) ? '<span class="ninja-forms-req-symbol">*</span>' : '' }}} {{{ data.maybeRenderHelp() }}}</label></div>
</script>
<script id="tmpl-nf-field-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-form-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-field-input-limit" type="text/template">
    {{{ data.currentCount() }}} {{{ nfi18n.of }}} {{{ data.input_limit }}} {{{ data.input_limit_msg }}}
</script><script id="tmpl-nf-field-null" type="text/template">
</script><script id="tmpl-nf-field-listcheckbox" type="text/template">
    <ul aria-describedby="nf-error-{{{ data.id }}}">
        {{{ data.renderOptions() }}}
    </ul>
</script>
<script id='tmpl-nf-field-listcheckbox-option' type='text/template'>
    <# if ( ! data.visible ) { return '' } #>
    <li>
        <input type="checkbox" id="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}" name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element {{{ ( data.isSelected ) ? ' nf-checked' : '' }}}" value="{{{ data.value }}}" {{{ ( data.isSelected ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
            <# if( data.required ) { #>
			required
			<# } #>
        >
        <label for="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               id="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               class="{{{ ( data.isSelected ) ? 'nf-checked-label' : '' }}}">{{{ data.label }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other' type='text/template'>
    <li {{{ ( ! data.visible ) ? 'style="display:none"' : '' }}}>
        <input type="checkbox"
               id="nf-field-{{{ data.fieldID }}}-other"
               name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element" value="nf-other" {{{ ( ! data.valueFound ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-other"
            <# if( data.required ) { #>
			required
			<# } #>
        >
         <label id="nf-label-field-{{{ data.fieldID }}}-other">Other
            {{{ data.renderOtherText() }}}
        </label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other-text' type='text/template'>
    <input type="text" name="nf-field-{{{ data.fieldID }}}" class="nf-element" value="{{{ data.currentValue }}}">
</script>
<script id='tmpl-nf-field-input' type='text/template'>
    <input id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" aria-invalid="false" aria-describedby="nf-error-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element" type="text" value="{{{ _.escape( data.value ) }}}" {{{ data.renderPlaceholder() }}} {{{ data.maybeDisabled() }}}
           aria-labelledby="nf-label-field-{{{ data.id }}}"

            {{{ data.maybeRequired() }}}
    >
</script>
<script id="tmpl-nf-field-email" type="text/template">
	<input
			type="email"
			value="{{{ _.escape( data.value ) }}}"
			class="{{{ data.renderClasses() }}} nf-element"

			id="nf-field-{{{ data.id }}}"
			<# if( ! data.disable_browser_autocompletes ){ #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id + '-' + data.type }}"
			autocomplete="email"
			<# } else { #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id }}"
			{{{ data.maybeDisableAutocomplete() }}}
			<# } #>
			{{{ data.renderPlaceholder() }}}
			{{{ data.maybeDisabled() }}}

			aria-invalid="false"
			aria-describedby="nf-error-{{{ data.id }}}"
			aria-labelledby="nf-label-field-{{{ data.id }}}"

			{{{ data.maybeRequired() }}}
	>
</script>
<script id="tmpl-nf-field-submit" type="text/template">
	<input id="nf-field-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element " type="button" value="{{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}}" {{{ ( data.disabled ) ? 'disabled' : '' }}}>
</script><script id='tmpl-nf-field-button' type='text/template'>
    <button id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" class="{{{ data.classes }}} nf-element">
        {{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}}
    </button>
</script><script>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</script>
</body>
</html>
