2020-01-22
2286
#node
Ebenezer Don
12814
Jan 22, 2020 ⋅ 8 min read

Building a sentiment analysis app with Node.js

Ebenezer Don Full-stack software engineer with a passion for building meaningful products that ease the lives of users.

Recent posts:

How To Integrate WunderGraph With Your Frontend Application

How to integrate WunderGraph with your frontend application

Unify and simplify APIs using WunderGraph to integrate REST, GraphQL, and databases in a single endpoint.

Boemo Mmopelwa
May 17, 2024 ⋅ 5 min read
Understanding The Latest Webkit Features In Safari 17.4

Understanding the latest Webkit features in Safari 17.4

The Safari 17.4 update brought in many modern features and bug fixes. Explore the major development-specific updates you should be aware of.

Rahul Chhodde
May 16, 2024 ⋅ 10 min read
Using Webrtc To Implement Peer To Peer Video Streaming In A Node Js Project

Using WebRTC to implement P2P video streaming

Explore one of WebRTC’s major use cases in this step-by-step tutorial: live peer-to-peer audio and video streaming between systems.

Oduah Chigozie
May 16, 2024 ⋅ 18 min read
Htmx Vs React

htmx vs. React: Choosing the right library for your project

Both htmx and React provide powerful tools for building web apps, but in different ways that are suited to different types of projects.

Temitope Oyedele
May 15, 2024 ⋅ 9 min read
View all posts

11 Replies to "Building a sentiment analysis app with Node.js"

  1. Hey,nice article !
    does this application analyses only English language ?
    if yes how could i make it a multiple language analyzer!

  2. Thanks soo much for this! Exactly what I needed to help a student doing some text sentiment analysis for programming in Indesign. Stripped down the code to just make a simple endpoint API that could be called via GET… dubbed [sentilyzer](https://github.com/ffd8/sentilyzer)

  3. One of the best and comprehensive article on Building a sentiment analysis app, I am bookmarking it so I can read it again. Thank you Ebenezer Don, You really inspired me to learn more.

  4. Thanks for article, I get following messages when installing spelling corrector. Any idea how to resolve?

    root@mail:/webserver/sites/discordBot# npm install –save spelling-corrector
    npm WARN deprecated [email protected]: to-iso-string has been deprecated, use @segment/to-iso-string instead.
    npm WARN deprecated [email protected]: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
    npm WARN deprecated [email protected]: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
    npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    npm WARN deprecated [email protected].3: Jade has been renamed to pug, please install the latest version of pug instead of jade

    added 24 packages, changed 1 package, and audited 370 packages in 2s

    25 packages are looking for funding
    run `npm fund` for details

    9 vulnerabilities (1 low, 2 moderate, 4 high, 2 critical)

    Some issues need review, and may require choosing
    a different dependency.

    Run `npm audit` for details.
    root@mail:/webserver/sites/discordBot# npm audit
    # npm audit report

    debug <2.6.9
    Regular Expression Denial of Service in debug – https://github.com/advisories/GHSA-gxpj-cx7g-858c
    No fix available
    node_modules/mocha/node_modules/debug
    mocha 0.6.0 – 6.2.2 || 7.0.0-esm1 – 7.1.0
    Depends on vulnerable versions of debug
    Depends on vulnerable versions of diff
    Depends on vulnerable versions of glob
    Depends on vulnerable versions of growl
    Depends on vulnerable versions of mkdirp
    node_modules/mocha
    spelling-corrector *
    Depends on vulnerable versions of mocha
    node_modules/spelling-corrector

    diff <3.5.0
    Severity: high
    Regular Expression Denial of Service (ReDoS) – https://github.com/advisories/GHSA-h6ch-v84p-w6p9
    No fix available
    node_modules/diff
    mocha 0.6.0 – 6.2.2 || 7.0.0-esm1 – 7.1.0
    Depends on vulnerable versions of debug
    Depends on vulnerable versions of diff
    Depends on vulnerable versions of glob
    Depends on vulnerable versions of growl
    Depends on vulnerable versions of mkdirp
    node_modules/mocha
    spelling-corrector *
    Depends on vulnerable versions of mocha
    node_modules/spelling-corrector

    growl <1.10.0
    Severity: critical
    Command Injection in growl – https://github.com/advisories/GHSA-qh2h-chj9-jffq
    No fix available
    node_modules/growl
    mocha 0.6.0 – 6.2.2 || 7.0.0-esm1 – 7.1.0
    Depends on vulnerable versions of debug
    Depends on vulnerable versions of diff
    Depends on vulnerable versions of glob
    Depends on vulnerable versions of growl
    Depends on vulnerable versions of mkdirp
    node_modules/mocha
    spelling-corrector *
    Depends on vulnerable versions of mocha
    node_modules/spelling-corrector

    minimatch <3.0.2
    Severity: high
    Regular Expression Denial of Service in minimatch – https://github.com/advisories/GHSA-hxm2-r34f-qmc5
    No fix available
    node_modules/mocha/node_modules/minimatch
    glob 3.0.0 – 5.0.14
    Depends on vulnerable versions of minimatch
    node_modules/mocha/node_modules/glob
    mocha 0.6.0 – 6.2.2 || 7.0.0-esm1 – 7.1.0
    Depends on vulnerable versions of debug
    Depends on vulnerable versions of diff
    Depends on vulnerable versions of glob
    Depends on vulnerable versions of growl
    Depends on vulnerable versions of mkdirp
    node_modules/mocha
    spelling-corrector *
    Depends on vulnerable versions of mocha
    node_modules/spelling-corrector

    minimist <0.2.1
    Severity: moderate
    Prototype Pollution in minimist – https://github.com/advisories/GHSA-vh95-rmgr-6w4m
    No fix available
    node_modules/mocha/node_modules/minimist
    mkdirp 0.4.1 – 0.5.1
    Depends on vulnerable versions of minimist
    node_modules/mocha/node_modules/mkdirp
    mocha 0.6.0 – 6.2.2 || 7.0.0-esm1 – 7.1.0
    Depends on vulnerable versions of debug
    Depends on vulnerable versions of diff
    Depends on vulnerable versions of glob
    Depends on vulnerable versions of growl
    Depends on vulnerable versions of mkdirp
    node_modules/mocha
    spelling-corrector *
    Depends on vulnerable versions of mocha
    node_modules/spelling-corrector

    9 vulnerabilities (1 low, 2 moderate, 4 high, 2 critical)

    Some issues need review, and may require choosing
    a different dependency.

Leave a Reply