<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v15.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>How to use React Context with TypeScript - LogRocket Blog</title>
	<meta name="description" content="Improve developer experience by learning how to use TypeScript with React Context by building a to-do app from scratch." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://blog.logrocket.com/how-to-use-react-context-with-typescript/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="How to use React Context with TypeScript - LogRocket Blog" />
	<meta property="og:description" content="Improve developer experience by learning how to use TypeScript with React Context by building a to-do app from scratch." />
	<meta property="og:url" content="https://blog.logrocket.com/how-to-use-react-context-with-typescript/" />
	<meta property="og:site_name" content="LogRocket Blog" />
	<meta property="article:published_time" content="2020-11-05T15:30:08+00:00" />
	<meta property="article:modified_time" content="2020-11-04T13:54:03+00:00" />
	<meta property="og:image" content="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?fit=730%2C487&#038;ssl=1" />
	<meta property="og:image:width" content="730" />
	<meta property="og:image:height" content="487" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@https://twitter.com/ibrahima92_" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Ibrahima Ndaw">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="6 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/how-to-use-react-context-with-typescript/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?fit=730%2C487&ssl=1","width":730,"height":487,"caption":"React Context Typescript"},{"@type":"WebPage","@id":"https://blog.logrocket.com/how-to-use-react-context-with-typescript/#webpage","url":"https://blog.logrocket.com/how-to-use-react-context-with-typescript/","name":"How to use React Context with TypeScript - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/how-to-use-react-context-with-typescript/#primaryimage"},"datePublished":"2020-11-05T15:30:08+00:00","dateModified":"2020-11-04T13:54:03+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/0bdb74a65de1dc80872af435c19448d7"},"description":"Improve developer experience by learning how to use TypeScript with React Context by building a to-do app from scratch.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/how-to-use-react-context-with-typescript/"]}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/0bdb74a65de1dc80872af435c19448d7","name":"Ibrahima Ndaw","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/9b341d8999ff10e0d9b94f2958822856?s=96&d=mm&r=g","caption":"Ibrahima Ndaw"},"description":"JavaScript enthusiast, full-stack developer, and blogger who also dabbles in UI/UX design.","sameAs":["https://www.ibrahima-ndaw.com/","https://www.linkedin.com/in/ibrahima-ndaw/","https://twitter.com/https://twitter.com/ibrahima92_"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; How to use React Context with TypeScript Comments Feed" href="https://blog.logrocket.com/how-to-use-react-context-with-typescript/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.5.3/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css'  href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/9.0.2/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.0.2/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/28099" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/paUW9B-7jd' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
    <script>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</script>


    <script>
    window.Raven && window.Raven.config('https://98e0ea7c6f2e492d94439ad5aaea48dd@e.logrocket.com/4').install()
    </script>
    <script type="text/javascript">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</script>

    <script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
    <script>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</script><style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=270%2C270&#038;ssl=1" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=d3289120fc" />
		<style id="kirki-inline-styles">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</style></head>

<body class="post-template-default single single-post postid-28099 single-format-standard">

<style>
    </style>


<header class="navbar-light bg-white fixed-top mediumnavigation">

    <div class="container">



        <div class="navarea">

<div class="nav-left">

  <a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>

<nav class="menu-container">

        <div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a></ul></div></nav>

</div>

<div class="nav-right">

  <div class="menu-container">
    <div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Free Trial</a></li>
</ul></div>  </div>

</div>

        </div>

    </div>

</header>


        <!-- Begin site-content
		================================================== -->
        <div class="site-content">


<div class="container"> 
    <div class="row">         
        <div class=" col-md-2 ">           
            <div class="share">
                
                <div class="sidebarapplause">
                                </div>
                
                				<p class="sharecolour">
					Share				</p>
                
<ul class="shareitnow"><li>
        <a target="_blank" href="https://twitter.com/intent/tweet?text=How%20to%20use%20React%20Context%20with%20TypeScript&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F">
        <i class="fa fa-twitter"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F">
        <i class="fa fa-facebook"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F">
        <i class="fa fa-google"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F&amp;media=https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?fit=730%2C487&ssl=1&amp;description=How%20to%20use%20React%20Context%20with%20TypeScript">
        <i class="fa fa-pinterest"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F&amp;title=How%20to%20use%20React%20Context%20with%20TypeScript">
        <i class="fa fa-linkedin"></i>
        </a>
    </li></ul>                		        
                
                                <div class="sep"></div>
                <div class="hidden-xs-down">      

                    <p>
                        Reply                    </p>
                    <ul>
                        <li>
                        <a class="smoothscroll" href="#comments">0<br/>
                        <svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
                        </a>
                        </li>
                    </ul>
                </div>
                            </div>			                                
        </div>
        
                    			                <div class="col-md-8 flex-first flex-md-unordered post-28099 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-react tag-typescript" id="post-28099"> 
                    <div class="mainheading">
                       
                                                <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-md-down"> 
                            <div class="col-md-2 col-xs-12"> 
                                <a href="https://blog.logrocket.com/author/ibrahimandaw/">
                                    <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/ibrahima-ndaw.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/ibrahima-ndaw.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/ibrahima-ndaw.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                                </a>
                            </div>                                         
                            <div class="col-md-10 col-xs-12"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/ibrahimandaw/">
                                Ibrahima Ndaw <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">JavaScript enthusiast, full-stack developer, and blogger who also dabbles in UI/UX design.</span> 
                            </div>                                         
                        </div>
                                                 
                                                
                        <h1 class="posttitle">How to use React Context with TypeScript</h1>
					    <h2 class="post-subtitle"></h2>

                        <p>
                                                        <span class="post-date"><time class="post-date">
                            November 5, 2020                            </time></span>
                                                        
                                                        <span class="dot"></span>
                            <span class="readingtime">5 min read</span>
						    <span class="wordcount">1431</span>

                                                    </p> 
                    </div>
                    
                  <img width="730" height="487" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?fit=730%2C487&amp;ssl=1" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="React Context Typescript" loading="lazy" data-attachment-id="28187" data-permalink="https://blog.logrocket.com/how-to-use-react-context-with-typescript/react-context-typescript/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?fit=730%2C487&amp;ssl=1" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="React-Context-Typescript" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?fit=300%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?fit=730%2C487&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?w=730&amp;ssl=1 730w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/React-Context-Typescript.png?fit=730%2C487&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    <article class="article-post">
                                                <p>TypeScript has become increasingly popular due to numerous benefits recently added to the code, such as static type-checking robustness, understandability, and type interface.</p>
<p>And when TypeScript is used with React, it offers improved developer experience and more predictability to the project.</p>
<p>In this guide, we will learn how to use TypeScript with React Context by building a to-do app from scratch. Let&#8217;s dive in.</p>
<h2>Prerequisites</h2>
<p>To get the most out of this tutorial, you need a basic understanding of React and TypeScript. If you’re new to web development, you can start with this <a href="https://blog.logrocket.com/how-why-a-guide-to-using-typescript-with-react-fffb76c61614/" target="_blank" rel="noopener noreferrer">React TypeScript tutorial</a> to get familiar with these technologies.</p>
<h2>Setting up</h2>
<p>To create a new app, I will use <a href="https://create-react-app.dev/" target="_blank" rel="noopener noreferrer">Create React App</a> in order to have a modern configuration with no hassle. But, you are welcome to set up a new app from scratch using <a href="https://webpack.js.org/" target="_blank" rel="noopener noreferrer">Webpack</a>.</p>
<p>Begin by opening your terminal and running the following command:</p>
<pre>npx create-react-app react-context-todo --template typescript</pre>
<p>To enable TypeScript when using Create React App, you need to add the flag <code>--template typescript</code>, otherwise the app will support only JavaScript.</p>
<p>Next, let&#8217;s structure the project as follows:</p>
<pre>├── src
|  ├── components
|  |  ├── AddTodo.tsx
|  |  └── Todo.tsx
|  ├── containers
|  |  └── Todos.tsx
|  ├── context
|  |  └── todoContext.tsx
|  ├── App.tsx
|  ├── index.css
|  ├── index.tsx
|  ├── react-app-env.d.ts
|  └── type.d.ts
├── tsconfig.json
├── package.json
└── yarn.lock
</pre>
<p>Here, there are two files to underline:</p>
<ul>
<li>The <code>context/todoContext.tsx</code> file that serves as a context for the project</li>
<li>The <code>type.d.ts</code> file that contains the TypeScript Types. The extension <code>.d.ts</code> allows using the types in other files without importing them</li>
</ul>
<p>With this in place, we can now get our hands dirty and code something meaningful.</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br/>No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>

<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>

<h2>Create the to-do type</h2>
<p>TypeScript Type allows you to define what a variable or function should expect as a value in order to help the compiler catch errors before runtime.</p>
<p><code>type.d.ts</code></p>
<pre>interface ITodo {
id: number
title: string
description: string
status: boolean
}type ContextType = {
todos: ITodo[]
saveTodo: (todo: ITodo) =&gt; void
updateTodo: (id: number) =&gt; void
}</pre>
<p>As you can see, the interface <code>ITodo</code> defines the shape of a to-do object. Next, we have the type <code>ContextType</code> that expects an array of to-dos and the methods to add or update a to-do.</p>
<h2>Create the context</h2>
<p>React Context allows you to share and manage state across your components without passing down props. The context will provide the data to just the components that need to consume it.</p>
<p><code>context/todoContext.tsx</code></p>
<pre>import * as React from "react";

export const TodoContext = React.createContext(null);

const TodoProvider: React.FC = ({ children }) =&gt; {
  const [todos, setTodos] = React.useState&lt;ITodo[]&gt;([
    {
      id: 1,
      title: "post 1",
      description: "this is my first description",
      status: false
    },
    {
      id: 2,
      title: "post 2",
      description: "this is my second description",
      status: true
    }
  ]);</pre>
<p>Here, we start by creating a new context and set its type to match <code>ContextType</code> or <code>null</code>. The latter is using <code>here</code> to initialize the context with a null value. Next, we create the component <code>TodoProvider</code> that provides the context to the component consumers. Here, I initialize the state with some data to have <code>todos</code> to work.</p>
<p><code>context/todoContext.tsx</code></p>
<pre>const saveTodo = (todo: ITodo) =&gt; {
  const newTodo: ITodo = {
    id: Math.random(), // not really unique - but fine for this example
    title: todo.title,
    description: todo.description,
    status: false,
  }
  setTodos([...todos, newTodo])
}

const updateTodo = (id: number) =&gt; {
  todos.filter((todo: ITodo) =&gt; {
    if (todo.id === id) {
      todo.status = true
      setTodos([...todos])
    }
  })
}</pre>
<p>The function <code>saveTodo</code> will create a new to-do based on the interface <code>ITodo</code> and then append the object to the array of to-dos. The next function, <code>updateTodo</code>, will look for the id of the to-do passed as a parameter in the array of to-dos and then update it.</p>
<p><code>context/todoContext.tsx</code></p>
<pre> return (
    
      {children}
    
  );
};

export default TodoProvider;</pre>
<p>Next, we pass the values to the context to make them consumable for the components.</p>
<p><code>context/todoContext.tsx</code></p>
<pre>import * as React from 'react'

export const TodoContext = React.createContext(null)

const TodoProvider: React.FC = ({ children }) =&gt; {
  const [todos, setTodos] = React.useState&lt;ITodo[]&gt;([
    {
      id: 1,
      title: 'post 1',
      description: 'this is a description',
      status: false,
    },
    {
      id: 2,
      title: 'post 2',
      description: 'this is a description',
      status: true,
    },
  ])

  const saveTodo = (todo: ITodo) =&gt; {
    const newTodo: ITodo = {
      id: Math.random(), // not really unique - but fine for this example
      title: todo.title,
      description: todo.description,
      status: false,
    }
    setTodos([...todos, newTodo])
  }

  const updateTodo = (id: number) =&gt; {
    todos.filter((todo: ITodo) =&gt; {
      if (todo.id === id) {
        todo.status = true
        setTodos([...todos])
      }
    })
  }

  return (
    
      {children}
    
  )
}

export default TodoProvider</pre>
<p>With this, we are now able to consume the context. So, let&#8217;s create the components in the next section.</p>
<h2>Create the components and consume the context</h2>
<p><code>components/AddTodo.tsx</code></p>
<pre>import * as React from 'react'
import { TodoContext } from '../context/todoContext'

const AddTodo: React.FC = () =&gt; {
  const { saveTodo } = React.useContext(TodoContext) as ContextType
  const [formData, setFormData] = React.useState&lt;ITodo | {}&gt;()

  const handleForm = (e: React.FormEvent&lt;HTMLInputElement&gt;): void =&gt; {
    setFormData({
      ...formData,
      [e.currentTarget.id]: e.currentTarget.value,
    })
  }

  const handleSaveTodo = (e: React.FormEvent, formData: ITodo | any) =&gt; {
    e.preventDefault()
    saveTodo(formData)
  }

  return (
    &lt;form className='Form' onSubmit={(e) =&gt; handleSaveTodo(e, formData)}&gt;
      &lt;div&gt;
        &lt;div&gt;
          &lt;label htmlFor='name'&gt;Title&lt;/label&gt;
          &lt;input onChange={handleForm} type='text' id='title' /&gt;
        &lt;/div&gt;
        &lt;div&gt;
          &lt;label htmlFor='description'&gt;Description&lt;/label&gt;
          &lt;input onChange={handleForm} type='text' id='description' /&gt;
        &lt;/div&gt;
      &lt;/div&gt;
      &lt;button disabled={formData === undefined ? true : false}&gt;Add Todo&lt;/button&gt;
    &lt;/form&gt;
  )
}

export default AddTodo</pre>
<p>Here, we have a form component that allows handling data entered by the user using the <code>useState</code> hook. Once we get the form data, we use the function <code>saveTodo</code> pulled from the context object to add a new to-do.</p>
<p>Note that I use typecasting on the <code>useContext</code> hook to avoid TypeScript throwing errors because the context will be null at the beginning.</p>
<p><code>components/Todo.tsx</code></p>
<pre>import * as React from 'react'

type Props = {
  todo: ITodo
  updateTodo: (id: number) =&gt; void
}

const Todo: React.FC&lt;Props&gt; = ({ todo, updateTodo }) =&gt; {
  const checkTodo: string = todo.status ? `line-through` : ''
  return (
    &lt;div className='Card'&gt;
      &lt;div className='Card--text'&gt;
        &lt;h1 className={checkTodo}&gt;{todo.title}&lt;/h1&gt;
        &lt;span className={checkTodo}&gt;{todo.description}&lt;/span&gt;
      &lt;/div&gt;
      &lt;button
        onClick={() =&gt; updateTodo(todo.id)}
        className={todo.status ? `hide-button` : 'Card--button'}
      &gt;
        Complete
      &lt;/button&gt;
    &lt;/div&gt;
  )
}

export default Todo</pre>
<p>As you can see here, we have a presentational component that shows a single to-do. It receives the to-do object and the function to update it as parameters that need to match the <code>Props</code> type defined above.</p>
<p><span class="inline-code author-d-1gg9uz65z1iz85zgdz68zmqkz84zo2qoxuz76zz87zz69z8z90znz73zoboz71z3z86zz81zz86zz81zpz90zh8irz72zz87zymez83zz86zz77z"><code>containers/Todos.tsx</code></span></p>
<pre>import * as React from 'react'

import { TodoContext } from '../context/todoContext'
import Todo from '../components/Todo'

const Todos = () =&gt; {
  const { todos, updateTodo } = React.useContext(TodoContext) as ContextType
  return (
    &lt;&gt;
      {todos.map((todo: ITodo) =&gt; (
        
      ))}
    &lt;/&gt;
  )
}

export default Todos</pre>
<p>This component shows the list of to-dos when the page loads. It pulls the <code>todos</code> and the function <code>updateTodo</code> from the to-do context. Next, we loop through the array and pass to the <code>Todo</code> component the object to show. With this step forward, we are now able to provide the to-do context in the <code>App.tsx</code> file to finish up building the app. So, let&#8217;s use the context provider in the next part.</p>
<h2>Provide the context</h2>
<pre>import * as React from 'react'
import TodoProvider from './context/todoContext'
import Todos from './containers/Todos'
import AddTodo from './components/AddTodo'
import './styles.css'

export default function App() {
  return (
    &lt;TodoProvider&gt;
      &lt;main className='App'&gt;
        &lt;h1&gt;My Todos&lt;/h1&gt;
        &lt;AddTodo /&gt;
        &lt;Todos /&gt;
      &lt;/main&gt;
    &lt;/TodoProvider&gt;
  )
}
</pre>
<p>Here, we import the <code>TodoProvider</code> component that wraps the consumers of the to-do context. That said, we can now access the <code>todos</code> array and the function to add or update a to-do using the <code>useContext</code> hook in other components.</p>
<p>With this, we can now open the project on the terminal and run the following command:</p>
<pre>  yarn start
</pre>
<p>Or</p>
<pre>  npm start
</pre>
<p>If everything works, you’ll be able to see this in the browser:</p>
<ul>
<li><code><a href="http://localhost:3000" rel="nofollow">http://localhost:3000</a></code></li>
</ul>
<figure id="attachment_28121" aria-describedby="caption-attachment-28121" style="width: 730px" class="wp-caption aligncenter"><img data-attachment-id="28121" data-permalink="https://blog.logrocket.com/how-to-use-react-context-with-typescript/todo-provider-react-context/" data-orig-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/Todo-Provider-React-Context-e1604353975614.png?fit=730%2C407&amp;ssl=1" data-orig-size="730,407" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Todo-Provider-React-Context" data-image-description data-medium-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/Todo-Provider-React-Context-e1604353975614.png?fit=300%2C167&amp;ssl=1" data-large-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/Todo-Provider-React-Context-e1604353975614.png?fit=730%2C407&amp;ssl=1" loading="lazy" class="size-full wp-image-28121 jetpack-lazy-image" src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/Todo-Provider-React-Context-e1604353975614.png?resize=730%2C407&#038;ssl=1" alt="Todo Provider React Context" width="730" height="407" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/Todo-Provider-React-Context-e1604353975614.png?resize=730%2C407&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="28121" data-permalink="https://blog.logrocket.com/how-to-use-react-context-with-typescript/todo-provider-react-context/" data-orig-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/Todo-Provider-React-Context-e1604353975614.png?fit=730%2C407&amp;ssl=1" data-orig-size="730,407" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Todo-Provider-React-Context" data-image-description="" data-medium-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/Todo-Provider-React-Context-e1604353975614.png?fit=300%2C167&amp;ssl=1" data-large-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/Todo-Provider-React-Context-e1604353975614.png?fit=730%2C407&amp;ssl=1" loading="lazy" class="size-full wp-image-28121" src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/Todo-Provider-React-Context-e1604353975614.png?resize=730%2C407&#038;ssl=1" alt="Todo Provider React Context" width="730" height="407" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-28121" class="wp-caption-text">Here&#8217;s a preview of your to-do app</figcaption></figure>
<p>Great! With that final touch, we have now finished building a to-do app using React Context and TypeScript.</p>
<p>You can find the finished project <a href="https://codesandbox.io/s/react-context-typescript-s5brd" target="_blank" rel="noopener noreferrer">here</a>.</p>
<h2>Conclusion</h2>
<p>TypeScript is a great language that makes our code better. In this tutorial, we’ve learned how to use TypeScript with React Context. Hopefully, it helps you with your next project. Thanks for reading.</p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<div class="plug-poll"><h2>You come here a lot! We hope you enjoy the <a href="https://logrocket.com/signup/">LogRocket</a> blog. Could you fill out a survey about what you want us to write about?</h2>
<div role="form" class="wpcf7" id="wpcf7-f27299-p28099-o1" lang="en-US" dir="ltr">
<div class="screen-reader-response"><p role="status" aria-live="polite" aria-atomic="true"></p> <ul></ul></div>
<form action="/how-to-use-react-context-with-typescript/#wpcf7-f27299-p28099-o1" method="post" class="wpcf7-form init" novalidate="novalidate" data-status="init">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="27299" />
<input type="hidden" name="_wpcf7_version" value="5.3" />
<input type="hidden" name="_wpcf7_locale" value="en_US" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f27299-p28099-o1" />
<input type="hidden" name="_wpcf7_container_post" value="28099" />
<input type="hidden" name="_wpcf7_posted_data_hash" value="" />
</div>
<div id="plug-survey-framework">
Which of these topics are you most interested in?<br />
<span class="wpcf7-form-control-wrap frameworks"><span class="wpcf7-form-control wpcf7-radio"><span class="wpcf7-list-item first"><input type="radio" name="frameworks" value="React" /><span class="wpcf7-list-item-label">React</span></span><span class="wpcf7-list-item"><input type="radio" name="frameworks" value="Vue" /><span class="wpcf7-list-item-label">Vue</span></span><span class="wpcf7-list-item"><input type="radio" name="frameworks" value="Angular" /><span class="wpcf7-list-item-label">Angular</span></span><span class="wpcf7-list-item last"><input type="radio" name="frameworks" value="New frameworks" /><span class="wpcf7-list-item-label">New frameworks</span></span></span></span>
</div>
<div id="plug-survey-errors">
Do you spend a lot of time reproducing errors in your apps?<br />
<span class="wpcf7-form-control-wrap errors"><span class="wpcf7-form-control wpcf7-radio"><span class="wpcf7-list-item first"><input type="radio" name="errors" value="Yes" /><span class="wpcf7-list-item-label">Yes</span></span><span class="wpcf7-list-item last"><input type="radio" name="errors" value="No" /><span class="wpcf7-list-item-label">No</span></span></span></span>
</div>
<div id="plug-survey-help">
Which, if any, do you think would help you reproduce errors more effectively?<br />
<span class="wpcf7-form-control-wrap help"><span class="wpcf7-form-control wpcf7-radio"><span class="wpcf7-list-item first"><input type="radio" name="help" value="A solution to see exactly what a user did to trigger an error" /><span class="wpcf7-list-item-label">A solution to see exactly what a user did to trigger an error</span></span><span class="wpcf7-list-item"><input type="radio" name="help" value="Proactive monitoring which automatically surfaces issues" /><span class="wpcf7-list-item-label">Proactive monitoring which automatically surfaces issues</span></span><span class="wpcf7-list-item last"><input type="radio" name="help" value="Having a support team triage issues more efficiently" /><span class="wpcf7-list-item-label">Having a support team triage issues more efficiently</span></span></span></span>
</div>
<div id="plug-survey-email">
Thanks! Interested to hear how LogRocket can improve your bug fixing processes? Leave your email:<br />
<span class="wpcf7-form-control-wrap email-248"><input type="email" name="email-248" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-email" aria-invalid="false" /></span><br />
<input type="submit" value="Send" class="wpcf7-form-control wpcf7-submit" />
</div>
<div class="wpcf7-response-output" aria-hidden="true"></div></form></div>
</div>
<div class="blog-plug inline-plug react-plug"><h2>Full visibility into production React apps</h2> Debugging React applications can be difficult, especially when users experience issues that are difficult to reproduce. If you’re interested in monitoring and tracking Redux state, automatically surfacing JavaScript errors, and tracking slow network requests and component load time, <a href="https://www2.logrocket.com/react-performance-monitoring">try LogRocket</a>. <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i2.wp.com/files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?ssl=1" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i2.wp.com/files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?ssl=1" data-recalc-dims="1" /></noscript></a><a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" /></noscript></a><p style="margin-top: 15px;"><a href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web apps, recording literally everything that happens on your React app. Instead of guessing why problems happen, you can aggregate and report on what state your application was in when an issue occurred. LogRocket also monitors your app's performance, reporting with metrics like client CPU load, client memory usage, and more.</p><p>The LogRocket Redux middleware package adds an extra layer of visibility into your user sessions. LogRocket logs all actions and state from your Redux stores. </p><p>Modernize how you debug your React apps — <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">start monitoring for free</a>.</p></div>

<style>
.plug-poll {margin-bottom: 2rem;}
.code-block-3 .fadeIn {
    opacity:1 !important;
    height:auto !important;
}

.code-block-3 .fadeOut {
    opacity:0 !important;
}

.code-block-3 .wpcf7-email {margin: 15px 0;}

#plug-survey-errors, #plug-survey-help, #plug-survey-email  {opacity:0; height:1px; transition: all 1s;overflow:hidden; width: 100%;}

</style>

<script>
  jQuery("#plug-survey-framework input").click(function() {
  analytics.track('footer-poll', {
      'footer-poll-framework': jQuery(this).val()
    });
    jQuery('#plug-survey-framework').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-errors').delay(800).addClass('fadeIn');
  });
    jQuery("#plug-survey-errors input").click(function() {
    jQuery('#plug-survey-errors').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-help').delay(800).addClass('fadeIn');
  });
  
      jQuery("#plug-survey-help input").click(function() {
        analytics.track('footer-poll', {
      'footer-poll-help': jQuery(this).val()
    });
    jQuery('#plug-survey-help').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-email').delay(800).addClass('fadeIn');
  });
  
  </script>

</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-28099" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/how-to-use-react-context-with-typescript/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/how-to-use-react-context-with-typescript/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-28099" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/how-to-use-react-context-with-typescript/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-28099" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/how-to-use-react-context-with-typescript/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><!-- AI CONTENT END 1 -->
                        <div class="clearfix"></div>
                                                <div class="clearfix"></div>
                    </article>
                            
                                             <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-lg-up"> 
                            <div class="col-md-2 col-xs-4"> 
                                <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/ibrahima-ndaw.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/ibrahima-ndaw.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/ibrahima-ndaw.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                            </div>                                         
                            <div class="col-md-10 col-xs-8"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/ibrahimandaw/">
                                Ibrahima Ndaw <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">JavaScript enthusiast, full-stack developer, and blogger who also dabbles in UI/UX design.</span> 
                            </div>                                         
                        </div>
                                         
                    <div class="after-post-tags">
                                                    <ul class="post-categories">
	<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul>                                                                            <ul class="post-categories aretags">
                            <li><a href="https://blog.logrocket.com/tag/react/">#react</a></li> <li><a href="https://blog.logrocket.com/tag/typescript/">#typescript</a></li>                             </ul>
                                            </div>
                    
                  
                    <div class="row mb-5 prevnextlinks justify-content-center align-items-center"> 
                       <div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/using-feature-flags-with-unleash-and-node-js/" rel="prev">Using feature flags with Unleash and Node.js</a></div></div>
                       <div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/positioning-elements-with-vue-3-teleport/" rel="next">Positioning elements with Vue 3 Teleport</a> &raquo;</div></div>
                    </div>
                    
                </div>
        
                    
         
        
        
    </div>                 
</div>             
          
<div class="hideshare"></div>

    <div class="graybg"> 
        <div class="container"> 
                <div class="row justify-content-center listrecent listrelated">
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/next-js-vs-react-developer-experience/" style="background-image:url(https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/next-js-vs-react-developer-experience.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/next-js-vs-react-developer-experience/">Next.js vs. React: The developer experience</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/andrewevans/">
                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/10/AndrewEvans.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/10/AndrewEvans.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/10/AndrewEvans.jpg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/andrewevans/">Andrew Evans</a></span><br>
                    <span class="post-date">Nov 5, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">9 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/next-js-vs-react-developer-experience/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/positioning-elements-with-vue-3-teleport/" style="background-image:url(https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/vue3teleport.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/positioning-elements-with-vue-3-teleport/">Positioning elements with Vue 3 Teleport</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/peterekeneeze/">
                    <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/04/peterekeneeze.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/04/peterekeneeze.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/04/peterekeneeze.jpg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/peterekeneeze/">Peter Ekene Eze</a></span><br>
                    <span class="post-date">Nov 5, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">6 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/positioning-elements-with-vue-3-teleport/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/using-feature-flags-with-unleash-and-node-js/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/11/using-feture-flags-unleash-node.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/using-feature-flags-with-unleash-and-node-js/">Using feature flags with Unleash and Node.js</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/diogospinola/">
                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/04/diogo-spinola.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/04/diogo-spinola.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/04/diogo-spinola.jpg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/diogospinola/">Diogo Spínola</a></span><br>
                    <span class="post-date">Nov 5, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">6 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/using-feature-flags-with-unleash-and-node-js/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
            </div>
    <div class="clearfix"></div>
                
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-use-react-context-with-typescript/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=28099&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.0.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=86f983ce93dc5dea831b0d34afd81306f622b63d#parent=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
</div>
</div>        </div>                 
    </div>

    <div class="alertbar"> 
        <div class="container text-center"> 
                    </div>
    </div>

</div><!-- /.site-content -->
        
        <div class="container">
            <footer class="footer"> 
                <div class="pull-left"> Does something seem off? Email <a>support@logrocket.com</a> </div> 
                <div class="pull-right"> <div class = "footerRight">			<div id="jetpack-search-filters-2-wrapper" >
		<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field"
placeholder="Search..."
value="" name="s"
title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>   
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div>  </div> 
                <div class="clearfix"></div>
                <a href="" class="back-to-top hidden-md-down"> 
                <i class="fa fa-angle-up"></i>
                </a>
            </footer>
        </div>
        
<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202045'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
};
</script>	<div style="display:none">
	<div class="grofile-hash-map-9b341d8999ff10e0d9b94f2958822856">
	</div>
	<div class="grofile-hash-map-6efa4ca33412da0d60a917ce67cba4b1">
	</div>
	<div class="grofile-hash-map-97b8897f620c6dc18f4ea6a53e0e0796">
	</div>
	<div class="grofile-hash-map-8b7ae12ea95ac09168e808a34d8e0fca">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/how-to-use-react-context-with-typescript\/":28099};
	</script>
				<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blog.logrocket.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.5.3/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.0.2/modules/widgets/search/js/search-widget.js' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.5.3/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"6ed270a05f","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.7' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=28099&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=86f983ce93dc5dea831b0d34afd81306f622b63d#parent=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=28099&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=86f983ce93dc5dea831b0d34afd81306f622b63d#parent=https%3A%2F%2Fblog.logrocket.com%2Fhow-to-use-react-context-with-typescript%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202045.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'161333275',post:'28099',tz:'-5',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '28099' ]);
</script>
<script>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</script>
            </body>     
</html>
