<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>CSS Reference Guide: Button styling - LogRocket Blog</title>
	<meta name="description" content="Learn how to create and style button classes using CSS, including a detailed look at style properties and animated effects." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://blog.logrocket.com/css-reference-guide-button-styling/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="CSS Reference Guide: Button styling - LogRocket Blog" />
	<meta property="og:description" content="Learn how to create and style button classes using CSS, including a detailed look at style properties and animated effects." />
	<meta property="og:url" content="https://blog.logrocket.com/css-reference-guide-button-styling/" />
	<meta property="og:site_name" content="LogRocket Blog" />
	<meta property="article:published_time" content="2020-09-30T19:00:18+00:00" />
	<meta property="article:modified_time" content="2020-09-30T19:20:12+00:00" />
	<meta property="og:image" content="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?fit=730%2C487&#038;ssl=1" />
	<meta property="og:image:width" content="730" />
	<meta property="og:image:height" content="487" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/css-reference-guide-button-styling/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?fit=730%2C487&ssl=1","width":730,"height":487,"caption":"CSS Reference Guide: Button Styling"},{"@type":"WebPage","@id":"https://blog.logrocket.com/css-reference-guide-button-styling/#webpage","url":"https://blog.logrocket.com/css-reference-guide-button-styling/","name":"CSS Reference Guide: Button styling - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/css-reference-guide-button-styling/#primaryimage"},"datePublished":"2020-09-30T19:00:18+00:00","dateModified":"2020-09-30T19:20:12+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/31c8dfaa642b2354f2254d0593185b42"},"description":"Learn how to create and style button classes using CSS, including a detailed look at style properties and animated effects.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/css-reference-guide-button-styling/"]}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/31c8dfaa642b2354f2254d0593185b42","name":"Chidume Nnamdi","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/dbafebf712fa816299231d2763fd292e?s=96&d=mm&r=g","caption":"Chidume Nnamdi"},"description":"I'm a software engineer with 6+ years of experience. I've worked with different stacks ranging from WAMP, to MERN, to MEAN. My language of choice is JavaScript; frameworks are Angular and Nodejs."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; CSS Reference Guide: Button styling Comments Feed" href="https://blog.logrocket.com/css-reference-guide-button-styling/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css'  href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.9.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.9.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/26219" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/paUW9B-6OT' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">

    <script>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</script>


    <script>
    window.Raven && window.Raven.config('https://98e0ea7c6f2e492d94439ad5aaea48dd@e.logrocket.com/4').install()
    </script>
    <script type="text/javascript">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</script>

<!-- Start VWO Async Smartcode -->
<script type='text/javascript'>
window._vwo_code = window._vwo_code || (function(){
var account_id=338524,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
is_spa=1,
hide_element='body',

/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document,code={use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){
settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b=hide_element?hide_element+'{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}':'',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&f='+(+is_spa)+'&r='+Math.random());return settings_timer; }};window._vwo_settings_timer = code.init(); return code; }());
</script>
<!-- End VWO Async Smartcode -->

    <script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
    <script>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</script><style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=270%2C270&#038;ssl=1" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=b747feeae3" />
		<style id="kirki-inline-styles">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</style></head>

<body class="post-template-default single single-post postid-26219 single-format-standard">

<style>
    </style>


<header class="navbar-light bg-white fixed-top mediumnavigation">

    <div class="container">



        <div class="navarea">

<div class="nav-left">

  <a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>

<nav class="menu-container">

        <div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a></ul></div></nav>

</div>

<div class="nav-right">

  <div class="menu-container">
    <div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Free Trial</a></li>
</ul></div>  </div>

</div>

        </div>

    </div>

</header>


        <!-- Begin site-content
		================================================== -->
        <div class="site-content">


<div class="container"> 
    <div class="row">         
        <div class=" col-md-2 ">           
            <div class="share">
                
                <div class="sidebarapplause">
                                </div>
                
                				<p class="sharecolour">
					Share				</p>
                
<ul class="shareitnow"><li>
        <a target="_blank" href="https://twitter.com/intent/tweet?text=CSS%20Reference%20Guide:%20Button%20styling&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F">
        <i class="fa fa-twitter"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F">
        <i class="fa fa-facebook"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F">
        <i class="fa fa-google"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F&amp;media=https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?fit=730%2C487&ssl=1&amp;description=CSS%20Reference%20Guide:%20Button%20styling">
        <i class="fa fa-pinterest"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F&amp;title=CSS%20Reference%20Guide:%20Button%20styling">
        <i class="fa fa-linkedin"></i>
        </a>
    </li></ul>                		        
                
                                <div class="sep"></div>
                <div class="hidden-xs-down">      

                    <p>
                        Reply                    </p>
                    <ul>
                        <li>
                        <a class="smoothscroll" href="#comments">0<br/>
                        <svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
                        </a>
                        </li>
                    </ul>
                </div>
                            </div>			                                
        </div>
        
                    			                <div class="col-md-8 flex-first flex-md-unordered post-26219 post type-post status-publish format-standard has-post-thumbnail hentry category-reference-guides category-uncategorized tag-css tag-reference-guide" id="post-26219"> 
                    <div class="mainheading">
                       
                                                <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-md-down"> 
                            <div class="col-md-2 col-xs-12"> 
                                <a href="https://blog.logrocket.com/author/chidumennamdi/">
                                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                                </a>
                            </div>                                         
                            <div class="col-md-10 col-xs-12"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/chidumennamdi/">
                                Chidume Nnamdi <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">I'm a software engineer with 6+ years of experience. I've worked with different stacks ranging from WAMP, to MERN, to MEAN. My language of choice is JavaScript; frameworks are Angular and Nodejs.</span> 
                            </div>                                         
                        </div>
                                                 
                                                
                        <h1 class="posttitle">CSS Reference Guide: Button styling</h1>
					    <h2 class="post-subtitle"></h2>

                        <p>
                                                        <span class="post-date"><time class="post-date">
                            September 30, 2020                            </time></span>
                                                        
                                                        <span class="dot"></span>
                            <span class="readingtime">4 min read</span>
						    <span class="wordcount">1121</span>

                                                    </p> 
                    </div>
                    
                  <img width="730" height="487" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?fit=730%2C487&amp;ssl=1" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="CSS Reference Guide: Button Styling" loading="lazy" data-attachment-id="26236" data-permalink="https://blog.logrocket.com/css-reference-guide-button-styling/lr-css-reference-guide-button-styling/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?fit=730%2C487&amp;ssl=1" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CSS Reference Guide: Button styling" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?fit=300%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?fit=730%2C487&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?w=730&amp;ssl=1 730w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-button-styling.png?fit=730%2C487&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    <article class="article-post">
                                                <p>Normal buttons are rendered using the default browser styling. We can override this default styling using CSS.</p>
<h4><em>Jump ahead:</em></h4>
<ul>
<li><a href="#basic"><em>Basic buttons</em></a></li>
<li><a href="#colors"><em>Button colors</em></a></li>
<li><a href="#sizes"><em>Button sizes</em></a></li>
<li><a href="#block"><em>Block buttons</em></a></li>
<li><a href="#disabled"><em>Disabled buttons</em></a></li>
<li><a href="#round"><em>Round buttons</em></a></li>
<li><a href="#elevated"><em>Elevated buttons</em></a></li>
<li><a href="#animated"><em>Animated buttons</em></a></li>
</ul>
<hr />
<p>The basic CSS properties for styling buttons are: <code>padding</code>, <code>margin</code>, <code>border-radius</code>, and <code>background</code>. CSS frameworks like Material Design, Bootstrap, Tailwind CSS, and others use these to style their buttons to produce their own style classes.</p>
<p>In this guide, we will create our own button style classes from pure CSS. The following demo shows the results of our implementation:</p>
<p class="codepen" style="height: 500px; box-sizing: border-box; display: flex; align-items: center; justify-content: center; border: 2px solid; margin: 1em 0; padding: 1em;" data-height="500" data-theme-id="dark" data-default-tab="css,result" data-user="philipsz-davido" data-slug-hash="qBZoMXm" data-pen-title="buttons examples">See the Pen <a href="https://codepen.io/philipsz-davido/pen/qBZoMXm"><br />
buttons examples</a> by Chidume David (<a href="https://codepen.io/philipsz-davido">@philipsz-davido</a>)<br />
on <a href="https://codepen.io">CodePen</a>.</p>
<p><script async src="https://static.codepen.io/assets/embed/ei.js"></script></p>
<h2 id="basic">Basic buttons</h2>
<p>Let&#8217;s create a base button style class with basic styling:</p>
<pre class="language-css">.button {
    padding: 6px 12px;
    margin-bottom: 0;
    font-weight: 400;
    cursor: pointer;
    text-align: center;
    white-space: nowrap;
    display: inline-block;
    background-image: none;

    border-radius: 3px;
    box-shadow: none;
    border: 1px solid transparent;
}</pre>
<p>All buttons in this guide will take the above styling by default. Let&#8217;s break down the styling properties:</p>
<ul>
<li><code>padding</code>: Pads the content of the button to 6px on the top and bottom, 12px on the left and right</li>
<li><code>margin-bottom</code>: Declares no margin at the bottom of the button</li>
<li><code>font-weight</code>: Here, we&#8217;ve set the text content to be slightly bolder</li>
<li><code>cursor</code>: The system cursor will convert to a hand icon on hover</li>
<li><code>text-align</code>: Center-aligns the button text</li>
<li><code>white-space</code>: The button text will remain on the same line; it does not break on limited space</li>
<li><code>display</code>: Sets the button to wrap around its siblings, while making its height and width adjustable</li>
<li><code>background-image</code>: Toggles off any image set in the background</li>
<li><code>border-radius</code>: Set to be 3px</li>
<li><code>box-shadow</code>: Set to be removed around the button</li>
<li><code>border</code>: Set to be 1px wide, solid, and transparent</li>
</ul>
<p>This forms the base of our class and allows us to create child buttons from it. Simply set the <code>.button</code> to a button class attribute and our styling takes over:</p>
<pre class="language-html">&lt;button class="button"&gt;Button&lt;/button&gt;</pre>
<hr />
<h2 id="colors">Button colors</h2>
<p>We can then create variations of buttons from the <code>.button</code> base class. These variations will be buttons with different colors.</p>
<p>To create CSS buttons with different colors, we use the <code>color</code>, <code>background-color</code>, and <code>border-color</code> properties to create the variations.</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br/>No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>

<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>

<h4>Red button</h4>
<pre class="language-css">.button .buttonRed {
    color: #fff;
    background-color: red;
    border-color: #ac2925;            
}</pre>
<p>The <code>color</code> prop in hex is <code>#fff</code>; the <code>background-color</code> prop makes the button appear <code>red</code> in color. The <code>border-color</code> is set to be slightly darker than <code>red</code> to better define the button borders.</p>
<p>We can now set the <code>.buttonRed</code> class to <code>.button</code> buttons to create buttons with a tomato-red color.</p>
<pre class="language-html">&lt;button class="button buttonRed"&gt;Red Button&lt;/button&gt;</pre>
<h4>Green button</h4>
<pre class="language-css">.button .buttonGreen {
    color: #fff;
    background-color: green;
    border-color: #4cae4c;
}</pre>
<p>The <code>background-color</code> prop here is set to <code>green</code>. Applying <code>.buttonGreen</code> to a button:</p>
<pre class="language-html">&lt;button class="button buttonGreen"&gt;Green Button&lt;/button&gt;</pre>
<h4>Blue button</h4>
<pre class="language-css">.button .buttonBlue {
    color: #fff;
    background-color: blue;
    border-color: #2e6da4;    
}</pre>
<p>This will make any button with the <code>.buttonBlue</code> class appear blue in color. Applying <code>.buttonBlue</code> to a button:</p>
<pre class="language-html">&lt;button class="button buttonBlue"&gt;Blue Button&lt;/button&gt;
</pre>
<hr />
<h2 id="sizes">Button sizes</h2>
<p>We can use the <code>padding</code> and <code>font-size</code> properties to increase the button sizes.</p>
<h4>Large button</h4>
<pre class="language-css">.buttonLarge {
    padding: 10px 16px;
    font-size: 18px;
}</pre>
<h4>Small button</h4>
<pre class="language-css">.buttonSmall {
    padding: 5px 10px;
    font-size: 12px;    
}</pre>
<h4>Extra-small button</h4>
<pre class="language-css">.buttonXSmall {
    padding: 1px 5px;
    font-size: 12px;    
}</pre>
<p>Notice how the <code>padding</code> and <code>font-size</code> values decreased from <code>.buttonLarge</code> to <code>.buttonXSmall</code> — especially the <code>font-size</code> because it sets the element&#8217;s text size.</p>
<hr />
<h2 id="block">Block buttons</h2>
<p>Block buttons expand to fill the width of their parent container. This is done using the <code>width</code> property.</p>
<pre class="language-css">.buttonBlock {
    width: 100%;
}</pre>
<p>The <code>width</code> is set to <code>100%</code>, so that it stretches to fill the entire length of its parent.</p>
<p>We can also use <code>width</code> to define our button length; it can be set to any percentage or to any unit.</p>
<pre class="language-css">.buttonBlock {
    width: 50%;
}</pre>
<pre class="language-css">.buttonBlock {
    width: 10px;
}</pre>
<pre class="language-css">.buttonBlock {
    width: 10em;
}</pre>
<hr />
<h2 id="disabled">Disabled buttons</h2>
<p>We can simulate a disabled button by using the <code>cursor</code> and <code>opacity</code> properties.</p>
<pre class="language-css">.button.disabled {
    cursor: not-allowed;
    opacity: 0.65;
}</pre>
<p>The system cursor will become a stop icon on hover based on the <code>not-allowed</code> value in the <code>cursor</code> property. This disables any clicking event or any other mouse-associated events on the button.</p>
<p><code>opacity</code> defines the button visibility. Here, the value <code>0.65</code> makes it slightly dimmer to signify that the button is disabled.</p>
<hr />
<h2 id="round">Round buttons</h2>
<p>We create round buttons in CSS by using the <code>border-radius</code>, <code>height</code>, and <code>width</code> properties.</p>
<pre class="language-css">.buttonRound {
    border-radius: 50%;
    height: 44px;
    width: 44px;
}</pre>
<p>To make a button round, we set the <code>border-radius</code> to <code>50%</code>. <code>height</code> and <code>width</code> ultimately determine the size of the button. If they were not the same value, the button would appear oval; to make it a circle, they share the same value of <code>44px</code>.</p>
<hr />
<h2 id="elevated">Elevated buttons</h2>
<p>Creating elevated or raised buttons is accomplished with the <code>box-shadow</code> property. This property casts a shadow around an element&#8217;s border.</p>
<pre class="language-css">.buttonRaised {
    box-shadow: 0 3px 8px 0 black;
}</pre>
<p>This will give the button a 3D look. The first value of the <code>box-shadow</code> property sets the top part shadow to <code>0</code>, the right side to <code>3px</code>, the bottom to <code>8px</code>, and the left to <code>0</code>. We&#8217;ve also defined a <code>black</code> color. With these values, we will see black shadows cast on the bottom more than on the right sides.</p>
<hr />
<h2 id="animated">Animated buttons</h2>
<p>We can add animated effects to buttons using CSS as well.</p>
<p>In particular, we&#8217;d like animated effects when a button is hovered over, when the mouse hovers way from the button, and when the button is clicked.</p>
<h3>Hover effect</h3>
<p>We use the <code>:hover</code> pseudo-class selector to set styling to a button when the mouse moves over it.</p>
<p>Let&#8217;s add a hover effect for each of our different button colors:</p>
<pre class="language-css">//red button
.buttonRed:hover {
    color: #fff;
    background-color: red;
    border-color: #ac2925;
    box-shadow: 1px 1px 1px 3px grey;
}

//green button
.buttonGreen:hover {
    color: #fff;
    background-color: green;
    border-color: #398439;
    box-shadow: 1px 1px 1px 3px grey;
}

//blue button
.buttonBlue:hover {
    color: #fff;
    background-color: blue;
    border-color: #269abc;
    box-shadow: 1px 1px 1px 3px grey;
}</pre>
<p>The colors we&#8217;ve selected for the <code>color</code>, <code>border-color</code>, and <code>background-color</code> properties of our buttons have a respectively lighter opacity than their original state. The shadow cast by the elements is also set to be more defined using the <code>box-shadow</code> property on hover.</p>
<p>This provides a visual cue for the user when they hover the button. They will see a dim in the button&#8217;s color, background color, and a deeper shadow cast on hover.</p>
<h3>Click effect</h3>
<p>To create a click effect, we use the <code>:active</code> pseudo-class selector.</p>
<pre class="language-css">//red button
.buttonRed:active {
    color: #fff;
    background-color: #3b0404;
    border-color: #ac2925;
}

//green button
.buttonGreen:active {
    color: #fff;
    background-color: #022c02;
    border-color: #398439;
}

//blue button
.buttonBlue:active {
    color: #fff;
    background-color: #020221;
    border-color: #269abc;
}</pre>
<p>Just like in the hover effect, we changed the color of the border, text, background when the button is clicked. In CSS, when the button is clicked the <code>:active</code> pseudo-selector is triggered.</p><div class='code-block code-block-26' style='margin: 8px 0; clear: both;'>
<div class="inline-plug css-plug"><h2>Is your frontend hogging your users' CPU?</h2>As web frontends get increasingly complex, resource-greedy features demand more and more from the browser. If you’re interested in monitoring and tracking client-side CPU usage, memory usage, and more for all of your users in production, <a href="https://logrocket.com/signup/">try LogRocket</a>.<a class="signup" href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/12/cpu-memory-usage.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/12/cpu-memory-usage.png?resize=1200%2C677&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2019/12/cpu-memory-usage.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" /></noscript></a><a href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">https://logrocket.com/signup/</a><p style="margin-top: 15px;"><a href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web apps, recording everything that happens in your web app or site. Instead of guessing why problems happen, you can aggregate and report on key frontend performance metrics, replay user sessions along with application state, log network requests, and automatically surface all errors.</p><p>Modernize how you debug web apps — <a class="signup" href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">Start monitoring for free</a>.</p></div></div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-26219" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/css-reference-guide-button-styling/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/css-reference-guide-button-styling/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-26219" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/css-reference-guide-button-styling/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-26219" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/css-reference-guide-button-styling/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><!-- AI CONTENT END 1 -->
                        <div class="clearfix"></div>
                                                <div class="clearfix"></div>
                    </article>
                            
                                             <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-lg-up"> 
                            <div class="col-md-2 col-xs-4"> 
                                <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                            </div>                                         
                            <div class="col-md-10 col-xs-8"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/chidumennamdi/">
                                Chidume Nnamdi <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">I'm a software engineer with 6+ years of experience. I've worked with different stacks ranging from WAMP, to MERN, to MEAN. My language of choice is JavaScript; frameworks are Angular and Nodejs.</span> 
                            </div>                                         
                        </div>
                                         
                    <div class="after-post-tags">
                                                    <ul class="post-categories">
	<li><a href="https://blog.logrocket.com/category/reference-guides/" rel="category tag">Reference Guides</a></li>
	<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul>                                                                            <ul class="post-categories aretags">
                            <li><a href="https://blog.logrocket.com/tag/css/">#css</a></li> <li><a href="https://blog.logrocket.com/tag/reference-guide/">#reference guide</a></li>                             </ul>
                                            </div>
                    
                  
                    <div class="row mb-5 prevnextlinks justify-content-center align-items-center"> 
                       <div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/css-reference-guide-overflow/" rel="prev">CSS Reference Guide: <code>overflow</code></a></div></div>
                       <div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/css-reference-guide-transitions/" rel="next">CSS Reference Guide: Transitions</a> &raquo;</div></div>
                    </div>
                    
                </div>
        
                    
         
        
        
    </div>                 
</div>             
          
<div class="hideshare"></div>

    <div class="graybg"> 
        <div class="container"> 
                <div class="row justify-content-center listrecent listrelated">
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/css-reference-guide-calc/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-calc-nocdn.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/css-reference-guide-calc/">CSS Reference Guide: calc()</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">Chidume Nnamdi</a></span><br>
                    <span class="post-date">Sep 30, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">2 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/css-reference-guide-calc/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/css-reference-guide-flex/" style="background-image:url(https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-flex.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/css-reference-guide-flex/">CSS Reference Guide: flex</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">Chidume Nnamdi</a></span><br>
                    <span class="post-date">Sep 30, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">3 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/css-reference-guide-flex/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/css-reference-guide-border/" style="background-image:url(https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-border.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/css-reference-guide-border/">CSS Reference Guide: border</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">Chidume Nnamdi</a></span><br>
                    <span class="post-date">Sep 30, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">3 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/css-reference-guide-border/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
            </div>
    <div class="clearfix"></div>
                
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/css-reference-guide-button-styling/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=26219&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.9.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=448adceb71015a7a6a54fa5348917ce00e15978d#parent=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
</div>
</div>        </div>                 
    </div>

    <div class="alertbar"> 
        <div class="container text-center"> 
                    </div>
    </div>

</div><!-- /.site-content -->
        
        <div class="container">
            <footer class="footer"> 
                <div class="pull-left"> Does something seem off? Email <a>support@logrocket.com</a> </div> 
                <div class="pull-right"> <div class = "footerRight">			<div id="jetpack-search-filters-2-wrapper" >
		<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field"
placeholder="Search..."
value="" name="s"
title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>   
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div>  </div> 
                <div class="clearfix"></div>
                <a href="" class="back-to-top hidden-md-down"> 
                <i class="fa fa-angle-up"></i>
                </a>
            </footer>
        </div>
        
<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
};
var current_url = location.pathname;
if (current_url == "/") {
jQuery( "#post-20374 span.readingtime" ).replaceWith( "<span class='readingtime'>12 min read</span>" );
};
</script>	<div style="display:none">
	<div class="grofile-hash-map-dbafebf712fa816299231d2763fd292e">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/css-reference-guide-button-styling\/":26219};
	</script>
				<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blog.logrocket.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.5.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.9.1/modules/widgets/search/js/search-widget.js' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.5.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=26219&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=448adceb71015a7a6a54fa5348917ce00e15978d#parent=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=26219&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=448adceb71015a7a6a54fa5348917ce00e15978d#parent=https%3A%2F%2Fblog.logrocket.com%2Fcss-reference-guide-button-styling%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202040.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'161333275',post:'26219',tz:'-4',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '26219' ]);
</script>
<script>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</script>
            </body>     
</html>
<!--
	generated 200 seconds ago
	generated in 0.395 seconds
	served from batcache in 0.003 seconds
	expires in 100 seconds
-->
