<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />


<title>Building a React live streaming app with 100ms - LogRocket Blog</title>
<meta name="description" content="Learn about 100ms by building a live streaming app with an interactive feature where broadcasters and viewers can communicate using chat." />
<link rel="canonical" href="https://blog.logrocket.com/build-react-live-streaming-app-100ms/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Building a React live streaming app with 100ms - LogRocket Blog" />
<meta property="og:description" content="Learn about 100ms by building a live streaming app with an interactive feature where broadcasters and viewers can communicate using chat." />
<meta property="og:url" content="https://blog.logrocket.com/build-react-live-streaming-app-100ms/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2022-10-14T13:00:23+00:00" />
<meta property="article:modified_time" content="2022-10-10T18:07:14+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="487" />
<meta property="og:image:type" content="image/png" />
<meta name="author" content="Taminoturoko Briggs" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Taminoturoko Briggs" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="18 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://blog.logrocket.com/build-react-live-streaming-app-100ms/","url":"https://blog.logrocket.com/build-react-live-streaming-app-100ms/","name":"Building a React live streaming app with 100ms - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/build-react-live-streaming-app-100ms/#primaryimage"},"image":{"@id":"https://blog.logrocket.com/build-react-live-streaming-app-100ms/#primaryimage"},"thumbnailUrl":"https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png","datePublished":"2022-10-14T13:00:23+00:00","dateModified":"2022-10-10T18:07:14+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/30e3c91a2af400ab00c2f0100365c31b"},"description":"Learn about 100ms by building a live streaming app with an interactive feature where broadcasters and viewers can communicate using chat.","breadcrumb":{"@id":"https://blog.logrocket.com/build-react-live-streaming-app-100ms/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/build-react-live-streaming-app-100ms/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blog.logrocket.com/build-react-live-streaming-app-100ms/#primaryimage","url":"https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png","contentUrl":"https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png","width":730,"height":487,"caption":"React Live Streaming 100ms"},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/build-react-live-streaming-app-100ms/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://blog.logrocket.com/"},{"@type":"ListItem","position":2,"name":"Building a React live streaming app with 100ms"}]},{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://blog.logrocket.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/30e3c91a2af400ab00c2f0100365c31b","name":"Taminoturoko Briggs","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blog.logrocket.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/43994b0a2a6162c555d4acc9d55dcaaa?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/43994b0a2a6162c555d4acc9d55dcaaa?s=96&d=mm&r=g","caption":"Taminoturoko Briggs"},"description":"Software developer and technical writer. Core languages include JavaScript and Python.","url":"https://blog.logrocket.com/author/taminoturokobriggs/"}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Building a React live streaming app with 100ms Comments Feed" href="https://blog.logrocket.com/build-react-live-streaming-app-100ms/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/6.0.0-beta2/css/all.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=11.5-a.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.5-a.3' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/136201" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-zqN' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<script src="//geoip-js.com/js/apis/geoip2/v2.1/geoip2.js" type="text/javascript"></script>
<script src="https://storage.googleapis.com/lr-marketing-js/lr-web-analytics/script/4.js"></script>
<script>
    function geoipCountry() {
      return new Promise((resolve, reject) => {
        window.geoip2.country(resolve, reject);
      });
    }
</script>
<script>
  (async function () {
    let geoipResponse;
    try {
      geoipResponse = await geoipCountry();
    } catch (err) {
      // Geoip potentially got blocked.
      // TODO: add this to the analytics proxy
      console.error('geoip blocked');
    }

    window.lr_analytics.init({
      analyticsProxy: {
        enabled: true,
      },
      segment: {
        enabled: true,
        writeKey: 'hn3yvJCms37nkkjrwDQ08PuKJKydGtAZ',
        load: true,
      },
      sixSense: {
        enabled: () => {
          if (!geoipResponse) {
            return false;
          }
          if (geoipResponse.country.iso_code === 'US') {
            return true;
          } else if (geoipResponse.continent.code === 'NA' || geoipResponse.continent.code === 'EU') {
            return false;
          } else {
            return true;
          }
        },
        apiKey: 'd5fbd2e5f08cba3d3d417f7a67cd8d1f',
        companyDetails: {
          enabled: () => geoipResponse.country.iso_code === 'US',
          apiKey: 'a2d1a28025c555de9af13fd94f96f9044dbb8331',
          callback: async (sixSenseResponse) => {
            // send to segment
            window.lr_analytics.sixSenseCallbacks.sendSegmentEvents(sixSenseResponse);
            
            // try to personalize the page
            const data = JSON.parse(sixSenseResponse);

            if (data?.company?.domain && !window.location.href.includes('product-management')) {
              try {
                // Get the custom demo and image links
                const custom = await window.lr_analytics.fetchOutreachAccountCustomFields({
                  domain: data.company.domain,
                  fields: [17, 18]
                });

                window.lr_analytics.personalizePage({
                  items: [
                    {
                      selector: "#blog-personalized-demo-link",
                      source: custom['custom17'],
                      attribute: 'href'
                    },
                    {
                      selector: "#blog-personalized-demo-thumbnail",
                      source: custom['custom18'],
                      attribute: 'src'
                    },
                    {
                      selector: "#personalized-company-account-name",
                      source: data.company.name,
                      attribute: 'innerHTML'
                    }
                  ]
                });

                window.analytics.track('Personalization-deployed-blog', {
                  Domain: data.company.domain,
                });
              } catch (err) {
                window.analytics.track('personalization-failed');
                throw err;
              }
            }
          }
        },
      },
      redditPixel: {
        enabled: true,
        accountId: 't2_3xdvtyx2',
      },
      vwo: {
        enabled: true,
        accountId: 338524
      },
      utmMediumHash: {
        enabled: true,
      }
    });

    analytics.page();
  })()

</script>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://a39e555ed62c408792586c55bbb2ce3b@e.logrocket.com/9').install()
    </script> <style>img#wpstats{display:none}</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=4ebfe50e4a" /><style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-136201 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="nav-left">

<a class="blog-logo" href='https://logrocket.com' rel='home'><img src='https://blog.logrocket.com/wp-content/uploads/2022/09/logrocket-logo-frontend-analytics.png' alt='LogRocket Blog'></a>
<div class="col-lg-4 col-md-4 mr-auto col-xs-12 text-right searcharea">
</div>

<div class="navarea">
<nav class="navbar navbar-toggleable-sm">
<button class="navbar-toggler navbar-toggler-right" type="button" data-toggle="collapse" data-target="#bs4navbar" aria-controls="bs4navbar" aria-expanded="false" aria-label="Toggle navigation">
<span class="navbar-toggler-icon"></span>
</button>
<div id="bs4navbar" class="collapse navbar-collapse"><ul id="menu-primary" class="navbar-nav col-md-12 justify-content-center"><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6 nav-item dropdown"><a href="#" class="nav-link dropdown-toggle">Blog</a>
<div class="dropdown-menu">
<a href="/" class="dropdown-item">Dev</a><a href="https://blog.logrocket.com/product-management" class="dropdown-item">Product Management</a></div>
<li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">Podcast</a><li id="menu-item-72923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72923 nav-item"><a href="https://blog.logrocket.com/tech-meetups/" class="nav-link">Meetups</a></ul></div> </nav>
</div>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Start monitoring for free</a></li>
</ul></div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container container-first-lr">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Building%20a%20React%20live%20streaming%20app%20with%20100ms&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png&amp;description=Building%20a%20React%20live%20streaming%20app%20with%20100ms">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms%2F&amp;title=Building%20a%20React%20live%20streaming%20app%20with%20100ms">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-136201 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-react" id="post-136201">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/taminoturokobriggs/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/11/IMG-20210729-WA0008_2-150x150.jpg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/11/IMG-20210729-WA0008_2-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/11/IMG-20210729-WA0008_2-150x150.jpg?crop=1' class='avatar avatar-72 photo' height='72' width='72'  /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/taminoturokobriggs/">
Taminoturoko Briggs <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Software developer and technical writer. Core languages include JavaScript and Python.</span>
</div>
</div>
<h1 class="posttitle">Building a React live streaming app with 100ms</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
October 14, 2022 </time></span>
<span class="dot"></span>
<span class="readingtime">13 min read</span>
<span class="wordcount">3708</span>
</p>
</div>
<img width="730" height="487" src="https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="React Live Streaming 100ms" data-attachment-id="136345" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/react-live-streaming-100-ms/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="react-live-streaming-100-ms" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms-300x200.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms-300x200.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/react-live-streaming-100-ms.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> <article class="article-post">
<p>Live streaming is a great way to engage with audiences ranging anywhere from one person to millions in real-time. Unlike video conferences where anyone can share their screen or speak at any time, in live streaming, viewers have limited permissions. Implementing live streaming from scratch would be time-consuming, but there are services that we can use to add this feature with just a few steps, one of which is <a href="https://www.100ms.live/">100ms</a>.</p>
<p>In this tutorial, we’ll learn about 100ms by building a live streaming app with an interactive feature where broadcasters and viewers can communicate using chat.</p>
<p>To follow along with this tutorial, you should be familiar with React and React Hooks. You should also have Node.js installed in your system.</p>
<p>The full code for this tutorial is available on <a href="https://github.com/Tammibriggs/LiveStreaming-100ms">GitHub</a>. Let’s get started!</p>
<ul>
<li><a href="#introduction-100ms">Introduction to 100ms</a></li>
<li><a href="#setting-up-100ms">Setting up 100ms</a></li>
<li><a href="#building-livestreaming-app-100ms">Building a live streaming app with 100ms</a></li>
<li><a href="#setting-up-react">Setting up React</a></li>
<li><a href="#integrate-100ms-into-app">Integrate 100ms into our app</a></li>
<li><a href="#joining-room">Joining a room</a></li>
<li><a href="displaying-video-tiles">Displaying video tiles</a></li>
<li><a href="#live-stream-hls-display-stream-viewers">Live stream via HLS and display stream to viewers</a></li>
<li><a href="#adding-room-control-functionalities">Adding room control functionalities</a></li>
<li><a href="#add-chat-functionality-display-participants">Add chat functionality and display all participants</a></li>
</ul>
<h2 id="introduction-100ms">Introduction to 100ms</h2>
<p>100ms is a cloud platform that allows developers to add video and audio conferencing to web, Android, and iOS applications. It provides REST APIs, SDKs, and a dashboard that makes it simple to capture, distribute, record, and render live interactive audio and video.</p>
<p>Using 100ms to build a live app is quite straightforward, involving just two major steps. The first is creating and configuring a <a href="https://www.100ms.live/docs/javascript/v2/foundation/templates-and-roles">template</a> in the dashboard with roles and settings for the app and its users.</p>
<p>The template configuration will be different depending on what type of app you&#8217;re building, video conference, virtual event, or live streaming. For example, in a live streaming app, streamers or broadcasters can share video, audio, or their screen, while a viewer cannot do any of the above. We’ll set all this up in the template.</p>
<p>Instead of creating a custom template, we can choose from the <a href="https://www.100ms.live/examples/virtual-events-starter-kit">available starter kits</a> that already have the appropriate configurations for different types of live apps and just add a little fine tuning. After setting up the template, we&#8217;ll use the SDK with its intuitive methods, hooks, and selectors on the client side to integrate and work with 100ms.</p>
<p>Before getting started, you should be familiar with the 100ms concepts below:</p>
<ul>
<li>Room: When we join an audio or video call, the participants are said to be in a room</li>
<li>Peer: A participant in the audio or video call. You are the local peer, while others are remote peers</li>
<li>Track: There are two types of tracks a peer can have, audio and video</li>
</ul>
<h2 id="setting-up-100ms">Setting up 100ms</h2>
<p>To set up the live streaming template, navigate to <a href="https://dashboard.100ms.live/register?pathname=/">100ms</a> and set up a user account in the browser. When logged in, click <strong>Create Your First App</strong> on the dashboard and a modal will appear where we can create a custom template or choose one that has already been created:</p>
<p><img data-attachment-id="136316" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/100-ms-app-templates/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates.png" data-orig-size="730,435" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="100-ms-app-templates" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates-300x179.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates.png" class="aligncenter wp-image-136316 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates.png" alt="100ms App Templates" width="730" height="435" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates-300x179.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136316" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/100-ms-app-templates/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates.png" data-orig-size="730,435" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="100-ms-app-templates" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates-300x179.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates.png" loading="lazy" class="aligncenter wp-image-136316 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates.png" alt="100ms App Templates" width="730" height="435" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/100-ms-app-templates-300x179.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>Instead of creating a new template, we&#8217;ll use the live streaming app starter kit. Hover on the <strong>Live Streaming Starter Kit</strong> template and click on the <strong>Deploy now</strong> button that appears. You’ll see the following:</p>
<p><img data-attachment-id="136318" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/deploy-live-streaming-starter-kit/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit.png" data-orig-size="730,408" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="deploy-live-streaming-starter-kit" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit-300x168.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit.png" class="aligncenter wp-image-136318 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit.png" alt="Deploy Live Streaming Starter Kit" width="730" height="408" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit-300x168.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136318" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/deploy-live-streaming-starter-kit/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit.png" data-orig-size="730,408" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="deploy-live-streaming-starter-kit" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit-300x168.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit.png" loading="lazy" class="aligncenter wp-image-136318 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit.png" alt="Deploy Live Streaming Starter Kit" width="730" height="408" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-live-streaming-starter-kit-300x168.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>In the <strong>Choose your Account Type</strong> area, select <strong>Personal</strong>, then click <strong>Next</strong>, and you’ll see the following:</p>
<p><img data-attachment-id="136320" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/choose-personal-account-type/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type.png" data-orig-size="730,457" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="choose-personal-account-type" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type-300x188.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type.png" class="aligncenter wp-image-136320 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type.png" alt="Choose Personal Account Type" width="730" height="457" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type-300x188.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136320" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/choose-personal-account-type/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type.png" data-orig-size="730,457" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="choose-personal-account-type" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type-300x188.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type.png" loading="lazy" class="aligncenter wp-image-136320 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type.png" alt="Choose Personal Account Type" width="730" height="457" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/choose-personal-account-type-300x188.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>We need to enter a unique subdomain. For this, I’ll enter <code>livestreamnow</code>, but you can use any other name. After that, click <strong>Continue.</strong> With this, a live streaming starter kit has been created, and you’ll see it when we navigate to our dashboard:</p>
<p><img data-attachment-id="136323" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/live-stream-starter-kit-created/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created.png" data-orig-size="730,417" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="live-stream-starter-kit-created" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created-300x171.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created.png" class="aligncenter wp-image-136323 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created.png" alt="Live Stream Starter Kit Created" width="730" height="417" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created-300x171.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136323" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/live-stream-starter-kit-created/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created.png" data-orig-size="730,417" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="live-stream-starter-kit-created" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created-300x171.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created.png" loading="lazy" class="aligncenter wp-image-136323 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created.png" alt="Live Stream Starter Kit Created" width="730" height="417" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/live-stream-starter-kit-created-300x171.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>To view the configuration of the starter template, hover on it and click on the <strong>setting icon</strong> that appears. You&#8217;ll see the following screen:</p>
<p><img data-attachment-id="136325" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/configure-starter-template/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template.png" data-orig-size="731,511" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Configure Starter Template" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template-300x210.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template.png" class="aligncenter wp-image-136325 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template.png" alt width="731" height="511" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template.png 731w, https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template-300x210.png 300w" data-lazy-sizes="(max-width: 731px) 100vw, 731px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136325" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/configure-starter-template/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template.png" data-orig-size="731,511" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Configure Starter Template" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template-300x210.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template.png" loading="lazy" class="aligncenter wp-image-136325 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template.png" alt="" width="731" height="511" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template.png 731w, https://blog.logrocket.com/wp-content/uploads/2022/10/configure-starter-template-300x210.png 300w" sizes="(max-width: 731px) 100vw, 731px"  /></noscript></p>
<p>Notice that two roles suitable for a live streaming app have already been created, <code>broadcaster</code> and <code>hls-viewer</code>.</p>
<p>The <code>broadcaster</code> role represents a streamer that publishes their audio or video. They have all permissions turned on, allowing them to perform all available operations, like sharing audio and video, muting and unmuting any participant in the room, stopping and starting the live stream, and more. We can edit the operations allowed for this role or any other role by just toggling the switch next to the operation we want to disable or enable.</p>
<p>The <code>hls-viewer</code> role represents the audience members that join the live stream and can interact using messaging. None of their permissions are turned on, which is usually the case for the audience in a live stream.</p>
<p>We can create other roles by clicking on <strong>Add a Role</strong> on the right side of the screen and then editing the permissions to suit our needs. However, since the required roles for our use case have already been created for us, we won’t do that.</p>
<h2 id="building-livestreaming-app-100ms">Building a live streaming app with 100ms</h2>
<p>100ms includes support for <a href="https://www.100ms.live/blog/hls-101-beginners-guide">HLS</a> for live streaming, which enables scaling to millions of viewers, mainly due to its support by OSes and CDNs. However, compared to other protocols, live streaming via HLS is slower and has a higher latency.</p>
<p>In this section, we’ll use the 100ms SDK to build the live streaming app. Before proceeding, you should be familiar with the following:</p>
<ul>
<li><code>hmsStore</code>: Contains the complete state of the room at any given time, including, for example, participant details, messages, and track states</li>
<li><code>hmsActions</code>: Used to perform any action like joining, muting, and sending a message</li>
</ul>
<h2 id="setting-up-react">Setting up React</h2>
<p>I’ve already created a starter template that we’ll use for this tutorial, so we can focus solely on using 100ms. Clone the GitHub repo with the following commands:</p>
<pre class="language-bash hljs">$ git clone -b starter https://github.com/Tammibriggs/LiveStreaming-100ms.git

$ cd LiveStreaming-100ms

$ npm install
</pre>
<p>Now, when we start the app using the <code>npm start</code> command, we’ll see the following page:</p>
<p><img data-attachment-id="136327" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/start-100ms-example-app-homepage/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage.png" data-orig-size="730,498" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="start-100ms-example-app-homepage" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage.png" class="aligncenter wp-image-136327 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage.png" alt="Start 100ms Example App Homepage" width="730" height="498" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage-300x205.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136327" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/start-100ms-example-app-homepage/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage.png" data-orig-size="730,498" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="start-100ms-example-app-homepage" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage.png" loading="lazy" class="aligncenter wp-image-136327 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage.png" alt="Start 100ms Example App Homepage" width="730" height="498" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/start-100ms-example-app-homepage-300x205.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>On the page above, we can enter a name and select the role we want to use when joining the room.</p>
<p>At this point in the tutorial, when we click on the <strong>Join</strong> button, we won’t be taken to a different page; we’ll work on that later. Instead, after clicking on the <strong>Join</strong> button, the page will look like the following image:</p>
<p><img data-attachment-id="136329" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/join-live-stream-app-example-100ms/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms.png" data-orig-size="701,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="join-live-stream-app-example-100ms" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms.png" class="aligncenter wp-image-136329 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms.png" alt="Join Live Stream App Example 100ms" width="701" height="478" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms.png 701w, https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms-300x205.png 300w" data-lazy-sizes="(max-width: 701px) 100vw, 701px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136329" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/join-live-stream-app-example-100ms/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms.png" data-orig-size="701,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="join-live-stream-app-example-100ms" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms.png" loading="lazy" class="aligncenter wp-image-136329 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms.png" alt="Join Live Stream App Example 100ms" width="701" height="478" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms.png 701w, https://blog.logrocket.com/wp-content/uploads/2022/10/join-live-stream-app-example-100ms-300x205.png 300w" sizes="(max-width: 701px) 100vw, 701px"  /></noscript></p>
<h2 id="integrate-100ms-into-app">Integrate 100ms into our app</h2>
<p>To integrate 100ms into our React app, first, we&#8217;ll install the SDK, which we’ll need to build the app. We’ll install one additional dependency, <a href="https://github.com/video-dev/hls.js/">HLS.js</a>, to aid us in displaying the HLS stream for browsers that don’t support HLS natively:</p>
<pre class="language-bash hljs">$ npm i @100mslive/<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1567707476613866717e55797461706661">[email&#160;protected]</a> hls.js
</pre>
<p>Next, to initialize the SDK, we need to wrap our entire application with the <code>&lt;HMSRoomProvider /&gt;</code> component. In the starter app, head over to the <code>index.js</code> file in the <code>src</code> directory and modify it to look like the following code:</p>
<pre class="language-javascript hljs">// src/index.js
import React from 'react';
import ReactDOM from 'react-dom/client';
import './index.css';
import App from './App';
import { HMSRoomProvider } from '@100mslive/react-sdk';

const root = ReactDOM.createRoot(document.getElementById('root'));
root.render(
  &lt;React.StrictMode&gt;
    &lt;HMSRoomProvider&gt;
      &lt;App /&gt;
    &lt;/HMSRoomProvider&gt;
  &lt;/React.StrictMode&gt;
);
</pre>
<p>Now, let’s go ahead and retrieve the necessary credentials for building our app, <code>room_id</code> and <code>token_endpoint</code>. To get the <code>room_id</code>, navigate to your 100ms dashboard. In the sidebar, click on <strong>Rooms</strong>, and you’ll be taken to the following page:</p>
<p><img data-attachment-id="136332" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/fetch-100ms-room-credentials/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials.png" data-orig-size="730,209" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="fetch-100ms-room-credentials" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials-300x86.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials.png" class="aligncenter wp-image-136332 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials.png" alt="Fetch 100ms Room Credentials" width="730" height="209" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials-300x86.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136332" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/fetch-100ms-room-credentials/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials.png" data-orig-size="730,209" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="fetch-100ms-room-credentials" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials-300x86.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials.png" loading="lazy" class="aligncenter wp-image-136332 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials.png" alt="Fetch 100ms Room Credentials" width="730" height="209" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/fetch-100ms-room-credentials-300x86.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>The two rooms above have already been created for us, which was done when deployed the live streaming starter kit. To verify that the rooms have the <code>broadcaster</code> and <code>hls-viewer</code> roles required for our app, click on any of the IDs under the <code>Room Id</code> table head to check:</p>
<p><img data-attachment-id="136334" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/100ms-room-id-verification/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification.png" data-orig-size="730,249" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="100ms-room-id-verification" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification-300x102.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification.png" class="aligncenter wp-image-136334 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification.png" alt="100ms Room ID Verification" width="730" height="249" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification-300x102.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136334" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/100ms-room-id-verification/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification.png" data-orig-size="730,249" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="100ms-room-id-verification" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification-300x102.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification.png" loading="lazy" class="aligncenter wp-image-136334 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification.png" alt="100ms Room ID Verification" width="730" height="249" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-room-id-verification-300x102.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>Now, copy one of the IDs and paste it in the appropriate variable in the <code>.env</code> file of the starter app.</p><div class='code-block code-block-57' style='margin: 8px 0; clear: both;'>
<hr>
<div style="display:block; margin-bottom: 20px;">
<a href="https://lp.logrocket.com/blg/learn-more" class="embed-link">
<div class="tweet-embed-container">
<div class="single-tweet">
<img src="https://blog.logrocket.com/wp-content/uploads/2022/08/tweet-embed.png" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/08/tweet-embed.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img data-lazy-fallback="1" src="https://blog.logrocket.com/wp-content/uploads/2022/08/tweet-embed.png" /></noscript>
</div>
<div class="embed-tweet-right">
<h2>Over 200k developers use LogRocket to create better digital experiences</h2>
<div class="embed-btn"><img src="https://blog.logrocket.com/wp-content/uploads/2022/08/rocket-button-icon.png" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/08/rocket-button-icon.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img data-lazy-fallback="1" src="https://blog.logrocket.com/wp-content/uploads/2022/08/rocket-button-icon.png" /></noscript>Learn more →</div>
</div>
</div></a></div>
<hr>
<style>
@media all and (max-width: 800px){
    .tweet-embed-container {flex-direction: column !important;}
    .single-tweet, .embed-tweet-right {width: 100% !important;}
}
.embed-link {text-decoration: none;}
.embed-link:hover {text-decoration: none;}
.tweet-embed-container {border-radius: 20px;
  background: radial-gradient(79.69% 102.24% at 100% 100.11%, rgba(0, 0, 0, 0.2), rgba(0, 0, 0, 0)), radial-gradient(89.7% 115.09% at 3.43% 2.75%, rgba(255, 255, 255, 0.7), rgba(255, 255, 255, 0)), #764ABC;
background-blend-mode: overlay, overlay, normal;
  box-shadow: 0 4px 0 #d5d5d5;
  width: auto;
  padding: 10px 15px;
  display: flex;
  flex-direction: row;
  justify-content: space-evenly;
  align-items: center;
  margin: 0 auto;
  gap: 3%;
}
.single-tweet {width: 50%;}
.single-tweet img {max-width: 100%;height: auto;}
.embed-tweet-right {width: 46%;}
.embed-tweet-right h2 {padding-top: 20px;font-family: 'Avenir';
font-style: normal;
font-weight: 500;
font-size: 16px;
line-height: 28px;
color: #FFFFFF;}
.embed-btn {
  display: flex;
  flex-direction: row;
  justify-content: left;
  width: 170px;
  gap: 5px;
  align-items: center;
  padding: 0px 10px;
  font-family: 'Avenir';
font-style: normal;
font-weight: 900;
font-size: 16px;
line-height: 16px;
color: #764ABC;
height: 48px;
/* White */
background: #FFFFFF;
mix-blend-mode: normal;
box-shadow: 0px 24px 30px rgba(0, 0, 0, 0.11);
border-radius: 80px;
  border: none;
}</style></div>
<p>To get the <code>token_endpoint</code> on the sidebar, first click on <strong>Developer</strong>. On the next page, copy the <code>token_endpoint</code> and paste it in the appropriate variable in the <code>.env</code> file:</p>
<p><img data-attachment-id="136337" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/100ms-token-endpoint-credentials/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials.png" data-orig-size="730,278" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="100ms-token-endpoint-credentials" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials-300x114.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials.png" class="aligncenter wp-image-136337 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials.png" alt="100ms Token Endpoint Credentials" width="730" height="278" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials-300x114.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136337" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/100ms-token-endpoint-credentials/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials.png" data-orig-size="730,278" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="100ms-token-endpoint-credentials" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials-300x114.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials.png" loading="lazy" class="aligncenter wp-image-136337 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials.png" alt="100ms Token Endpoint Credentials" width="730" height="278" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-token-endpoint-credentials-300x114.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<h2 id="joining-room">Joining a room</h2>
<p>Now, we’ll work on the page below:</p>
<p><img data-attachment-id="136339" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/joining-chat-room-100ms/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms.png" data-orig-size="730,498" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joining-chat-room-100ms" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms.png" class="aligncenter wp-image-136339 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms.png" alt="Joining Chat Room 100ms" width="730" height="498" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms-300x205.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136339" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/joining-chat-room-100ms/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms.png" data-orig-size="730,498" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="joining-chat-room-100ms" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms.png" loading="lazy" class="aligncenter wp-image-136339 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms.png" alt="Joining Chat Room 100ms" width="730" height="498" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/joining-chat-room-100ms-300x205.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>Before we can begin streaming via HLS, we first need to join a room using the <code>join</code> method on <code>hmsActions</code>, which requires us to pass a <code>config</code> object. The <code>config</code> object must have the following fields:</p>
<ul>
<li><code>userName</code>: The name of the user that will be visible to everyone connected to the room</li>
<li><code>authToken</code>: A client-side token that we&#8217;ll use to authenticate the user</li>
</ul>
<p>If we were <a href="https://blog.logrocket.com/remotion-a-framework-for-making-videos-in-react/">building a video conference, virtual meeting, or any other video call app</a>, we could publish our video by joining the room, which could be seen by other peers or participants in the room. However, since we’ll be live streaming via HLS, the process is different.</p>
<p>Head over to <code>src/JoinRoom.js</code> and add the following import:</p>
<pre class="language-javascript hljs">// src/JoinRoom.js
import { useHMSActions } from "@100mslive/react-sdk";
</pre>
<p>Next, add the following lines of code after the <code>selectedRole</code> state:</p>
<pre class="language-javascript hljs">// src/JoinRoom.js
const hmsActions = useHMSActions()
</pre>
<p>Next, let’s create the function for generating the <code>authToken</code> and join the room. Add the following lines of code after the <code>hmsActions</code> variable:</p>
<pre class="language-javascript hljs">// src/JoinRoom.js
const handleSubmit = async (e) =&gt; {
  e.preventDefault()
  const response = await fetch(`${ENDPOINT}api/token`, {
    method: "POST",
    body: JSON.stringify({
      user_id: `${Date.now()}`,
      role: selectedRole, //broadcaster, hls-viewer
      type: "app",
      room_id: ROOM_ID,
    }),
  })
  const { token } = await response.json()
  // Joining the room
  hmsActions.join({
    userName: username,
    authToken: token,
  })
}
</pre>
<p>In the code above, we are sending a request to generate the authentication token using the endpoint we supplied in our <code>.env</code> file. The request takes the selected role and room ID as parameters. After generating the token, we use it along with the username entered in the input field to join the room using the <code>join</code> method.</p>
<p>To call this function when the form is submitted, modify the opening form tag <code>&lt;form&gt;</code> to look like the following code:</p>
<pre class="language-javascript hljs">// src/JoinRoom.js
&lt;form className="join" onSubmit={handleSubmit}&gt;
</pre>
<p>Right now, when we navigate to <code><a href="http://localhost:3000/" rel="nofollow">http://localhost:3000/</a></code> in our browser, enter a username, and click on the <strong>Join</strong> button, we’ll join the room. However, there won&#8217;t be any changes in the UI yet. To fix this, we need a way to know the connection state of the room and to hide the form after we&#8217;ve connected. We can do so using the <code>selectIsConnectedToRoom</code> selector and the <code>useHMSStore</code> Hook.</p>
<p>Head over to <code>src/App.js</code> and add the following import:</p>
<pre class="language-javascript hljs">// src/App.js
import { useHMSStore, selectIsConnectedToRoom } from '@100mslive/react-sdk';
</pre>
<p>Next, add the following lines of code in the <code>App</code> component:</p>
<pre class="language-javascript hljs">// src/App.js  
const isConnected = useHMSStore(selectIsConnectedToRoom)
</pre>
<p>Next, modify the return statement in the <code>App</code> component to look like the following:</p>
<pre class="language-javascript hljs">// src/App.js
return (
  &lt;div className="App wrapper"&gt; 
    {isConnected
      ? &lt;Room /&gt;
      : &lt;JoinRoom /&gt;
    }
  &lt;/div&gt;
);
</pre>
<p>With this, after joining the room, we’ll see the following page:</p>
<p><img data-attachment-id="136341" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/100ms-page-join/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join.png" data-orig-size="730,498" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="100ms-page-join" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join.png" class="aligncenter wp-image-136341 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join.png" alt="100ms Page Join" width="730" height="498" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join-300x205.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="136341" data-permalink="https://blog.logrocket.com/build-react-live-streaming-app-100ms/attachment/100ms-page-join/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join.png" data-orig-size="730,498" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="100ms-page-join" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join.png" loading="lazy" class="aligncenter wp-image-136341 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join.png" alt="100ms Page Join" width="730" height="498" srcset="https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/10/100ms-page-join-300x205.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<h2 id="displaying-video-tiles">Displaying video tiles</h2>
<p>After joining the room, our video and audio will be published, meaning other peers in the room can view it. However, since we’re live streaming via HLS, other viewers shouldn’t be able to see this. For every broadcaster that joins the room, we want only a video tile of their published video to be displayed to other broadcasters.</p>
<p>For this, we’ll use the <code>useVideo</code> Hook, which takes in a video track ID and returns a <code>videoRef</code> to be passed to a video element. To get the video track ID, we first need to get the list of peers in the room. We can do so using the <code>useHMSStore</code> Hook and <code>selectPeers</code> selector.</p>
<p>Modify the <code>Stream.js</code> file in the <code>src</code> directory to look like the following code:</p>
<pre class="language-javascript hljs">// src/Stream.js
import VideoTile from "./VideoTile";
import HlsView from "./HlsView";
import { selectLocalPeer, selectPeers, useHMSStore } from "@100mslive/react-sdk";

function Stream() {
  const peers = useHMSStore(selectPeers)
  const localPeer = useHMSStore(selectLocalPeer)

  return (
    &lt;div className="stream"&gt;
      {localPeer.roleName === 'broadcaster' &amp;&amp;
        peers.filter((peer) =&gt; peer.roleName === 'broadcaster')
        .map((peer) =&gt; (
          &lt;VideoTile key={peer.id} peer={peer} peers={peers} /&gt;
        )) 
      }
    &lt;/div&gt;
  )
}

export default Stream
</pre>
<p>In the code above, we are getting the list of peers in the room as well as the local peer, which is <code>you</code>. We are conditionally rendering the <code>VideoTile</code> component only when the <code>roleName</code> field of <code>localPeer</code> equals <code>broadcaster</code>.</p>
<p>Doing so will make the video tiles visible only to broadcasters because we haven’t started streaming yet. After that, using the <code>filter</code> method, we can create a new array containing only peers who are broadcasters, then mapping through it and passing each peer to the <code>VideoTile</code> component.</p>
<p>Now, head over to the <code>src/VideoTile.js</code> file. Let’s use <code>useVideo</code> to start displaying the published video of broadcasters in the room. Modify the <code>VideoTile.js</code> file to look like the following code:</p>
<pre class="language-javascript hljs">// src/VideoTile.js
import { useVideo } from "@100mslive/react-sdk";

function VideoTile({ peer, peers }) {
  const { videoRef } = useVideo({
    trackId: peer.videoTrack
  })

  const numberOfBroadCasters = () =&gt; {
    const broadcasters = peers.filter((peer) =&gt; {
      return peer.roleName === 'broadcaster'
    })
    return broadcasters.length
  }

  return (
    &lt;video
      ref={videoRef}
      className={numberOfBroadCasters() &gt;= 2 ? 'video' : ''}
      autoPlay
      muted
      playsInline
    /&gt;
  )
}

export default VideoTile
</pre>
<p>With this, when we join the room as a broadcaster, we should see our published video and the videos of other broadcasters in the room.</p>
<h2 id="live-stream-hls-display-stream-viewers">Live stream via HLS and display stream to viewers</h2>
<p>To start <a href="https://www.100ms.live/docs/javascript/v2/features/hls">streaming via HLS</a>, we just need to call the <code>startHLSStreaming</code> in <code>hmsActions</code>. To stop the stream, we can call the <code>stopHLSStreaming</code> method, and to get the HLS state, we can use the <code>selectHLSState</code> selector. It&#8217;s that simple.</p>
<p>Head over to <code>src/Controls.js</code> and add the following imports:</p>
<pre class="language-javascript hljs">// src/Controls.js
import { selectHLSState, useHMSActions, useHMSStore } from '@100mslive/react-sdk'
</pre>
<p>Next, add the following lines of code in the <code>Controls</code> component:</p>
<pre class="language-javascript hljs">// src/Controls.js
const hmsActions = useHMSActions()
const hlsState = useHMSStore(selectHLSState)
</pre>
<p>Next, add the following functions after the <code>hlsState</code> variable for starting and stopping the live stream:</p>
<pre class="language-javascript hljs">// src/Controls.js
const startHLSStreaming = async () =&gt; {
  try {
    await hmsActions.startHLSStreaming()
  } catch (err) {
      alert(`failed to start hls ${err}`)
  }
}

const stopHLSStreaming = async () =&gt; { 
  try {
    await hmsActions.stopHLSStreaming()
  } catch (err) {
      alert(`failed to stop hls ${err}`)
  }
}
</pre>
<p>To call the functions above, replace the button component under the <code>{/* HLS stream button */}</code> comment in the return statement with the following code:</p>
<pre class="language-javascript hljs">// src/Controls.js
{hlsState.running
  ? &lt;Button 
      variant="contained" 
      disableElevation
      className='leave'
      onClick={stopHLSStreaming}
    &gt;
      &lt;StopCircleOutlined /&gt; Stop Streaming
    &lt;/Button&gt;
  : &lt;Button 
      variant="contained"
      disableElevation
      onClick={startHLSStreaming}
    &gt;
      &lt;PodcastsOutlined /&gt; Go Live 
    &lt;/Button&gt;
}
</pre>
<p>Now, to display the HLS stream to viewers, we’ll use HLS.js, which we installed earlier. For more UI customizations, you can check out <a href="https://videojs.com/">V</a><a href="https://videojs.com/">ideo</a><a href="https://videojs.com/">.</a><a href="https://videojs.com/">js</a>, which uses HLS.js internally.</p>
<p>When using HLS.js in displaying the stream, we need to pass the stream URL to its <code>loadSource</code> method and also pass a video element to it using the <code>attachMedia</code> method. We can get the stream URL from the <code>hls</code> state, which we can retrieve using the <code>selectHLSState</code> selector.</p><div class='code-block code-block-54' style='margin: 8px 0; clear: both;'>
<hr>
<h3>More great articles from LogRocket:</h3>
<ul>
<li>Don't miss a moment with <a href="https://lp.logrocket.com/subscribe-thereplay">The Replay</a>, a curated newsletter from LogRocket</li>
<li><a href="https://blog.logrocket.com/rethinking-error-tracking-product-analytics/">Learn</a> how LogRocket's Galileo cuts through the noise to proactively resolve issues in your app
</li>
<li>Use React's useEffect <a href="https://blog.logrocket.com/understanding-react-useeffect-cleanup-function/">to optimize your application's performance</a></li>
<li>Switch between <a href="https://blog.logrocket.com/switching-between-node-versions-during-development/">multiple versions of Node</a></li>
<li><a href="https://blog.logrocket.com/animate-react-app-animxyz/">Discover how to animate</a> your React app with AnimXYZ</li>
<li><a href="https://blog.logrocket.com/rust-solid-js-tauri-desktop-app/">Explore Tauri</a>, a new framework for building binaries</li>
<li>Compare <a href="https://blog.logrocket.com/nestjs-vs-express-js/">NestJS vs. Express.js</a></li>
</ul>
<hr></div>
<p>Head over to <code>src/Stream.js</code> and add the following code before the closing tag <code>&lt;/&gt;</code> of the <code>div</code> with <code>stream</code> as the <code>className</code>:</p>
<pre class="language-javascript hljs">// src/Stream.js
{localPeer.roleName === 'hls-viewer' &amp;&amp;
  &lt;HlsView/&gt;
}
</pre>
<p>Next, head over to <code>src/HlsView</code> and modify the file to look like the following code:</p>
<pre class="language-javascript hljs">// src/HlsView
import { selectHLSState, useHMSStore } from '@100mslive/react-sdk'
import Hls from 'hls.js'
import { useEffect, useRef } from 'react'

function HlsView() {
    const videoRef = useRef(null)
    const hlsState = useHMSStore(selectHLSState)
    const hlsUrl = hlsState.variants[0]?.url
    useEffect(() =&gt; {
        if (videoRef.current &amp;&amp; hlsUrl) {
            const browserHasNativeHLSSupport = videoRef.current.canPlayType(
                'application/vnd.apple.mpegurl'
            );
            if (Hls.isSupported()) {
                let hls = new Hls()
                hls.loadSource(hlsUrl)
                hls.attachMedia(videoRef.current)
            }
            else if (browserHasNativeHLSSupport) {
                videoRef.current.src = hlsUrl
            }
        }
    }, [hlsUrl])
    return &lt;video ref={videoRef} autoPlay controls&gt;&lt;/video&gt;;
}

export default HlsView
</pre>
<p>With this, viewers will now be able to see the stream from broadcasters.</p>
<h2 id="adding-room-control-functionalities">Adding room control functionalities</h2>
<p>Let’s add functionality to mute and unmute audio and video and to leave the room. Head over to <code>src/Controls.js</code> and add the following imports:</p>
<pre class="language-javascript hljs">// src/Controls.js
import { selectIsLocalAudioEnabled, selectIsLocalVideoEnabled, selectLocalPeer } from '@100mslive/react-sdk'
</pre>
<p>Next, add the following lines of code after the <code>hlsState</code> variable:</p>
<pre class="language-javascript hljs">// src/Controls.js
const audioEnabled = useHMSStore(selectIsLocalAudioEnabled)
const videoEnabled = useHMSStore(selectIsLocalVideoEnabled)
const localPeer = useHMSStore(selectLocalPeer)
</pre>
<p>We use the <code>selectIsLocalAudioEnabled</code> and <code>selectIsLocalVideoEnabled</code> selectors to get the respective boolean states of the audio and video and determine whether they are currently muted or unmuted. We&#8217;ll then toggle the current state and show the appropriate icon in the UI. We also get <code>localPeer</code> using the <code>selectLocalPeer</code> selector.</p>
<p>To mute and unmute audio and video, we can use <code>setLocalVideoEnabled</code> and <code>setLocalAudioEnabled</code> in <code>hmsActions</code>, which receives a boolean as parameter. In the <code>Controls</code> component, add the following functions after the <code>stopHLSStreaming</code> function:</p>
<pre class="language-javascript hljs">// src/Controls.js
const toggleAudio = async () =&gt; {
  await hmsActions.setLocalAudioEnabled(!audioEnabled);
}

const toggleVideo = async () =&gt; {
  await hmsActions.setLocalVideoEnabled(!videoEnabled);
}
</pre>
<p>Now, to call the function above, find the following lines of code in the return statement:</p>
<pre class="language-javascript hljs">&lt;IconButton&gt;
  &lt;MicOffOutlined /&gt;
&lt;/IconButton&gt;
&lt;IconButton&gt;
  &lt;VideocamOffOutlined /&gt;
&lt;/IconButton&gt;
</pre>
<p>Modify the code above to the following code:</p>
<pre class="language-javascript hljs">// src/Controls.js
&lt;IconButton onClick={toggleAudio}&gt;
  {audioEnabled
    ? &lt;MicNoneOutlined /&gt;
    : &lt;MicOffOutlined /&gt;
  }
&lt;/IconButton&gt;
&lt;IconButton onClick={toggleVideo}&gt;
  {videoEnabled
    ? &lt;VideocamOutlined /&gt;
    : &lt;VideocamOffOutlined /&gt;
  }
&lt;/IconButton&gt;
</pre>
<p>To leave the room, we need to call the <code>leave()</code> method in <code>hmsActions</code>. After the <code>toggleVideo</code> function, we need to add the following lines of code:</p>
<pre class="language-javascript hljs">// src/Controls.js
const leaveRoom = async () =&gt; {
  if(localPeer.roleName === 'broadcaster'){
    hmsActions.leave()
    await hmsActions.stopHLSStreaming()
  }else{
    hmsActions.leave()
  }
}
</pre>
<p>In the code above, if the <code>roleName</code> field of the <code>localPeer</code> equals <code>broadcaster</code>, along with leaving the room, we are also ending the HLS stream in case it’s ongoing.</p>
<p>To call the function above in the <code>return</code> statement, we’ll see the following lines of code:</p>
<pre class="language-javascript hljs">&lt;Button 
  variant="contained" 
  disableElevation
  className='leave'
>
  &lt;LogoutOutlined /&gt; Leave Room
&lt;/Button&gt; 
</pre>
<p>Modify it to the following:</p>
<pre class="language-javascript hljs">// src/Controls.js
&amp;lt;Button 
  variant="contained" 
  disableElevation
  className='leave'
  onClick={leaveRoom}
>
  &lt;LogoutOutlined /&gt; Leave Room
&lt;/Button&gt;
</pre>
<p>With this, the mute, unmute, and leave functionality should be working fine.</p>
<p>However, you&#8217;ll notice that even when we join the room as a viewer, all the UI components meant to be seen or used only by the broadcaster will be visible, which shouldn’t be so. Viewers should only be able to see the <code>leave</code> button.</p>
<p>To fix this, modify the <code>return</code> statement of the <code>Controls</code> component to look like the following:</p>
<pre class="language-javascript hljs">// src/Controls.js
return (
  &lt;div className='controls'&gt;
    {localPeer.roleName === 'broadcaster'
      ? &lt;&gt;
          &lt;IconButton onClick={toggleAudio}&gt;
            {audioEnabled
              ? &lt;MicNoneOutlined /&gt;
              : &lt;MicOffOutlined /&gt;
            }
          &lt;/IconButton&gt;
          &lt;IconButton onClick={toggleVideo}&gt;
            {videoEnabled
              ? &lt;VideocamOutlined /&gt;
              : &lt;VideocamOffOutlined /&gt;
            }
          &lt;/IconButton&gt;
          &lt;Button 
            variant="contained" 
            disableElevation
            className='leave'
            onClick={leaveRoom}
          &gt;
            &lt;LogoutOutlined /&gt; Leave Room
          &lt;/Button&gt;
          {hlsState.running
            ? &lt;Button 
                variant="contained" 
                disableElevation
                className='leave'
                onClick={stopHLSStreaming}
              &gt;
                &lt;StopCircleOutlined /&gt; Stop Streaming
              &lt;/Button&gt;
            : &lt;Button 
                variant="contained"
                disableElevation
                onClick={startHLSStreaming}
              &gt;
                &lt;PodcastsOutlined /&gt; Go Live 
              &lt;/Button&gt;
          }
        &lt;/&gt;
      : &lt;Button 
          variant="contained" 
          disableElevation
          className='leave'
          onClick={leaveRoom}
        &gt;
          &lt;LogoutOutlined /&gt; Leave Room
        &lt;/Button&gt;
    }
  &lt;/div&gt;
)
</pre>
<h2 id="add-chat-functionality-display-participants">Add chat functionality and display all participants</h2>
<p>There are three different methods available to send chat messages that have different use cases.</p>
<ul>
<li><code>sendBroadcastMessage('message')</code>: For messages that will be received by everyone in the room</li>
<li><code>sendGroupMessage('message', ['role1'])</code>: For messages that will be received by every peer who is part of the passed-in roles</li>
<li><code>sendDirectMessage('message', peer.id)</code>: For messages that will be received only by the peer whose ID was passed</li>
</ul>
<p>In our app, we’ll only use <code>sendBroadcastMessage()</code>, but you can add features for the rest if you like.</p>
<p>Head over to <code>src/ChatNdParticipants.js</code> and add the following lines of code:</p>
<pre class="language-javascript hljs">// src/ChatNdParticipants.js
import { selectHMSMessages, useHMSActions, useHMSStore } from "@100mslive/react-sdk"
</pre>
<p>Next, add the following lines of code after the <code>message</code> state:</p>
<pre class="language-javascript hljs">// src/ChatNdParticipants.js
const messages = useHMSStore(selectHMSMessages)
const hmsActions = useHMSActions()

const handleSubmit = (e) =&gt; {
  e.preventDefault();
  hmsActions.sendBroadcastMessage(message)
  setMessage('')
}
</pre>
<p>We’ve created a <code>handleSubmit</code>, which will send the messages. We are also retrieving all the sent messages using the <code>selectHMSMessages</code> selector.</p>
<p>When the <code>send-message</code> form is submitted, we need to call <code>handleSubmit</code> and loop through the retrieved messages and display them. To call <code>handleSubmit</code>, modify the open tag <code>&lt;form&gt;</code> of the form with a name of <code>send-message</code> to the code below:</p>
<pre class="language-javascript hljs">// src/ChatNdParticipants.js
&lt;form name='send-messge' onSubmit={handleSubmit}&gt;
</pre>
<p>Next, replace the <code>Message</code> component under the <code>{/* Messages */}</code> comment with the following:</p>
<pre class="language-javascript hljs">// src/ChatNdParticipants.js
{messages.map((msg) =&gt; (
  &lt;Message key={msg.id} message={msg} /&gt;
))}
</pre>
<p>Next, modify the <code>Message.js</code> file in the <code>src</code> directory to look like the following code:</p>
<pre class="language-javascript hljs">// src/ChatNdParticipants.js
import { selectLocalPeer, useHMSStore } from '@100mslive/react-sdk'

function Message({message}) {
  const localPeer = useHMSStore(selectLocalPeer)

  return (
    &lt;div 
      className={`message ${message.senderUserId === localPeer.customerUserId &amp;&amp; 'myMessage'}`}
    &gt;
      &lt;span&gt;{message.senderName}&lt;/span&gt;
      &lt;p&gt;{message.message}&lt;/p&gt;
    &lt;/div&gt;
  )
}

export default Message
</pre>
<p>Now, the chat functionality should be working. To display the participants, we’ll use the <code>selectPeers</code> selector to get all the peers in the room, loop over them, and display their name and role.</p>
<p>In the <code>ChatNdParticipants.js</code>, add the following import:</p>
<pre class="language-javascript hljs">// src/ChatNdParticipants.js
import { selectPeers } from "@100mslive/react-sdk"
</pre>
<p>Next, add the following line of code after the <code>hmsActions</code> variable:</p>
<pre class="language-javascript hljs">// src/ChatNdParticipants.js
const peers = useHMSStore(selectPeers)
</pre>
<p>Now, add the following lines of code after the <code>{/* Participants */}</code> comment:</p>
<pre class="language-javascript hljs">// src/ChatNdParticipants.js
{peers.map((peer) =&gt; (
  &lt;div className='rightBox__participant'&gt;
    {peer.name}
    &lt;p&gt;{peer.roleName}&lt;/p&gt;
  &lt;/div&gt;
))}
</pre>
<p>With this, we’re done building our live streaming app.</p>
<h2 id="conclusion">Conclusion</h2>
<p>In this tutorial, we learned how to build a live streaming app using 100ms. Aside from the features covered in this tutorial, there are a lot others we can add, like streaming on YouTube, Twitch, Facebook, etc using <a href="https://www.100ms.live/docs/javascript/v2/features/rtmp-recording">RTMP streaming</a>, displaying <a href="https://www.100ms.live/docs/javascript/v2/features/notifications">notifications</a> for activities happening in the room, and more.</p>
<p>I hope you enjoyed this tutorial, and be sure to leave a comment if you have any questions. Happy coding!</p><div class='code-block code-block-17' style='margin: 8px 0; clear: both;'>
<div class="blog-plug inline-plug react-plug"><h2>Full visibility into production React apps</h2> Debugging React applications can be difficult, especially when users experience issues that are hard to reproduce. If you’re interested in monitoring and tracking Redux state, automatically surfacing JavaScript errors, and tracking slow network requests and component load time, <a href="https://www2.logrocket.com/react-performance-monitoring" target="_blank">try LogRocket</a>. <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png" data-lazy-src="https://files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" class="alignnone size-full wp-image-46" src="https://files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png"  /></noscript></a><a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" class="alignnone size-full wp-image-46" src="https://blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677"  /></noscript></a><p style="margin-top: 15px;"><a href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web and mobile apps, recording literally everything that happens on your React app. Instead of guessing why problems happen, you can aggregate and report on what state your application was in when an issue occurred. LogRocket also monitors your app's performance, reporting with metrics like client CPU load, client memory usage, and more.</p><p>The LogRocket Redux middleware package adds an extra layer of visibility into your user sessions. LogRocket logs all actions and state from your Redux stores. </p><p>Modernize how you debug your React apps — <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">start monitoring for free</a>.</p></div>
</div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-136201" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/build-react-live-streaming-app-100ms/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/build-react-live-streaming-app-100ms/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-136201" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/build-react-live-streaming-app-100ms/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-136201" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/build-react-live-streaming-app-100ms/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/11/IMG-20210729-WA0008_2-150x150.jpg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/11/IMG-20210729-WA0008_2-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/11/IMG-20210729-WA0008_2-150x150.jpg?crop=1' class='avatar avatar-72 photo' height='72' width='72'  /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/taminoturokobriggs/">
Taminoturoko Briggs <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Software developer and technical writer. Core languages include JavaScript and Python.</span>
</div>
</div>
<div class="after-post-tags">
<ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/react/">#react</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/how-and-why-you-should-use-next-js-django/" rel="prev">How and why you should use Next.js with Django</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/product-management/how-to-create-deliver-product-presentation/" rel="next">How to create and deliver an impactful product presentation</a> &raquo;</div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/understanding-vue-touch-events-android-ios/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/10/Understanding-Vue-js-touch-events-Android-iOS.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/understanding-vue-touch-events-android-ios/">Understanding Vue.js touch events for Android and iOS</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/pelumiakintokun/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/02/pelumi-akintokun-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/02/pelumi-akintokun-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/02/pelumi-akintokun-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/pelumiakintokun/">Pelumi Akintokun</a></span><br>
<span class="post-date">Oct 14, 2022</span>
<span class="dot"></span>
<span class="readingtime">6 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/understanding-vue-touch-events-android-ios/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/build-web-application-hono/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/10/deploy-web-app-hono-nocdn.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/build-web-application-hono/">Build a web application with Hono</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/claraekekenta/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/01/clara-ekekenta-150x150.jpeg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/01/clara-ekekenta-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/01/clara-ekekenta-150x150.jpeg?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/claraekekenta/">Clara Ekekenta</a></span><br>
<span class="post-date">Oct 14, 2022</span>
<span class="dot"></span>
<span class="readingtime">4 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/build-web-application-hono/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/how-and-why-you-should-use-next-js-django/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/09/next-js-django.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/how-and-why-you-should-use-next-js-django/">How and why you should use Next.js with Django</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/oyinkansolaawosan/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/11/0-150x150.jpeg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/11/0-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/11/0-150x150.jpeg?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/oyinkansolaawosan/">Oyinkansola Awosan</a></span><br>
<span class="post-date">Oct 13, 2022</span>
<span class="dot"></span>
<span class="readingtime">4 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/how-and-why-you-should-use-next-js-django/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/build-react-live-streaming-app-100ms#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=136201&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;jetpack_comments_nonce=c1fb571b4a&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=11.5-a.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=e1add3f662f8b87888e5b6caab503878d479bbf9#parent=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="footerRight"><form role="search" method="get" action="https://blog.logrocket.com/" class="wp-block-search__button-outside wp-block-search__text-button alignright wp-block-search"><label for="wp-block-search__input-1" class="wp-block-search__label screen-reader-text">Search</label><div class="wp-block-search__inside-wrapper " style="width: 100%"><input type="search" id="wp-block-search__input-1" class="wp-block-search__input " name="s" value="" placeholder="" required /><button type="submit" class="wp-block-search__button has-text-color " style="color: #764abc">Search</button></div></form></div> <div class="clearfix"></div>
<a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script defer id="bilmur" data-provider="wordpress.com" data-service="atomic" src="https://s0.wp.com/wp-content/js/bilmur.min.js?m=202241"></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length && document.location.href.indexOf('product-management') === -1) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text(),
	postAuthor: jQuery("meta[name='twitter:data1']").attr("content"),
	id: jQuery(".mainheading").closest(".col-md-8").attr("id").replace('post-','')
  });
}
jQuery(".aretags li a:contains('archive')").parent('li').hide();
jQuery(".aretags li a:contains('86919')").parent('li').hide();
jQuery(".aretags li a:contains('72293')").parent('li').hide();
};</script> <div style="display:none">
<div class="grofile-hash-map-43994b0a2a6162c555d4acc9d55dcaaa">
</div>
<div class="grofile-hash-map-784522be88e77b8c064582ef1be62983">
</div>
<div class="grofile-hash-map-2ff9e1b480b9968807d73d7b86e65d02">
</div>
<div class="grofile-hash-map-f5cdc79009b4943ee406337720f7c98d">
</div>
</div>
<div id="jp-carousel-loading-overlay">
<div id="jp-carousel-loading-wrapper">
<span id="jp-carousel-library-loading">&nbsp;</span>
</div>
</div>
<div class="jp-carousel-overlay" style="display: none;">
<div class="jp-carousel-container">

<div class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions" itemscope itemtype="https://schema.org/ImageGallery">
<div class="jp-carousel swiper-wrapper"></div>
<div class="jp-swiper-button-prev swiper-button-prev">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white" />
</mask>
<g mask="url(#maskPrev)">
<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
<div class="jp-swiper-button-next swiper-button-next">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white" />
</mask>
<g mask="url(#maskNext)">
<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
</div>

<div class="jp-carousel-close-hint">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white" />
</mask>
<g mask="url(#maskClose)">
<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>

<div class="jp-carousel-info">
<div class="jp-carousel-info-footer">
<div class="jp-carousel-pagination-container">
<div class="jp-swiper-pagination swiper-pagination"></div>
<div class="jp-carousel-pagination"></div>
</div>
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-caption"></h2>
</div>
<div class="jp-carousel-photo-icons-container">
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white" />
</mask>
<g mask="url(#maskInfo)">
<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</span>
</a>
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white" />
</mask>
<g mask="url(#maskComments)">
<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
</span>
</a>
</div>
</div>
<div class="jp-carousel-info-extra">
<div class="jp-carousel-info-content-wrapper">
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-title"></h2>
</div>
<div class="jp-carousel-comments-wrapper">
<div id="jp-carousel-comments-loading">
<span>Loading Comments...</span>
</div>
<div class="jp-carousel-comments"></div>
<div id="jp-carousel-comment-form-container">
<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
<div id="jp-carousel-comment-post-results"></div>
<form id="jp-carousel-comment-form">
<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
<textarea name="comment" class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea" id="jp-carousel-comment-form-comment-field" placeholder="Write a Comment..."></textarea>
<div id="jp-carousel-comment-form-submit-and-info-wrapper">
<div id="jp-carousel-comment-form-commenting-as">
<fieldset>
<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-url-field">Website</label>
<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
</fieldset>
</div>
<input type="submit" name="submit" class="jp-carousel-comment-form-button" id="jp-carousel-comment-form-button-submit" value="Post Comment" />
</div>
</form>
</div>
</div>
<div class="jp-carousel-image-meta">
<div class="jp-carousel-title-and-caption">
<div class="jp-carousel-photo-info">
<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
</div>
<div class="jp-carousel-photo-description"></div>
</div>
<ul class="jp-carousel-image-exif" style="display: none;"></ul>
<a class="jp-carousel-image-download" target="_blank" style="display: none;">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white" />
</mask>
<g mask="url(#mask0)">
<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-download-text"></span>
</a>
<div class="jp-carousel-image-map" style="display: none;"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/build-react-live-streaming-app-100ms\/":136201};
	</script>
<link rel='stylesheet' id='dashicons-css' href='https://blog.logrocket.com/wp-includes/css/dashicons.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='nf-display-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/display-opinions-light.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='nf-font-awesome-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/font-awesome.min.css?ver=6.0.2' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-before'>
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=6.0.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=83ec8aa758f883d6da14' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=8767d0da914b289bd862' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/blog.logrocket.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"59f0e107ea","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=11.5-a.3' id='jetpack-carousel-js'></script>
<script defer type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1664378836' id='akismet-frontend-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/backbone.min.js?ver=1.4.1' id='backbone-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end-deps.js?ver=3.6.14' id='nf-front-end-deps-js'></script>
<script type='text/javascript' id='nf-front-end-js-extra'>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</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end.js?ver=3.6.14' id='nf-front-end-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.5-a.3' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=136201&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=c1fb571b4a&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=e1add3f662f8b87888e5b6caab503878d479bbf9#parent=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=136201&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=c1fb571b4a&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.5-a.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=e1add3f662f8b87888e5b6caab503878d479bbf9#parent=https%3A%2F%2Fblog.logrocket.com%2Fbuild-react-live-streaming-app-100ms";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202241.js' defer></script>
<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'161333275',post:'136201',tz:'-4',srv:'blog.logrocket.com',hp:'atomic',ac:'2',amp:'0',j:'1:11.5-a.3'} ]);
		_stq.push([ 'clickTrackerInit', '161333275', '136201' ]);
	</script><script id="tmpl-nf-layout" type="text/template">
	<span id="nf-form-title-{{{ data.id }}}" class="nf-form-title">
		{{{ ( 1 == data.settings.show_title ) ? '<h3>' + data.settings.title + '</h3>' : '' }}}
	</span>
	<div class="nf-form-wrap ninja-forms-form-wrap">
		<div class="nf-response-msg"></div>
		<div class="nf-debug-msg"></div>
		<div class="nf-before-form"></div>
		<div class="nf-form-layout"></div>
		<div class="nf-after-form"></div>
	</div>
</script>
<script id="tmpl-nf-empty" type="text/template">

</script>
<script id="tmpl-nf-before-form" type="text/template">
	{{{ data.beforeForm }}}
</script><script id="tmpl-nf-after-form" type="text/template">
	{{{ data.afterForm }}}
</script><script id="tmpl-nf-before-fields" type="text/template">
    <div class="nf-form-fields-required">{{{ data.renderFieldsMarkedRequired() }}}</div>
    {{{ data.beforeFields }}}
</script><script id="tmpl-nf-after-fields" type="text/template">
    {{{ data.afterFields }}}
    <div id="nf-form-errors-{{{ data.id }}}" class="nf-form-errors" role="alert"></div>
    <div class="nf-form-hp"></div>
</script>
<script id="tmpl-nf-before-field" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-after-field" type="text/template">
    {{{ data.afterField }}}
</script><script id="tmpl-nf-form-layout" type="text/template">
	<form>
		<div>
			<div class="nf-before-form-content"></div>
			<div class="nf-form-content {{{ data.element_class }}}"></div>
			<div class="nf-after-form-content"></div>
		</div>
	</form>
</script><script id="tmpl-nf-form-hp" type="text/template">
	<label for="nf-field-hp-{{{ data.id }}}" aria-hidden="true">
		{{{ nfi18n.formHoneypot }}}
		<input id="nf-field-hp-{{{ data.id }}}" name="nf-field-hp" class="nf-element nf-field-hp" type="text" value=""/>
	</label>
</script>
<script id="tmpl-nf-field-layout" type="text/template">
    <div id="nf-field-{{{ data.id }}}-container" class="nf-field-container {{{ data.type }}}-container {{{ data.renderContainerClass() }}}">
        <div class="nf-before-field"></div>
        <div class="nf-field"></div>
        <div class="nf-after-field"></div>
    </div>
</script>
<script id="tmpl-nf-field-before" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-field-after" type="text/template">
    <#
    /*
     * Render our input limit section if that setting exists.
     */
    #>
    <div class="nf-input-limit"></div>
    <#
    /*
     * Render our error section if we have an error.
     */
    #>
    <div id="nf-error-{{{ data.id }}}" class="nf-error-wrap nf-error" role="alert"></div>
    <#
    /*
     * Render any custom HTML after our field.
     */
    #>
    {{{ data.afterField }}}
</script>
<script id="tmpl-nf-field-wrap" type="text/template">
	<div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
		<#
		/*
		 * This is our main field template. It's called for every field type.
		 * Note that must have ONE top-level, wrapping element. i.e. a div/span/etc that wraps all of the template.
		 */
        #>
		<#
		/*
		 * Render our label.
		 */
        #>
		{{{ data.renderLabel() }}}
		<#
		/*
		 * Render our field element. Uses the template for the field being rendered.
		 */
        #>
		<div class="nf-field-element">{{{ data.renderElement() }}}</div>
		<#
		/*
		 * Render our Description Text.
		 */
        #>
		{{{ data.renderDescText() }}}
	</div>
</script>
<script id="tmpl-nf-field-wrap-no-label" type="text/template">
    <div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
        <div class="nf-field-label"></div>
        <div class="nf-field-element">{{{ data.renderElement() }}}</div>
        <div class="nf-error-wrap"></div>
    </div>
</script>
<script id="tmpl-nf-field-wrap-no-container" type="text/template">

        {{{ data.renderElement() }}}

        <div class="nf-error-wrap"></div>
</script>
<script id="tmpl-nf-field-label" type="text/template">
	<div class="nf-field-label"><label for="nf-field-{{{ data.id }}}"
	                                   id="nf-label-field-{{{ data.id }}}"
	                                   class="{{{ data.renderLabelClasses() }}}">{{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}} {{{ ( 'undefined' != typeof data.required && 1 == data.required ) ? '<span class="ninja-forms-req-symbol">*</span>' : '' }}} {{{ data.maybeRenderHelp() }}}</label></div>
</script>
<script id="tmpl-nf-field-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-form-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-field-input-limit" type="text/template">
    {{{ data.currentCount() }}} {{{ nfi18n.of }}} {{{ data.input_limit }}} {{{ data.input_limit_msg }}}
</script><script id="tmpl-nf-field-null" type="text/template">
</script><script id="tmpl-nf-field-listcheckbox" type="text/template">
    <ul aria-describedby="nf-error-{{{ data.id }}}">
        {{{ data.renderOptions() }}}
    </ul>
</script>
<script id='tmpl-nf-field-listcheckbox-option' type='text/template'>
    <# if ( ! data.visible ) { return '' } #>
    <li>
        <input type="checkbox" id="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}" name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element {{{ ( data.isSelected ) ? ' nf-checked' : '' }}}" value="{{{ data.value }}}" {{{ ( data.isSelected ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
            <# if( data.required ) { #>
			required
			<# } #>
        >
        <label for="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               id="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               class="{{{ ( data.isSelected ) ? 'nf-checked-label' : '' }}}">{{{ data.label }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other' type='text/template'>
    <li {{{ ( ! data.visible ) ? 'style="display:none"' : '' }}}>
        <input type="checkbox"
               id="nf-field-{{{ data.fieldID }}}-other"
               name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element" value="nf-other" {{{ ( ! data.valueFound ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-other"
            <# if( data.required ) { #>
			required
			<# } #>
        >
         <label id="nf-label-field-{{{ data.fieldID }}}-other">Other
            {{{ data.renderOtherText() }}}
        </label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other-text' type='text/template'>
    <input type="text" name="nf-field-{{{ data.fieldID }}}" class="nf-element" value="{{{ data.currentValue }}}">
</script>
<script id='tmpl-nf-field-input' type='text/template'>
    <input id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" aria-invalid="false" aria-describedby="nf-error-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element" type="text" value="{{{ _.escape( data.value ) }}}" {{{ data.renderPlaceholder() }}} {{{ data.maybeDisabled() }}}
           aria-labelledby="nf-label-field-{{{ data.id }}}"

            {{{ data.maybeRequired() }}}
    >
</script>
<script id="tmpl-nf-field-email" type="text/template">
	<input
			type="email"
			value="{{{ _.escape( data.value ) }}}"
			class="{{{ data.renderClasses() }}} nf-element"

			id="nf-field-{{{ data.id }}}"
			<# if( ! data.disable_browser_autocompletes ){ #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id + '-' + data.type }}"
			autocomplete="email"
			<# } else { #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id }}"
			{{{ data.maybeDisableAutocomplete() }}}
			<# } #>
			{{{ data.renderPlaceholder() }}}
			{{{ data.maybeDisabled() }}}

			aria-invalid="false"
			aria-describedby="nf-error-{{{ data.id }}}"
			aria-labelledby="nf-label-field-{{{ data.id }}}"

			{{{ data.maybeRequired() }}}
	>
</script>
<script id="tmpl-nf-field-submit" type="text/template">
	<input id="nf-field-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element " type="button" value="{{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}}" {{{ ( data.disabled ) ? 'disabled' : '' }}}>
</script><script id='tmpl-nf-field-button' type='text/template'>
    <button id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" class="{{{ data.classes }}} nf-element">
        {{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}}
    </button>
</script><script>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</script>
</body>
</html>
