<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="http://blog.logrocket.com/xmlrpc.php">
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v14.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Why you don&#039;t need Babel - LogRocket Blog</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="http://blog.logrocket.com/why-you-dont-need-babel/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Why you don&#039;t need Babel - LogRocket Blog" />
	<meta property="og:description" content="In 2020, frontend developers are still wasting a lot of time with excessive tooling. Babel is seen by some as a necessity. Here&#039;s why it&#039;s not." />
	<meta property="og:url" content="http://blog.logrocket.com/why-you-dont-need-babel/" />
	<meta property="og:site_name" content="LogRocket Blog" />
	<meta property="article:published_time" content="2020-07-16T16:00:20+00:00" />
	<meta property="article:modified_time" content="2020-07-15T17:56:18+00:00" />
	<meta property="og:image" content="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?fit=730%2C487" />
	<meta property="og:image:width" content="730" />
	<meta property="og:image:height" content="487" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://blog.logrocket.com/#website","url":"http://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"http://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://blog.logrocket.com/why-you-dont-need-babel/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?fit=730%2C487","width":730,"height":487,"caption":"Why You Don't Need Babel"},{"@type":"WebPage","@id":"http://blog.logrocket.com/why-you-dont-need-babel/#webpage","url":"http://blog.logrocket.com/why-you-dont-need-babel/","name":"Why you don't need Babel - LogRocket Blog","isPartOf":{"@id":"http://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"http://blog.logrocket.com/why-you-dont-need-babel/#primaryimage"},"datePublished":"2020-07-16T16:00:20+00:00","dateModified":"2020-07-15T17:56:18+00:00","author":{"@id":"http://blog.logrocket.com/#/schema/person/03ec1c61b1f2c19c0fe5071a699b084e"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://blog.logrocket.com/why-you-dont-need-babel/"]}]},{"@type":["Person"],"@id":"http://blog.logrocket.com/#/schema/person/03ec1c61b1f2c19c0fe5071a699b084e","name":"David Else","image":{"@type":"ImageObject","@id":"http://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"http://2.gravatar.com/avatar/8ab6e8f4e8633e470ec2261599632505?s=96&d=mm&r=g","caption":"David Else"},"description":"TypeScript/JavaScript software developer | elsewebdevelopment.com"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="http://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="http://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Why you don&#8217;t need Babel Comments Feed" href="http://blog.logrocket.com/why-you-dont-need-babel/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css'  href='http://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css'  href='http://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css'  href='http://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.7.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.7.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='http://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1'></script>
<script type='text/javascript' async='async' src='http://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0'></script>
<script type='text/javascript' async='async' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js'></script>
<script type='text/javascript' async='async' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js'></script>
<link rel='https://api.w.org/' href='http://blog.logrocket.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://blog.logrocket.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/paUW9B-5Es' />
<link rel="alternate" type="application/json+oembed" href="http://blog.logrocket.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://blog.logrocket.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">

    <script>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</script>


    <script>
    window.Raven && window.Raven.config('https://98e0ea7c6f2e492d94439ad5aaea48dd@e.logrocket.com/4').install()
    </script>
    <script type="text/javascript">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</script>

<!-- Start VWO Async Smartcode -->
<script type='text/javascript'>
window._vwo_code = window._vwo_code || (function(){
var account_id=338524,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
is_spa=1,
hide_element='body',

/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document,code={use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){
settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b=hide_element?hide_element+'{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}':'',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&f='+(+is_spa)+'&r='+Math.random());return settings_timer; }};window._vwo_settings_timer = code.init(); return code; }());
</script>
<!-- End VWO Async Smartcode -->

    <script src="https://cdn.logrocket.com/LogRocket.min.js"></script>
    <script>
        if (window.LogRocket) {
            window.LogRocket.init('apphub/logrocket-website',{
                dashboardHost: "https://staging.logrocket.com",
                serverURL: "https://staging-i.logrocket.com/i",
            });
        }

        fetch('https://ga.clearbit.com/v1/ga.js?authorization=pk_66a3fd2085d9f04c4d4b68a62b70ed7e').then(function(res){
            res.text().then(function(val){
                var regex = /this.done((.*)}})/;
                var regexVal = regex.exec(val);
                if (!regexVal) {
                    return;
                }

                var dict = regexVal[0].replace('this.done(', '');

                var clearbitData = JSON.parse(dict);
                window.clearbitData = clearbitData;

                window._vis_opt_queue = window._vis_opt_queue || [];
                window._vis_opt_queue.push(function() {_vis_opt_goal_conversion(202);});

                window.LogRocket && window.LogRocket.identify(Math.random().toString(36).substring(7), {
                    company: clearbitData.company.name,
                    email: 'anonymous@' + clearbitData.company.domain,
                });
                if (clearbitData.company.domain && window.location.pathname != "/") {
                    var demoButton = document.getElementById("blog-personalized-demo-link");
                    var personalizeImage = document.getElementById("blog-personalized-demo-thumbnail");
                    var companyName = document.getElementById("personalized-company-account-name");
                    var perUrl = "https://us-central1-logrocket-com.cloudfunctions.net/findPersonalization?targetDomain=" + clearbitData.company.domain;
                    fetch(perUrl)
                        .then(response => {
                            return response.json()
                        })
                        .then(data => {
                            var imageReturn = data.image_url;
                            var linkReturn = data.link_url;
                            if (imageReturn.includes("not-found") || linkReturn.includes("not-found")) {
                                return "not-found";
                            } else {
                                personalizeImage.src = imageReturn;
                                demoButton.href = linkReturn;
                                companyName.innerHTML = clearbitData.company.name;
var intersectionOptions = {
root: null,  // use the viewport
rootMargin: '-240px',
threshold: 1.0
}
function intersectionCallback(entries, observer) {
entries.forEach(entry => {
 if (entry.intersectionRatio >= 1) {
   jQuery('.inline-demo').slideDown(1500);
 //  jQuery('.crp-list-item-image img').delay(550).fadeIn(1000);
     observer.unobserve(target);
 } else {
 }
});
}
var observer = new IntersectionObserver(intersectionCallback, intersectionOptions);
var target = document.querySelector('.code-block-28');
observer.observe(target);

                                analytics.track('Personalization-deployed-blog', {
                                    'Domain': clearbitData.company.domain
                                });
                                LogRocket.track('post-personalized-blog');
                            }
                        })
                        .catch(err => {
                            analytics.track("personalization-failed");
                            throw err;
                        })
                };

                _linkedin_partner_id = "1468257";
                window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
                window._linkedin_data_partner_ids.push(_linkedin_partner_id);
                (function(){var s = document.getElementsByTagName("script")[0];
                var b = document.createElement("script");
                b.type = "text/javascript";b.async = true;
                b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
                s.parentNode.insertBefore(b, s);})();

                var linkedIn_img = document.createElement("img");
                linkedIn_img.src = "https://px.ads.linkedin.com/collect/?pid=1468257&fmt=gif";
                document.getElementsByTagName('head')[0].appendChild( linkedIn_img );

                window.analytics && window.analytics.track('clearbit domain', { domain: clearbitData.company.domain });
            });
        })
    </script>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="preload" as="style" href="http://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=270%2C270" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="http://blog.logrocket.com/?custom-css=a2bf79682d" />
		<style id="kirki-inline-styles">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</style></head>

<body class="post-template-default single single-post postid-21728 single-format-standard">

<style>
    </style>


<header class="navbar-light bg-white fixed-top mediumnavigation">

    <div class="container">



        <div class="navarea">

<div class="nav-left">

  <a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>

<nav class="menu-container">

        <div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a></ul></div></nav>

</div>

<div class="nav-right">

  <div class="menu-container">
    <div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Free Trial</a></li>
</ul></div>  </div>

</div>

        </div>

    </div>

</header>


        <!-- Begin site-content
		================================================== -->
        <div class="site-content">


<div class="container"> 
    <div class="row">         
        <div class=" col-md-2 ">           
            <div class="share">
                
                <div class="sidebarapplause">
                                </div>
                
                				<p class="sharecolour">
					Share				</p>
                
<ul class="shareitnow"><li>
        <a target="_blank" href="https://twitter.com/intent/tweet?text=Why%20you%20don&#8217;t%20need%20Babel&amp;url=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F">
        <i class="fa fa-twitter"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F">
        <i class="fa fa-facebook"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://plus.google.com/share?url=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F">
        <i class="fa fa-google"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://pinterest.com/pin/create/button/?url=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F&amp;media=https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?fit=730%2C487&amp;description=Why%20you%20don&#8217;t%20need%20Babel">
        <i class="fa fa-pinterest"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F&amp;title=Why%20you%20don&#8217;t%20need%20Babel">
        <i class="fa fa-linkedin"></i>
        </a>
    </li></ul>                		        
                
                                <div class="sep"></div>
                <div class="hidden-xs-down">      

                    <p>
                        Reply                    </p>
                    <ul>
                        <li>
                        <a class="smoothscroll" href="#comments">0<br/>
                        <svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
                        </a>
                        </li>
                    </ul>
                </div>
                            </div>			                                
        </div>
        
                    			                <div class="col-md-8 flex-first flex-md-unordered post-21728 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-babel" id="post-21728"> 
                    <div class="mainheading">
                       
                                                <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-md-down"> 
                            <div class="col-md-2 col-xs-12"> 
                                <a href="http://blog.logrocket.com/author/davidelse/">
                                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/david-else.png?resize=150%2C150" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/david-else.png?resize=150%2C150&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/david-else.png?resize=150%2C150' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                                </a>
                            </div>                                         
                            <div class="col-md-10 col-xs-12"> 
                                <a class="text-capitalize link-dark" href="http://blog.logrocket.com/author/davidelse/">
                                David Else <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">TypeScript/JavaScript software developer | <a href="http://elsewebdevelopment.com" rel="noopener noreferrer">elsewebdevelopment.com</a></span> 
                            </div>                                         
                        </div>
                                                 
                                                
                        <h1 class="posttitle">Why you don&#8217;t need Babel</h1>
					    <h2 class="post-subtitle"></h2>

                        <p>
                                                        <span class="post-date"><time class="post-date">
                            July 16, 2020                            </time></span>
                                                        
                                                        <span class="dot"></span>
                            <span class="readingtime">7 min read</span>
						    <span class="wordcount">2185</span>

                                                    </p> 
                    </div>
                    
                  <img width="730" height="487" src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?fit=730%2C487" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="Why You Don&#039;t Need Babel" data-attachment-id="21935" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/why-you-dont-need-babel/" data-orig-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?fit=730%2C487" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Why you don&#8217;t need Babel" data-image-description="" data-medium-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?fit=300%2C200" data-large-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?fit=730%2C487" data-lazy-srcset="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?w=730 730w, https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?resize=300%2C200 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/why-you-dont-need-babel.png?fit=730%2C487&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    <article class="article-post">
                                                <p>In 2020, frontend developers are still wasting a lot of time with excessive tooling. Babel is seen by some as a necessity, but I aim to show you that it&#8217;s not.</p>
<p>By the end of this article, you will know:</p>
<ul>
<li>How to confirm which browsers actually need supporting on a case-by-case basis</li>
<li>How to lint with Visual Studio Code to avoid the need for Babel</li>
<li>Another software alternative to get the same job done faster</li>
</ul>
<h2 id="whatisbabelandwhatproblemdoesitsolve">What is Babel and what problem does it solve?</h2>
<p>Babel is a compiler that converts your modern JavaScript to run in older browsers. It can also perform other jobs such as converting JSX syntax, but it is not the only tool for that.</p>
<p>As browsers evolve, new APIs and ECMAScript features are added. Different browsers evolve at different speeds and prioritize different features. This leaves us with a tricky problem to solve: how can we support them all and still use modern features? Some will be incompatible.</p>
<p>A common solution is to write using the latest features and transpile down to older-style code the browser will understand. Transpiling describes a specialized type of compilation. It has different meanings in different contexts. In our case, there are also two separate parts to transpiling.</p>
<h3 id="thedifferencebetweentranspilingandpolyfilling">The difference between transpiling and polyfilling</h3>
<p>Transpiling is the process of converting newer language syntax that old browsers can&#8217;t understand into the old syntax they recognize.</p>
<p>Here is an example of transpiling the <code>let</code> statement:</p>
<pre>// the new syntax `let` was added in ECMAScript 2015 aka ES6
let x = 11;

// `let` transpiles to the old syntax `var` if your transpiler target was ES5
var x = 11;
</pre>
<p>Polyfilling is the process of adding the missing methods, properties, or APIs to the old browsers by supplying your own version of the missing native code.</p>
<p>It can be thought of as filling in the gaps. For example, here is a polyfill for <code>isNaN</code>:</p>
<pre>// check if the method `isNaN` exists on the standard built-in `Number` object
if (!Number.isNaN) {
  // if not we add our own version of the native method newer browsers provide
  Number.isNaN = function isNaN(x) {
    return x !== x;
  };
}
</pre>
<p>The best place to get polyfils is via <a href="https://github.com/zloirock/core-js" target="_blank" rel="noopener noreferrer">core-js</a>.</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br/>No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>

<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>

<p>Transpiling and polyfilling are sometimes impossible and can add a lot of code bloat, it&#8217;s best to avoid them altogether if possible. That is why the first alternative we&#8217;re going to discuss is the best one.</p>
<h2 id="alternativeonedonotsupportancientbrowsers">Alternative No. 1: Don&#8217;t support ancient browsers</h2>
<p><!-- ![elderly-browsers](images/man-woman-elderly-couple-logos.png) --></p>
<p><span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;">If users would just upgrade their browsers, we could avoid the hassle of transpiling and they could enjoy the enhanced features and performance of the new browser. Unfortunately, things aren&#8217;t that simple.</span></p>
<p>The main culprit is large corporations having to support legacy software. The classic example is Internet Explorer, which has been a blight on web development from the beginning.</p>
<p>That said, things have improved a lot in recent years. Now, most browsers are evergreen, meaning they&#8217;re constantly updated. Microsoft now promotes its evergreen Edge browser, which, conveniently, uses the same V8 engine as Chrome, meaning one fewer engine to support.</p>
<p>To determine whether you have to support a particular browser, ask yourself the following questions.</p>
<h3 id="1whichbrowsersareyourcustomerscurrentlyusing">1. Which browsers are your customers currently using?</h3>
<p>If you already have a website or app that serves the same customer base, you can get this information from the analytics software. Below are some recent statistics from a UK-based sound engineering website I&#8217;m managing. If it were a JavaScript application with the same customers demographic, I would assume they would be using the same browsers.</p>
<p><img data-attachment-id="21916" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/browsers/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?fit=309%2C567" data-orig-size="309,567" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Browsers" data-image-description data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?fit=163%2C300" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?fit=309%2C567" class="aligncenter size-full wp-image-21916 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?resize=309%2C567&#038;ssl=1" alt="List of Browsers" width="309" height="567" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?w=309 309w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?resize=163%2C300 163w" data-lazy-sizes="(max-width: 309px) 100vw, 309px" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?resize=309%2C567&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="21916" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/browsers/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?fit=309%2C567" data-orig-size="309,567" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Browsers" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?fit=163%2C300" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?fit=309%2C567" class="aligncenter size-full wp-image-21916" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?resize=309%2C567&#038;ssl=1" alt="List of Browsers" width="309" height="567" srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?w=309 309w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browsers.png?resize=163%2C300 163w" sizes="(max-width: 309px) 100vw, 309px" data-recalc-dims="1" /></noscript></p>
<p><img style="float: right; margin-left: 12px;" src="images/browsers.png" data-lazy-src="http://images/browsers.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img style="float: right; margin-left: 12px;" src="images/browsers.png" /></noscript></p>
<p><!-- ![Matomo Analytics](images/browsers.png) --></p>
<p>If you don&#8217;t have analytic software installed, you won&#8217;t know which browsers you need to support. You&#8217;ll have to make an educated guess. If you have corporate customers, it&#8217;s far more likely you&#8217;ll need to support IE11 than if you&#8217;re marketing to web-literate technology fans.</p>
<p>When you support a browser, you make a commitment. Do you really want to have additional tests on every release, additional build tooling to configure, and extra dependencies to babysit?</p>
<p>There must be a clear financial reason to go to through all this bother. Will losing those customers who can&#8217;t access your site or app cost more than it would to support the browser?</p>
<h3 id="2whichmodernbrowserfeaturesdoyouwanttouse">2. Which modern browser features do you want to use?</h3>
<p>Using modern language features and browser APIs makes writing code easier, faster, and more fun. It also makes your code more maintainable.</p>
<p>If you&#8217;re happy writing ES5 and using <code>XMLHttpRequest()</code>, you definitely don&#8217;t need Babel, but you might need some kind of therapy.</p>
<h3 id="3whichmodernbrowserfeaturesdoyourcustomersbrowserssupport">3. Which modern browser features do your customers&#8217; browsers support?</h3>
<p>This data is available on via <a href="https://caniuse.com/" target="_blank" rel="noopener noreferrer">Can I use</a>, but it&#8217;s a waste of time to manually look it up. Now that you know the names of the browsers you want to support, looking up compatible features can be automated with the awesome <code>Browserlist</code> application (more on this in the next section).</p>
<h2 id="alternativetwouseeslintplugincompat">Alternative No. 2: Use eslint-plugin-compat</h2>
<p>You can avoid the entire transpiling process altogether and instead allow your code editor to alert you if you&#8217;re using any features that are too modern for your customers&#8217; browsers. This is the simplest option because it:</p>
<ul>
<li>Eliminates any reliance on transpilers</li>
<li>Gives you back hands-on control over your production code</li>
</ul>
<p>If there&#8217;s a modern feature you can&#8217;t live without, you can manually polyfill it. Otherwise, you can just use the older syntax when needed.</p>
<h3 id="createatest">Create a test</h3>
<p>Before we can break down the pros and cons, we need to confirm that our Babel alternatives can do the same basic job. Let&#8217;s create a small test.</p>
<p>Below is the modern code we want our target environment to support once transpiled.</p>
<p>After the transportation, there&#8217;s a <code>console.assert</code> for each function to verify it&#8217;s working as intended. In the case of <code>eslint-plugin-compat</code> we&#8217;ll instead check that the incompatible code is being flagged in the linting.</p>
<h4><code>test.js</code></h4>
<pre>// test nullish coalescing - return right side when left side null or undefined
const x = null ?? "default string";
console.assert(x === "default string");

const y = 0 ?? 42;
console.assert(y === 0);

// test optional chaining - return undefined on non existent property or method
const adventurer = {
  name: "Alice",
  cat: {
    name: "Dinah",
  },
};

const dogName = adventurer.dog?.name;
console.assert(dogName === undefined);

console.assert(adventurer.someNonExistentMethod?.() === undefined);

// use browser API fetch, to check linting
fetch("https://jsonplaceholder.typicode.com/todos/1")
  .then((response) =&gt; response.json())
  .then((json) =&gt; console.log(json));
</pre>
<h3 id="usingtheeslintenvpropertytogetherwitheslintplugincompat">Using the eslint <code>env</code> property with eslint-plugin-compat</h3>
<p>We need a workaround for linting both language features and browser APIs together.</p>
<p>You can use eslint to check for the language syntax. To do that, change the <code>env</code> property down from <code>es2020</code>.</p>
<p>To check browser API compatibility, use <code>eslint-plugin-compat</code>. It uses the same Browserlist config used by Babel and other tools.</p>
<p>Full instruction can be found in the <a href="https://github.com/amilajack/eslint-plugin-compat" target="_blank" rel="noopener noreferrer">eslint-plugin-compat repo</a>. We&#8217;ll use the browserlist <code>defaults</code> preset to use the default settings. Replace this with your own selection based on your analytics.</p>
<h3 id="whatisbrowserlist">What is browserlist?</h3>
<p><img data-attachment-id="21927" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/browserlist-logo-2/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?fit=200%2C200" data-orig-size="200,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Browserlist logo" data-image-description data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?fit=200%2C200" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?fit=200%2C200" class="alignleft size-full wp-image-21927 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?resize=200%2C200&#038;ssl=1" alt="Browserlist Logo" width="200" height="200" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?w=200 200w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?resize=150%2C150 150w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?resize=200%2C200&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="21927" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/browserlist-logo-2/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?fit=200%2C200" data-orig-size="200,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Browserlist logo" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?fit=200%2C200" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?fit=200%2C200" class="alignleft size-full wp-image-21927" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?resize=200%2C200&#038;ssl=1" alt="Browserlist Logo" width="200" height="200" srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?w=200 200w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/browserlist-logo-1.png?resize=150%2C150 150w" sizes="(max-width: 200px) 100vw, 200px" data-recalc-dims="1" /></noscript>Browserlist automatically selects a list of browsers based on various criteria you give it.</p>
<p>Have a look at the list of <a href="https://browserl.ist/?q=defaults" target="_blank" rel="noopener noreferrer">browsers supported by the <code>defaults</code> setting for browserlist</a>. <code>defaults</code> is a shortcut for:</p>
<ul>
<li>&gt; 0.5 percent (browser versions selected by global usage statistics)</li>
<li>Last two versions (of every &#8220;not dead&#8221; browser)</li>
<li>Firefox ESR</li>
<li>Not dead (browsers without official support or updates for 24 months)</li>
</ul>
<p>Head to <a href="https://github.com/browserslist/browserslist#full-list" target="_blank" rel="noopener noreferrer">GitHub</a> for the full list of queries available to choose your supported browsers.</p>
<h3 id="settingupeslintplugincompatforvisualstudiocode">Setting up eslint-plugin-compat for Visual Studio Code</h3>
<p>Add the following packages to your project.</p>
<pre>npm install --save-dev eslint eslint-plugin-compat
</pre>
<p>Add the following to <code>package.json</code>.</p>
<pre>  "browserslist": [
    "defaults"
  ]
</pre>
<p>Create the following <code>.eslintrc.json</code> file or add these settings to your current one.</p>
<pre>{
  "extends": ["plugin:compat/recommended"],
  "env": {
    "browser": true,
    "es2020": true
  }
}
</pre>
<p>Make sure you have the <a href="https://marketplace.visualstudio.com/items?itemName=dbaeumer.vscode-eslint" target="_blank" rel="noopener noreferrer">VS Code ESLint extension</a> installed</p>
<p>Now any browser API that is incompatible with the <code>browserlist</code> config in your <code>package.json</code> is shown as a linting error. You can separately control which version of ECMAScript you want to support using the <code>env</code> property in the <code>.eslintrc.json</code> file.</p>
<p>It would be nice if the <code>eslint-plugin-compat</code> automatically linted the language features as well, but this is currently an <a href="https://github.com/amilajack/eslint-plugin-compat/issues/206" target="_blank" rel="noopener noreferrer">open issue</a>.</p>
<p>With the <code>IE 11</code> setting selected —</p>
<p><img data-attachment-id="21917" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/fetch_config_error/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_config_error.png?fit=193%2C61" data-orig-size="193,61" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fetch config error" data-image-description data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_config_error.png?fit=193%2C61" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_config_error.png?fit=193%2C61" class="aligncenter size-full wp-image-21917 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_config_error.png?resize=193%2C61&#038;ssl=1" alt="Fetch Config Error" width="193" height="61" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_config_error.png?resize=193%2C61&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="21917" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/fetch_config_error/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_config_error.png?fit=193%2C61" data-orig-size="193,61" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fetch config error" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_config_error.png?fit=193%2C61" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_config_error.png?fit=193%2C61" class="aligncenter size-full wp-image-21917" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_config_error.png?resize=193%2C61&#038;ssl=1" alt="Fetch Config Error" width="193" height="61" data-recalc-dims="1" /></noscript></p>
<p>— our <code>fetch()</code> API is flagged.</p>
<p><img data-attachment-id="21918" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/fetch_error/" data-orig-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?fit=697%2C160" data-orig-size="697,160" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fetch error" data-image-description data-medium-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?fit=300%2C69" data-large-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?fit=697%2C160" class="aligncenter size-full wp-image-21918 jetpack-lazy-image" src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?resize=697%2C160&#038;ssl=1" alt="Fetch Error" width="697" height="160" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?w=697 697w, https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?resize=300%2C69 300w" data-lazy-sizes="(max-width: 697px) 100vw, 697px" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?resize=697%2C160&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="21918" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/fetch_error/" data-orig-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?fit=697%2C160" data-orig-size="697,160" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fetch error" data-image-description="" data-medium-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?fit=300%2C69" data-large-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?fit=697%2C160" class="aligncenter size-full wp-image-21918" src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?resize=697%2C160&#038;ssl=1" alt="Fetch Error" width="697" height="160" srcset="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?w=697 697w, https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/fetch_error.png?resize=300%2C69 300w" sizes="(max-width: 697px) 100vw, 697px" data-recalc-dims="1" /></noscript></p>
<p>Change the <code>env</code> property to <code>es6</code>.</p>
<p><img data-attachment-id="21920" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/nullish_coalescing_error_config/" data-orig-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?fit=413%2C152" data-orig-size="413,152" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Nullish coalescing error config" data-image-description data-medium-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?fit=300%2C110" data-large-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?fit=413%2C152" class="aligncenter size-full wp-image-21920 jetpack-lazy-image" src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?resize=413%2C152&#038;ssl=1" alt="Nullish Coalescing Error Config" width="413" height="152" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?w=413 413w, https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?resize=300%2C110 300w" data-lazy-sizes="(max-width: 413px) 100vw, 413px" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?resize=413%2C152&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="21920" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/nullish_coalescing_error_config/" data-orig-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?fit=413%2C152" data-orig-size="413,152" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Nullish coalescing error config" data-image-description="" data-medium-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?fit=300%2C110" data-large-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?fit=413%2C152" class="aligncenter size-full wp-image-21920" src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?resize=413%2C152&#038;ssl=1" alt="Nullish Coalescing Error Config" width="413" height="152" srcset="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?w=413 413w, https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error_config.png?resize=300%2C110 300w" sizes="(max-width: 413px) 100vw, 413px" data-recalc-dims="1" /></noscript></p>
<p>You&#8217;ll immediately see an error trying to use <code>nullish coalescing</code>, which was released as part of Es2020.</p>
<p><img data-attachment-id="21921" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/nullish_coalescing_error/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?fit=730%2C81" data-orig-size="730,81" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Nullish coalescing error" data-image-description data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?fit=300%2C33" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?fit=730%2C81" class="aligncenter size-full wp-image-21921 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?resize=730%2C81&#038;ssl=1" alt="Nullish Coalescing Error" width="730" height="81" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?w=730 730w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?resize=300%2C33 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?resize=730%2C81&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="21921" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/nullish_coalescing_error/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?fit=730%2C81" data-orig-size="730,81" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Nullish coalescing error" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?fit=300%2C33" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?fit=730%2C81" class="aligncenter size-full wp-image-21921" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?resize=730%2C81&#038;ssl=1" alt="Nullish Coalescing Error" width="730" height="81" srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?w=730 730w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/nullish_coalescing_error.png?resize=300%2C33 300w" sizes="(max-width: 730px) 100vw, 730px" data-recalc-dims="1" /></noscript></p>
<h2 id="alternativethreeuseothersoftwaretoreplacebabel">Alternative No. 3: Use other software to replace Babel</h2>
<p>Before we look at alternatives, let&#8217;s quickly review how to use Babel.</p>
<h3 id="usingbabeltotranspileandpollyfill">Using Babel to transpile and polyfill</h3>
<p>First, create a mini-project directory and install the dependencies we need.</p>
<pre>mkdir babel-test
cd babel-test
npm init -y
mkdir src dist
npm install --save-dev @babel/core @babel/cli @babel/preset-env
npm install --save @babel/polyfill
</pre>
<p>Add the following to your <code>package.json</code>.</p>
<pre>"browserslist": "defaults",
</pre>
<p>Write the <code>test.js</code> file into <code>src</code>, and then issue the following command.</p>
<pre>npx babel src --out-dir dist --presets=@babel/env
</pre>
<p>Finally, run the file to check that the tests still work.</p>
<pre>node dist/test.js
</pre>
<p>There should be no assertion errors, but it will say <code>fetch is not defined</code> since Node.js has no <code>fetch()</code> method. Here is the resulting transpiled code. Observe all the extra cruft and bloat added.</p>
<pre>"use strict";

var _ref, _, _adventurer$dog, _adventurer$someNonEx;

// test nullish coalescing - return right side when left side null or undefined
var x = (_ref = null) !== null &amp;&amp; _ref !== void 0 ? _ref : "default string";
console.assert(x === "default string");
var y = (_ = 0) !== null &amp;&amp; _ !== void 0 ? _ : 42;
console.assert(y === 0); // test optional chaining - return undefined on non existent property or method

var adventurer = {
  name: "Alice",
  cat: {
    name: "Dinah",
  },
};
var dogName =
  (_adventurer$dog = adventurer.dog) === null || _adventurer$dog === void 0
    ? void 0
    : _adventurer$dog.name;
console.assert(dogName === undefined);
console.assert(
  ((_adventurer$someNonEx = adventurer.someNonExistentMethod) === null ||
  _adventurer$someNonEx === void 0
    ? void 0
    : _adventurer$someNonEx.call(adventurer)) === undefined,
); // use browser API fetch, to check linting

fetch("https://jsonplaceholder.typicode.com/todos/1")
  .then(function (response) {
    return response.json();
  })
  .then(function (json) {
    return console.log(json);
  });
</pre>
<h3 id="theprosandconsofbabel">The pros and cons of using Babel</h3>
<p>Pros:</p>
<ul>
<li>This most basic setup was relatively straightforward</li>
<li>Babel has a large community for support and continued updates with 36.8k GitHub stars at the time of writing</li>
</ul>
<p>Cons:</p>
<ul>
<li>Slow compile time</li>
<li>A lot of dependencies, even if they are dev-dependencies (269 packages installed)</li>
<li>39M of disk space used, as reported by <code>du -sh</code></li>
<li>5728 files installed, as reported by <code>find . -type f | wc -l</code></li>
</ul>
<h3 id="usingswctotranspileandpolyfill">Using swc to transpile and polyfill</h3>
<p><img data-attachment-id="21931" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/swc-2/" data-orig-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/swc-1.png?fit=200%2C71" data-orig-size="200,71" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swc" data-image-description data-medium-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/swc-1.png?fit=200%2C71" data-large-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/swc-1.png?fit=200%2C71" class="alignleft size-full wp-image-21931 jetpack-lazy-image" src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/swc-1.png?resize=200%2C71&#038;ssl=1" alt="swc Logo" width="200" height="71" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/swc-1.png?resize=200%2C71&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="21931" data-permalink="http://blog.logrocket.com/why-you-dont-need-babel/swc-2/" data-orig-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/swc-1.png?fit=200%2C71" data-orig-size="200,71" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swc" data-image-description="" data-medium-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/swc-1.png?fit=200%2C71" data-large-file="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/swc-1.png?fit=200%2C71" class="alignleft size-full wp-image-21931" src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/swc-1.png?resize=200%2C71&#038;ssl=1" alt="swc Logo" width="200" height="71" data-recalc-dims="1" /></noscript>swc is a new competitor to Babel. It is written in Rust and up to 20 times faster. This can be very important if you find yourself waiting a long time to build your project.</p>
<p>To set it up:</p>
<pre>mkdir swc-test
cd swc-test
npm init -y
mkdir src dist
npm install --save-dev @swc/cli @swc/core browserslist
</pre>
<p>Add the following to your <code>package.json</code>.</p>
<pre>"browserslist": "defaults",
</pre>
<p>Write the <code>.swcrc</code> config file into the project root. Note: some features need turning on.</p>
<pre>{
  "env": {
    "coreJs": 3
  },
  "jsc": {
    "parser": {
      "syntax": "ecmascript",
      "nullishCoalescing": true,
      "optionalChaining": true
    }
  }
}
</pre>
<p>Write your test file into <code>src</code>, then issue the following command to transpile.</p>
<pre>npx swc src -d dist
</pre>
<p>Run the resulting file to check that the tests still work.</p>
<pre>node dist/test.js
</pre>
<p>The resulting swc-transpiled file looks like this:</p>
<pre>var ref, ref1;
var ref2;
// test nullish coalescing - return right side when left side null or undefined
var x = (ref2 = null) !== null &amp;&amp; ref2 !== void 0 ? ref2 : "default string";
console.assert(x === "default string");
var ref3;
var y = (ref3 = 0) !== null &amp;&amp; ref3 !== void 0 ? ref3 : 42;
console.assert(y === 0);
// test optional chaining - return undefined on non existent property or method
var adventurer = {
  name: "Alice",
  cat: {
    name: "Dinah",
  },
};
var dogName =
  (ref = adventurer.dog) === null || ref === void 0 ? void 0 : ref.name;
console.assert(dogName === undefined);
console.assert(
  ((ref1 = adventurer.someNonExistentMethod) === null || ref1 === void 0
    ? void 0
    : ref1.call(ref1)) === undefined,
);
// use browser API fetch, to check linting
fetch("https://jsonplaceholder.typicode.com/todos/1")
  .then(function (response) {
    return response.json();
  })
  .then(function (json) {
    return console.log(json);
  });
</pre>
<h3 id="theprosandconsofswc">The pros and cons of using swc</h3>
<p>Pros:</p>
<ul>
<li>swc is <a href="https://github.com/swc-project/swc#performance" target="_blank" rel="noopener noreferrer">much faster</a></li>
<li>Far fewer dependencies (43 packages installed)</li>
</ul>
<p>Cons:</p>
<ul>
<li><a href="https://swc-project.github.io/docs/comparison-babel" target="_blank" rel="noopener noreferrer">Not all Babel features</a> are currently supported</li>
<li>Smaller user base and number of regular contributors</li>
</ul>
<h2 id="otheralternativesgoogleclosurecompilerandtypescript">Other alternatives: Google Closure Compiler and TypeScript</h2>
<p>I did not include <a href="https://developers.google.com/closure/compiler/" target="_blank" rel="noopener noreferrer">Google Closure Compiler</a> as an option because it&#8217;s notoriously complicated to use. That said, it can do a good job of transpiling and polyfilling. If you have some spare time on your hands, I recommend you check it out — especially if you value small file sizes since its built-in minification is demonstrably superior.</p>
<p>You can also use <a href="https://www.typescriptlang.org/" target="_blank" rel="noopener noreferrer">TypeScript</a> to transpile and core-js to manually polyfill, but this is a clumsy solution that could easily create more problems than it solves.</p>
<h2 id="conclusion">Conclusion</h2>
<p>You don&#8217;t automatically need to support old browsers. It&#8217;s important to first look at your analytics data to see which browsers your customers are actually using.</p>
<p>If necessary, you can use linting to ensure backward compatibility. This will save you the hassle of creating a special build step and relying on transpilation.</p>
<p>If you do opt for automatic translating, then SWC is much faster than Babel and contains far fewer dependencies. There is also the option to use Google Closure Compiler or TypeScript, but these will require a bit more work to configure.</p><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<div class="base-cta"><h2><a class="signup" href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">LogRocket</a>: Full visibility into your web apps</h2>
<a href="https://logrocket.com/signup/" class="signup" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" /></noscript></a>

<p style="margin-top:15px;"><a href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">LogRocket</a> is a frontend application monitoring solution that lets you replay problems as if they happened in your own browser. Instead of guessing why errors happen, or asking users for screenshots and log dumps, LogRocket lets you replay the session to quickly understand what went wrong. It works perfectly with any app, regardless of framework, and has plugins to log additional context from Redux, Vuex, and @ngrx/store.</p>

<p>In addition to logging Redux actions and state, LogRocket records console logs, JavaScript errors, stacktraces, network requests/responses with headers + bodies, browser metadata, and custom logs. It also instruments the DOM to record the HTML and CSS on the page, recreating pixel-perfect videos of even the most complex single-page apps.</p>

<a class="signup" href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">Try it for free</a>.</div>
</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-21728" class="share-twitter sd-button share-icon" href="http://blog.logrocket.com/why-you-dont-need-babel/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="http://blog.logrocket.com/why-you-dont-need-babel/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-21728" class="share-linkedin sd-button share-icon" href="http://blog.logrocket.com/why-you-dont-need-babel/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-21728" class="share-facebook sd-button share-icon" href="http://blog.logrocket.com/why-you-dont-need-babel/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><!-- AI CONTENT END 1 -->
                        <div class="clearfix"></div>
                                                <div class="clearfix"></div>
                    </article>
                            
                                             <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-lg-up"> 
                            <div class="col-md-2 col-xs-4"> 
                                <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/david-else.png?resize=150%2C150" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/david-else.png?resize=150%2C150&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/david-else.png?resize=150%2C150' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                            </div>                                         
                            <div class="col-md-10 col-xs-8"> 
                                <a class="text-capitalize link-dark" href="http://blog.logrocket.com/author/davidelse/">
                                David Else <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">TypeScript/JavaScript software developer | <a href="http://elsewebdevelopment.com" rel="noopener noreferrer">elsewebdevelopment.com</a></span> 
                            </div>                                         
                        </div>
                                         
                    <div class="after-post-tags">
                                                    <ul class="post-categories">
	<li><a href="http://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul>                                                                            <ul class="post-categories aretags">
                            <li><a href="http://blog.logrocket.com/tag/babel/">#babel</a></li>                             </ul>
                                            </div>
                    
                  
                    <div class="row mb-5 prevnextlinks justify-content-center align-items-center"> 
                       <div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="http://blog.logrocket.com/receiving-emails-with-bref-php-and-sendgrid/" rel="prev">Receiving emails with Bref PHP and SendGrid</a></div></div>
                       <div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"></div></div>
                    </div>
                    
                </div>
        
                    
         
        
        
    </div>                 
</div>             
          
<div class="hideshare"></div>

    <div class="graybg"> 
        <div class="container"> 
                <div class="row justify-content-center listrecent listrelated">
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="http://blog.logrocket.com/receiving-emails-with-bref-php-and-sendgrid/" style="background-image:url(https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/Untitled-design-11.png?fit=730%2C412);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="http://blog.logrocket.com/receiving-emails-with-bref-php-and-sendgrid/">Receiving emails with Bref PHP and SendGrid</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="http://blog.logrocket.com/author/okokomichaels/">
                    <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/michaelo.jpg?resize=150%2C150" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/michaelo.jpg?resize=150%2C150&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/michaelo.jpg?resize=150%2C150' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="http://blog.logrocket.com/author/okokomichaels/">Michael Okoko</a></span><br>
                    <span class="post-date">Jul 16, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">5 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="http://blog.logrocket.com/receiving-emails-with-bref-php-and-sendgrid/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="http://blog.logrocket.com/setting-up-first-gutenberg-project/" style="background-image:url(https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/setting-up-first-gutenberg-project.png?fit=730%2C487);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="http://blog.logrocket.com/setting-up-first-gutenberg-project/">Setting up your first Gutenberg project</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="http://blog.logrocket.com/author/leonardolosoviz/">
                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/leonardo-losoviz.jpg?resize=150%2C150" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/leonardo-losoviz.jpg?resize=150%2C150&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/leonardo-losoviz.jpg?resize=150%2C150' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="http://blog.logrocket.com/author/leonardolosoviz/">Leonardo Losoviz</a></span><br>
                    <span class="post-date">Jul 15, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">6 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="http://blog.logrocket.com/setting-up-first-gutenberg-project/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="http://blog.logrocket.com/testing-vue-components-with-vue-testing-library/" style="background-image:url(https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/testing-vue-components-with-vue-testing-library-2.png?fit=730%2C487);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="http://blog.logrocket.com/testing-vue-components-with-vue-testing-library/">Testing Vue components with Vue Testing Library</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="http://blog.logrocket.com/author/jamesjames/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/james-james.png?resize=150%2C150" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/james-james.png?resize=150%2C150&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/james-james.png?resize=150%2C150' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="http://blog.logrocket.com/author/jamesjames/">James James</a></span><br>
                    <span class="post-date">Jul 15, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">5 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="http://blog.logrocket.com/testing-vue-components-with-vue-testing-library/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
            </div>
    <div class="clearfix"></div>
                
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/why-you-dont-need-babel/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=21728&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.7.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=e8f6bc3f277cb6d139971f39fa415d8e0d1f3858#parent=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
</div>
</div>        </div>                 
    </div>

    <div class="alertbar"> 
        <div class="container text-center"> 
                    </div>
    </div>

</div><!-- /.site-content -->
        
        <div class="container">
            <footer class="footer"> 
                <div class="pull-left"> Does something seem off? Email <a>support@logrocket.com</a> </div> 
                <div class="pull-right"> <div class = "footerRight">			<div id="jetpack-search-filters-2-wrapper" >
		<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="http://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field"
placeholder="Search..."
value="" name="s"
title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>   
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div>  </div> 
                <div class="clearfix"></div>
                <a href="" class="back-to-top hidden-md-down"> 
                <i class="fa fa-angle-up"></i>
                </a>
            </footer>
        </div>
        <!--  -->
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
};
var current_url = location.pathname;
if (current_url == "/") {
jQuery( "#post-20374 span.readingtime" ).replaceWith( "<span class='readingtime'>12 min read</span>" );
};
</script>	<div style="display:none">
	<div class="grofile-hash-map-8ab6e8f4e8633e470ec2261599632505">
	</div>
	<div class="grofile-hash-map-a64fbe74173fca211ef3ef037a621f41">
	</div>
	<div class="grofile-hash-map-60f8da4ba3b1b7f01d76183c7d453bce">
	</div>
	<div class="grofile-hash-map-d710fc14c915391861c50f46556a575e">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/blog.logrocket.com\/why-you-dont-need-babel\/":21728};
	</script>
				<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "http:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='http://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js'></script>
<script type='text/javascript' async='async' src='http://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js'></script>
<script type='text/javascript' async='async' src='http://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js'></script>
<script type='text/javascript' async='async' src='http://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js'></script>
<script type='text/javascript' async='async' src='http://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.4.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.7.1/modules/widgets/search/js/search-widget.js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.4.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"61bf12884f","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/blog.logrocket.com\/wp-login.php?redirect_to=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script async="async" type='text/javascript' async='async' src='http://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=21728&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.7.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=e8f6bc3f277cb6d139971f39fa415d8e0d1f3858#parent=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=21728&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.7.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=e8f6bc3f277cb6d139971f39fa415d8e0d1f3858#parent=http%3A%2F%2Fblog.logrocket.com%2Fwhy-you-dont-need-babel%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202029.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'161333275',post:'21728',tz:'-4',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '21728' ]);
</script>
            </body>     
</html>
