<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />


<title>Boost your productivity with TypeScript project references - LogRocket Blog</title>
<link rel="canonical" href="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Boost your productivity with TypeScript project references - LogRocket Blog" />
<meta property="og:description" content="If you have a TypeScript codebase in a monorepo that is not using TypeScript project references then you are missing out on a productivity boost." />
<meta property="og:url" content="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2021-04-19T13:00:44+00:00" />
<meta property="article:modified_time" content="2021-04-02T14:35:25+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="487" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Paul Cowan">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="4 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/#primaryimage","inLanguage":"en-US","url":"https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences.png","width":730,"height":487,"caption":"Boost your productivity with TypeScript project references"},{"@type":"WebPage","@id":"https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/#webpage","url":"https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/","name":"Boost your productivity with TypeScript project references - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/#primaryimage"},"datePublished":"2021-04-19T13:00:44+00:00","dateModified":"2021-04-02T14:35:25+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/e3dcc8316ea54bc4ac911b29cf4b89ce"},"breadcrumb":{"@id":"https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/"]}]},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://blog.logrocket.com/","url":"https://blog.logrocket.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/","url":"https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/","name":"Boost your productivity with TypeScript project references"}}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/e3dcc8316ea54bc4ac911b29cf4b89ce","name":"Paul Cowan","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/2bf8a82df6ec1a5022df12ec6e5e280e?s=96&d=mm&r=g","caption":"Paul Cowan"},"description":"Contract software developer"}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Boost your productivity with TypeScript project references Comments Feed" href="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=9.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/41283" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-aJR' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://a39e555ed62c408792586c55bbb2ce3b@e.logrocket.com/9').install()
    </script>
<script type="text/javascript">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</script>
<script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
<script>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</script><style type='text/css'>img#wpstats{display:none}</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
 <link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=f350f49b26" />
<style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-41283 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="navarea">
<div class="nav-left">
<a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>
<nav class="menu-container">
<div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a><li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">PodRocket</a></ul></div></nav>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Start your self-service trial</a></li>
</ul></div> </div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Boost%20your%20productivity%20with%20TypeScript%20project%20references&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences.png&amp;description=Boost%20your%20productivity%20with%20TypeScript%20project%20references">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F&amp;title=Boost%20your%20productivity%20with%20TypeScript%20project%20references">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-41283 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-typescript" id="post-41283">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/paulcowan/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/11/paulcowan-150x150.jpg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/11/paulcowan-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/11/paulcowan-150x150.jpg?crop=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/paulcowan/">
Paul Cowan <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Contract software developer</span>
</div>
</div>
<h1 class="posttitle">Boost your productivity with TypeScript project references</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
April 19, 2021 </time></span>
<span class="dot"></span>
<span class="readingtime">3 min read</span>
<span class="wordcount">865</span>
 </p>
</div>
<img width="730" height="487" src="https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="Boost your productivity with TypeScript project references" loading="lazy" data-attachment-id="41317" data-permalink="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/typescriptprojectreferences/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences.png" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="typescriptprojectreferences" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences-300x200.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences-300x200.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/04/typescriptprojectreferences.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> <article class="article-post">
<p>If you have a TypeScript codebase in a monorepo that is not using <a href="https://www.typescriptlang.org/docs/handbook/project-references.html" target="_blank" rel="noopener">TypeScript project references</a> then you are missing a trick.</p>
<p>TypeScript project references have been around since TypeScript 3.0 and allow you to specify dependant packages in the <code>tsconfig.json</code> that the current package depends on. When you build a package with dependencies, then the dependencies get built first.</p>
<p>The <code>tsconfig.json</code> below specifies that this package references a <code>common</code> package and that the <code>common</code> package is built before the current package:</p>
<pre>{
  "extends": "../tsconfig-base.json",
  "compilerOptions": {
    "outDir": "../lib/animals",
    "rootDir": ".",
  },
  "references": [
    { "path": "../core" }
  ]
}</pre>
<p>Project references are specified via a <code>references</code> array of objects with a <code>path</code> property. The <code>path</code> property is a relative path to a different location containing a <code>tsconfig.json</code> file.</p>
<p>If the project were not using project references, then all packages would have to be built individually, which can be a huge drag if there are multiple dependent packages.</p>
<h2>Building incrementally</h2>
<p>The <code>-b</code> or <code>--build</code> switch is added to the <a href="https://www.typescriptlang.org/docs/handbook/compiler-options.html" target="_blank" rel="noopener">tsc</a> compiler when transpiling a package that has project references:</p>
<pre> &gt; tsc -b                           # Use the tsconfig.json in the current directory
 &gt; tsc -b src                       # Use src/tsconfig.json
 &gt; tsc -b foo/prd.tsconfig.json bar # Use foo/prd.tsconfig.json and bar/tsconfig.json</pre>
<p>A successful build will output a <code>tsconfig.tsbuildinfo</code>, used in subsequent builds to ensure only new code or changed code is built for a faster build time. The <code>tsconfig.tsbuildinfo</code> file contains the signatures and timestamps of all files required to build the whole project. On subsequent builds, TypeScript will use that information to detect the least costly way to type check and emit changes to your project.</p>
<h2>Watch all packages in the monorepo for changes</h2>
<p>What has really boosted my TypeScript development is the ability to have <code>tsc</code> watch for changes in every package of a monorepo.</p>
<p>I have a script like this running the whole time I am developing:</p>
<pre>"watch": "tsc -b ./tsconfig.packages.json --watch"</pre>
<p>When the <code>watch</code> script is running, any TypeScript changes in the whole monorepo will result in a new efficient build:</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br />No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>
<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>
<p><img data-attachment-id="41295" data-permalink="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/watch/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/04/watch.png" data-orig-size="1122,180" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="watch" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/04/watch-300x48.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/04/watch-1024x164.png" loading="lazy" class="aligncenter size-full wp-image-41295 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/04/watch.png" alt="tsc watching for changes" width="1122" height="180" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/04/watch.png 1122w, https://blog.logrocket.com/wp-content/uploads/2021/04/watch-300x48.png 300w, https://blog.logrocket.com/wp-content/uploads/2021/04/watch-1024x164.png 1024w, https://blog.logrocket.com/wp-content/uploads/2021/04/watch-768x123.png 768w" data-lazy-sizes="(max-width: 1122px) 100vw, 1122px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/04/watch.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="41295" data-permalink="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/watch/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/04/watch.png" data-orig-size="1122,180" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="watch" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/04/watch-300x48.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/04/watch-1024x164.png" loading="lazy" class="aligncenter size-full wp-image-41295" src="https://blog.logrocket.com/wp-content/uploads/2021/04/watch.png" alt="tsc watching for changes" width="1122" height="180" srcset="https://blog.logrocket.com/wp-content/uploads/2021/04/watch.png 1122w, https://blog.logrocket.com/wp-content/uploads/2021/04/watch-300x48.png 300w, https://blog.logrocket.com/wp-content/uploads/2021/04/watch-1024x164.png 1024w, https://blog.logrocket.com/wp-content/uploads/2021/04/watch-768x123.png 768w" sizes="(max-width: 1122px) 100vw, 1122px" /></noscript></p>
<h2>Monorepo project structure</h2>
<p>In most monorepos, the individual package nodes are in a folder named <code>packages</code>. Below is an example monorepo with the various <code>tsconfig.json</code> files strategically placed with surgical precision:</p>
<pre>tsconfig.base.json         # base tsconfig.json that all packages will extend
tsconfig.packages.json     # tsconfig.json that is used to watch eveything
all packages
/package.json
/packages
  /common                  # Common utitliies used by all package
    /src
      .index.ts            # entry point for package
    /tsconfig.json         # Config file for 'common' project
    /package.json
  /web                     # Depends on 'common'
    /src
      .index.ts            # entry point for package
    /tsconfig.json         # Config file for 'web' project
  /api                     # Depends on 'common'
    /src
      .index.ts            # entry point for package
    /tsconfig.json         # Config file for 'api' project
    /package.json</pre>
<p>At the root folder is a <code>tsconfig.base.json</code> file that is extended by all packages in the monorepo:</p>
<pre>{
  "compilerOptions": {
    "baseUrl": ".",
    "composite": true,
    "declaration": true,
    "declarationMap": true,
    "paths": {
      "common": ["packages/common/src"],
      "web": ["packages/web/src"],
      "api": ["packages/api/src"]
    }
  }
}</pre>
<p>There is actually a lot going on here:</p>
<ul>
<li><code>"composite": true</code> instructs <code>tsc</code> that there are project references</li>
<li><code>"declarationMap": true</code> adds source maps for <code>.d.ts</code> declaration files. It means <code>Go to Definition</code> in VS code and will go to the actual file and not the <code>.d.ts</code> file</li>
<li>The <code>paths</code> field contains an object with each object key (common, web, or API in this example) pointing to a package&#8217;s location. With this set, we can import packages without a nasty relative or absolute path.<br />
e.g. <code>import { a } from 'web';</code></li>
</ul>
<p>In this example, each package extends <code>tsconfig.base.json</code> using the <code>extends</code> option of <code>tsconfig</code>:</p>
<pre>{
  "extends": "../tsconfig-base.json",
  "compilerOptions": {
    "rootDir": ".",
  },
  "references": [
    { "path": "../core" }
  ]
}</pre>
<h2>Watching and building</h2>
<p>The <code>tsconfig.packages.json</code> at the root of the project structure references all packages that we want to watch or build:</p>
<pre>{
  "files": [],
  "references": [
  {
    "path": "./packages/common"
  },
  {
    "path": "./packages/web"
  },
  {
    "path": "./packages/api"
  }
 ]
}</pre>
<p>With this structure in place, we can now build all packages in one swoop:</p>
<pre>tsc -b ./tsconfig.packages.json</pre>
<p>or watch:</p>
<pre>tsc -b ./tsconfig.packages.json</pre>
<h2>Useful switches</h2>
<p>The following switches are handy when working with project references:</p>
<pre>--verbose: Prints out verbose logging to explain what is going on (may be combined with any other flag)
--dry: Shows what would be done but does not actually build anything
--clean: Deletes the outputs of the specified projects (may be combined with --dry)
--force: Acts as if all projects are out of date
--watch: Watch mode (may not be combined with any flag except --verbose)</pre>
<h2>Webpack</h2>
<p>Bundlers like webpack and Rollup did not offer support for project references for quite some time, and Rollup only has partial support. This has not helped adoption.</p>
<h2>webpack ts-loader</h2>
<p>When configuring the webpack loader <code>ts-loader</code>, you need to set the <code>projectReferences</code> option to true:</p>
<pre>{
  test: /\.tsx?$/,
  use: {
    loader: 'ts-loader',
    options: {
      projectReferences: true,
    },
  },
},</pre>
<h2>Epilogue</h2>
<p>I do most of my main development in monorepo&#8217;s these days, both in client projects and my own personal development. If I use TypeScript as my main language, then I will enable project references just like I have outlined here. I find them a great productivity boost that not everyone is using.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-41283" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-41283" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-41283" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/boost-your-productivity-with-typescript-project-references/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/11/paulcowan-150x150.jpg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/11/paulcowan-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/11/paulcowan-150x150.jpg?crop=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/paulcowan/">
Paul Cowan <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Contract software developer</span>
</div>
</div>
<div class="after-post-tags">
<ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/typescript/">#typescript</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/ecommerce-storefront-ui-tailwind-css/" rel="prev">Building an ecommerce storefront with Storefront UI and Tailwind CSS</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"></div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/ecommerce-storefront-ui-tailwind-css/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/04/tailwindstorefront.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/ecommerce-storefront-ui-tailwind-css/">Building an ecommerce storefront with Storefront UI and Tailwind&hellip;</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/emmanuelakhigbe/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/01/emmanuel.jpeg" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/01/emmanuel.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/01/emmanuel.jpeg' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/emmanuelakhigbe/">Emmanuel Akhigbe</a></span><br>
<span class="post-date">Apr 16, 2021</span>
<span class="dot"></span>
<span class="readingtime">8 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/ecommerce-storefront-ui-tailwind-css/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/optimize-your-react-native-app-performance/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/04/optimize-react-native-performance.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/optimize-your-react-native-app-performance/">Optimize your React Native app performance</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/ifeanyidike/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/04/Ifeanyi-Dike.png" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/04/Ifeanyi-Dike.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/04/Ifeanyi-Dike.png' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/ifeanyidike/">Ifeanyi Dike</a></span><br>
<span class="post-date">Apr 16, 2021</span>
<span class="dot"></span>
<span class="readingtime">11 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/optimize-your-react-native-app-performance/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/top-express-js-template-engines-for-dynamic-html-pages/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/04/express-js-template-engines.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/top-express-js-template-engines-for-dynamic-html-pages/">Top Express.js template engines for dynamic HTML pages</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/sijuadeajagunna/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/01/IMG_0417-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/01/IMG_0417-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/01/IMG_0417-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/sijuadeajagunna/">Sijuade Ajagunna</a></span><br>
<span class="post-date">Apr 16, 2021</span>
<span class="dot"></span>
<span class="readingtime">7 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/top-express-js-template-engines-for-dynamic-html-pages/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/boost-your-productivity-with-typescript-project-references/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=41283&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.6.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=5d784fe13ea5bbe15c20ef8da5930af03db420af#parent=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="pull-left"> Does something seem off? Email <a><span class="__cf_email__" data-cfemail="1665636666796462567a79716479757d73623875797b">[email&#160;protected]</span></a> </div>
<div class="pull-right"> <div class="footerRight"> <div id="jetpack-search-filters-2-wrapper">
<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div> </div>
<div class="clearfix"></div>
<a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202116'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text(),
	postAuthor: jQuery("meta[name='twitter:data1']").attr("content")
  });
}
};</script> <div style="display:none">
<div class="grofile-hash-map-2bf8a82df6ec1a5022df12ec6e5e280e">
</div>
<div class="grofile-hash-map-95d7097a88019e1b709d767f472b3c1a">
</div>
<div class="grofile-hash-map-760e742bdb8a3c99c4450cfedf0b34c1">
</div>
<div class="grofile-hash-map-a0b2985aa9fb337464da8dfdd07dbc4c">
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/boost-your-productivity-with-typescript-project-references\/":41283};
	</script>
<link rel='stylesheet' id='dashicons-css' href='https://blog.logrocket.com/wp-includes/css/dashicons.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='nf-display-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/display-opinions-light.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='nf-font-awesome-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/font-awesome.min.css?ver=5.7.1' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/modules/widgets/search/js/search-widget.js?ver=9.6.1' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"8bf90318d7","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=9.6.1' id='jetpack-carousel-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/backbone.min.js?ver=1.4.0' id='backbone-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end-deps.js?ver=3.5.3' id='nf-front-end-deps-js'></script>
<script type='text/javascript' id='nf-front-end-js-extra'>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</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end.js?ver=3.5.3' id='nf-front-end-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.6.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=41283&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=5d784fe13ea5bbe15c20ef8da5930af03db420af#parent=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=41283&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=5d784fe13ea5bbe15c20ef8da5930af03db420af#parent=https%3A%2F%2Fblog.logrocket.com%2Fboost-your-productivity-with-typescript-project-references%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202116.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6.1',blog:'161333275',post:'41283',tz:'-4',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '41283' ]);
</script>
<script id="tmpl-nf-layout" type="text/template">
	<span id="nf-form-title-{{{ data.id }}}" class="nf-form-title">
		{{{ ( 1 == data.settings.show_title ) ? '<h3>' + data.settings.title + '</h3>' : '' }}}
	</span>
	<div class="nf-form-wrap ninja-forms-form-wrap">
		<div class="nf-response-msg"></div>
		<div class="nf-debug-msg"></div>
		<div class="nf-before-form"></div>
		<div class="nf-form-layout"></div>
		<div class="nf-after-form"></div>
	</div>
</script>
<script id="tmpl-nf-empty" type="text/template">

</script>
<script id="tmpl-nf-before-form" type="text/template">
	{{{ data.beforeForm }}}
</script><script id="tmpl-nf-after-form" type="text/template">
	{{{ data.afterForm }}}
</script><script id="tmpl-nf-before-fields" type="text/template">
    <div class="nf-form-fields-required">{{{ data.renderFieldsMarkedRequired() }}}</div>
    {{{ data.beforeFields }}}
</script><script id="tmpl-nf-after-fields" type="text/template">
    {{{ data.afterFields }}}
    <div id="nf-form-errors-{{{ data.id }}}" class="nf-form-errors" role="alert"></div>
    <div class="nf-form-hp"></div>
</script>
<script id="tmpl-nf-before-field" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-after-field" type="text/template">
    {{{ data.afterField }}}
</script><script id="tmpl-nf-form-layout" type="text/template">
	<form>
		<div>
			<div class="nf-before-form-content"></div>
			<div class="nf-form-content {{{ data.element_class }}}"></div>
			<div class="nf-after-form-content"></div>
		</div>
	</form>
</script><script id="tmpl-nf-form-hp" type="text/template">
	<label for="nf-field-hp-{{{ data.id }}}" aria-hidden="true">
		{{{ nfi18n.formHoneypot }}}
		<input id="nf-field-hp-{{{ data.id }}}" name="nf-field-hp" class="nf-element nf-field-hp" type="text" value=""/>
	</label>
</script>
<script id="tmpl-nf-field-layout" type="text/template">
    <div id="nf-field-{{{ data.id }}}-container" class="nf-field-container {{{ data.type }}}-container {{{ data.renderContainerClass() }}}">
        <div class="nf-before-field"></div>
        <div class="nf-field"></div>
        <div class="nf-after-field"></div>
    </div>
</script>
<script id="tmpl-nf-field-before" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-field-after" type="text/template">
    <#
    /*
     * Render our input limit section if that setting exists.
     */
    #>
    <div class="nf-input-limit"></div>
    <#
    /*
     * Render our error section if we have an error.
     */
    #>
    <div id="nf-error-{{{ data.id }}}" class="nf-error-wrap nf-error" role="alert"></div>
    <#
    /*
     * Render any custom HTML after our field.
     */
    #>
    {{{ data.afterField }}}
</script>
<script id="tmpl-nf-field-wrap" type="text/template">
	<div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
		<#
		/*
		 * This is our main field template. It's called for every field type.
		 * Note that must have ONE top-level, wrapping element. i.e. a div/span/etc that wraps all of the template.
		 */
        #>
		<#
		/*
		 * Render our label.
		 */
        #>
		{{{ data.renderLabel() }}}
		<#
		/*
		 * Render our field element. Uses the template for the field being rendered.
		 */
        #>
		<div class="nf-field-element">{{{ data.renderElement() }}}</div>
		<#
		/*
		 * Render our Description Text.
		 */
        #>
		{{{ data.renderDescText() }}}
	</div>
</script>
<script id="tmpl-nf-field-wrap-no-label" type="text/template">
    <div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
        <div class="nf-field-label"></div>
        <div class="nf-field-element">{{{ data.renderElement() }}}</div>
        <div class="nf-error-wrap"></div>
    </div>
</script>
<script id="tmpl-nf-field-wrap-no-container" type="text/template">

        {{{ data.renderElement() }}}

        <div class="nf-error-wrap"></div>
</script>
<script id="tmpl-nf-field-label" type="text/template">
	<div class="nf-field-label"><label for="nf-field-{{{ data.id }}}"
	                                   id="nf-label-field-{{{ data.id }}}"
	                                   class="{{{ data.renderLabelClasses() }}}">{{{ data.label }}} {{{ ( 'undefined' != typeof data.required && 1 == data.required ) ? '<span class="ninja-forms-req-symbol">*</span>' : '' }}} {{{ data.maybeRenderHelp() }}}</label></div>
</script>
<script id="tmpl-nf-field-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-form-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-field-input-limit" type="text/template">
    {{{ data.currentCount() }}} {{{ nfi18n.of }}} {{{ data.input_limit }}} {{{ data.input_limit_msg }}}
</script><script id="tmpl-nf-field-null" type="text/template">
</script><script id="tmpl-nf-field-listcheckbox" type="text/template">
    <ul aria-describedby="nf-error-{{{ data.id }}}">
        {{{ data.renderOptions() }}}
    </ul>
</script>
<script id='tmpl-nf-field-listcheckbox-option' type='text/template'>
    <# if ( ! data.visible ) { return '' } #>
    <li>
        <input type="checkbox" id="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}" name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element {{{ ( data.isSelected ) ? ' nf-checked' : '' }}}" value="{{{ data.value }}}" {{{ ( data.isSelected ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
            <# if( data.required ) { #>
			required
			<# } #>
        >
        <label for="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               id="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               class="{{{ ( data.isSelected ) ? 'nf-checked-label' : '' }}}">{{{ data.label }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other' type='text/template'>
    <li {{{ ( ! data.visible ) ? 'style="display:none"' : '' }}}>
        <input type="checkbox"
               id="nf-field-{{{ data.fieldID }}}-other"
               name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element" value="nf-other" {{{ ( ! data.valueFound ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-other"
            <# if( data.required ) { #>
			required
			<# } #>
        >
         <label id="nf-label-field-{{{ data.fieldID }}}-other">Other
            {{{ data.renderOtherText() }}}
        </label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other-text' type='text/template'>
    <input type="text" name="nf-field-{{{ data.fieldID }}}" class="nf-element" value="{{{ data.currentValue }}}">
</script>
<script id='tmpl-nf-field-input' type='text/template'>
    <input id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" aria-invalid="false" aria-describedby="nf-error-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element" type="text" value="{{{ data.value }}}" {{{ data.renderPlaceholder() }}} {{{ data.maybeDisabled() }}}
           aria-labelledby="nf-label-field-{{{ data.id }}}"

            {{{ data.maybeRequired() }}}
    >
</script>
<script id="tmpl-nf-field-email" type="text/template">
	<input
			type="email"
			value="{{{ data.value }}}"
			class="{{{ data.renderClasses() }}} nf-element"

			id="nf-field-{{{ data.id }}}"
			<# if( ! data.disable_browser_autocompletes ){ #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id + '-' + data.type }}"
			autocomplete="email"
			<# } else { #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id }}"
			{{{ data.maybeDisableAutocomplete() }}}
			<# } #>
			{{{ data.renderPlaceholder() }}}
			{{{ data.maybeDisabled() }}}

			aria-invalid="false"
			aria-describedby="nf-error-{{{ data.id }}}"
			aria-labelledby="nf-label-field-{{{ data.id }}}"

			{{{ data.maybeRequired() }}}
	>
</script>
<script id="tmpl-nf-field-submit" type="text/template">
	<input id="nf-field-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element " type="button" value="{{{ data.label }}}" {{{ ( data.disabled ) ? 'disabled' : '' }}}>
</script><script id='tmpl-nf-field-button' type='text/template'>
    <button id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" class="{{{ data.classes }}} nf-element">
        {{{ data.label }}}
    </button>
</script><script>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</script>
</body>
</html>

