<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />


<title>Theming Vue.js with styled-components - LogRocket Blog</title>
<meta name="description" content="Learn how utilizing styled-components to theme in Vue.js can provide an alternative way to style compared to traditional CSS in JavaScript." />
<link rel="canonical" href="https://blog.logrocket.com/theming-vue-js-with-styled-components/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Theming Vue.js with styled-components - LogRocket Blog" />
<meta property="og:description" content="Learn how utilizing styled-components to theme in Vue.js can provide an alternative way to style compared to traditional CSS in JavaScript." />
<meta property="og:url" content="https://blog.logrocket.com/theming-vue-js-with-styled-components/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2021-05-28T17:30:01+00:00" />
<meta property="article:modified_time" content="2021-05-27T20:08:00+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="445" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Kasra Khosravi">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="8 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/theming-vue-js-with-styled-components/#primaryimage","inLanguage":"en-US","url":"https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components.png","contentUrl":"https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components.png","width":730,"height":445,"caption":"Theming Vue.js With Styled-Components"},{"@type":"WebPage","@id":"https://blog.logrocket.com/theming-vue-js-with-styled-components/#webpage","url":"https://blog.logrocket.com/theming-vue-js-with-styled-components/","name":"Theming Vue.js with styled-components - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/theming-vue-js-with-styled-components/#primaryimage"},"datePublished":"2021-05-28T17:30:01+00:00","dateModified":"2021-05-27T20:08:00+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/3116f1b50d86382282fb55a070fc4e4d"},"description":"Learn how utilizing styled-components to theme in Vue.js can provide an alternative way to style compared to traditional CSS in JavaScript.","breadcrumb":{"@id":"https://blog.logrocket.com/theming-vue-js-with-styled-components/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/theming-vue-js-with-styled-components/"]}]},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/theming-vue-js-with-styled-components/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://blog.logrocket.com/","url":"https://blog.logrocket.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://blog.logrocket.com/theming-vue-js-with-styled-components/#webpage"}}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/3116f1b50d86382282fb55a070fc4e4d","name":"Kasra Khosravi","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/057a723c5946bcfcb0613720cd4f32b3?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/057a723c5946bcfcb0613720cd4f32b3?s=96&d=mm&r=g","caption":"Kasra Khosravi"},"description":"Founder @ FeedbackOnSite.co"}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Theming Vue.js with styled-components Comments Feed" href="https://blog.logrocket.com/theming-vue-js-with-styled-components/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=9.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.7' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/51813" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-dtH' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>
function setlrAdwinExpiry(lrAdwin, value, ttl) {
				var now = new Date()

				// `item` is an object which contains the original value
				// as well as the time when it's supposed to expire
				const item = {
					value: 'isSet',
					expiry: now.getTime() + 4665600000,
				}
				localStorage.setItem(lrAdwin, JSON.stringify(item))
				setTimeout(function(){
					analytics.track("lrAdwin", {
  active: "true"
});
    }, 1000);
			}

			function getWithExpiry(lrAdwin) {
				const itemStr = localStorage.getItem(lrAdwin)

				// if the item doesn't exist, return null
				if (!itemStr) {
					return null
				}

				const item = JSON.parse(itemStr)
				const now = new Date()

				// compare the expiry time of the item with the current time
				if (now.getTime() > item.expiry) {
					// If the item is expired, delete the item from storage
					// and return null
					localStorage.removeItem(lrAdwin)
					if (analytics) {					analytics.track("lrAdwin", {
  active: "false"
});}
					return null
				}
				return item.value
			}

			if (!localStorage.getItem('_lr_id_')){
				setlrAdwinExpiry();
			}
			getWithExpiry();
</script>
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://a39e555ed62c408792586c55bbb2ce3b@e.logrocket.com/9').install()
    </script>
<script type="text/javascript">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</script>
<script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
<script>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</script><style type='text/css'>img#wpstats{display:none}</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=12b43dd855" />
<style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-51813 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="navarea">
<div class="nav-left">
<a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>
<nav class="menu-container">
<div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a><li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">PodRocket</a></ul></div></nav>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Start your self-service trial</a></li>
</ul></div> </div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Theming%20Vue.js%20with%20styled-components&amp;url=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components.png&amp;description=Theming%20Vue.js%20with%20styled-components">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F&amp;title=Theming%20Vue.js%20with%20styled-components">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-51813 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-css-in-js tag-vue" id="post-51813">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/kasrakhosravi/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/03/Khosravi-150x150.jpg" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/03/Khosravi-150x150.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/03/Khosravi-150x150.jpg' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/kasrakhosravi/">
Kasra Khosravi <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Founder @ FeedbackOnSite.co</span>
</div>
</div>
<h1 class="posttitle">Theming Vue.js with styled-components</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
May 28, 2021 </time></span>
<span class="dot"></span>
<span class="readingtime">5 min read</span>
<span class="wordcount">1451</span>
</p>
</div>
<img width="730" height="445" src="https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="Theming Vue.js With Styled-Components" loading="lazy" data-attachment-id="51860" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/theming-vue-js-styled-components/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components.png" data-orig-size="730,445" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Theming Vue.js Styled-Components" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components-300x183.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components-300x183.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/theming-vue-js-styled-components.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> <article class="article-post">
<p>As web development capabilities and tools evolve, web development framework styling has mirrored that evolution. Moving away from inline styles to CSS-in-JS solutions has made the development experience more consistent.</p>
<p>With the <a href="https://styled-components.com/">styled-components</a> library, developers can utilize CSS within JavaScript or JavaScript frameworks instead of creating traditional separate CSS files when styling. It has seen huge success in React, and now it is available for Vue projects.</p>
<p>In this post, we’ll see why utilizing styled-components is advantageous when styling in Vue.</p>
<h2>Advantages of styled-components in Vue.js</h2>
<h3>Build your own components</h3>
<p>Styled-components gives you the freedom to make your own custom styled components in <a href="https://blog.logrocket.com/new-features-in-vue-3-and-how-to-use-them-2/">Vue</a>. You can style the HTML tags and give them the name of your choice to make your code more readable.</p>
<h3>No classes policy</h3>
<p>With styled-components, everything is done with the help of props. You can dynamically change the style of your components without using classes. It gives you the power to use the ternary operators inside the string literals of the styled components.</p>
<h3>Concurrent design</h3>
<p>Styled-components makes the styling and design of your components concurrent and similar throughout the entire application without much effort. The <a href="https://dev.to/aromanarguello/how-to-use-themes-in-styled-components-49h">theming capabilities</a> provide a central place to define the basic design elements such as color, size, and spacing, and can be easily integrated into all of the components in the app.</p>
<h3>A huge community</h3>
<p>Seeing <a href="https://github.com/styled-components/styled-components/network/dependents?package_id=UGFja2FnZS01MDYyMTAyMzk%3D">tremendous growth</a>, the styled-components community provides help for any issue and has <a href="https://github.com/styled-components">a popular library for developers</a>.</p>
<p>Now that we’ve seen the benefits of the styled-components, it’s time to install the library in our Vue project and look at how we can use its different features.</p>
<h2>Installing styled-components in Vue.js</h2>
<p>Before installing the library, have a Vue project up and running on your local machine. With a project set up, install the library with the following command:</p>
<pre>npm i vue-styled-components
</pre>
<p>If you used Vue CLI to set up the project, the folder structure will look something like this:</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br />No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>
<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>
<p><img data-attachment-id="51876" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/vue-cli-project-folder-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1.png" data-orig-size="306,510" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Vue CLI project folder" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1-180x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1.png" loading="lazy" class="aligncenter size-full wp-image-51876 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1.png" alt="Vue CLI Project Folder" width="306" height="510" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1.png 306w, https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1-180x300.png 180w" data-lazy-sizes="(max-width: 306px) 100vw, 306px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51876" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/vue-cli-project-folder-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1.png" data-orig-size="306,510" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Vue CLI project folder" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1-180x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1.png" loading="lazy" class="aligncenter size-full wp-image-51876" src="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1.png" alt="Vue CLI Project Folder" width="306" height="510" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1.png 306w, https://blog.logrocket.com/wp-content/uploads/2021/05/vue-cli-project-folder-1-180x300.png 180w" sizes="(max-width: 306px) 100vw, 306px" /></noscript></p>
<p>With all the styles removed from our Vue app, <code>HelloWorld.vue</code> looks like the following:</p>
<pre>// HelloWorld.vue

&lt;template&gt;
  &lt;div class="hello"&gt;
    &lt;h1&gt;{{ msg }}&lt;/h1&gt;
  &lt;/div&gt;
&lt;/template&gt;

&lt;script&gt;
export default {
  name: 'HelloWorld',
  props: {
    msg: String
  }
}
&lt;/script&gt;
</pre>
<p>Let’s run the project to see the following output in the browser:</p>
<p><img data-attachment-id="51828" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/vue-app-output-browser/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser.png" data-orig-size="730,379" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Vue app output browser" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser-300x156.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser.png" loading="lazy" class="aligncenter wp-image-51828 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser.png" alt="Vue App Output In Browser" width="730" height="379" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser-300x156.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51828" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/vue-app-output-browser/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser.png" data-orig-size="730,379" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Vue app output browser" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser-300x156.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser.png" loading="lazy" class="aligncenter wp-image-51828 size-full" src="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser.png" alt="Vue App Output In Browser" width="730" height="379" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/vue-app-output-browser-300x156.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<p>As we can see, there is a simple <code>h1</code> header tag with no styles applied. We will style this <code>h1</code> with styled-components, and we must create a new folder in the <code>src</code> directory to store them. In that folder, create a <code>Header.js</code> file. The project structure will look as follows:</p>
<p><img data-attachment-id="51878" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/h1-styled-components-folder-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1.png" data-orig-size="292,564" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="H1 styled components folder" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1-155x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1.png" loading="lazy" class="aligncenter size-full wp-image-51878 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1.png" alt="H1 Styled-Components Folder" width="292" height="564" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1.png 292w, https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1-155x300.png 155w" data-lazy-sizes="(max-width: 292px) 100vw, 292px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51878" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/h1-styled-components-folder-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1.png" data-orig-size="292,564" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="H1 styled components folder" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1-155x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1.png" loading="lazy" class="aligncenter size-full wp-image-51878" src="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1.png" alt="H1 Styled-Components Folder" width="292" height="564" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1.png 292w, https://blog.logrocket.com/wp-content/uploads/2021/05/h1-styled-components-folder-1-155x300.png 155w" sizes="(max-width: 292px) 100vw, 292px" /></noscript></p>
<p>Then, add the following lines of code in <code>Header.js</code>:</p>
<pre>import styled from "vue-styled-components";

export const StyledHeader = styled.h1`
  font-size: 1.5em;
  text-align: center;
  color: red;
  background-color: grey;
`;
</pre>
<p>Finally, we can register <code>StyledHeader</code> in <code>HelloWorld.vue</code> and use it instead of <code>h1</code>:</p>
<pre>&lt;template&gt;
  &lt;div class="hello"&gt;
    &lt;StyledHeader&gt;{{ msg }}&lt;/StyledHeader&gt;
  &lt;/div&gt;
&lt;/template&gt;

&lt;script&gt;
import {StyledHeader} from "../styled-components/Header"
export default {
  name: 'HelloWorld',
  components:{
    StyledHeader
  },
  props: {
    msg: String
  }
}
&lt;/script&gt;
</pre>
<p>Now, let’s start the server and see how the plain and boring header tag changes:</p>
<p><img data-attachment-id="51832" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/header-tag-change/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change.png" data-orig-size="730,476" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Header tag change" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change-300x196.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change.png" loading="lazy" class="size-full wp-image-51832 aligncenter jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change.png" alt="The Header Tag Changes" width="730" height="476" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change-300x196.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51832" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/header-tag-change/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change.png" data-orig-size="730,476" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Header tag change" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change-300x196.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change.png" loading="lazy" class="size-full wp-image-51832 aligncenter" src="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change.png" alt="The Header Tag Changes" width="730" height="476" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/header-tag-change-300x196.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<p>As we can see, the required styles have been applied without using any CSS!</p>
<h2>Passing the props in styled-components</h2>
<p>Styled components, like any other components, have the ability to accept props. For example, we can create an input field and pass a prop to it. Here, we’ll create a new component named <code>Input.js</code> in the <code>components</code> folder and add the following code to it:</p>
<pre>import styled from "vue-styled-components";

export const StyledInput = styled.input`
  font-size: 1.25em;
  padding: 0.5em;
  margin: 0.5em;
  color: blueviolet;
  border: none;
  background-color: lavender;
  border-radius: 3px;

  &amp;:hover {
    box-shadow: inset 1px 1px 2px rgba(0, 0, 0, 0.1);
  }
`;
</pre>
<p>The next step is to use it in <code>HelloWorld.vue</code>:</p>
<pre>&lt;template&gt;
  &lt;div class="hello"&gt;
    &lt;StyledHeader&gt;{{ msg }}&lt;/StyledHeader&gt;
    &lt;StyledInput/&gt;  
  &lt;/div&gt;
&lt;/template&gt;

&lt;script&gt;
import {StyledInput} from "../styled-components/Input"
import {StyledHeader} from "../styled-components/Header"

export default {
  name: 'HelloWorld',
  components:{
    StyledInput,StyledHeader
  },
     props: {
    msg: String
  }

}
&lt;/script&gt;
</pre>
<p>Saving the changes will reflect them in the browser, confirming our input is rendered:</p>
<p><img data-attachment-id="51833" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/render-input-field-browser/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser.png" data-orig-size="730,294" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Render input field browser" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser-300x121.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser.png" loading="lazy" class="aligncenter wp-image-51833 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser.png" alt="Render The Input Field In The Browser" width="730" height="294" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser-300x121.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51833" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/render-input-field-browser/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser.png" data-orig-size="730,294" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Render input field browser" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser-300x121.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser.png" loading="lazy" class="aligncenter wp-image-51833 size-full" src="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser.png" alt="Render The Input Field In The Browser" width="730" height="294" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/render-input-field-browser-300x121.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<p>But this looks weird without a proper input. Let’s pass it as a prop to <code>StyledInput</code> along with the type:</p>
<pre>&lt;template&gt;
  &lt;div class="hello"&gt;
  &lt;StyledHeader&gt;{{ msg }}&lt;/StyledHeader&gt;
  &lt;StyledInput placeholder="Password" type="text"/&gt;  
  &lt;/div&gt;
&lt;/template&gt;

...
</pre>
<p>Running this gives us the following output:</p>
<p><img data-attachment-id="51834" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/styled-input-browser/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser.png" data-orig-size="730,328" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Styled input browser" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser-300x135.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser.png" loading="lazy" class="aligncenter size-full wp-image-51834 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser.png" alt="Styled Input Appears In Browser" width="730" height="328" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser-300x135.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51834" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/styled-input-browser/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser.png" data-orig-size="730,328" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Styled input browser" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser-300x135.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser.png" loading="lazy" class="aligncenter size-full wp-image-51834" src="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser.png" alt="Styled Input Appears In Browser" width="730" height="328" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/styled-input-browser-300x135.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<h2>Dynamic styling with props in Vue.js</h2>
<p>This is one of the strongest features of styled-components. It allows developers to set dynamic styles without using tons of classes.</p>
<p>Because styled-components can take props and apply style based on props, let’s give custom props to <code>StyledHeader</code>.</p>
<p>Let’s modify our <code>Header.js</code> file as follows:</p>
<pre>import styled from "vue-styled-components";
const hdrProps = { primary: Boolean };

export const StyledHeader = styled("h1", hdrProps)`
  font-size: 1.5em;
  text-align: start;
  color: ${(props) =&gt; (props.primary ? "white" : "red")};
  background-color: ${(props) =&gt; (props.primary ? "green" : "yellow")};
`;
</pre>
<p>Here, we have defined the props for our <code>StyledHeader</code>. The styled function takes the HTML element with the props as an argument, after which we can specify the behavior of our CSS based on the value of that prop.</p>
<p>Let’s run the project without giving any prop to our previously created header, and see the following output in the browser:</p>
<p>&nbsp;</p>
<p>This is working exactly as we have specified. Now, let&#8217;s provide a <code>primary</code> prop to our <code>StyledHeader</code>, and check whether the styles are applied correctly:</p>
<pre>&lt;template&gt;
  &lt;div class="hello"&gt;
  &lt;StyledHeader primary&gt;{{ msg }}&lt;/StyledHeader&gt;
  &lt;StyledInput placeholder="Password" type="text"/&gt;  
  &lt;/div&gt;
&lt;/template&gt;

&lt;script&gt;
import {StyledInput} from "../styled-components/Input"
import {StyledHeader} from "../styled-components/Header"

export default {
  name: 'HelloWorld',
  components:{
    StyledInput,StyledHeader
  },
     props: {
    msg: String
  }

}
&lt;/script&gt;
</pre>
<p>As we can see, the <code>StyledHeader</code> is accepting <code>primary</code> as a prop. After saving the changes, our project renders the following output:</p>
<p><img data-attachment-id="51844" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/styledheader-accepting-primary-output-browser/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser.png" data-orig-size="730,328" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="StyledHeader accepting primary output browser" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser-300x135.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser.png" loading="lazy" class="aligncenter size-full wp-image-51844 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser.png" alt="StyledHeader Accepting The Primary Output In The Browser" width="730" height="328" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser-300x135.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51844" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/styledheader-accepting-primary-output-browser/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser.png" data-orig-size="730,328" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="StyledHeader accepting primary output browser" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser-300x135.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser.png" loading="lazy" class="aligncenter size-full wp-image-51844" src="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser.png" alt="StyledHeader Accepting The Primary Output In The Browser" width="730" height="328" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/styledheader-accepting-primary-output-browser-300x135.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<p>With this, we have successfully changed the style based on our props, giving us the basic concept behind the approach. Styles with props can be changed with button events, form submissions, and more. We can now leverage the full power of dynamic styling with styled-components.</p>
<h2>Applying the same style to multiple components</h2>
<p>Styled-components also provides the ability to make components follow the same style. This creates a consistent style for applications and removes a lot of repetitious code.</p>
<p>By simply adding the following line of code in <code>Header.js</code>, we can apply the following to use the same styles for <code>h2</code>:</p>
<pre>export const StyledHeader2
= StyledHeader.withComponent("h2");
</pre>
<p>After using this component in the <code>HelloWorld.vue</code> file, we will get the following output:</p>
<p><img data-attachment-id="51838" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/applying-same-styles-h2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2.png" data-orig-size="730,276" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Applying same styles h2" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2-300x113.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2.png" loading="lazy" class="aligncenter size-full wp-image-51838 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2.png" alt="Applying The Same Styles To H2" width="730" height="276" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2-300x113.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51838" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/applying-same-styles-h2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2.png" data-orig-size="730,276" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Applying same styles h2" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2-300x113.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2.png" loading="lazy" class="aligncenter size-full wp-image-51838" src="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2.png" alt="Applying The Same Styles To H2" width="730" height="276" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/applying-same-styles-h2-300x113.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<h2>Dynamically changing the type of rendered component</h2>
<p>Sometimes, components must change based on a specific scenario but retain the same styles. For this instance, styled-components can use a prop to change the component being rendered.</p>
<p>If we apply the <code>as</code> prop to change the <code>StyledHeader</code>, we can change it to a button:</p>
<pre>&lt;template&gt;
  &lt;div class="hello"&gt;
  &lt;StyledHeader as=button&gt;{{ msg }}&lt;/StyledHeader&gt;
  &lt;StyledInput placeholder="Password" type="text"/&gt;  
  &lt;/div&gt;
&lt;/template&gt;
</pre>
<p>The browser then gives us the following output:</p>
<p><img data-attachment-id="51846" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/change-styledheader-button/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button.png" data-orig-size="730,243" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Change StyledHeader Button" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button-300x100.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button.png" loading="lazy" class="aligncenter size-full wp-image-51846 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button.png" alt="Change The StyledHeader Button" width="730" height="243" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button-300x100.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51846" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/change-styledheader-button/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button.png" data-orig-size="730,243" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Change StyledHeader Button" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button-300x100.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button.png" loading="lazy" class="aligncenter size-full wp-image-51846" src="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button.png" alt="Change The StyledHeader Button" width="730" height="243" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/change-styledheader-button-300x100.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<p>Inspecting the <code>role</code>, we can clearly see that it is a button:</p>
<p><img data-attachment-id="51840" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/role-button/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button.png" data-orig-size="730,813" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Role button" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button-269x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button.png" loading="lazy" class="aligncenter size-full wp-image-51840 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button.png" alt="The Role is a Button" width="730" height="813" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/role-button-269x300.png 269w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51840" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/role-button/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button.png" data-orig-size="730,813" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Role button" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button-269x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button.png" loading="lazy" class="aligncenter size-full wp-image-51840" src="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button.png" alt="The Role is a Button" width="730" height="813" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/role-button.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/role-button-269x300.png 269w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<h2>Extending styles</h2>
<p>If changes must be made to the component styling without rewriting it, we can override or add new styles to it.</p>
<p>By creating a new component named <code>NewHeader.js</code>, we can override the <code>color</code> attribute from the previously created <code>Header.js</code>.</p>
<p>Then, let’s add the following code in the <code>NewHeader.js</code>:</p>
<pre>import { StyledHeader } from "./Header";
export const NewHeader = StyledHeader.extend`
  color: purple;
  border-color: purple;
`;
</pre>
<p>Let us now render and use it in our <code>HelloWorld.vue</code> file:</p>
<pre>&lt;template&gt;
  &lt;div class="hello"&gt;
  &lt;StyledHeader &gt;{{ msg }}&lt;/StyledHeader&gt;
  &lt;NewHeader &gt;{{ msg }}&lt;/NewHeader&gt;
  &lt;StyledInput placeholder="Password" type="text"/&gt;  
  &lt;/div&gt;
&lt;/template&gt;

&lt;script&gt;
import {StyledInput} from "../styled-components/Input"
import {NewHeader} from "../styled-components/NewHeader"

import {StyledHeader} from "../styled-components/Header"

export default {
  name: 'HelloWorld',
  components:{
    StyledInput,StyledHeader,NewHeader
  },
     props: {
    msg: String
  }

}
&lt;/script&gt;
</pre>
<p>After saving the changes, we get the following output:</p>
<p><img data-attachment-id="51842" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/override-color-attribute/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute.png" data-orig-size="730,417" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Override color attribute" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute-300x171.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute.png" loading="lazy" class="aligncenter size-full wp-image-51842 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute.png" alt="Override The Color Attribute" width="730" height="417" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute-300x171.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="51842" data-permalink="https://blog.logrocket.com/theming-vue-js-with-styled-components/override-color-attribute/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute.png" data-orig-size="730,417" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Override color attribute" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute-300x171.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute.png" loading="lazy" class="aligncenter size-full wp-image-51842" src="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute.png" alt="Override The Color Attribute" width="730" height="417" srcset="https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/05/override-color-attribute-300x171.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<p>As we can see, we have overridden the color of <code>Header.js</code> and used its styling in our newly created <code>NewHeader.js</code>.</p>
<h2>Conclusion</h2>
<p>Styled-components is a powerful library that solves most of the pain points we would find using plain CSS. While the learning curve can be steep initially, the benefits are worth it.</p><div class='code-block code-block-8' style='margin: 8px 0; clear: both;'>
<div class="blog-plug inline-plug vue-inline"><h2>Experience your Vue apps exactly how a user does</h2> Debugging Vue.js applications can be difficult, especially when there are dozens, if not hundreds of mutations during a user session. If you’re interested in monitoring and tracking Vue mutations for all of your users in production, <a href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank">try LogRocket</a>. <a class="signup" href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://files.readme.io/00591d0-687474703a2f2f692e696d6775722e636f6d2f6a3049327856572e706e67.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-lazy-src="https://files.readme.io/00591d0-687474703a2f2f692e696d6775722e636f6d2f6a3049327856572e706e67.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://files.readme.io/00591d0-687474703a2f2f692e696d6775722e636f6d2f6a3049327856572e706e67.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" /></noscript></a><a href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank" rel="noopener noreferrer">https://logrocket.com/signup/</a><p style="margin-top: 15px;"><a href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web apps, recording literally everything that happens in your Vue apps including network requests, JavaScript errors, performance problems, and much more. Instead of guessing why problems happen, you can aggregate and report on what state your application was in when an issue occurred. </p><p>The LogRocket Vuex plugin logs Vuex mutations to the LogRocket console, giving you context around what led to an error, and what state the application was in when an issue occurred.</p><p>Modernize how you debug your Vue apps - <a class="signup" href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank" rel="noopener noreferrer">Start monitoring for free</a>.</p></div>
<style>
.plug-poll {margin-bottom: 2rem;}
.code-block-8 .fadeIn {
    opacity:1 !important;
    height:auto !important;
}

.code-block-8 .fadeOut {
    opacity:0 !important;
}

.code-block-8 .wpcf7-email {margin: 15px 0;}

#plug-survey-errors, #plug-survey-help, #plug-survey-email  {opacity:0; height:1px; transition: all 1s;overflow:hidden; width: 100%;}

</style>
<script>
  jQuery("#plug-survey-framework input").click(function() {
  analytics.track('footer-poll', {
      'footer-poll-framework': jQuery(this).val()
    });
    jQuery('#plug-survey-framework').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-errors').delay(800).addClass('fadeIn');
  });
    jQuery("#plug-survey-errors input").click(function() {
    jQuery('#plug-survey-errors').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-help').delay(800).addClass('fadeIn');
  });
  
      jQuery("#plug-survey-help input").click(function() {
        analytics.track('footer-poll', {
      'footer-poll-help': jQuery(this).val()
    });
    jQuery('#plug-survey-help').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-email').delay(800).addClass('fadeIn');
  });
  
  </script>
</div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-51813" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/theming-vue-js-with-styled-components/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/theming-vue-js-with-styled-components/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-51813" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/theming-vue-js-with-styled-components/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-51813" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/theming-vue-js-with-styled-components/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/03/Khosravi-150x150.jpg" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/03/Khosravi-150x150.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/03/Khosravi-150x150.jpg' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/kasrakhosravi/">
Kasra Khosravi <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Founder @ FeedbackOnSite.co</span>
</div>
</div>
<div class="after-post-tags">
<ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/css-in-js/">#css-in-js</a></li> <li><a href="https://blog.logrocket.com/tag/vue/">#vue</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/swift-enums-an-overview-with-examples/" rel="prev">Swift enums: An overview with examples</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"></div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/swift-enums-an-overview-with-examples/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/05/swift-enums-overview-examples.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/swift-enums-an-overview-with-examples/">Swift enums: An overview with examples</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/ejiroasiuwhu/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/12/ejiro.jpeg" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/12/ejiro.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/12/ejiro.jpeg' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/ejiroasiuwhu/">Ejiro Asiuwhu</a></span><br>
<span class="post-date">May 28, 2021</span>
<span class="dot"></span>
<span class="readingtime">5 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/swift-enums-an-overview-with-examples/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/using-mobx-for-large-scale-enterprise-state-management/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/05/MobX-enterprise-state-management.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/using-mobx-for-large-scale-enterprise-state-management/">Using MobX for large-scale enterprise state management</a>
</h2>
 <div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/varun-pujari/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/05/Varun-Pujari-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/05/Varun-Pujari-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/05/Varun-Pujari-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/varun-pujari/">Varun Pujari</a></span><br>
<span class="post-date">May 28, 2021</span>
<span class="dot"></span>
<span class="readingtime">13 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/using-mobx-for-large-scale-enterprise-state-management/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/the-best-ui-frameworks-for-vue-3/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/05/Best-UI-Frameworks-Vue-3.jpg);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/the-best-ui-frameworks-for-vue-3/">The best UI frameworks for Vue 3</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/dylan-tientcheu/">
<img alt src="https://secure.gravatar.com/avatar/233e3732883e9b44839aa665c26efb3c?s=40&#038;d=mm&#038;r=g" class="avatar avatar-40 photo author-thumb jetpack-lazy-image" height="40" width="40" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/233e3732883e9b44839aa665c26efb3c?s=80&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/233e3732883e9b44839aa665c26efb3c?s=40&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/233e3732883e9b44839aa665c26efb3c?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/233e3732883e9b44839aa665c26efb3c?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo author-thumb' height='40' width='40' loading='lazy'/></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/dylan-tientcheu/">Dylan Tientcheu</a></span><br>
<span class="post-date">May 28, 2021</span>
<span class="dot"></span>
<span class="readingtime">4 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/the-best-ui-frameworks-for-vue-3/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/theming-vue-js-with-styled-components/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=51813&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.7&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=0695f995c3cd6e503e6284a528d4940eeab5fb58#parent=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="pull-left"> Does something seem off? Email <a><span class="__cf_email__" data-cfemail="fc8f898c8c938e88bc90939b8e939f979988d29f9391">[email&#160;protected]</span></a> </div>
<div class="pull-right"> <div class="footerRight"> <div id="jetpack-search-filters-2-wrapper">
<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div> </div>
<div class="clearfix"></div>
<a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202121'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text(),
	postAuthor: jQuery("meta[name='twitter:data1']").attr("content"),
	id: jQuery(".mainheading").closest(".col-md-8").attr("id").replace('post-','')
  });
}
};</script> <div style="display:none">
<div class="grofile-hash-map-057a723c5946bcfcb0613720cd4f32b3">
</div>
<div class="grofile-hash-map-f1a4b1000507a0e5f1133a43200f107e">
</div>
<div class="grofile-hash-map-649d16da63f8e5a1e64ad4ed9201f5d8">
</div>
<div class="grofile-hash-map-233e3732883e9b44839aa665c26efb3c">
</div>
</div>
<div class="jp-carousel-wrap jp-carousel-transitions" itemscope itemtype="https://schema.org/ImageGallery" style="display: none;">
<div class="jp-carousel-overlay"></div>
<div class="jp-carousel"></div>
<div class="jp-carousel-fadeaway"></div>
<div class="jp-carousel-info">
<div class="jp-carousel-photo-info">
<h2 class="jp-carousel-caption" itemprop="caption description"></h2>
</div>
<div class="jp-carousel-info-columns">
<div class="jp-carousel-left-column-wrapper">
<div class="jp-carousel-titleanddesc"></div>

<div class="jp-carousel-photo-info">
<h2 class="jp-carousel-caption" itemprop="caption description"></h2>
</div>
<div id="jp-carousel-comment-form-container">
<form id="jp-carousel-comment-form">
<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
<textarea name="comment" class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea" id="jp-carousel-comment-form-comment-field" placeholder="Write a Comment..."></textarea>
<div id="jp-carousel-comment-form-submit-and-info-wrapper">
<div id="jp-carousel-comment-form-commenting-as">
<fieldset>
<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-url-field">Website</label>
<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
</fieldset>
</div>
<input type="submit" name="submit" class="jp-carousel-comment-form-button" id="jp-carousel-comment-form-button-submit" value="Post Comment" />
<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
<div id="jp-carousel-comment-post-results"></div>
</div>
</form>
</div>
<div class="jp-carousel-comments"></div>
<div id="jp-carousel-comments-loading">
<span>Loading Comments...</span>
</div>
</div>
<div class="jp-carousel-image-meta">
<div class="jp-carousel-buttons">
<a class="jp-carousel-commentlink" href="#">Comment</a>
</div>
 <ul class="jp-carousel-image-exif" style="display: none;"></ul>
<a class="jp-carousel-image-download" style="display: none;"></a>
<div class="jp-carousel-image-map" style="display: none;"></div>
</div>
</div>
</div>
<div class="jp-carousel-next-button" style="display: none;">
<span></span>
</div>
<div class="jp-carousel-previous-button" style="display: none;">
<span></span>
</div>
<div class="jp-carousel-close-hint"><span>&times;</span></div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/theming-vue-js-with-styled-components\/":51813};
	</script>
<link rel='stylesheet' id='dashicons-css' href='https://blog.logrocket.com/wp-includes/css/dashicons.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='nf-display-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/display-opinions-light.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='nf-font-awesome-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/font-awesome.min.css?ver=5.7.2' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/modules/widgets/search/js/search-widget.js?ver=9.7' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"bfb187e108","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=9.7' id='jetpack-carousel-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/backbone.min.js?ver=1.4.0' id='backbone-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end-deps.js?ver=3.5.4' id='nf-front-end-deps-js'></script>
<script type='text/javascript' id='nf-front-end-js-extra'>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</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end.js?ver=3.5.4' id='nf-front-end-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.7' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=51813&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.7&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0695f995c3cd6e503e6284a528d4940eeab5fb58#parent=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=51813&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.7&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0695f995c3cd6e503e6284a528d4940eeab5fb58#parent=https%3A%2F%2Fblog.logrocket.com%2Ftheming-vue-js-with-styled-components%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202121.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.7',blog:'161333275',post:'51813',tz:'-4',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '51813' ]);
</script>
<script id="tmpl-nf-layout" type="text/template">
	<span id="nf-form-title-{{{ data.id }}}" class="nf-form-title">
		{{{ ( 1 == data.settings.show_title ) ? '<h3>' + data.settings.title + '</h3>' : '' }}}
	</span>
	<div class="nf-form-wrap ninja-forms-form-wrap">
		<div class="nf-response-msg"></div>
		<div class="nf-debug-msg"></div>
		<div class="nf-before-form"></div>
		<div class="nf-form-layout"></div>
		<div class="nf-after-form"></div>
	</div>
</script>
<script id="tmpl-nf-empty" type="text/template">

</script>
<script id="tmpl-nf-before-form" type="text/template">
	{{{ data.beforeForm }}}
</script><script id="tmpl-nf-after-form" type="text/template">
	{{{ data.afterForm }}}
</script><script id="tmpl-nf-before-fields" type="text/template">
    <div class="nf-form-fields-required">{{{ data.renderFieldsMarkedRequired() }}}</div>
    {{{ data.beforeFields }}}
</script><script id="tmpl-nf-after-fields" type="text/template">
    {{{ data.afterFields }}}
    <div id="nf-form-errors-{{{ data.id }}}" class="nf-form-errors" role="alert"></div>
    <div class="nf-form-hp"></div>
</script>
<script id="tmpl-nf-before-field" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-after-field" type="text/template">
    {{{ data.afterField }}}
</script><script id="tmpl-nf-form-layout" type="text/template">
	<form>
		<div>
			<div class="nf-before-form-content"></div>
			<div class="nf-form-content {{{ data.element_class }}}"></div>
			<div class="nf-after-form-content"></div>
		</div>
	</form>
</script><script id="tmpl-nf-form-hp" type="text/template">
	<label for="nf-field-hp-{{{ data.id }}}" aria-hidden="true">
		{{{ nfi18n.formHoneypot }}}
		<input id="nf-field-hp-{{{ data.id }}}" name="nf-field-hp" class="nf-element nf-field-hp" type="text" value=""/>
	</label>
</script>
<script id="tmpl-nf-field-layout" type="text/template">
    <div id="nf-field-{{{ data.id }}}-container" class="nf-field-container {{{ data.type }}}-container {{{ data.renderContainerClass() }}}">
        <div class="nf-before-field"></div>
        <div class="nf-field"></div>
        <div class="nf-after-field"></div>
    </div>
</script>
<script id="tmpl-nf-field-before" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-field-after" type="text/template">
    <#
    /*
     * Render our input limit section if that setting exists.
     */
    #>
    <div class="nf-input-limit"></div>
    <#
    /*
     * Render our error section if we have an error.
     */
    #>
    <div id="nf-error-{{{ data.id }}}" class="nf-error-wrap nf-error" role="alert"></div>
    <#
    /*
     * Render any custom HTML after our field.
     */
    #>
    {{{ data.afterField }}}
</script>
<script id="tmpl-nf-field-wrap" type="text/template">
	<div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
		<#
		/*
		 * This is our main field template. It's called for every field type.
		 * Note that must have ONE top-level, wrapping element. i.e. a div/span/etc that wraps all of the template.
		 */
        #>
		<#
		/*
		 * Render our label.
		 */
        #>
		{{{ data.renderLabel() }}}
		<#
		/*
		 * Render our field element. Uses the template for the field being rendered.
		 */
        #>
		<div class="nf-field-element">{{{ data.renderElement() }}}</div>
		<#
		/*
		 * Render our Description Text.
		 */
        #>
		{{{ data.renderDescText() }}}
	</div>
</script>
<script id="tmpl-nf-field-wrap-no-label" type="text/template">
    <div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
        <div class="nf-field-label"></div>
        <div class="nf-field-element">{{{ data.renderElement() }}}</div>
        <div class="nf-error-wrap"></div>
    </div>
</script>
<script id="tmpl-nf-field-wrap-no-container" type="text/template">

        {{{ data.renderElement() }}}

        <div class="nf-error-wrap"></div>
</script>
<script id="tmpl-nf-field-label" type="text/template">
	<div class="nf-field-label"><label for="nf-field-{{{ data.id }}}"
	                                   id="nf-label-field-{{{ data.id }}}"
	                                   class="{{{ data.renderLabelClasses() }}}">{{{ data.label }}} {{{ ( 'undefined' != typeof data.required && 1 == data.required ) ? '<span class="ninja-forms-req-symbol">*</span>' : '' }}} {{{ data.maybeRenderHelp() }}}</label></div>
</script>
<script id="tmpl-nf-field-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-form-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-field-input-limit" type="text/template">
    {{{ data.currentCount() }}} {{{ nfi18n.of }}} {{{ data.input_limit }}} {{{ data.input_limit_msg }}}
</script><script id="tmpl-nf-field-null" type="text/template">
</script><script id="tmpl-nf-field-listcheckbox" type="text/template">
    <ul aria-describedby="nf-error-{{{ data.id }}}">
        {{{ data.renderOptions() }}}
    </ul>
</script>
<script id='tmpl-nf-field-listcheckbox-option' type='text/template'>
    <# if ( ! data.visible ) { return '' } #>
    <li>
        <input type="checkbox" id="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}" name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element {{{ ( data.isSelected ) ? ' nf-checked' : '' }}}" value="{{{ data.value }}}" {{{ ( data.isSelected ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
            <# if( data.required ) { #>
			required
			<# } #>
        >
        <label for="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               id="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               class="{{{ ( data.isSelected ) ? 'nf-checked-label' : '' }}}">{{{ data.label }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other' type='text/template'>
    <li {{{ ( ! data.visible ) ? 'style="display:none"' : '' }}}>
        <input type="checkbox"
               id="nf-field-{{{ data.fieldID }}}-other"
               name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element" value="nf-other" {{{ ( ! data.valueFound ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-other"
            <# if( data.required ) { #>
			required
			<# } #>
        >
         <label id="nf-label-field-{{{ data.fieldID }}}-other">Other
            {{{ data.renderOtherText() }}}
        </label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other-text' type='text/template'>
    <input type="text" name="nf-field-{{{ data.fieldID }}}" class="nf-element" value="{{{ data.currentValue }}}">
</script>
<script id='tmpl-nf-field-input' type='text/template'>
    <input id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" aria-invalid="false" aria-describedby="nf-error-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element" type="text" value="{{{ data.value }}}" {{{ data.renderPlaceholder() }}} {{{ data.maybeDisabled() }}}
           aria-labelledby="nf-label-field-{{{ data.id }}}"

            {{{ data.maybeRequired() }}}
    >
</script>
<script id="tmpl-nf-field-email" type="text/template">
	<input
			type="email"
			value="{{{ data.value }}}"
			class="{{{ data.renderClasses() }}} nf-element"

			id="nf-field-{{{ data.id }}}"
			<# if( ! data.disable_browser_autocompletes ){ #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id + '-' + data.type }}"
			autocomplete="email"
			<# } else { #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id }}"
			{{{ data.maybeDisableAutocomplete() }}}
			<# } #>
			{{{ data.renderPlaceholder() }}}
			{{{ data.maybeDisabled() }}}

			aria-invalid="false"
			aria-describedby="nf-error-{{{ data.id }}}"
			aria-labelledby="nf-label-field-{{{ data.id }}}"

			{{{ data.maybeRequired() }}}
	>
</script>
<script id="tmpl-nf-field-submit" type="text/template">
	<input id="nf-field-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element " type="button" value="{{{ data.label }}}" {{{ ( data.disabled ) ? 'disabled' : '' }}}>
</script><script id='tmpl-nf-field-button' type='text/template'>
    <button id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" class="{{{ data.classes }}} nf-element">
        {{{ data.label }}}
    </button>
</script><script>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</script>
</body>
</html>

