<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='max-image-preview:large, index, follow, max-snippet:-1, max-video-preview:-1' />


<title>Scalable state management with Vuex and Nuxt.js - LogRocket Blog</title>
<meta name="description" content="This short overview covers the various ways you can structure different-sized applications using Vuex and Nuxt.js." />
<link rel="canonical" href="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Scalable state management with Vuex and Nuxt.js - LogRocket Blog" />
<meta property="og:description" content="This short overview covers the various ways you can structure different-sized applications using Vuex and Nuxt.js." />
<meta property="og:url" content="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2021-03-10T17:00:25+00:00" />
<meta property="article:modified_time" content="2021-03-08T22:31:36+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="487" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Emmanuel Akhigbe">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="9 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/#primaryimage","inLanguage":"en-US","url":"https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex.png","width":730,"height":487,"caption":"The Nuxt.js and Vuex Logos"},{"@type":"WebPage","@id":"https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/#webpage","url":"https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/","name":"Scalable state management with Vuex and Nuxt.js - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/#primaryimage"},"datePublished":"2021-03-10T17:00:25+00:00","dateModified":"2021-03-08T22:31:36+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/a768920822afa0ee63d8a6b57d10744e"},"description":"This short overview covers the various ways you can structure different-sized applications using Vuex and Nuxt.js.","breadcrumb":{"@id":"https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/"]}]},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://blog.logrocket.com/","url":"https://blog.logrocket.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/","url":"https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/","name":"Scalable state management with Vuex and Nuxt.js"}}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/a768920822afa0ee63d8a6b57d10744e","name":"Emmanuel Akhigbe","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/95d7097a88019e1b709d767f472b3c1a?s=96&d=mm&r=g","caption":"Emmanuel Akhigbe"}}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Scalable state management with Vuex and Nuxt.js Comments Feed" href="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=9.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.5.1' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/36999" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-9CL' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<script src="//geoip-js.com/js/apis/geoip2/v2.1/geoip2.js" type="text/javascript"></script>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://98e0ea7c6f2e492d94439ad5aaea48dd@e.logrocket.com/4').install()
    </script>
<script type="text/javascript">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</script>
<script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
<script>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</script><style type='text/css'>img#wpstats{display:none}</style> <style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=de679bb724" />
<style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-36999 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="navarea">
<div class="nav-left">
<a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>
<nav class="menu-container">
<div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a><li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">PodRocket</a></ul></div></nav>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Free Trial</a></li>
</ul></div> </div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Scalable%20state%20management%20with%20Vuex%20and%20Nuxt.js&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex.png&amp;description=Scalable%20state%20management%20with%20Vuex%20and%20Nuxt.js">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F&amp;title=Scalable%20state%20management%20with%20Vuex%20and%20Nuxt.js">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-36999 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-nuxtjs tag-vue" id="post-36999">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/emmanuelakhigbe/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/01/emmanuel.jpeg" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/01/emmanuel.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/01/emmanuel.jpeg' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/emmanuelakhigbe/">
Emmanuel Akhigbe <span class="btn follow">Follow</span></a>
<span class="author-description d-block"></span>
</div>
</div>
<h1 class="posttitle">Scalable state management with Vuex and Nuxt.js</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
March 10, 2021 </time></span>
<span class="dot"></span>
<span class="readingtime">6 min read</span>
<span class="wordcount">1701</span>
 </p>
</div>
<img width="730" height="487" src="https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="The Nuxt.js and Vuex Logos" loading="lazy" data-attachment-id="37004" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/nuxtvuex/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex.png" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The Nuxt.js and Vuex logos" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex-300x200.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex-300x200.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/nuxtvuex.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> <article class="article-post">
<p>Application state management is a key factor in structuring applications for better scalability and maintainability. In this article, we will learn different ways to structure different sized applications using Vuex and Nuxt.js.</p>
<h2>Introduction to Nuxt</h2>
<p><a href="https://nuxtjs.org/" target="_blank" rel="noopener">Nuxt</a> is a high-level framework built on top of Vue to help you build production-ready Vue applications.</p>
<p>Nuxt.js can help improve development work in <a href="https://vuejs.org/" target="_blank" rel="noopener">Vue</a> in several ways. First, right out of the box, Nuxt.js gives you a great structure for your code, which is also flexible and configurable in the <code>next.config.js</code> file. Nuxt.js optimizes your code and facilitates proper indexing of your application by search engines.</p>
<p>Nuxt.js also comes packed with awesome packages like <a href="https://router.vuejs.org/" target="_blank" rel="noopener">Vue-router</a>, <a href="https://vuex.vuejs.org/guide/" target="_blank" rel="noopener">Vuex</a>, <a href="https://webpack.js.org/" target="_blank" rel="noopener">Webpack</a>, <a href="https://babeljs.io/" target="_blank" rel="noopener">Babel</a>, and <a href="https://postcss.org/" target="_blank" rel="noopener">PostCSS</a>, as well as cool features like auto importing components and seamlessly setting up routing by just creating names of files in the pages directory.</p>
<p>Nuxt.js also provides server-side rendering (SSR) capabilities which enable faster <a href="https://scotch.io/courses/10-web-performance-audit-tips-for-your-next-billion-users-in-2018/fmp-first-meaningful-paint" target="_blank" rel="noopener">first meaningful paint</a>.</p>
<h2>Introduction to Vuex</h2>
<figure id="attachment_37010" aria-describedby="caption-attachment-37010" style="width: 701px" class="wp-caption aligncenter"><img data-attachment-id="37010" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/state-management-diagram/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram.png" data-orig-size="701,551" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="State management diagram" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram-300x236.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram.png" loading="lazy" class="size-full wp-image-37010 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram.png" alt="State Management Diagram" width="701" height="551" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram.png 701w, https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram-300x236.png 300w" data-lazy-sizes="(max-width: 701px) 100vw, 701px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="37010" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/state-management-diagram/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram.png" data-orig-size="701,551" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="State management diagram" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram-300x236.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram.png" loading="lazy" class="size-full wp-image-37010" src="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram.png" alt="State Management Diagram" width="701" height="551" srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram.png 701w, https://blog.logrocket.com/wp-content/uploads/2021/03/state-management-diagram-300x236.png 300w" sizes="(max-width: 701px) 100vw, 701px" /></noscript><figcaption id="caption-attachment-37010" class="wp-caption-text">Image from <a href="https://vuex.vuejs.org/#what-is-a-state-management-pattern" target="_blank" rel="noopener">https://vuex.vuejs.org/#what-is-a-state-management-pattern</a></figcaption></figure>
<p>According to its <a href="https://vuex.vuejs.org/" target="_blank" rel="noopener">documentation</a>, Vuex is Vue’s state management pattern and library. So, what does that mean? Simply put, Vuex is a library for managing the data that your components depend on.</p>
<p>Vuex was designed based on <a href="https://vuex.vuejs.org/" target="_blank" rel="noopener">Flux</a> (developed by Facebook for managing state) and provides a store that serves as the single source of truth for your Vue application as well as mutations and actions for predictable manipulation of the data in the store.</p>
<p>Before we continue, here are a few important Vuex terminologies to keep in mind:</p>
<ul>
<li><strong><a href="https://vuex.vuejs.org/guide/state.html#single-state-tree" target="_blank" rel="noopener">Store </a></strong>&#8212; A Vuex store contains the application&#8217;s state, mutations, and actions. Stores are reactive, if a component is using the store’s state and there is a change in the state, the component will be rerendered optimally to reflect the change</li>
<li><strong><a href="https://vuex.vuejs.org/guide/state.html#single-state-tree" target="_blank" rel="noopener">State </a></strong>&#8212; A state is a simple object that contains an application-level state. Vue provides an in-component state through the <code>data</code> hook, but if you want the data to be accessible by any component, it is recommended that you store it in the state</li>
<li><strong><a href="https://vuex.vuejs.org/guide/getters.html" target="_blank" rel="noopener">Getters</a></strong> &#8212; These enable computation to be done with data from the store’s state. Alternatively, you can retrieve the state from the store, and perform the computation as needed by a component, but this can become tedious and repetitive if you have several components that need the same computation. With a getter handling the computation, you can just retrieve the computed value</li>
<li><strong><a href="https://vuex.vuejs.org/guide/mutations.html#commit-with-payload" target="_blank" rel="noopener">Mutations</a></strong> &#8212; The store’s state is immutable and can only be mutated through mutations. Mutations are linked with actions. Imagine Vuex’s mutation as just a block of code. This code won’t run unless it is executed</li>
<li><strong><a href="https://vuex.vuejs.org/guide/actions.html" target="_blank" rel="noopener">Action</a></strong> &#8212; An action performs mutations. An action is a command that executes the “block of code” I mentioned in the definition of mutations above. Without this command, the block of code won’t be executed</li>
</ul>
<h2>Why we need state management</h2>
<p>State management in an application with many components can be a real pain. The more components you have, the more you’ll need to pass the data up the component tree with the use of events (until you reach a parent component), and then down to the component that needs the data with the use of props.</p>
<p>With fewer components, this relatively is simple:</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br />No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>
<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>
<p><img data-attachment-id="37011" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/simple-component-structure/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simple-component-structure.png" data-orig-size="141,103" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Simple component structure" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simple-component-structure.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simple-component-structure.png" loading="lazy" class="aligncenter size-full wp-image-37011 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/03/simple-component-structure.png" alt="Simple Component Structure" width="141" height="103" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/simple-component-structure.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="37011" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/simple-component-structure/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simple-component-structure.png" data-orig-size="141,103" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Simple component structure" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simple-component-structure.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simple-component-structure.png" loading="lazy" class="aligncenter size-full wp-image-37011" src="https://blog.logrocket.com/wp-content/uploads/2021/03/simple-component-structure.png" alt="Simple Component Structure" width="141" height="103" /></noscript></p>
<p>With more, however, things become complicated, like in this example component structure:</p>
<p><img data-attachment-id="37013" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/complex-component-structure/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure.png" data-orig-size="325,222" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Complex component structure" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure.png" loading="lazy" class="aligncenter size-full wp-image-37013 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure.png" alt="Complex Component Structure" width="325" height="222" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure.png 325w, https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure-300x205.png 300w" data-lazy-sizes="(max-width: 325px) 100vw, 325px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="37013" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/complex-component-structure/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure.png" data-orig-size="325,222" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Complex component structure" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure-300x205.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure.png" loading="lazy" class="aligncenter size-full wp-image-37013" src="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure.png" alt="Complex Component Structure" width="325" height="222" srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure.png 325w, https://blog.logrocket.com/wp-content/uploads/2021/03/complex-component-structure-300x205.png 300w" sizes="(max-width: 325px) 100vw, 325px" /></noscript></p>
<p>If component A has the data needed by component G, then you’ll need to move the data through B and E, if component G has data needed by component C, you’ll need to move the data through E, B, and A by emitting events, and then to C through props. As you can imagine, this can become a huge mess as the number of components and nesting grows.</p>
<p>If you can easily move data between components, then <a href="https://blog.logrocket.com/do-you-really-need-vuex/" target="_blank" rel="noopener">you probably don’t need a state management tool like Vuex</a>. But, as Dan Abramov, the author of Redux <a href="https://twitter.com/dan_abramov/status/704304462739939328?lang=en" target="_blank" rel="noopener">said</a>, “Flux libraries are like glasses: you’ll know when you need them.” I’d say the same for any state management library.</p>
<p>With Vuex, you can access application-level data and functions from all the components, easily and predictably. You can begin to see what I mean in the diagram below.</p>
<p><img data-attachment-id="37014" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/simplified-vuex-component-structure/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure.png" data-orig-size="385,315" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Simplified Vuex component structure" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure-300x245.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure.png" loading="lazy" class="aligncenter size-full wp-image-37014 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure.png" alt="Simplified Vuex Component Structure" width="385" height="315" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure.png 385w, https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure-300x245.png 300w" data-lazy-sizes="(max-width: 385px) 100vw, 385px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="37014" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/simplified-vuex-component-structure/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure.png" data-orig-size="385,315" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Simplified Vuex component structure" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure-300x245.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure.png" loading="lazy" class="aligncenter size-full wp-image-37014" src="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure.png" alt="Simplified Vuex Component Structure" width="385" height="315" srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure.png 385w, https://blog.logrocket.com/wp-content/uploads/2021/03/simplified-vuex-component-structure-300x245.png 300w" sizes="(max-width: 385px) 100vw, 385px" /></noscript></p>
<h2>State management in a Nuxt application</h2>
<p>Vuex automatically enables a Vuex store instance when it notices a file that isn’t hidden in the store directory (located in the root directory of the project). Nuxt automatically converts every file (except actions, mutations, and state files) in the store directory to a namespaced module, this means that the actions or mutations of these modules can have the same names and be run independently. Nuxt then scopes the action or mutation to that module.</p>
<p>Nuxt stores can be created in two modes, classic mode, and modules mode.</p>
<p>Classic mode is set to be deprecated in Vuex 3. In this mode, <code>store/index.js</code> returns a method that creates a store instance like this:</p>
<pre>import Vuex from "vuex";
import state from './state';
import actions from './actions';
import mutations from './mutations;
import moduleOne from './moduleOne;
const createStore = () =&gt; {
    return new Vuex.Store({
       state,
       actions,
       mutations,
        modules: {
            moduleOne
        },
    });
};
export default createStore;
</pre>
<p>In modules mode, every .js file in the store directory is automatically converted into a namespaced module (index.js). This is the root module that will export an object like this:</p>
<pre>import Vuex from "vuex";
import state from './state';
import actions from './actions';
import mutations from './mutations;
export default {
       state,
       actions,
       mutations,
};
</pre>
<p>There is no need to import the modules because Nuxt will do that for you.</p>
<h2>State management in a small scale application</h2>
<p>A typical small-scale application includes around five state properties, one action, and five mutations. When you put the state, mutation, action, and getters in the same file, it will not be complex to manage and the file won’t be overly code-heavy.</p>
<p>For this kind of app, simply create a store directory in the root directory of your project, and create an index.js file within it.</p>
<p><strong>Index.js</strong></p>
<pre>export const state = () =&gt; ({
  counter: 0
})
 
export const mutations = {
  increment(state) {
    state.counter++
  },
  decrement(state) {
    state.counter--
  }
}
</pre>
<p>When creating a module, the state value must always be a function, while your mutations and actions can be objects. For the store to be created, your store, mutations, and actions must be exported. The store that will be created by Vuex for the above file will be:</p>
<pre>new Vuex.Store({
  state: () =&gt; ({
    counter: 0
  }),
  mutations: {
    increment(state) {
      state.counter++
    }
  }
})
</pre>
<p>That is pretty much as simple as a root module can look in Nuxt.</p>
<p>As the number of state properties, actions, and mutations grow to about 20 each, the index.js file begins to look less presentable, maintainable, and manageable. Hence the need to break the store down.</p>
<p>Here are two <a href="https://dev.to/kevtiq/how-to-create-a-scalable-and-maintainable-front-end-architecture-4f47" target="_blank" rel="noopener">approaches to structuring your state</a> in a medium and large scale application</p>
<ol>
<li><strong>Division of concerns</strong> &#8212; In this approach, you group <code>like-logic</code> together, that is, you have different files for your actions, mutations, and state</li>
<li><strong>Modular approach</strong> &#8212; In the modular approach, state, actions, and mutations are grouped in the same file or folder based on modules</li>
</ol>
<h2>State management in a medium scale application</h2>
<p>Following the first approach means your store directory will look like this:</p>
<p><img data-attachment-id="37016" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/store-directory/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory.png" data-orig-size="376,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Store directory" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory-300x293.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory.png" loading="lazy" class="aligncenter size-full wp-image-37016 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory.png" alt="Store Directory" width="376" height="367" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory.png 376w, https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory-300x293.png 300w" data-lazy-sizes="(max-width: 376px) 100vw, 376px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="37016" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/store-directory/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory.png" data-orig-size="376,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Store directory" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory-300x293.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory.png" loading="lazy" class="aligncenter size-full wp-image-37016" src="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory.png" alt="Store Directory" width="376" height="367" srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory.png 376w, https://blog.logrocket.com/wp-content/uploads/2021/03/store-directory-300x293.png 300w" sizes="(max-width: 376px) 100vw, 376px" /></noscript></p>
<p>While this will better accommodate a growing store, I think that each file can get bogus and messy. Imagine there are 30 actions, mutations, and state properties, navigation through the code becomes more hectic and then we may start using comments and spacing to demarcate actions related to different models.</p>
<p>If we follow the second approach, we’ll have to divide our store into modules.</p>
<p><img data-attachment-id="37017" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/modules-broken-out/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out.png" data-orig-size="730,298" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Modules broken out" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out-300x122.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out.png" loading="lazy" class="aligncenter size-full wp-image-37017 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out.png" alt="Modules Broken Out" width="730" height="298" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out-300x122.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="37017" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/modules-broken-out/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out.png" data-orig-size="730,298" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Modules broken out" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out-300x122.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out.png" loading="lazy" class="aligncenter size-full wp-image-37017" src="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out.png" alt="Modules Broken Out" width="730" height="298" srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/03/modules-broken-out-300x122.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<p>There are different opinions on what should make up a module, some think modules should represent features in the application, some think modules should represent data models from API endpoints. From experience and reading on the subject, I’d recommend the latter for medium-scale applications.</p>
<p>Therefore if we have some endpoints serving these models:</p>
<table>
<tbody>
<tr>
<td>URL</td>
<td>Method</td>
<td>Description</td>
</tr>
<tr>
<td>/product</td>
<td>POST</td>
<td>Adds a product to the DB</td>
</tr>
<tr>
<td>/product/:id</td>
<td>GET</td>
<td>Gets info of a product</td>
</tr>
<tr>
<td>/product/id</td>
<td>PUT</td>
<td>Edits the info of a product</td>
</tr>
<tr>
<td>/product/:id</td>
<td>DELETE</td>
<td>Deletes a product from the DB</td>
</tr>
<tr>
<td>/products</td>
<td>GET</td>
<td>Gets all the products in the DB</td>
</tr>
<tr>
<td>/user</td>
<td>GET</td>
<td>Gets a user’s info</td>
</tr>
<tr>
<td>/user</td>
<td>POST</td>
<td>Add a user</td>
</tr>
<tr>
<td>/user</td>
<td>PUT</td>
<td>Edit information of a user</td>
</tr>
</tbody>
</table>
<p>Representing data models with modules will make the directory look something like this:</p>
<p><img data-attachment-id="37018" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/data-models-modules-store-directory/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory.png" data-orig-size="375,452" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Data models with modules in store directory" data-image-description data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory-249x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory.png" loading="lazy" class="aligncenter size-full wp-image-37018 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory.png" alt="Data Models With Modules in Store Directory" width="375" height="452" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory.png 375w, https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory-249x300.png 249w" data-lazy-sizes="(max-width: 375px) 100vw, 375px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="37018" data-permalink="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/data-models-modules-store-directory/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory.png" data-orig-size="375,452" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Data models with modules in store directory" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory-249x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory.png" loading="lazy" class="aligncenter size-full wp-image-37018" src="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory.png" alt="Data Models With Modules in Store Directory" width="375" height="452" srcset="https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory.png 375w, https://blog.logrocket.com/wp-content/uploads/2021/03/data-models-modules-store-directory-249x300.png 249w" sizes="(max-width: 375px) 100vw, 375px" /></noscript></p>
<p>Each module will then have its state (exported as a function), mutations, and actions (exported as objects) either in the module’s index.js file or in their respective files.</p>
<h2>State management in a large scale application</h2>
<p>Following the modular approach, and representing each data model from the API as modules, we can scale our large application easily. Imagine our app has grown to the point that we are dealing with over 60 state properties, actions, and mutations, neither the approach we used in the small scale or medium scale application will yield an easily manageable store structure.</p>
<p>Instead of creating just a file for our module like we did in the medium-scale application, Nuxt allows us to work with subdirectories in the state, these subdirectories should be inside a <code>modules</code> directory. Each subdirectory in the <code>modules</code> directory will be a module, the name of the subdirectory will be the name of the module.</p>
<p>In this subdirectory, we can create a state.js for the state, actions.js for the actions, mutation.js file for the mutations, and an index.js file that will import these files and export them as an object. Nuxt will take this object as a module and include it in the store (no need for us to import it manually in the root index.js file).</p>
<h2>Conclusion</h2>
<p>In this article, we have looked at what Nuxt is, some advantages of using Nuxt, what Vuex is, and how it communicates with Nuxt.</p>
<p>We also went through how you can structure your store in a small scale, medium scale, and large scale Nuxt application. Their documentation is also a great resource for understanding these concepts.</p><div class='code-block code-block-8' style='margin: 8px 0; clear: both;'>
<div class="blog-plug inline-plug vue-inline"><h2>Experience your Vue apps exactly how a user does</h2> Debugging Vue.js applications can be difficult, especially when there are dozens, if not hundreds of mutations during a user session. If you’re interested in monitoring and tracking Vue mutations for all of your users in production, <a href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank">try LogRocket</a>. <a class="signup" href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://files.readme.io/00591d0-687474703a2f2f692e696d6775722e636f6d2f6a3049327856572e706e67.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-lazy-src="https://files.readme.io/00591d0-687474703a2f2f692e696d6775722e636f6d2f6a3049327856572e706e67.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://files.readme.io/00591d0-687474703a2f2f692e696d6775722e636f6d2f6a3049327856572e706e67.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" /></noscript></a><a href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank" rel="noopener noreferrer">https://logrocket.com/signup/</a><p style="margin-top: 15px;"><a href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web apps, recording literally everything that happens in your Vue apps including network requests, JavaScript errors, performance problems, and much more. Instead of guessing why problems happen, you can aggregate and report on what state your application was in when an issue occurred. </p><p>The LogRocket Vuex plugin logs Vuex mutations to the LogRocket console, giving you context around what led to an error, and what state the application was in when an issue occurred.</p><p>Modernize how you debug your Vue apps - <a class="signup" href="https://www2.logrocket.com/vue-performance-monitoring" target="_blank" rel="noopener noreferrer">Start monitoring for free</a>.</p></div>
<style>
.plug-poll {margin-bottom: 2rem;}
.code-block-8 .fadeIn {
    opacity:1 !important;
    height:auto !important;
}

.code-block-8 .fadeOut {
    opacity:0 !important;
}

.code-block-8 .wpcf7-email {margin: 15px 0;}

#plug-survey-errors, #plug-survey-help, #plug-survey-email  {opacity:0; height:1px; transition: all 1s;overflow:hidden; width: 100%;}

</style>
<script>
  jQuery("#plug-survey-framework input").click(function() {
  analytics.track('footer-poll', {
      'footer-poll-framework': jQuery(this).val()
    });
    jQuery('#plug-survey-framework').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-errors').delay(800).addClass('fadeIn');
  });
    jQuery("#plug-survey-errors input").click(function() {
    jQuery('#plug-survey-errors').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-help').delay(800).addClass('fadeIn');
  });
  
      jQuery("#plug-survey-help input").click(function() {
        analytics.track('footer-poll', {
      'footer-poll-help': jQuery(this).val()
    });
    jQuery('#plug-survey-help').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-email').delay(800).addClass('fadeIn');
  });
  
  </script>
</div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-36999" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-36999" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-36999" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/scalable-state-management-with-vuex-and-nuxt-js/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/01/emmanuel.jpeg" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/01/emmanuel.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/01/emmanuel.jpeg' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/emmanuelakhigbe/">
Emmanuel Akhigbe <span class="btn follow">Follow</span></a>
<span class="author-description d-block"></span>
</div>
 </div>
<div class="after-post-tags">
<ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/nuxtjs/">#nuxtjs</a></li> <li><a href="https://blog.logrocket.com/tag/vue/">#vue</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/full-bleed-layout-css-grid/" rel="prev">How to create a full-bleed layout using CSS grid</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/using-zustand-to-simplify-state-management/" rel="next">Using Zustand to simplify state management</a> &raquo;</div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/using-zustand-to-simplify-state-management/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/03/zustand-state-management.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/using-zustand-to-simplify-state-management/">Using Zustand to simplify state management</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/lorenzweis/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/03/8QsTQKqa_400x400-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/8QsTQKqa_400x400-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/03/8QsTQKqa_400x400-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/lorenzweis/">Lorenz Weis</a></span><br>
<span class="post-date">Mar 10, 2021</span>
<span class="dot"></span>
<span class="readingtime">4 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/using-zustand-to-simplify-state-management/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
 </div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/full-bleed-layout-css-grid/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/03/create-fullbleed-layout-using-css-grid-web-nocdn.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/full-bleed-layout-css-grid/">How to create a full-bleed layout using CSS grid</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/annamonus/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/03/anna-monus-150x150.jpg" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/03/anna-monus-150x150.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/03/anna-monus-150x150.jpg' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/annamonus/">Anna Monus</a></span><br>
<span class="post-date">Mar 10, 2021</span>
<span class="dot"></span>
<span class="readingtime">5 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/full-bleed-layout-css-grid/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/testing-and-error-handling-patterns-in-next-js/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/03/testing-error-handling-nextjs-1.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/testing-and-error-handling-patterns-in-next-js/">Testing and error handling patterns in Next.js </a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/raphaelugwu/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2019/07/raphaelugwu-150x150.jpg" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2019/07/raphaelugwu-150x150.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2019/07/raphaelugwu-150x150.jpg' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/raphaelugwu/">Raphael Ugwu</a></span><br>
<span class="post-date">Mar 9, 2021</span>
<span class="dot"></span>
<span class="readingtime">3 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/testing-and-error-handling-patterns-in-next-js/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/scalable-state-management-with-vuex-and-nuxt-js/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=36999&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.5.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=61fbf2f58fbdc487d08df376e8a2409554b5d31a#parent=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="pull-left"> Does something seem off? Email <a><span class="__cf_email__" data-cfemail="12616762627d6066527e7d75607d717977663c717d7f">[email&#160;protected]</span></a> </div>
<div class="pull-right"> <div class="footerRight"> <div id="jetpack-search-filters-2-wrapper">
<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div> </div>
<div class="clearfix"></div>
<a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202110'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text()
  });
}
};</script> <div style="display:none">
<div class="grofile-hash-map-95d7097a88019e1b709d767f472b3c1a">
</div>
<div class="grofile-hash-map-441d2fbe45abcc70c93c328ad86b1761">
</div>
<div class="grofile-hash-map-fd93b9c0bdf8ccd4fa47f03ec2dbe29f">
</div>
<div class="grofile-hash-map-17f57c0662a0b062e2379bce791239e8">
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/scalable-state-management-with-vuex-and-nuxt-js\/":36999};
	</script>
<link rel='stylesheet' id='dashicons-css' href='https://blog.logrocket.com/wp-includes/css/dashicons.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='nf-display-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/display-opinions-light.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='nf-font-awesome-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/font-awesome.min.css?ver=5.7' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=5.7' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/modules/widgets/search/js/search-widget.js?ver=9.5.1' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"9317b5777a","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=9.5.1' id='jetpack-carousel-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/backbone.min.js?ver=1.4.0' id='backbone-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end-deps.js?ver=3.5.1' id='nf-front-end-deps-js'></script>
<script type='text/javascript' id='nf-front-end-js-extra'>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</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end.js?ver=3.5.1' id='nf-front-end-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.5.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=36999&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.5.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=61fbf2f58fbdc487d08df376e8a2409554b5d31a#parent=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=36999&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.5.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=61fbf2f58fbdc487d08df376e8a2409554b5d31a#parent=https%3A%2F%2Fblog.logrocket.com%2Fscalable-state-management-with-vuex-and-nuxt-js%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202110.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.5.1',blog:'161333275',post:'36999',tz:'-5',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '36999' ]);
</script>
<script id="tmpl-nf-layout" type="text/template">
	<span id="nf-form-title-{{{ data.id }}}" class="nf-form-title">
		{{{ ( 1 == data.settings.show_title ) ? '<h3>' + data.settings.title + '</h3>' : '' }}}
	</span>
	<div class="nf-form-wrap ninja-forms-form-wrap">
		<div class="nf-response-msg"></div>
		<div class="nf-debug-msg"></div>
		<div class="nf-before-form"></div>
		<div class="nf-form-layout"></div>
		<div class="nf-after-form"></div>
	</div>
</script>
<script id="tmpl-nf-empty" type="text/template">

</script>
<script id="tmpl-nf-before-form" type="text/template">
	{{{ data.beforeForm }}}
</script><script id="tmpl-nf-after-form" type="text/template">
	{{{ data.afterForm }}}
</script><script id="tmpl-nf-before-fields" type="text/template">
    <div class="nf-form-fields-required">{{{ data.renderFieldsMarkedRequired() }}}</div>
    {{{ data.beforeFields }}}
</script><script id="tmpl-nf-after-fields" type="text/template">
    {{{ data.afterFields }}}
    <div id="nf-form-errors-{{{ data.id }}}" class="nf-form-errors" role="alert"></div>
    <div class="nf-form-hp"></div>
</script>
<script id="tmpl-nf-before-field" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-after-field" type="text/template">
    {{{ data.afterField }}}
</script><script id="tmpl-nf-form-layout" type="text/template">
	<form>
		<div>
			<div class="nf-before-form-content"></div>
			<div class="nf-form-content {{{ data.element_class }}}"></div>
			<div class="nf-after-form-content"></div>
		</div>
	</form>
</script><script id="tmpl-nf-form-hp" type="text/template">
	<label for="nf-field-hp-{{{ data.id }}}" aria-hidden="true">
		{{{ nfi18n.formHoneypot }}}
		<input id="nf-field-hp-{{{ data.id }}}" name="nf-field-hp" class="nf-element nf-field-hp" type="text" value=""/>
	</label>
</script>
<script id="tmpl-nf-field-layout" type="text/template">
    <div id="nf-field-{{{ data.id }}}-container" class="nf-field-container {{{ data.type }}}-container {{{ data.renderContainerClass() }}}">
        <div class="nf-before-field"></div>
        <div class="nf-field"></div>
        <div class="nf-after-field"></div>
    </div>
</script>
<script id="tmpl-nf-field-before" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-field-after" type="text/template">
    <#
    /*
     * Render our input limit section if that setting exists.
     */
    #>
    <div class="nf-input-limit"></div>
    <#
    /*
     * Render our error section if we have an error.
     */
    #>
    <div id="nf-error-{{{ data.id }}}" class="nf-error-wrap nf-error" role="alert"></div>
    <#
    /*
     * Render any custom HTML after our field.
     */
    #>
    {{{ data.afterField }}}
</script>
<script id="tmpl-nf-field-wrap" type="text/template">
	<div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
		<#
		/*
		 * This is our main field template. It's called for every field type.
		 * Note that must have ONE top-level, wrapping element. i.e. a div/span/etc that wraps all of the template.
		 */
        #>
		<#
		/*
		 * Render our label.
		 */
        #>
		{{{ data.renderLabel() }}}
		<#
		/*
		 * Render our field element. Uses the template for the field being rendered.
		 */
        #>
		<div class="nf-field-element">{{{ data.renderElement() }}}</div>
		<#
		/*
		 * Render our Description Text.
		 */
        #>
		{{{ data.renderDescText() }}}
	</div>
</script>
<script id="tmpl-nf-field-wrap-no-label" type="text/template">
    <div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
        <div class="nf-field-label"></div>
        <div class="nf-field-element">{{{ data.renderElement() }}}</div>
        <div class="nf-error-wrap"></div>
    </div>
</script>
<script id="tmpl-nf-field-wrap-no-container" type="text/template">

        {{{ data.renderElement() }}}

        <div class="nf-error-wrap"></div>
</script>
<script id="tmpl-nf-field-label" type="text/template">
	<div class="nf-field-label"><label for="nf-field-{{{ data.id }}}"
	                                   id="nf-label-field-{{{ data.id }}}"
	                                   class="{{{ data.renderLabelClasses() }}}">{{{ data.label }}} {{{ ( 'undefined' != typeof data.required && 1 == data.required ) ? '<span class="ninja-forms-req-symbol">*</span>' : '' }}} {{{ data.maybeRenderHelp() }}}</label></div>
</script>
<script id="tmpl-nf-field-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-form-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-field-input-limit" type="text/template">
    {{{ data.currentCount() }}} {{{ nfi18n.of }}} {{{ data.input_limit }}} {{{ data.input_limit_msg }}}
</script><script id="tmpl-nf-field-null" type="text/template">
</script><script id="tmpl-nf-field-listcheckbox" type="text/template">
    <ul aria-describedby="nf-error-{{{ data.id }}}">
        {{{ data.renderOptions() }}}
    </ul>
</script>
<script id='tmpl-nf-field-listcheckbox-option' type='text/template'>
    <# if ( ! data.visible ) { return '' } #>
    <li>
        <input type="checkbox" id="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}" name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element {{{ ( data.isSelected ) ? ' nf-checked' : '' }}}" value="{{{ data.value }}}" {{{ ( data.isSelected ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
            <# if( data.required ) { #>
			required
			<# } #>
        >
        <label for="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               id="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               class="{{{ ( data.isSelected ) ? 'nf-checked-label' : '' }}}">{{{ data.label }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other' type='text/template'>
    <li {{{ ( ! data.visible ) ? 'style="display:none"' : '' }}}>
        <input type="checkbox"
               id="nf-field-{{{ data.fieldID }}}-other"
               name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element" value="nf-other" {{{ ( ! data.valueFound ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-other"
            <# if( data.required ) { #>
			required
			<# } #>
        >
         <label id="nf-label-field-{{{ data.fieldID }}}-other">Other
            {{{ data.renderOtherText() }}}
        </label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other-text' type='text/template'>
    <input type="text" name="nf-field-{{{ data.fieldID }}}" class="nf-element" value="{{{ data.currentValue }}}">
</script>
<script id='tmpl-nf-field-input' type='text/template'>
    <input id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" aria-invalid="false" aria-describedby="nf-error-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element" type="text" value="{{{ data.value }}}" {{{ data.renderPlaceholder() }}} {{{ data.maybeDisabled() }}}
           aria-labelledby="nf-label-field-{{{ data.id }}}"

            {{{ data.maybeRequired() }}}
    >
</script>
<script id="tmpl-nf-field-email" type="text/template">
	<input
			type="email"
			value="{{{ data.value }}}"
			class="{{{ data.renderClasses() }}} nf-element"

			id="nf-field-{{{ data.id }}}"
			<# if( ! data.disable_browser_autocompletes ){ #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id + '-' + data.type }}"
			autocomplete="email"
			<# } else { #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id }}"
			{{{ data.maybeDisableAutocomplete() }}}
			<# } #>
			{{{ data.renderPlaceholder() }}}
			{{{ data.maybeDisabled() }}}

			aria-invalid="false"
			aria-describedby="nf-error-{{{ data.id }}}"
			aria-labelledby="nf-label-field-{{{ data.id }}}"

			{{{ data.maybeRequired() }}}
	>
</script>
<script id="tmpl-nf-field-submit" type="text/template">
	<input id="nf-field-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element " type="button" value="{{{ data.label }}}" {{{ ( data.disabled ) ? 'disabled' : '' }}}>
</script><script id='tmpl-nf-field-button' type='text/template'>
    <button id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" class="{{{ data.classes }}} nf-element">
        {{{ data.label }}}
    </button>
</script><script>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</script>
</body>
</html>
