<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v14.8.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Integrating Stripe in your React app with React Stripe.js - LogRocket Blog</title>
	<meta name="description" content="React Stripe.js is a lightweight wrapper around Stripe Elements that allows you to quickly integrate Stripe in your React apps." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://blog.logrocket.com/integrating-stripe-react-stripe-js/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Integrating Stripe in your React app with React Stripe.js - LogRocket Blog" />
	<meta property="og:description" content="React Stripe.js is a lightweight wrapper around Stripe Elements that allows you to quickly integrate Stripe in your React apps." />
	<meta property="og:url" content="https://blog.logrocket.com/integrating-stripe-react-stripe-js/" />
	<meta property="og:site_name" content="LogRocket Blog" />
	<meta property="article:published_time" content="2020-08-28T13:00:09+00:00" />
	<meta property="article:modified_time" content="2020-08-27T11:51:31+00:00" />
	<meta property="og:image" content="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?fit=730%2C487&#038;ssl=1" />
	<meta property="og:image:width" content="730" />
	<meta property="og:image:height" content="487" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@https://twitter.com/faruqyusuffG" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/integrating-stripe-react-stripe-js/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?fit=730%2C487&ssl=1","width":730,"height":487,"caption":"Integrating Stripe In Your React App With React Stripe.js"},{"@type":"WebPage","@id":"https://blog.logrocket.com/integrating-stripe-react-stripe-js/#webpage","url":"https://blog.logrocket.com/integrating-stripe-react-stripe-js/","name":"Integrating Stripe in your React app with React Stripe.js - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/integrating-stripe-react-stripe-js/#primaryimage"},"datePublished":"2020-08-28T13:00:09+00:00","dateModified":"2020-08-27T11:51:31+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/ce940ea6c743df22bedff0e813f8ccf0"},"description":"React Stripe.js is a lightweight wrapper around Stripe Elements that allows you to quickly integrate Stripe in your React apps.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/integrating-stripe-react-stripe-js/"]}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/ce940ea6c743df22bedff0e813f8ccf0","name":"Yusuff Faruq","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/4f663587690a2a34c8ed779025635322?s=96&d=mm&r=g","caption":"Yusuff Faruq"},"description":"Frontend web developer and anime lover from Nigeria.","sameAs":["https://twitter.com/https://twitter.com/faruqyusuffG"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Integrating Stripe in your React app with React Stripe.js Comments Feed" href="https://blog.logrocket.com/integrating-stripe-react-stripe-js/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.5/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css'  href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.8.2/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.8.2/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0' id='jquery-migrate-js'></script>
<script type='text/javascript' async='async' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' async='async' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/23939" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/paUW9B-6e7' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">

    <script>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</script>


    <script>
    window.Raven && window.Raven.config('https://98e0ea7c6f2e492d94439ad5aaea48dd@e.logrocket.com/4').install()
    </script>
    <script type="text/javascript">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</script>

<!-- Start VWO Async Smartcode -->
<script type='text/javascript'>
window._vwo_code = window._vwo_code || (function(){
var account_id=338524,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
is_spa=1,
hide_element='body',

/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document,code={use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){
settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b=hide_element?hide_element+'{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}':'',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&f='+(+is_spa)+'&r='+Math.random());return settings_timer; }};window._vwo_settings_timer = code.init(); return code; }());
</script>
<!-- End VWO Async Smartcode -->

    <script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
    <script>
        if (window.LogRocket) {
            window.LogRocket.init('apphub/logrocket-website',{
                dashboardHost: "https://staging.lr-ingest.io",
                serverURL: "https://staging-i.lr-ingest.io/i",
                mergeIframes: true,
                rootHostname: "logrocket.com",
            });
        }

        fetch('https://ga.clearbit.com/v1/ga.js?authorization=pk_66a3fd2085d9f04c4d4b68a62b70ed7e').then(function(res){
            res.text().then(function(val){
                var regex = /this.done((.*)}})/;
                var regexVal = regex.exec(val);
                if (!regexVal) {
                    return;
                }

                var dict = regexVal[0].replace('this.done(', '');

                var clearbitData = JSON.parse(dict);
                window.clearbitData = clearbitData;

                window._vis_opt_queue = window._vis_opt_queue || [];
                window._vis_opt_queue.push(function() {_vis_opt_goal_conversion(202);});

                window.LogRocket && window.LogRocket.identify(Math.random().toString(36).substring(7), {
                    company: clearbitData.company.name,
                    email: 'anonymous@' + clearbitData.company.domain,
                });
                if (clearbitData.company.domain && window.location.pathname != "/") {
                    var demoButton = document.getElementById("blog-personalized-demo-link");
                    var personalizeImage = document.getElementById("blog-personalized-demo-thumbnail");
                    var companyName = document.getElementById("personalized-company-account-name");
                    var perUrl = "https://us-central1-logrocket-com.cloudfunctions.net/findPersonalization?targetDomain=" + clearbitData.company.domain;
                    fetch(perUrl)
                        .then(response => {
                            return response.json()
                        })
                        .then(data => {
                            var imageReturn = data.image_url;
                            var linkReturn = data.link_url;
                            if (imageReturn.includes("not-found") || linkReturn.includes("not-found")) {
                                return "not-found";
                            } else {
                                personalizeImage.src = imageReturn;
                                demoButton.href = linkReturn;
                                companyName.innerHTML = clearbitData.company.name;
var intersectionOptions = {
root: null,  // use the viewport
rootMargin: '-240px',
threshold: 1.0
}
function intersectionCallback(entries, observer) {
entries.forEach(entry => {
 if (entry.intersectionRatio >= 1) {
   jQuery('.inline-demo').slideDown(1500);
 //  jQuery('.crp-list-item-image img').delay(550).fadeIn(1000);
     observer.unobserve(target);
 } else {
 }
});
}
var observer = new IntersectionObserver(intersectionCallback, intersectionOptions);
var target = document.querySelector('.code-block-28');
observer.observe(target);

                                analytics.track('Personalization-deployed-blog', {
                                    'Domain': clearbitData.company.domain
                                });
                                LogRocket.track('post-personalized-blog');
                            }
                        })
                        .catch(err => {
                            analytics.track("personalization-failed");
                            throw err;
                        })
                };

                _linkedin_partner_id = "1468257";
                window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
                window._linkedin_data_partner_ids.push(_linkedin_partner_id);
                (function(){var s = document.getElementsByTagName("script")[0];
                var b = document.createElement("script");
                b.type = "text/javascript";b.async = true;
                b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
                s.parentNode.insertBefore(b, s);})();

                var linkedIn_img = document.createElement("img");
                linkedIn_img.src = "https://px.ads.linkedin.com/collect/?pid=1468257&fmt=gif";
                document.getElementsByTagName('head')[0].appendChild( linkedIn_img );

                window.analytics && window.analytics.track('clearbit domain', { domain: clearbitData.company.domain });
                window.analytics && window.analytics.track('clearbit subindustry', { subIndustry: clearbitData.company.category.subIndustry });
            });
        })
    </script><style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=270%2C270&#038;ssl=1" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=9b8b8093c7" />
		<style id="kirki-inline-styles">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</style></head>

<body class="post-template-default single single-post postid-23939 single-format-standard">

<style>
    </style>


<header class="navbar-light bg-white fixed-top mediumnavigation">

    <div class="container">



        <div class="navarea">

<div class="nav-left">

  <a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>

<nav class="menu-container">

        <div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog Home</a></ul></div></nav>

</div>

<div class="nav-right">

  <div class="menu-container">
    <div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup">Try LogRocket<br><span style="text-transform: none;font-size: 0.7rem;color: #e9e9ea;">Free forever</span></a></li>
</ul></div>  </div>

</div>

        </div>

    </div>

</header>


        <!-- Begin site-content
		================================================== -->
        <div class="site-content">


<div class="container"> 
    <div class="row">         
        <div class=" col-md-2 ">           
            <div class="share">
                
                <div class="sidebarapplause">
                                </div>
                
                				<p class="sharecolour">
					Share				</p>
                
<ul class="shareitnow"><li>
        <a target="_blank" href="https://twitter.com/intent/tweet?text=Integrating%20Stripe%20in%20your%20React%20app%20with%20React%20Stripe.js&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F">
        <i class="fa fa-twitter"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F">
        <i class="fa fa-facebook"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F">
        <i class="fa fa-google"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F&amp;media=https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?fit=730%2C487&ssl=1&amp;description=Integrating%20Stripe%20in%20your%20React%20app%20with%20React%20Stripe.js">
        <i class="fa fa-pinterest"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F&amp;title=Integrating%20Stripe%20in%20your%20React%20app%20with%20React%20Stripe.js">
        <i class="fa fa-linkedin"></i>
        </a>
    </li></ul>                		        
                
                                <div class="sep"></div>
                <div class="hidden-xs-down">      

                    <p>
                        Reply                    </p>
                    <ul>
                        <li>
                        <a class="smoothscroll" href="#comments">0<br/>
                        <svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
                        </a>
                        </li>
                    </ul>
                </div>
                            </div>			                                
        </div>
        
                    			                <div class="col-md-8 flex-first flex-md-unordered post-23939 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-react" id="post-23939"> 
                    <div class="mainheading">
                       
                                                <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-md-down"> 
                            <div class="col-md-2 col-xs-12"> 
                                <a href="https://blog.logrocket.com/author/yusufffaruq/">
                                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/yusuff-faruq.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/yusuff-faruq.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/yusuff-faruq.jpg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                                </a>
                            </div>                                         
                            <div class="col-md-10 col-xs-12"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/yusufffaruq/">
                                Yusuff Faruq <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">Frontend web developer and anime lover from Nigeria.</span> 
                            </div>                                         
                        </div>
                                                 
                                                
                        <h1 class="posttitle">Integrating Stripe in your React app with React Stripe.js</h1>
					    <h2 class="post-subtitle"></h2>

                        <p>
                                                        <span class="post-date"><time class="post-date">
                            August 28, 2020                            </time></span>
                                                        
                                                        <span class="dot"></span>
                            <span class="readingtime">5 min read</span>
						    <span class="wordcount">1578</span>

                                                    </p> 
                    </div>
                    
                  <img width="730" height="487" src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?fit=730%2C487&amp;ssl=1" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="Integrating Stripe In Your React App With React Stripe.js" loading="lazy" data-attachment-id="23943" data-permalink="https://blog.logrocket.com/integrating-stripe-react-stripe-js/integrating-stripe-react-stripe-js/" data-orig-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?fit=730%2C487&amp;ssl=1" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Integrating Stripe in your React app with React Stripe.js" data-image-description="" data-medium-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?fit=730%2C487&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?w=730&amp;ssl=1 730w, https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/integrating-stripe-react-stripe-js.png?fit=730%2C487&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    <article class="article-post">
                                                <p>Nowadays, making payments through a website or mobile app in exchange for a product of some sort has become ubiquitous. As such, there are a variety of payment gateway solutions that make it simple for these websites and mobile apps to accept payment.</p>
<p>Stripe is one of the leading payment gateways, and it allows businesses and individuals to accept payment through the use of their robust APIs and tools. In this article, we will discuss how to integrate Stripe in our React apps using React Stripe.js, an official library from Stripe.</p>
<h2>Stripe Elements</h2>
<p>React Stripe.js is simply a lightweight wrapper around Stripe Elements, which is a set of prebuilt UI components that allow developers to implement secure payment functionality in their applications quickly and easily. One such element is the Card Element, which is a single-line form that collects all the information required to make payments online using a debit/credit card.</p>
<p>Developers can also build their own custom payment forms using elements that represent the individual parts of the Card Element: the Card Number Element, the Card Expiry Element, and so on. You can learn more about Stripe Elements <a href="https://stripe.com/docs/stripe-js">here</a>.</p>
<h2>React Stripe.js</h2>
<p>Now that we are familiar with Stripe Elements, we will look at how React Stripe.js allows us to use Elements in our applications.</p>
<p>In React Stripe.js, Elements are available in the form of React components, so for each Element, we have a corresponding React component. Besides the Element components, React Stripe.js also contains some Hooks and other components, like the <code>Elements</code> provider and <code>ElementsConsumer</code>.</p>
<p>Before we move on to building a payment form that allows us to accept payment with Stripe and React Stripe.js, I’d like to briefly discuss some of these Hooks and components as they will be fundamental to what we will do later on in this article.</p>
<h3>The <code>Elements</code> provider</h3>
<p>The <code>Elements</code> provider is a component that allows any components nested in it to use the Element components and the Hooks provided by React Stripe.js. <code>Elements</code> has two props: <code>stripe</code> and <code>options</code>. Normally, <code>stripe</code> takes in a Stripe object or a promise that resolves to a Stripe object. To initialize a Stripe object, you can use the <code>loadStripe</code> function from the <code>stripe-js</code> module.</p>
<pre>import React from "react";
import { loadStripe } from "@stripe/stripe-js";
import { Elements } from "@stripe/react-stripe-js";

const stripe = loadStripe(
  "{PUBLIC-KEY}"
);
const App = () =&gt; {
  return (
    &lt;Elements stripe={stripe}&gt;
      ...
    &lt;/Elements&gt;
  );
};</pre>
<h3>The <code>useStripe</code> and <code>useElements</code> Hooks</h3>
<p>The <code>useStripe</code> and <code>useElements</code> Hooks are the two <a href="https://reactjs.org/docs/hooks-intro.html">React Hooks</a> that React Stripe.js offers. <code>useStripe</code> returns a reference to the Stripe object instance we initially passed to the <code>Elements</code> provider. With this Stripe object, we can interact with Stripe. <code>useElements</code> returns an Elements object, which we can use for interacting with our Elements and collecting sensitive for payment.</p>
<h3><code>ElementsConsumer</code></h3>
<p>Since Hooks can only be used in functional components, the <code>ElementsConsumer</code> component is used whenever we want to access the Stripe and Element instance in class-based components. It takes a function, from whose arguments we can get our Stripe and Element instances, as a child.</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br/>No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>

<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>

<pre>import React from "react";
import { ElementsConsumer, Elements } from "@stripe/react-stripe-js";
import { loadStripe } from "@stripe/stripe-js";

const App = () =&gt; {
  return (
    &lt;Elements stripe={stripe}&gt;
       &lt;CheckoutForm /&gt;
    &lt;/Elements&gt;
  );
};

const CheckoutForm = () =&gt; {
  return (
    &lt;ElementsConsumer&gt;
      {({elements, stripe}) =&gt; (
        ...
      )}
    &lt;/ElementsConsumer&gt;
  );
};</pre>
<p>Now that we are familiar with the toolbox React Stripe.js gives us, let&#8217;s go ahead and build a simple React component that can accept payments through a debit/credit card.</p>
<h2>Accepting payments with React Stripe.js and Stripe</h2>
<h3>Prerequisites</h3>
<ol>
<li>A Stripe account — this is necessary to integrate Stripe in your app or website. You can create one at <a href="https://dashboard.stripe.com/register">Stripe.com</a></li>
<li>Basic knowledge of React</li>
</ol>
<blockquote><p><strong>Note</strong>: To build an actual payment flow, you will need a server where client secrets can be generated to use for payment. This is beyond the scope of this article and will not be covered.</p></blockquote>
<p>Now that we have that covered, let&#8217;s start writing some code!</p>
<h3>Setting up our React project</h3>
<p>Firstly, we have to create a new React project using any preferred method. I recommend using create-react-app.</p>
<p>Once our React project has been created, we have to install some dependencies. Using npm, we can install React Stripe.js and the <code>stripe-js</code> module:</p>
<pre>npm install --save @stripe/react-stripe-js @stripe/stripe-js</pre>
<h3>Accepting payments</h3>
<p>In our <code>App</code> component, we will initialize our Stripe object using the <code>loadStripe</code> function. We will then pass this instance to the <code>stripe</code> prop of the <code>Elements</code> provider.</p>
<p>To do this, we will need a publishable key, which you can find on your Stripe dashboard once you create an account. Note that you should use the test version of your publishable key.</p>
<p>Once our <code>Elements</code> provider is ready, we will create a new component for our checkout form, from which we will accept the user&#8217;s card details.</p>
<p>We will use the <code>CardElement</code> component to securely collect the user&#8217;s card details and pass it to Stripe for processing. Let&#8217;s write some markup and CSS for our form.</p>
<h4><code>App.js</code></h4>
<pre>import React, { useState } from "react";
import {
  Elements,
  CardElement,
} from "@stripe/react-stripe-js";
import { loadStripe } from "@stripe/stripe-js";
import "./App.css";
const App = () =&gt; {
  const stripe = loadStripe(
    "pk_test_*****"
  );
  return (
    &lt;Elements stripe={stripe}&gt;
      &lt;CheckoutForm /&gt;
    &lt;/Elements&gt;
  );
};
function CheckoutForm() {
  const [isPaymentLoading, setPaymentLoading] = useState(false);
  return (
    &lt;div
      style={{
        padding: "3rem",
      }}
    &gt;
      &lt;div
        style={{
          maxWidth: "500px",
          margin: "0 auto",
        }}
      &gt;
        &lt;form
          style={{
            display: "block",
            width: "100%",
          }}
        &gt;
          &lt;div
            style={{
              display: "flex",
              flexDirection: "column",
              alignItems: "center",
            }}
          &gt;
            &lt;CardElement
              className="card"
              options={{
                style: {
                  base: {
                    backgroundColor: "white"
                  } 
                },
              }}
            /&gt;
            &lt;button
              className="pay-button"
              disabled={isPaymentLoading}
            &gt;
              {isPaymentLoading ? "Loading..." : "Pay"}
            &lt;/button&gt;
          &lt;/div&gt;
        &lt;/form&gt;
      &lt;/div&gt;
    &lt;/div&gt;
  );
}</pre>
<h4><code>App.css</code></h4>
<pre>.card {
  background-color: white;
  padding: 10px 20px 11px;
  border-radius: 5px;
  width: 100%;
  border: 1px solid #afafaf;
  box-shadow: 0px 4px 5.5px 0px rgba(0, 0, 0, 0.07);
}
.pay-button{
  padding: 0.7rem 2rem;
  width: 100%;
  margin: 1rem 0;
  color: white;
  font-weight: bold;
  font-size: medium;
  background-color: #556cd6;
  border: 0;
  border-radius: 5px;
  box-shadow: 0px 4px 5.5px 0px rgba(0, 0, 0, 0.07);
  transition: box-shadow 500ms;
  cursor: pointer;
}
.pay-button:disabled{
  background-color: #afafaf;
  box-shadow: none;
  cursor: default;
}
.pay-button:disabled:hover{
  box-shadow: none;
}
.pay-button:hover{
  box-shadow: 2px 5px 15px 2px rgba(0, 0, 0, 0.2);
}</pre>
<p>Now all we need to do is create a function, which we will call <code>payMoney</code>, for collecting users’ details and sending them to Stripe for payment. To do that, we will have to make a request to an endpoint on our server (which, again, we won’t be covering in this tutorial) to get the client secret, which we will use to make the payment.</p>
<p>Since we don’t have a server to make a request to, we will just use the a function to represent the process.</p>
<pre>const clientSecret = getClientSecret();</pre>
<p>We will now use the <code>useStripe</code> and <code>useElement</code> Hooks to get the stripe and element instance, which we will use for making payment through the <code>confirmCardPayment</code> method. This method takes in our client secret and an object specifying additional details about the user&#8217;s payment.</p>
<pre>const stripe = useStripe();
const elements = useElements();

const paymentResult = await stripe.confirmCardPayment(clientSecret, {
      payment_method: {
        card: elements.getElement(CardElement),
        billing_details: {
          name: "Faruq Yusuff",
        },
      },
});</pre>
<p>As you can see from the code block above, we used the <code>elements</code> instance and its <code>getElement</code> method, which takes in the <code>CardElement</code> component as an argument. We can also specify other details about this payment using the <code>billing_details</code> property.</p>
<p>If our result contains an error, we will trigger an alert with the error message, and if it is successful, we will trigger an alert with a success message. And with that, our <code>payMoney</code> function is complete.</p>
<pre>const payMoney = async (e) =&gt; {
    e.preventDefault();
    const clientSecret = getClientSecret();
    const paymentResult = await stripe.confirmCardPayment(clientSecret, {
      payment_method: {
        card: elements.getElement(CardElement),
        billing_details: {
          name: "Yusuff Faruq",
        },
      },
    });
    setPaymentLoading(false);
    if (paymentResult.error) {
      alert(paymentResult.error.message);
      console.log(paymentResult.error.message);
    } else {
      if (paymentResult.paymentIntent.status === "succeeded") {
        alert("Success!");
        console.log(paymentResult);
      }
    }
  };</pre>
<p>Now this should be our completed app.</p>
<pre>import React, { useState } from "react";
import {
  Elements,
  CardElement,
  useStripe,
  useElements,
} from "@stripe/react-stripe-js";
import { loadStripe } from "@stripe/stripe-js";
import "./App.css";
const App = () =&gt; {
  const stripe = loadStripe(
    "pk_test_***************"
  );
  return (
    &lt;Elements stripe={stripe}&gt;
      &lt;CheckoutForm /&gt;
    &lt;/Elements&gt;
  );
};
function CheckoutForm() {
  const [isPaymentLoading, setPaymentLoading] = useState(false);
  const stripe = useStripe();
  const elements = useElements();
  const payMoney = async (e) =&gt; {
    e.preventDefault();
    if (!stripe || !elements) {
      return;
    }
    setPaymentLoading(true);
    const clientSecret = getClientSecret();
    const paymentResult = await stripe.confirmCardPayment(clientSecret, {
      payment_method: {
        card: elements.getElement(CardElement),
        billing_details: {
          name: "Faruq Yusuff",
        },
      },
    });
    setPaymentLoading(false);
    if (paymentResult.error) {
      alert(paymentResult.error.message);
    } else {
      if (paymentResult.paymentIntent.status === "succeeded") {
        alert("Success!");
      }
    }
  };

  return (
    &lt;div
      style={{
        padding: "3rem",
      }}
    &gt;
      &lt;div
        style={{
          maxWidth: "500px",
          margin: "0 auto",
        }}
      &gt;
        &lt;form
          style={{
            display: "block",
            width: "100%",
          }}
          onSubmit = {payMoney}
        &gt;
          &lt;div
            style={{
              display: "flex",
              flexDirection: "column",
              alignItems: "center",
            }}
          &gt;
            &lt;CardElement
              className="card"
              options={{
                style: {
                  base: {
                    backgroundColor: "white"
                  } 
                },
              }}
            /&gt;
            &lt;button
              className="pay-button"
              disabled={isPaymentLoading}
            &gt;
              {isPaymentLoading ? "Loading..." : "Pay"}
            &lt;/button&gt;
          &lt;/div&gt;
        &lt;/form&gt;
      &lt;/div&gt;
    &lt;/div&gt;
  );
}</pre>
<p>We’ve just built a simple app that can accept payment using Stripe!</p>
<h3>A note about customization and styling</h3>
<p>We can customize our Element components’ styles using the <code>options</code> prop on each Element component or applying a classname to our Element component and styling the component with CSS.</p>
<h2>Conclusion</h2>
<p>React Stripe.js provides a fast and secure way for us to implement payment functionality in our React Apps. You can learn more about React Stripe.js and Stripe <a href="https://stripe.com/docs">here</a>.</p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<div class="inline-plug react-plug"><h2>Full visibility into production React apps</h2> Debugging React applications can be difficult, especially when users experience issues that are difficult to reproduce. If you’re interested in monitoring and tracking Redux state, automatically surfacing JavaScript errors, and tracking slow network requests and component load time, <a href="https://www2.logrocket.com/react-performance-monitoring">try LogRocket</a>. <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i2.wp.com/files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?ssl=1" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i2.wp.com/files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?ssl=1" data-recalc-dims="1" /></noscript></a><a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" /></noscript></a><p style="margin-top: 15px;"><a href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web apps, recording literally everything that happens on your React app. Instead of guessing why problems happen, you can aggregate and report on what state your application was in when an issue occurred. LogRocket also monitors your app's performance, reporting with metrics like client CPU load, client memory usage, and more.</p><p>The LogRocket Redux middleware package adds an extra layer of visibility into your user sessions. LogRocket logs all actions and state from your Redux stores. </p><p>Modernize how you debug your React apps — <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">start monitoring for free</a>.</p></div></div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-23939" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/integrating-stripe-react-stripe-js/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/integrating-stripe-react-stripe-js/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-23939" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/integrating-stripe-react-stripe-js/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-23939" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/integrating-stripe-react-stripe-js/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><!-- AI CONTENT END 1 -->
                        <div class="clearfix"></div>
                                                <div class="clearfix"></div>
                    </article>
                            
                                             <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-lg-up"> 
                            <div class="col-md-2 col-xs-4"> 
                                <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/yusuff-faruq.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/yusuff-faruq.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/yusuff-faruq.jpg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                            </div>                                         
                            <div class="col-md-10 col-xs-8"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/yusufffaruq/">
                                Yusuff Faruq <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">Frontend web developer and anime lover from Nigeria.</span> 
                            </div>                                         
                        </div>
                                         
                    <div class="after-post-tags">
                                                    <ul class="post-categories">
	<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul>                                                                            <ul class="post-categories aretags">
                            <li><a href="https://blog.logrocket.com/tag/react/">#react</a></li>                             </ul>
                                            </div>
                    
                  
                    <div class="row mb-5 prevnextlinks justify-content-center align-items-center"> 
                       <div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/creating-visuals-of-your-webpage-with-puppeteer/" rel="prev">Creating visuals of your webpage with Puppeteer</a></div></div>
                       <div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/getting-started-with-frontity/" rel="next">Getting started with Frontity</a> &raquo;</div></div>
                    </div>
                    
                </div>
        
                    
         
        
        
    </div>                 
</div>             
          
<div class="hideshare"></div>

    <div class="graybg"> 
        <div class="container"> 
                <div class="row justify-content-center listrecent listrelated">
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/getting-started-with-frontity/" style="background-image:url(https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/frontity-react.png?fit=730%2C412&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/getting-started-with-frontity/">Getting started with Frontity</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/dylan-tientcheu/">
                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/Dylan-Tientcheu.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/Dylan-Tientcheu.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/Dylan-Tientcheu.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/dylan-tientcheu/">Dylan Tientcheu</a></span><br>
                    <span class="post-date">Aug 28, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">4 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/getting-started-with-frontity/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/creating-visuals-of-your-webpage-with-puppeteer/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/puppeteer-node.png?fit=730%2C412&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/creating-visuals-of-your-webpage-with-puppeteer/">Creating visuals of your webpage with Puppeteer</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">Chidume Nnamdi</a></span><br>
                    <span class="post-date">Aug 27, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">7 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/creating-visuals-of-your-webpage-with-puppeteer/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/unfavorable-react-keys-unpredictable-behavior/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/unfavorable-react-keys-unpredictable-behavior.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/unfavorable-react-keys-unpredictable-behavior/">Why unfavorable React keys lead to unpredictable behavior</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/sebastianweber/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/03/sebastian-weber.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/03/sebastian-weber.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/03/sebastian-weber.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/sebastianweber/">Sebastian Weber</a></span><br>
                    <span class="post-date">Aug 27, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">8 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/unfavorable-react-keys-unpredictable-behavior/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
            </div>
    <div class="clearfix"></div>
                
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/integrating-stripe-react-stripe-js/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=23939&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.8.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=de9bd49f68bb91e11950125d7d43f6ed499d9be4#parent=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
</div>
</div>        </div>                 
    </div>

    <div class="alertbar"> 
        <div class="container text-center"> 
                    </div>
    </div>

</div><!-- /.site-content -->
        
        <div class="container">
            <footer class="footer"> 
                <div class="pull-left"> Does something seem off? Email <a>support@logrocket.com</a> </div> 
                <div class="pull-right"> <div class = "footerRight">			<div id="jetpack-search-filters-2-wrapper" >
		<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field"
placeholder="Search..."
value="" name="s"
title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>   
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div>  </div> 
                <div class="clearfix"></div>
                <a href="" class="back-to-top hidden-md-down"> 
                <i class="fa fa-angle-up"></i>
                </a>
            </footer>
        </div>
        
<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
};
var current_url = location.pathname;
if (current_url == "/") {
jQuery( "#post-20374 span.readingtime" ).replaceWith( "<span class='readingtime'>12 min read</span>" );
};
</script>	<div style="display:none">
	<div class="grofile-hash-map-4f663587690a2a34c8ed779025635322">
	</div>
	<div class="grofile-hash-map-233e3732883e9b44839aa665c26efb3c">
	</div>
	<div class="grofile-hash-map-dbafebf712fa816299231d2763fd292e">
	</div>
	<div class="grofile-hash-map-4d5ed9a3c839eaaeb055ecc57098a0ae">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/integrating-stripe-react-stripe-js\/":23939};
	</script>
				<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.8.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blog.logrocket.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.5/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.8.2/modules/widgets/search/js/search-widget.js' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.8.2/_inc/build/lazy-images/js/lazy-images.min.js' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.5/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.8.2/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=23939&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.8.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=de9bd49f68bb91e11950125d7d43f6ed499d9be4#parent=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=23939&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.8.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=de9bd49f68bb91e11950125d7d43f6ed499d9be4#parent=https%3A%2F%2Fblog.logrocket.com%2Fintegrating-stripe-react-stripe-js%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202035.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.8.2',blog:'161333275',post:'23939',tz:'-4',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '23939' ]);
</script>
<script>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</script>
            </body>     
</html>
