<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />


<title>Improve async network state handling with custom React Hooks - LogRocket Blog</title>
<meta name="description" content="Follow this guide to see the various states in which network requests exist and how to keep request management within custom React Hooks." />
<link rel="canonical" href="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Improve async network state handling with custom React Hooks - LogRocket Blog" />
<meta property="og:description" content="Follow this guide to see the various states in which network requests exist and how to keep request management within custom React Hooks." />
<meta property="og:url" content="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2021-08-26T14:30:05+00:00" />
<meta property="article:modified_time" content="2021-08-26T12:47:21+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="487" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Caleb Mathew" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="8 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://blog.logrocket.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/#primaryimage","inLanguage":"en-US","url":"https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks.png","contentUrl":"https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks.png","width":730,"height":487,"caption":"Improve Async Network State Handling With Custom React Hooks"},{"@type":"WebPage","@id":"https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/#webpage","url":"https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/","name":"Improve async network state handling with custom React Hooks - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/#primaryimage"},"datePublished":"2021-08-26T14:30:05+00:00","dateModified":"2021-08-26T12:47:21+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/0704dfe030ffff5a1537c69c220aa2fc"},"description":"Follow this guide to see the various states in which network requests exist and how to keep request management within custom React Hooks.","breadcrumb":{"@id":"https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/"]}]},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://blog.logrocket.com/"},{"@type":"ListItem","position":2,"name":"Improve async network state handling with custom React Hooks"}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/0704dfe030ffff5a1537c69c220aa2fc","name":"Caleb Mathew","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/28cfabf2a35cff728dd46032765c8e11?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/28cfabf2a35cff728dd46032765c8e11?s=96&d=mm&r=g","caption":"Caleb Mathew"},"description":"I'm an engineer (currently @Kudi) with over seven years of experience in building software that humans enjoy using. I can be caught playing kickball, watching anime, and listening to hip-hop.","url":"https://blog.logrocket.com/author/caleb-mathew/"}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Improve async network state handling with custom React Hooks Comments Feed" href="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
#start-resizable-editor-section{display:none}.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}#end-resizable-editor-section{display:none}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.0' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.0' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/64282" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-gIO' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<script src="//geoip-js.com/js/apis/geoip2/v2.1/geoip2.js" type="text/javascript"></script>

<script>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</script>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>
function setlrAdwinExpiry(lrAdwin, value, ttl) {
				var now = new Date()

				// `item` is an object which contains the original value
				// as well as the time when it's supposed to expire
				const item = {
					value: 'isSet',
					expiry: now.getTime() + 4665600000,
				}
				localStorage.setItem(lrAdwin, JSON.stringify(item))
				setTimeout(function(){
					analytics.track("lrAdwin", {
  active: "true"
});
    }, 1000);
			}

			function getWithExpiry(lrAdwin) {
				const itemStr = localStorage.getItem(lrAdwin)

				// if the item doesn't exist, return null
				if (!itemStr) {
					return null
				}

				const item = JSON.parse(itemStr)
				const now = new Date()

				// compare the expiry time of the item with the current time
				if (now.getTime() > item.expiry) {
					// If the item is expired, delete the item from storage
					// and return null
					localStorage.removeItem(lrAdwin)
					if (analytics) {					analytics.track("lrAdwin", {
  active: "false"
});}
					return null
				}
				return item.value
			}

			if (!localStorage.getItem('_lr_id_')){
				setlrAdwinExpiry();
			}
			getWithExpiry();
</script>
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://a39e555ed62c408792586c55bbb2ce3b@e.logrocket.com/9').install()
    </script>
<script type="text/javascript">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</script>
<script>

<!-- start vwo -->
      window._vwo_code = window._vwo_code || (function(){
        var account_id=338524,
        settings_tolerance=2000,
        library_tolerance=2500,
        use_existing_jquery=false,
        is_spa=1,
        hide_element='body',

        /* DO NOT EDIT BELOW THIS LINE */
        f=false,d=document,code={use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){
        settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b=hide_element?hide_element+'{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}':'',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&f='+(+is_spa)+'&r='+Math.random());return settings_timer; }};window._vwo_settings_timer = code.init(); return code; }());
<!-- Reddit Pixel -->
!function(w,d){if(!w.rdt){var p=w.rdt=function(){p.sendEvent?p.sendEvent.apply(p,arguments):p.callQueue.push(arguments)};p.callQueue=[];var t=d.createElement("script");t.src="https://www.redditstatic.com/ads/pixel.js",t.async=!0;var s=d.getElementsByTagName("script")[0];s.parentNode.insertBefore(t,s)}}(window,document);rdt('init','t2_3xdvtyx2');rdt('track', 'PageVisit');
<!-- DO NOT MODIFY -->
<!-- End Reddit Pixel -->
    </script><style type='text/css'>img#wpstats{display:none}</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=3cf84a28dc" />
<style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-64282 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="navarea">
<div class="nav-left">
<a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>
<nav class="menu-container">
<div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a><li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">PodRocket</a></ul></div></nav>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Start monitoring for free</a></li>
</ul></div> </div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Improve%20async%20network%20state%20handling%20with%20custom%20React%20Hooks&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks.png&amp;description=Improve%20async%20network%20state%20handling%20with%20custom%20React%20Hooks">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F&amp;title=Improve%20async%20network%20state%20handling%20with%20custom%20React%20Hooks">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-64282 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-react" id="post-64282">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/caleb-mathew/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/04/Caleb-Mathew-Author.png" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/04/Caleb-Mathew-Author.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/04/Caleb-Mathew-Author.png' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/caleb-mathew/">
Caleb Mathew <span class="btn follow">Follow</span></a>
<span class="author-description d-block">I'm an engineer (currently @Kudi) with over seven years of experience in building software that humans enjoy using. I can be caught playing kickball, watching anime, and listening to hip-hop.</span>
</div>
</div>
<h1 class="posttitle">Improve async network state handling with custom React Hooks</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
August 26, 2021 </time></span>
<span class="dot"></span>
<span class="readingtime">6 min read</span>
<span class="wordcount">1798</span>
</p>
</div>
<img width="730" height="487" src="https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="Improve Async Network State Handling With Custom React Hooks" loading="lazy" data-attachment-id="64290" data-permalink="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/improve-async-network-state-handling-custom-react-hooks-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks.png" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Improve async network state handling custom react hooks" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks-300x200.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks-300x200.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/08/improve-async-network-state-handling-custom-react-hooks.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> <article class="article-post">
<div class='code-block code-block-40' style='margin: 8px 0; clear: both;'>
<div class="top-level-cta" style="margin-bottom: 20px;font-style: italic; background: #F0F0F0; padding: 15px; border-left: 3px solid #808080;">Are you wondering why we publish all this free content that you always seem to stumble on when Googling stuff? Simple: trials! <br>If you’re enjoying LogRocket’s blog, we bet you’ll love our product. LogRocket helps you reproduce bugs more quickly, understand frontend performance issues, and see exactly how users interact with your React apps. Try <a href="https://logrocket.com/signup">LogRocket Pro for free</a> for 14 days.</div></div>
<p>React offers us flexibility in how we choose to address problems (such as state, network, and style management) within our apps. A great codebase has problem spots identified and addressed with a reproducible pattern that is standard and consistent.</p>
<p>And, as frontend engineers, it’s crucial to properly relay information about changes in network state to the user, as most apps we build need to interact with one or more servers. We can accomplish these goals by using custom <a href="https://reactjs.org/docs/hooks-intro.html" target="_blank" rel="noopener">React Hooks</a>.</p>
<p>In this article, I’ll cover the various states that network requests exist in and show you how to keep request management within custom Hooks. I’ll also walk you through building a small app that employs these Hooks.</p>
<h2>What is a network request?</h2>
<p>A network request typically exists in these states:</p>
<ul>
<li><code>idle</code></li>
<li><code>loading/processing/in-flight</code></li>
<li><code>success</code></li>
<li><code>error</code></li>
</ul>
<p>The <code>idle</code> network request state is the default (and ending) phase for a network request. During the <code>loading</code> phase, the client <a href="https://docs.oracle.com/cd/E19683-01/806-4075/ipov-100/index.html" target="_blank" rel="noopener">waits for acknowledgment and packets from the server</a>, then transitions into either the <code>success</code> or <code>error</code> state.</p>
<figure id="attachment_64292" aria-describedby="caption-attachment-64292" style="width: 730px" class="wp-caption aligncenter"><img data-attachment-id="64292" data-permalink="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/network-state-diagram/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram.png" data-orig-size="730,456" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Network state diagram" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram-300x187.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram.png" loading="lazy" class="wp-image-64292 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram.png" alt="Diagram Demonstrating The Network Request Process" width="730" height="456" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram-300x187.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="64292" data-permalink="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/network-state-diagram/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram.png" data-orig-size="730,456" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Network state diagram" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram-300x187.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram.png" loading="lazy" class="wp-image-64292 size-full" src="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram.png" alt="Diagram Demonstrating The Network Request Process" width="730" height="456" srcset="https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/08/network-state-diagram-300x187.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript><figcaption id="caption-attachment-64292" class="wp-caption-text">Network state transitions.</figcaption></figure>
<h2>Localizing network requests using custom React Hooks</h2>
<p>To keep network requests testable and decoupled from business logic, it’s best to manage requests with custom Hooks. This keeps your code lean and makes it easy to perform special one-off operations like data transformations on network responses.</p>
<p>For example, a request to fetch a list of blog posts can be kept in a <code>usePostsQuery</code> custom Hook, just like the one below:</p>
<pre>import { useState, useEffect } from 'react'

const api = {
  GET: async (url) =&gt; {
    const response = await fetch(url);
    const data = await response.json();
    return data;
  }
} 

export default function usePostsQuery() {
  const [error, setError] = useState()
  const [status, setStatus] = useState('idle')
  const [data, setData] =useState()

  const startFetch = async () =&gt; {
    try {
      let data = await api.GET('/posts')

      setError()
      setStatus('success')
      setData(data)
    } catch (error) {
      setError(error)
      setStatus('error')
    }
  }

  useEffect(() =&gt; {
    startFetch()
  }, []);  

  return {
    data,
    error,
    isSuccess: status === 'success',
    isError: status === 'error'
    refetch: startFetch
  }
}
</pre>
<p>This Hook can be made even more concise <a href="https://blog.logrocket.com/building-multi-step-wizards-with-formik-and-react-query/" target="_blank" rel="noopener">by leveraging React Query</a> (my preferred tool):</p>
<pre>import { useQuery } from "react-query";

export default function usePostsQuery() {
  return useQuery("posts", () =&gt;
    api.GET("/posts")
  );
}
</pre>
<h2>Creating the project</h2>
<p>Let’s build a small app called <code>Betflix</code>, <a href="https://betflix.netlify.app" target="_blank" rel="noopener">which you can both visit</a> and <a href="https://github.com/creatrixity/betflix" target="_blank" rel="noopener">clone</a>. This app will allow friends to choose sports teams from a set of fixtures and make predictions.</p>
<blockquote><p><strong>Note</strong>: For the sake of brevity, I’ll skip explaining the more mundane components used in this proof-of-concept. You are welcome to explore the <a href="https://github.com/creatrixity/betflix/" target="_blank" rel="noopener">entire code for this</a>.</p></blockquote>
<p><img data-attachment-id="64294" data-permalink="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/betflix-app-creation/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation.png" data-orig-size="730,415" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Betflix app creation" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation-300x171.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation.png" loading="lazy" class="aligncenter size-full wp-image-64294 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation.png" alt="Betflix App Showing Sport Teams To Be Chosen" width="730" height="415" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation-300x171.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="64294" data-permalink="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/betflix-app-creation/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation.png" data-orig-size="730,415" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Betflix app creation" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation-300x171.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation.png" loading="lazy" class="aligncenter size-full wp-image-64294" src="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation.png" alt="Betflix App Showing Sport Teams To Be Chosen" width="730" height="415" srcset="https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/08/betflix-app-creation-300x171.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br />No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>
<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>
<p>First of all, we’ll create a new React project and start the development server:</p>
<pre class="language-bash hljs">npx create-react-app betflix
cd betflix
npm start
</pre>
<p>We need to install dependencies for HTTP requests, a serverless function proxying, and a managed database (to keep fixtures and other records).</p>
<pre class="language-bash hljs">npm install react-query react-toast-notifications http-proxy-middleware @supabase/supabase-js --save
</pre>
<p>I’ll also include Netlify Lambda and CLI as development dependencies.</p>
<pre class="language-bash hljs">npm install netlify-lambda netlify -D
</pre>
<p>By the time we are done, you should have a directory structure like the one below.</p>
<p><img data-attachment-id="64298" data-permalink="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/directory-structure-betflix/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix.png" data-orig-size="730,1405" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Directory structure betflix" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix-156x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix-532x1024.png" loading="lazy" class="aligncenter size-full wp-image-64298 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix.png" alt="Betflix&#039;s Directory Structure Displaying Various Folders" width="730" height="1405" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix-156x300.png 156w, https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix-532x1024.png 532w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="64298" data-permalink="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/directory-structure-betflix/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix.png" data-orig-size="730,1405" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Directory structure betflix" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix-156x300.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix-532x1024.png" loading="lazy" class="aligncenter size-full wp-image-64298" src="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix.png" alt="Betflix's Directory Structure Displaying Various Folders" width="730" height="1405" srcset="https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix-156x300.png 156w, https://blog.logrocket.com/wp-content/uploads/2021/08/directory-structure-betflix-532x1024.png 532w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<h2>Displaying the fixtures list with custom React Hooks</h2>
<p>We’ll update the <code>&lt;App /&gt;</code> component to display a list of fixtures fetched from the serverless backend. We’ll be creating and handling requests for a list of bets and a list of fixtures in a sequential fashion.</p>
<pre>import "./App.css";

import Fixture from "./components/Fixture";
import Loader from "./components/Loader";

import useBetsQuery from "./hooks/queries/useBetsQuery";
import useFixturesQuery from "./hooks/queries/useFixturesQuery";

function App() {
  const { data, isLoading, isError } = useFixturesQuery();
  const {
    data: bets,
    isLoading: betsLoading,
    isError: betsErrored,
  } = useBetsQuery();

  if (isLoading || betsLoading) return &lt;Loader /&gt;;
  if (isError || betsErrored)
    return &lt;p&gt;We encountered an error fetching data&lt;/p&gt;;

  const sortFixtures = (fixtureA, fixtureB) =&gt; {
    return (
      bets.hasOwnProperty(fixtureB.fixture.id) -
        bets.hasOwnProperty(fixtureA.fixture.id) ||
      fixtureB.fixture.status.elapsed - fixtureA.fixture.status.elapsed
    );
  };

  return (
    &lt;div className="App"&gt;
      &lt;header className="App-header"&gt;
        &lt;h1 className="App-header__title"&gt;Upcoming fixtures&lt;/h1&gt;
      &lt;/header&gt;
      &lt;section className="Fixtures"&gt;
        {data.results.response.length ? (
          &lt;&gt;
            {data.results.response
              .sort(sortFixtures)
              .map(({ fixture, teams: { away, home } }) =&gt; (
                &lt;Fixture
                  key={fixture.id}
                  fixture={fixture}
                  away={away}
                  home={home}
                  isBetPlaced={bets.hasOwnProperty(fixture.id)}
                  defaultSelectedTeam={bets[fixture.id].choice}
                  defaultAmount={bets[fixture.id].amount}
                /&gt;
              ))}
          &lt;/&gt;
        ) : (
          &lt;div&gt;No fixtures at the moment&lt;/div&gt;
        )}
      &lt;/section&gt;
    &lt;/div&gt;
  );
}

export default App;
</pre>
<p>From the code above, we have declared dependencies on <code>useBetsQuery</code> and <code>useFixturesQuery</code>, so we’ll now define them.</p>
<p><code>useBetsQuery</code> is a custom Hook used to fetch and transform a list of bets into a map of keyed objects that we can use to track the bet status of a fixture.</p>
<p>Let’s create <code>useBetsQuery.js</code> in <code>/src/hooks/queries</code> and update it:</p>
<pre>import { useQuery } from "react-query";

const ENDPOINT = "/.netlify/functions/fetchBets";

// Normalize the bets payload into a keyed map with `fixture_id` as the key
function normalizeBets(betsList) {
  return betsList.reduce(
    (acc, curr) =&gt; ({
      ...acc,
      [curr.fixture_id]: curr,
    }),
    {}
  );
}

// Because we'll use the fetch API (instead of Axios), we need to explicitly return a 
// Promise when an error occurs so React Query can change the status.
const getBets = async (url) =&gt; {
  const response = await fetch(url);
  const data = await response.json();
  if (response.ok) {
    return normalizeBets(data.results);
  }
  return Promise.reject(new Error(data.message));
};

export default function useBetsQuery() {
  return useQuery("bets", () =&gt; getBets(ENDPOINT));
}
</pre>
<p>With that done, we also need to create the custom Hook where we’ll be fetching. Create the <code>useFixturesQuery.js</code> hook in <code>src/hooks/queries</code> and add the code below:</p>
<pre>import { useQuery } from "react-query";

const getFixtures = async (url) =&gt; {
  const response = await fetch(url);
  const data = await response.json();
  return data;
};

export default function useFixturesQuery() {
  return useQuery("fixtures", () =&gt;
    getFixtures("/.netlify/functions/fetchFixtures")
  );
}
</pre>
<p>We’re now ready to define the component that will display information about the individual fixture.</p>
<h2>Creating the <code>&lt;Fixture /&gt;</code> component</h2>
<p>We’ll create the <code>&lt;Fixture/&gt;</code> component in <code>src/components/Fixture.js</code> and display information about the home and away teams. We also introduce two new React Hooks, the <code>useMutationNotification</code> and <code>usePlaceBetMutation</code> Hooks.</p>
<p><code>useMutationNotification</code> is an interesting custom Hook that allows us to handle network state changes in a predictable ergonomic manner so we can provide feedback on user-initiated actions straight away.</p>
<pre>import { useEffect, useState } from "react";
import { useToasts } from "react-toast-notifications";
import { ReactComponent as ArrowLeft } from "../assets/svg/arrowLeft.svg";
import { ReactComponent as ChevronRight } from "../assets/svg/chevronRight.svg";
import TeamCard from "./TeamCard";
import FormInput from "./FormInput";
import useMutationNotification from "../hooks/useMutationNotification";
import usePlaceBetMutation from "../hooks/queries/usePlaceBetMutation";
import Loader from "./Loader";

function Fixture({
  fixture,
  away,
  home,
  isBetPlaced,
  defaultAmount,
  defaultSelectedTeam,
}) {
  const [amount, setAmount] = useState(defaultAmount || 0);
  const [selectedTeam, setSelectedTeam] = useState(defaultSelectedTeam);
  const [betPlaced, setBetPlaced] = useState(isBetPlaced);
  const { addToast } = useToasts();
  const [doPlaceBetRequest, placeBetState] = usePlaceBetMutation();

  useMutationNotification({
    ...placeBetState,
    useServerMessage: false,
    entity: "bet",
    actionType: "place",
  });
  useEffect(() =&gt; {
    if (placeBetState.isSuccess) setBetPlaced(true);
  }, [placeBetState.isSuccess]);
  const teams = {
    away,
    home,
  };

  const status = !fixture.status.elapsed ? "Up next" : "In progress";

  const doAmountUpdate = (e) =&gt; setAmount(e.target.value);
  const doTeamUpdate = (team) =&gt; {
    if (betPlaced) return;
    setSelectedTeam(team);
  };
  const doPlaceBet = () =&gt; {
    if (!selectedTeam || amount &lt;= 0) {
      addToast("Please select a team and add an amount", {
        appearance: "info",
        autoDismiss: true,
      });
      return;
    }
    doPlaceBetRequest({
      amount,
      choice: selectedTeam,
      fixture_id: fixture.id,
    });
  };

  return (
    &lt;div className="Fixture"&gt;
      &lt;section className="Fixture__teams"&gt;
        &lt;TeamCard
          name={home.name}
          logo={home.logo}
          id={home.id}
          type={"home"}
          selected={selectedTeam === "home"}
          onTeamChange={doTeamUpdate}
        /&gt;
        &lt;div className="Fixture__separator"&gt;vs&lt;/div&gt;
        &lt;TeamCard
          name={away.name}
          logo={away.logo}
          id={away.id}
          type={"away"}
          selected={selectedTeam === "away"}
          onTeamChange={doTeamUpdate}
        /&gt;
      &lt;/section&gt;

      {!betPlaced ? (
        &lt;&gt;
          &lt;section className="Fixture__controls"&gt;
            &lt;div className="Fixture__control"&gt;
              &lt;FormInput
                label={"Amount"}
                name={`amount-${fixture.id}`}
                type="number"
                value={amount}
                onChange={doAmountUpdate}
              /&gt;
            &lt;/div&gt;
            &lt;div className="Fixture__controls__separator"&gt;
              &lt;ArrowLeft /&gt;
            &lt;/div&gt;
            &lt;div className="Fixture__control"&gt;
              &lt;FormInput
                label={"Potential Winnings"}
                name={`potential-winnings-${fixture.id}`}
                value={amount * 2 || 0}
                disabled
              /&gt;
            &lt;/div&gt;
          &lt;/section&gt;
          &lt;section className="Fixture__footer"&gt;
            &lt;div className="Fixture__status"&gt;
              &lt;span className="Fixture__status__dot"&gt;&lt;/span&gt;
              {status}
            &lt;/div&gt;
            {!placeBetState.isLoading ? (
              &lt;button className="Button" onClick={doPlaceBet}&gt;
                Place bet &lt;ChevronRight /&gt;
              &lt;/button&gt;
            ) : (
              &lt;Loader /&gt;
            )}
          &lt;/section&gt;
        &lt;/&gt;
      ) : (
        &lt;section className="Fixture__controls"&gt;
          &lt;p&gt;
            You placed a &lt;b&gt;${amount}&lt;/b&gt; bet on{" "}
            &lt;b className="u-text-primary"&gt;{teams[selectedTeam]?.name}&lt;/b&gt; to
            potentially win &lt;b className="u-text-primary"&gt;${amount * 2}&lt;/b&gt;
          &lt;/p&gt;
        &lt;/section&gt;
      )}
    &lt;/div&gt;
  );
}

Fixture.defaultProps = {
  isBetPlaced: false,
};

export default Fixture;
</pre>
<p>In the code above, we declared dependencies on a few Hooks.</p>
<p><code>useMutationNotification</code> will accept the network request status options (<code>isError</code> and <code>isSuccess</code>) and will allow us to either show the error message from the server (if we set <code>useServerMessage</code> to <code>true</code>) or pass <code>entity</code> and <code>actionType</code> strings in to provide a generic message to the user.</p>
<p>Let’s create <code>useMutationNotification.js</code> in <code>src/hooks</code> and update it with the code below:</p>
<pre>import { useEffect, useState } from "react";
import useShowToast from "./useShowToast";

function capFirst(string) {
  return string.charAt(0).toUpperCase() + string.slice(1);
}

function useMutationNotification({
  isError,
  isSuccess,
  actionType = "create",
  entity,
  data,
  error,
  useServerMessage = true,
}) {
  const [notificationConfig, setNotificationConfig] = useState(null);
  const showToast = useShowToast();

  useEffect(() =&gt; {
    if (isError) {
      setNotificationConfig({
        type: "error",
        message: useServerMessage
          ? error.message
          : `${entity} could not be ${actionType}d`,
      });
    }
  }, [
    useServerMessage,
    isError,
    setNotificationConfig,
    entity,
    actionType,
    error,
  ]);

  useEffect(() =&gt; {
    if (isSuccess) {
      setNotificationConfig({
        type: "success",
        message: useServerMessage
          ? data.message
          : `${entity} successfully ${actionType}d`,
      });
    }
  }, [
    useServerMessage,
    isSuccess,
    setNotificationConfig,
    entity,
    actionType,
    data,
  ]);

  useEffect(() =&gt; {
    if (notificationConfig) {
      const { type, message } = notificationConfig;
      showToast({ type, message: capFirst(message) });
    }
  }, [notificationConfig, showToast]);
}

export default useMutationNotification;
</pre>
<p>We’ll then define the <code>usePlaceBet</code> mutation we intend to use in placing the bet. We’ll return the mutation action and its state. Create <code>usePlaceBetMutation</code> in <code>src/hooks/queries</code> and update it to the following code:</p>
<pre>import { useMutation } from "react-query";

const ENDPOINT = "/.netlify/functions/placeBet";

export default function usePlaceBetMutation() {
  const request = async (payload) =&gt; {
    const res = await fetch(ENDPOINT, {
      method: "POST",
      body: JSON.stringify(payload),
    });
    const data = await res.json();
    if (!res.ok) return Promise.reject(new Error(data.message));
    return data;
  };
  const { mutate, ...mutationState } = useMutation(request);
  return [mutate, mutationState];
}
</pre>
<p>With these updates made, we can now handle network state changes for mutations in simple, easy-to-read fashion.</p>
<p><img data-attachment-id="64300" data-permalink="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/updated-betflix-app/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app.png" data-orig-size="730,428" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Updated betflix app" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app-300x176.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app.png" loading="lazy" class="aligncenter size-full wp-image-64300 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app.png" alt="Betflix App Showing Sport Teams To Be Chosen" width="730" height="428" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app-300x176.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="64300" data-permalink="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/updated-betflix-app/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app.png" data-orig-size="730,428" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Updated betflix app" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app-300x176.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app.png" loading="lazy" class="aligncenter size-full wp-image-64300" src="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app.png" alt="Betflix App Showing Sport Teams To Be Chosen" width="730" height="428" srcset="https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/08/updated-betflix-app-300x176.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p>
<h2>Conclusion</h2>
<p>Reacting to network state changes can be challenging, but it’s also a massive opportunity to provide users with a much more meaningful experience.</p>
<p>You can check out the <a href="https://react-query.tanstack.com/quick-start" target="_blank" rel="noopener">React Query</a> documentation to learn more about enhancing the network state experience for your users when building React applications. You can find the full source code for this demo proof-of-concept on <a href="https://github.com/creatrixity/betflix" target="_blank" rel="noopener">GitHub</a>.</p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<div class="blog-plug inline-plug react-plug"><h2>Full visibility into production React apps</h2> Debugging React applications can be difficult, especially when users experience issues that are hard to reproduce. If you’re interested in monitoring and tracking Redux state, automatically surfacing JavaScript errors, and tracking slow network requests and component load time, <a href="https://www2.logrocket.com/react-performance-monitoring" target="_blank">try LogRocket</a>. <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png" data-lazy-src="https://files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://files.readme.io/27c94e7-Image_2017-06-05_at_9.46.04_PM.png" /></noscript></a><a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" /></noscript></a><p style="margin-top: 15px;"><a href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web apps, recording literally everything that happens on your React app. Instead of guessing why problems happen, you can aggregate and report on what state your application was in when an issue occurred. LogRocket also monitors your app's performance, reporting with metrics like client CPU load, client memory usage, and more.</p><p>The LogRocket Redux middleware package adds an extra layer of visibility into your user sessions. LogRocket logs all actions and state from your Redux stores. </p><p>Modernize how you debug your React apps — <a class="signup" href="https://www2.logrocket.com/react-performance-monitoring" target="_blank" rel="noopener noreferrer">start monitoring for free</a>.</p></div>
<style>
.plug-poll {margin-bottom: 2rem;}
.code-block-3 .fadeIn {
    opacity:1 !important;
    height:auto !important;
}

.code-block-3 .fadeOut {
    opacity:0 !important;
}

.code-block-3 .wpcf7-email {margin: 15px 0;}

#plug-survey-errors, #plug-survey-help, #plug-survey-email  {opacity:0; height:1px; transition: all 1s;overflow:hidden; width: 100%;}

</style>
<script>
  jQuery("#plug-survey-framework input").click(function() {
  analytics.track('footer-poll', {
      'footer-poll-framework': jQuery(this).val()
    });
    jQuery('#plug-survey-framework').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-errors').delay(800).addClass('fadeIn');
  });
    jQuery("#plug-survey-errors input").click(function() {
    jQuery('#plug-survey-errors').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-help').delay(800).addClass('fadeIn');
  });
  
      jQuery("#plug-survey-help input").click(function() {
        analytics.track('footer-poll', {
      'footer-poll-help': jQuery(this).val()
    });
    jQuery('#plug-survey-help').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-email').delay(800).addClass('fadeIn');
  });
  
  </script>
</div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-64282" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-64282" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-64282" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/improve-async-network-state-handling-custom-react-hooks/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/04/Caleb-Mathew-Author.png" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/04/Caleb-Mathew-Author.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/04/Caleb-Mathew-Author.png' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/caleb-mathew/">
Caleb Mathew <span class="btn follow">Follow</span></a>
<span class="author-description d-block">I'm an engineer (currently @Kudi) with over seven years of experience in building software that humans enjoy using. I can be caught playing kickball, watching anime, and listening to hip-hop.</span>
</div>
</div>
<div class="after-post-tags">
 <ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/react/">#react</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/why-scrum-is-becoming-irrelevant/" rel="prev">Why scrum has become irrelevant</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/how-to-build-responsive-navbar-tailwind-css/" rel="next">How to build a responsive navbar in Tailwind CSS</a> &raquo;</div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/intro-flutter-stack-widget/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/08/intro-flutter-stack-widget.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/intro-flutter-stack-widget/">Intro to the Flutter Stack widget</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/lewiscianci/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/07/Lewis-Cianci-e1627401031826-150x150.jpeg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/07/Lewis-Cianci-e1627401031826-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/07/Lewis-Cianci-e1627401031826-150x150.jpeg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/lewiscianci/">Lewis Cianci</a></span><br>
<span class="post-date">Aug 26, 2021</span>
<span class="dot"></span>
<span class="readingtime">5 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/intro-flutter-stack-widget/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/understanding-javascript-currying/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/08/understanding-javascript-currying.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/understanding-javascript-currying/">Understanding JavaScript currying</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/ezekiellawson/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/08/ezekiel-lawson2-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/08/ezekiel-lawson2-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/08/ezekiel-lawson2-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/ezekiellawson/">Ezekiel Lawson</a></span><br>
<span class="post-date">Aug 26, 2021</span>
<span class="dot"></span>
<span class="readingtime">5 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/understanding-javascript-currying/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/how-to-build-responsive-navbar-tailwind-css/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/08/Building-responsive-navbar-tailwindcss.jpg);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/how-to-build-responsive-navbar-tailwind-css/">How to build a responsive navbar in Tailwind CSS</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/hulyakarakaya/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/07/1530813605455-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/07/1530813605455-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/07/1530813605455-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/hulyakarakaya/">Hulya Karakaya</a></span><br>
<span class="post-date">Aug 26, 2021</span>
<span class="dot"></span>
<span class="readingtime">7 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/how-to-build-responsive-navbar-tailwind-css/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/improve-async-network-state-handling-custom-react-hooks/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=64282&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.0&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=8259b716223d005844447fee9dc01f7d0af2ef58#parent=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="footerRight"><style>

	.footer .container{padding:20px 20px 10px 20px; color:white !important;}

	.footer .grid{
		display: grid;
		grid-template: auto auto auto / 150px auto;
		height:100%;
		grid-gap:20px;
		justify-items: left;
		align-items: center;
		font-family: 'PT Sans';
		padding:40px;
		background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/podrocket_slider_bg.png");
		background-position: center;
		background-repeat: no-repeat;
		background-size:cover;
		border-radius:30px;
		/* box-shadow: 0px 50px 120px 0px #2024734d; */
	}

	.footer .grid2{background-image: url('https://blog.logrocket.com/wp-content/uploads/2021/07/podrocket_slider_bg_v3.png');}

	.footer .epname{color:white !important; font-size: 24px;font-weight:700;}
	.footer .desc{color:white !important; font-size: 16px;align-self:start;}

	.footer .epname2{color:#202473 !important;}
	.footer .desc2{color:#383f4D !important;}

	.footer .info{
		font-weight:700;
		font-size: 13px;
		padding: 5px 10px 5px 10px;
		margin-bottom:10px;
		background-color: #ffffff;
		text-transform: uppercase;
		color:#202473;
		display:flex;
		width: 160px !important;
		border-radius:20px;
		letter-spacing: 1px;
	}

	.footer .info2{background-color:#202473; color:white;}

	.footer .a{grid-area: 1 / 1 / span 1 / span 1;}
	.footer .b{grid-area: 1 / 2 / span 1 / span 1;}
	.footer .cd{grid-area: 2 / 1 / span 1 / span 2;}
	.footer .ef{grid-area: 3 / 1 / span 1 / span 2; justify-self: start;}

	.footer .cta{
		font-weight: 700;
		font-size: 20px;
		text-transform: uppercase;
		padding: 15px 40px 15px 40px;
		background-color: white;
		color: #202473;
		letter-spacing: 1px;
		border: 0px;
		border-radius: 45px;
		transition: 400ms;
	}

	.footer .cta:hover{
		box-shadow: 0px 20px 40px 0px rgba(255,255,255,0.2);
		transition: 400ms;
	}

	.footer .cta2{background-color:#202473; color:white !important;}
	.footer .cta2:hover{box-shadow: 0px 20px 40px 0px #20247333;}

	.avatar1 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_rome.png");border-radius: 0px !important;}
	.avatar2 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_rocket-surgery.png");border-radius: 100%;}
	.avatar3 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_mark-erikson.png");border-radius: 100%;}
	.avatar4 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_continuing-education.png");border-radius: 100%;}

	.footer .avatar{
		width:150px;
		height:150px;
		
		background-position: center;
		background-repeat: no-repeat;
		background-size:cover;
		z-index: 99;
		/* box-shadow: 0px 36px 50px 0px rgba(32,36,115,0.75); */
	}

	.avatar_light{box-shadow: 0px 36px 50px 0px rgba(32,36,115,0.2);}

	.footer .owl-stage-outer a{
		text-decoration:none !important;
		color: #202473 !important;
	}

	@media only screen and (max-width: 900px){
		
		.footer .container{padding:10px;}

		.footer .grid{
			display: grid;
			grid-template: 150px auto auto auto / auto;
			padding:30px;
			border-radius:20px;
			grid-gap:14px;
		}

		.footer .a{grid-area: 1 / 1 / span 1 / span 1;}
		.footer .b{grid-area: 2 / 1 / span 1 / span 1;}
		.footer .cd{grid-area: 3 / 1 / span 1 / span 1;}
		.footer .ef{grid-area: 4 / 1 / span 1 / span 1; justify-self: start;}

		.footer .cta{font-size:16px; padding: 10px 20px 10px 20px;}
		.footer .epname{font-size: 20px;}
		.footer .desc{font-size: 14px;}
		
	}

</style>
<h2>Have you listened to our podcast? Check it out:</h2>
<div class='white' style='background:rgb(255, 255, 255); border:solid 0px #f0f0f0; border-radius:20px; padding:0px 0px 0px 0px;'>
<div id='sample_slider' class='owl-carousel sa_owl_theme owl-pagination-true' data-slider-id='sample_slider' style='visibility:hidden;'>
<div id='sample_slider_slide01' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid">
<div class="a"><div class="avatar avatar1"></div></div>
<div class="b">
<span class="info">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 34</span>
</span>
<span class="epname">Rome and Rome Tools, Inc. with Sebastian McKenzie and Jamie Kyle</span>
</div>
<div class="cd desc">In this episode, Ben and Kaelan talk to Sebastian McKenzie and Jamie Kyle about Rome Tools, Inc., the roadmap for Rome, and the experience of getting funding as an open-source tool.</div>
<a href="https://podrocket.logrocket.com/rome" class="ef cta">Listen now</a>
</div>
</div></div>
<div id='sample_slider_slide02' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid grid2">
<div class="a"><div class="avatar avatar_light avatar2"></div></div>
<div class="b">
<span class="info info2">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 30</span>
</span>
<span class="epname epname2">Rocket Surgery: Kaelan and Chris Coyier compare notes</span>
</div>
<div class="cd desc desc2">Are you up to speed on all of this new CSS stuff? Chris Coyier and Kaelan compare notes on CSS and frontend development (they also discuss MDN plus).</div>
<a href="https://podrocket.logrocket.com/css" class="ef cta cta2" style="color: white !important;">Listen now</a>
</div>
</div></div>
<div id='sample_slider_slide03' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid">
<div class="a"><div class="avatar avatar3"></div></div>
<div class="b">
<span class="info">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 26</span>
</span>
<span class="epname">Redux is alive and well with Mark Erikson</span>
</div>
<div class="cd desc">What is modern Redux? What is it with the obsession of declaring Redux dead? In this episode, Ben and Brian interview Mark Erikson to talk about all things Redux.</div>
<a href="https://podrocket.logrocket.com/redux" class="ef cta">Listen now</a>
</div>
</div></div>
<div id='sample_slider_slide04' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid grid2">
<div class="a"><div class="avatar avatar_light avatar4"></div></div>
<div class="b">
<span class="info info2">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 29</span>
</span>
<span class="epname epname2">Continuing education with Eve Porcello</span>
</div>
<div class="cd desc desc2">In this episode, we talk to Eve Porcello about her experience teaching web development and Moon Highway, a training and curriculum development company she runs.</div>
<a href="https://podrocket.logrocket.com/continuing-education" class="ef cta cta2" style="color: white !important;">Listen now</a>
</div>
</div></div>
</div>
</div>
<script type='text/javascript'>
	document.addEventListener('DOMContentLoaded', function() {
		jQuery('#sample_slider').owlCarousel({
			responsive:{
				0:{ items:1 },
				480:{ items:1 },
				768:{ items:2 },
				980:{ items:2 },
				1200:{ items:2 },
				1500:{ items:2 }
			},
			autoplay : false,
			autoplayHoverPause : false,
			smartSpeed : 300,
			fluidSpeed : 300,
			autoplaySpeed : 300,
			navSpeed : 300,
			dotsSpeed : 300,
			loop : true,
			nav : true,
			navText : ['Previous','Next'],
			dots : true,
			responsiveRefreshRate : 200,
			slideBy : 1,
			mergeFit : true,
			autoHeight : false,
			mouseDrag : false,
			touchDrag : true
		});
		jQuery('#sample_slider').css('visibility', 'visible');
		var owl_goto = jQuery('#sample_slider');
		jQuery('.sample_slider_goto1').click(function(event){
			owl_goto.trigger('to.owl.carousel', 0);
		});
		jQuery('.sample_slider_goto2').click(function(event){
			owl_goto.trigger('to.owl.carousel', 1);
		});
		jQuery('.sample_slider_goto3').click(function(event){
			owl_goto.trigger('to.owl.carousel', 2);
		});
		jQuery('.sample_slider_goto4').click(function(event){
			owl_goto.trigger('to.owl.carousel', 3);
		});
		var resize_59470 = jQuery('.owl-carousel');
		resize_59470.on('initialized.owl.carousel', function(e) {
			if (typeof(Event) === 'function') {
				window.dispatchEvent(new Event('resize'));
			} else {
				var evt = window.document.createEvent('UIEvents');
				evt.initUIEvent('resize', true, false, window, 0);
				window.dispatchEvent(evt);
			}
		});
	});
</script>
</div><div class="footerRight"> <div id="jetpack-search-filters-2-wrapper">
<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div> <div class="clearfix"></div>
<a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202134'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text(),
	postAuthor: jQuery("meta[name='twitter:data1']").attr("content"),
	id: jQuery(".mainheading").closest(".col-md-8").attr("id").replace('post-','')
  });
}
jQuery(".aretags li a:contains('archive')").parent('li').hide();
jQuery(".aretags li a:contains('86919')").parent('li').hide();
jQuery(".aretags li a:contains('72293')").parent('li').hide();
};</script> <div style="display:none">
<div class="grofile-hash-map-28cfabf2a35cff728dd46032765c8e11">
</div>
<div class="grofile-hash-map-ab45af79c41efd4bad88b0df8dfcbdb9">
</div>
<div class="grofile-hash-map-a18355d33f8b4524b0788099f4bb1f45">
</div>
<div class="grofile-hash-map-8c6e43037fd738e10af58cd9b25a85e3">
</div>
</div>
<div id="jp-carousel-loading-overlay">
<div id="jp-carousel-loading-wrapper">
<span id="jp-carousel-library-loading">&nbsp;</span>
</div>
</div>
<div class="jp-carousel-overlay" style="display: none;">
<div class="jp-carousel-container">

<div class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions" itemscope itemtype="https://schema.org/ImageGallery">
<div class="jp-carousel swiper-wrapper"></div>
<div class="jp-swiper-button-prev swiper-button-prev">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white" />
</mask>
<g mask="url(#maskPrev)">
<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
<div class="jp-swiper-button-next swiper-button-next">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white" />
</mask>
<g mask="url(#maskNext)">
<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
</div>

<div class="jp-carousel-close-hint">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white" />
</mask>
<g mask="url(#maskClose)">
<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>

<div class="jp-carousel-info">
<div class="jp-carousel-info-footer">
<div class="jp-carousel-pagination-container">
<div class="jp-swiper-pagination swiper-pagination"></div>
<div class="jp-carousel-pagination"></div>
</div>
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-caption"></h2>
</div>
<div class="jp-carousel-photo-icons-container">
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white" />
</mask>
<g mask="url(#maskInfo)">
<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</span>
</a>
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white" />
</mask>
<g mask="url(#maskComments)">
<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
</span>
</a>
</div>
</div>
<div class="jp-carousel-info-extra">
<div class="jp-carousel-info-content-wrapper">
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-title"></h2>
</div>
<div class="jp-carousel-comments-wrapper">
<div id="jp-carousel-comments-loading">
<span>Loading Comments...</span>
</div>
<div class="jp-carousel-comments"></div>
<div id="jp-carousel-comment-form-container">
<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
<div id="jp-carousel-comment-post-results"></div>
<form id="jp-carousel-comment-form">
<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
<textarea name="comment" class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea" id="jp-carousel-comment-form-comment-field" placeholder="Write a Comment..."></textarea>
<div id="jp-carousel-comment-form-submit-and-info-wrapper">
<div id="jp-carousel-comment-form-commenting-as">
<fieldset>
<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-url-field">Website</label>
<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
</fieldset>
</div>
<input type="submit" name="submit" class="jp-carousel-comment-form-button" id="jp-carousel-comment-form-button-submit" value="Post Comment" />
</div>
</form>
</div>
</div>
<div class="jp-carousel-image-meta">
<div class="jp-carousel-title-and-caption">
<div class="jp-carousel-photo-info">
<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
</div>
<div class="jp-carousel-photo-description"></div>
</div>
<ul class="jp-carousel-image-exif" style="display: none;"></ul>
<a class="jp-carousel-image-download" target="_blank" style="display: none;">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white" />
</mask>
<g mask="url(#mask0)">
<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-download-text"></span>
</a>
<div class="jp-carousel-image-map" style="display: none;"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/improve-async-network-state-handling-custom-react-hooks\/":64282};
	</script>
<link rel='stylesheet' id='owl_carousel_css-css' href='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/owl.carousel.css?ver=2.2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='owl_theme_css-css' href='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/sa-owl-theme.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='owl_animate_css-css' href='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/animate.min.css?ver=2.0' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=5.8' id='comment-reply-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/modules/widgets/search/js/search-widget.js?ver=10.0' id='jetpack-search-widget-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/../dist/intersection-observer.js?ver=1.1.3' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/../dist/lazy-images.js?ver=1.1.3' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/wp-embed.min.js?ver=5.8' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/blog.logrocket.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"7bc5d04644","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=10.0' id='jetpack-carousel-js'></script>
<script defer type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.11' id='akismet-form-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/owl.carousel.min.js?ver=2.2.1' id='owl_carousel_js-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/slide-anything/js/jquery.mousewheel.min.js?ver=3.1.13' id='mousewheel_js-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.0' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=64282&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.0&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=8259b716223d005844447fee9dc01f7d0af2ef58#parent=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=64282&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.0&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=8259b716223d005844447fee9dc01f7d0af2ef58#parent=https%3A%2F%2Fblog.logrocket.com%2Fimprove-async-network-state-handling-custom-react-hooks%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202134.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.0',blog:'161333275',post:'64282',tz:'-4',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '64282' ]);
</script>
<script>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</script>
</body>
</html>

