<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v14.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Getting started with TypeScript generics - LogRocket Blog</title>
	<meta name="description" content="In this article, we&#039;ll learn how to use generic types in our functions to create more reusable functions along with generic classes and generic interfaces." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://blog.logrocket.com/getting-started-with-typescript-generics/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Getting started with TypeScript generics - LogRocket Blog" />
	<meta property="og:description" content="In this article, we&#039;ll learn how to use generic types in our functions to create more reusable functions along with generic classes and generic interfaces." />
	<meta property="og:url" content="https://blog.logrocket.com/getting-started-with-typescript-generics/" />
	<meta property="og:site_name" content="LogRocket Blog" />
	<meta property="article:published_time" content="2020-06-05T16:00:02+00:00" />
	<meta property="article:modified_time" content="2020-06-05T14:05:39+00:00" />
	<meta property="og:image" content="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?fit=730%2C411&#038;ssl=1" />
	<meta property="og:image:width" content="730" />
	<meta property="og:image:height" content="411" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/getting-started-with-typescript-generics/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?fit=730%2C411&ssl=1","width":730,"height":411},{"@type":"WebPage","@id":"https://blog.logrocket.com/getting-started-with-typescript-generics/#webpage","url":"https://blog.logrocket.com/getting-started-with-typescript-generics/","name":"Getting started with TypeScript generics - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/getting-started-with-typescript-generics/#primaryimage"},"datePublished":"2020-06-05T16:00:02+00:00","dateModified":"2020-06-05T14:05:39+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/f5d702b0e3440a914d1194d9b5cbd265"},"description":"In this article, we'll learn how to use generic types in our functions to create more reusable functions along with generic classes and generic interfaces.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/getting-started-with-typescript-generics/"]}]},{"@type":["Person"],"@id":"https://blog.logrocket.com/#/schema/person/f5d702b0e3440a914d1194d9b5cbd265","name":"Leonardo Maldonado","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/543d9964f07575b1311232abf55edef7?s=96&d=mm&r=g","caption":"Leonardo Maldonado"},"description":"Full Stack Developer. JavaScript, React, TypeScript, GraphQL."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Getting started with TypeScript generics Comments Feed" href="https://blog.logrocket.com/getting-started-with-typescript-generics/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.4.1/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css'  href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.6.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.6.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0'></script>
<script type='text/javascript' async='async' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js'></script>
<script type='text/javascript' async='async' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js'></script>
<link rel='https://api.w.org/' href='https://blog.logrocket.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/paUW9B-5aD' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F&#038;format=xml" />
<script>
if (typeof jQuery == 'undefined') {
var script = document.createElement("SCRIPT");
script.src = 'https://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js';
script.type = 'text/javascript';
script.onload = function() {
var $ = window.jQuery;
// LogRocket.captureMessage('jQuery failed to load and triggered catch');
};
document.getElementsByTagName("head")[0].appendChild(script);
}</script>
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">

    <script>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</script>


    <script>
    window.Raven && window.Raven.config('https://98e0ea7c6f2e492d94439ad5aaea48dd@e.logrocket.com/4').install()
    </script>
    <script type="text/javascript">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</script>

<!-- Start VWO Async Smartcode -->
<script type='text/javascript'>
window._vwo_code = window._vwo_code || (function(){
var account_id=338524,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
is_spa=1,
hide_element='body',

/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document,code={use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){
settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b=hide_element?hide_element+'{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}':'',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&f='+(+is_spa)+'&r='+Math.random());return settings_timer; }};window._vwo_settings_timer = code.init(); return code; }());
</script>
<!-- End VWO Async Smartcode -->

    <script src="https://cdn.logrocket.com/LogRocket.min.js"></script>
    <script>
        if (window.LogRocket) {
            window.LogRocket.init('apphub/logrocket-website',{
                dashboardHost: "https://staging.logrocket.com",
                serverURL: "https://staging-i.logrocket.com/i",
            });
        }

        fetch('https://ga.clearbit.com/v1/ga.js?authorization=pk_66a3fd2085d9f04c4d4b68a62b70ed7e').then(function(res){
            res.text().then(function(val){
                var regex = /this.done((.*)}})/;
                var regexVal = regex.exec(val);
                if (!regexVal) {
                    return;
                }

                var dict = regexVal[0].replace('this.done(', '');

                var clearbitData = JSON.parse(dict);
                window.clearbitData = clearbitData;

                window._vis_opt_queue = window._vis_opt_queue || [];
                window._vis_opt_queue.push(function() {_vis_opt_goal_conversion(202);});

                window.LogRocket && window.LogRocket.identify(Math.random().toString(36).substring(7), {
                    company: clearbitData.company.name,
                    email: 'anonymous@' + clearbitData.company.domain,
                });
                if (clearbitData.company.domain && window.location.pathname != "/") {
                    var demoButton = document.getElementById("blog-personalized-demo-link");
                    var personalizeImage = document.getElementById("blog-personalized-demo-thumbnail");
                    var companyName = document.getElementById("personalized-company-account-name");
                    var perUrl = "https://us-central1-logrocket-com.cloudfunctions.net/findPersonalization?targetDomain=" + clearbitData.company.domain;
                    fetch(perUrl)
                        .then(response => {
                            return response.json()
                        })
                        .then(data => {
                            var imageReturn = data.image_url;
                            var linkReturn = data.link_url;
                            if (imageReturn.includes("not-found") || linkReturn.includes("not-found")) {
                                return "not-found";
                            } else {
                                personalizeImage.src = imageReturn;
                                demoButton.href = linkReturn;
                                companyName.innerHTML = clearbitData.company.name;
var intersectionOptions = {
root: null,  // use the viewport
rootMargin: '-240px',
threshold: 1.0
}
function intersectionCallback(entries, observer) {
entries.forEach(entry => {
 if (entry.intersectionRatio >= 1) {
   jQuery('.inline-demo').slideDown(1500);
 //  jQuery('.crp-list-item-image img').delay(550).fadeIn(1000);
     observer.unobserve(target);
 } else {
 }
});
}
var observer = new IntersectionObserver(intersectionCallback, intersectionOptions);
var target = document.querySelector('.code-block-28');
observer.observe(target);

                                analytics.track('Personalization-deployed-blog', {
                                    'Domain': clearbitData.company.domain
                                });
                                LogRocket.track('post-personalized-blog');
                            }
                        })
                        .catch(err => {
                            analytics.track("personalization-failed");
                            throw err;
                        })
                };

                _linkedin_partner_id = "1468257";
                window._linkedin_data_partner_ids = window._linkedin_data_partner_ids || [];
                window._linkedin_data_partner_ids.push(_linkedin_partner_id);
                (function(){var s = document.getElementsByTagName("script")[0];
                var b = document.createElement("script");
                b.type = "text/javascript";b.async = true;
                b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
                s.parentNode.insertBefore(b, s);})();

                var linkedIn_img = document.createElement("img");
                linkedIn_img.src = "https://px.ads.linkedin.com/collect/?pid=1468257&fmt=gif";
                document.getElementsByTagName('head')[0].appendChild( linkedIn_img );

                window.analytics && window.analytics.track('clearbit domain', { domain: clearbitData.company.domain });
            });
        })
    </script>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=270%2C270&#038;ssl=1" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=a2bf79682d" />
		<style id="kirki-inline-styles">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</style></head>

<body class="post-template-default single single-post postid-19879 single-format-standard">

<style>
    </style>


<header class="navbar-light bg-white fixed-top mediumnavigation">

    <div class="container">



        <div class="navarea">

<div class="nav-left">

  <a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>

<nav class="menu-container">

        <div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a></ul></div></nav>

</div>

<div class="nav-right">

  <div class="menu-container">
    <div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Free Trial</a></li>
</ul></div>  </div>

</div>

        </div>

    </div>

</header>


        <!-- Begin site-content
		================================================== -->
        <div class="site-content">


<div class="container"> 
    <div class="row">         
        <div class=" col-md-2 ">           
            <div class="share">
                
                <div class="sidebarapplause">
                                </div>
                
                				<p class="sharecolour">
					Share				</p>
                
<ul class="shareitnow"><li>
        <a target="_blank" href="https://twitter.com/intent/tweet?text=Getting%20started%20with%20TypeScript%20generics&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F">
        <i class="fa fa-twitter"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F">
        <i class="fa fa-facebook"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F">
        <i class="fa fa-google"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F&amp;media=https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?fit=730%2C411&ssl=1&amp;description=Getting%20started%20with%20TypeScript%20generics">
        <i class="fa fa-pinterest"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F&amp;title=Getting%20started%20with%20TypeScript%20generics">
        <i class="fa fa-linkedin"></i>
        </a>
    </li></ul>                		        
                
                                <div class="sep"></div>
                <div class="hidden-xs-down">      

                    <p>
                        Reply                    </p>
                    <ul>
                        <li>
                        <a class="smoothscroll" href="#comments">0<br/>
                        <svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
                        </a>
                        </li>
                    </ul>
                </div>
                            </div>			                                
        </div>
        
                    			                <div class="col-md-8 flex-first flex-md-unordered post-19879 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-typescript" id="post-19879"> 
                    <div class="mainheading">
                       
                                                <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-md-down"> 
                            <div class="col-md-2 col-xs-12"> 
                                <a href="https://blog.logrocket.com/author/leonardomaldonado/">
                                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/leonardomaldonado.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/leonardomaldonado.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/leonardomaldonado.jpg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                                </a>
                            </div>                                         
                            <div class="col-md-10 col-xs-12"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/leonardomaldonado/">
                                Leonardo Maldonado <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">Full Stack Developer. JavaScript, React, TypeScript, GraphQL.</span> 
                            </div>                                         
                        </div>
                                                 
                                                
                        <h1 class="posttitle">Getting started with TypeScript generics</h1>
					    <h2 class="post-subtitle"></h2>

                        <p>
                                                        <span class="post-date"><time class="post-date">
                            June 5, 2020                            </time></span>
                                                        
                                                        <span class="dot"></span>
                            <span class="readingtime">5 min read</span>
						    <span class="wordcount">1414</span>

                                                    </p> 
                    </div>
                    
                  <img width="730" height="411" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?fit=730%2C411&amp;ssl=1" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="" data-attachment-id="19893" data-permalink="https://blog.logrocket.com/getting-started-with-typescript-generics/typescriptgenerics2/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?fit=730%2C411&amp;ssl=1" data-orig-size="730,411" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="typescriptgenerics2" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?fit=730%2C411&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?w=730&amp;ssl=1 730w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?resize=300%2C169&amp;ssl=1 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/typescriptgenerics2.png?fit=730%2C411&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    <article class="article-post">
                                                <p>TypeScript came to solve the problem of types in JavaScript for us by bringing optional static type-checking in JavaScript. It is fairly easy to get started with TypeScript, in just a few minutes you can have a TypeScript project running along with your first types. But after using TypeScript and creating your first union types, you might start to notice a problem. You have a lot of similar types that have been created just for some specific piece of code.</p>
<p>In other words, you’re creating more code than you need. That’s something that will not help you scale your code long term. But how can you solve this problem?</p>
<p>For this, we have <a href="https://www.typescriptlang.org/docs/handbook/generics.html" target="_blank" rel="noopener noreferrer">generics</a> in TypeScript. You don’t need to create a lot of types, you can benefit from the usage of generics to have more reusable code.</p>
<h2>Generics</h2>
<p>TypeScript can increase the code complexity of your project if you’re using it the wrong way. When you have more types, interfaces, and union types than you need, your code will get more difficult to read and maintain.</p>
<p>To understand what generics are and how it works, let’s start with an example. Let’s imagine that we have a function called <code>print</code>, this function is responsible for simply returning our user:</p>
<pre>type User = {
  name: string;
  age: number;
};

const user: User = {
  name: "Leonardo",
  age: 22
};

function print(user: User): User {
  return user;
};</pre>
<p>As you can see, there is nothing too difficult or unusual for now. We create a type called <code>User</code>, an object called <code>user</code> which we specified with our <code>User</code> type. Also, in our <code>print</code> function, we&#8217;re going to receive a <code>user</code> argument that needs to be equal <code>User</code>, and as the final result, our function is going to return a <code>User</code>.</p>
<p>Now, let’s imagine that we want to change something in our function. Instead of returning a <code>User</code>, we’re going to need to return something similar to <code>User</code>, but a little different.</p>
<p>Let’s imagine that we have a type called <code>Admin</code>, that’s similar to <code>User</code> but has an additional property:</p>
<pre>type Admin = {
  name: string;
  age: number;
  admin: true;
};</pre>
<p>We now have a new type, and for reusability purposes, it would be better if our <code>print</code> function allows us to print both <code>User</code> and <code>Admin</code> types.</p>
<p>This is the perfect use case to create a generic type. With generics, we can work with a variety of types instead of a single one. In our case, we can use our <code>print</code> function to print our <code>User</code> and <code>Admin</code> types.</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br/>No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>

<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}</style>
</div>

<p>This is how we can create a generic type for a function. After the function name, we pass our generic type between the <code>&lt;&gt;</code>. In our case, we’re going to name our generic type <code>T</code>. The argument of our function is also going to be the generic type that we created, and the return of our function is also going to be our generic type. We’re using <code>T</code> as our generic type, this generic type allows us to work with a variety of types instead of a single one.</p>
<p>You might be wondering here, ‘but why <code>T</code>?’ <code>T</code> stands for Type, and it’s commonly used by TypeScript to refer to the first type variable name. You can name it whatever you would like, but for type variables, when using generics, it’s a common practice (especially when you have more than one generic type) to name it another single letter.</p>
<p>Now, if we call our <code>print</code> function to print both <code>user</code> and <code>admin</code> objects, it will work perfectly. We’re using a generic type to make sure that we’re printing an object with the correct properties, and we can notice that our code gets more readable and reusable:</p>
<pre>type User = {
  name: string;
  age: number;
};

type Admin = {
  name: string;
  age: number;
  admin: true;
};

const user: User = {
  name: "Leonardo",
  age: 22
};

const admin: Admin = {
  name: "Leonardo",
  age: 22,
  admin: true
};

function print&lt;T&gt;(user: T): T {
  return user;
};    

print&lt;User&gt;(user); // Result: { name: "Leonardo", age: 22 }
print&lt;Admin&gt;(admin); // Result: { name: "Leonardo", age: 22, admin: true }</pre>
<p>A thing to notice here is that generics allow us to work with a variety of types instead of a single one, and when we’re going to invoke or instantiate our code, we need to pass our type as a “parameter”.</p>
<p>In our previous example, when we invoked the print function to print a user, we need to pass the user type as a parameter, if we didn’t pass anything, it would work the same but without the benefits of TypeScript.</p>
<h2>Classes</h2>
<p>We can work with generic classes in TypeScript. Another nice thing about generics is that we can have multiple type parameters. Let’s imagine that we have a class called <code>User</code>, and we want to pass two type parameters for this class &#8212; one for <code>name</code> and another one for <code>age</code>. This is how we could do it:</p>
<pre>class User&lt;T, U&gt; {
  name: T;
  age: U;
  constructor(name: T, age: U) {
    this.name = name;
    this.age = age;
  }

  print(): void {
    console.log(`Hello ${this.name}, you are ${this.age} years old!`);
  }
};

const newUser = new User&lt;string, number&gt;("Leonardo", 23);
newUser.print(); // Hello Leonardo, you are 23 years old!</pre>
<h2>Interfaces</h2>
<p>Another nice thing about generics is that we can create generic interfaces, we can easily create reusable interfaces and use different types and interfaces.</p>
<p>Let’s imagine that we have three interfaces <code>Admin</code>, <code>User</code>, and <code>Client</code>. We’re going to pass our generic type parameter on our <code>Admin</code> interface, and another two interfaces that we’re going to use for testing purposes:</p>
<pre>interface User {
  firstName: string;
};

interface Client {
  firstName: string;
  lastName: string;
};

interface Admin&lt;T&gt; {
  values: T;
  isAdmin: true;
};</pre>
<p>Our <code>Client</code> interface is different from our <code>User</code> interface. Now, let’s create two different objects and pass different interfaces for our generic interface <code>Admin</code>:</p>
<pre>interface User {
  firstName: string;
};

interface Client {
  firstName: string;
  lastName: string;
};

interface Admin&lt;T&gt; {
  values: T;
  isAdmin: true;
};

const user: Admin&lt;User&gt; = {
  values: {
    firstName: "Leonardo"
  },
  isAdmin: true
};

const client: Admin&lt;Client&gt; = {
  values: {
    firstName: "Leonardo",
    lastName: "Maldonado"
  },
  isAdmin: true
};</pre>
<h2>Constraints</h2>
<p>When we’re using generics, we can use constraints to apply to our generic type parameters. To implement it, all we have to do is use the extends keyword. Before using it, you need to make sure of something &#8212; the <code>extends</code> keyword only works with interfaces and classes, otherwise, it will throw an error.</p>
<p>Let’s take our first print function as an example, and apply a constraint using the <code>extends</code> keyword in our <code>T</code> type parameter:</p>
<pre>type User = {
  name: string;
  age: number;
};

const user: User = {
  name: "Leonardo",
  age: 22
};

function print&lt;T&gt;(user: T): T {
  return user;
};
print&lt;User&gt;(user); // Result: { name: "Leonardo", age: 22 }</pre>
<h2>When to use generics?</h2>
<p>Once you feel more comfortable with generics and understand how it works, you can start to use it more and hopefully realize the real benefits of it. But before you start to use it everywhere, you need to identify when to use it to create a performative piece of code.</p>
<p>To identify when to use a generic type, you can consider two things:</p>
<ol>
<li>Will this function or class be required to work with a variety of data types?</li>
<li>Will this function or class be used in more than one place?</li>
</ol>
<p>These are two questions that can help you to decide if you’re going to need generics or not. As your application grows, the chances that you’re working and creating more types than you need might increase. Something we might forget to consider is to use something like generics to help us have more reusable and maintainable code.</p>
<p>In the long-term, not only will you benefit from it, but your whole team will. Your code will get more readable, that means that other developers can easily understand and maintain it if needed, your code will get more concise and well-written, and you will feel that your application is more secure and consistent than ever.</p>
<h2>Conclusion</h2>
<p>In this article, we learned how we can use generic types in our functions to create more reusable functions. We also learned about generic classes and generic interfaces. The concept of generics is one of the best when you’re trying to achieve a more reusable and maintainable code, it makes your life easier to reuse types without having to create a few similar types.</p><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<div class="base-cta"><h2><a class="signup" href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">LogRocket</a>: Full visibility into your web apps</h2>
<a href="https://logrocket.com/signup/" class="signup" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2017/03/1d0cd-1s_rmyo6nbrasp-xtvbaxfg.png?resize=1200%2C677&#038;ssl=1" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-recalc-dims="1" /></noscript></a>

<p style="margin-top:15px;"><a href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">LogRocket</a> is a frontend application monitoring solution that lets you replay problems as if they happened in your own browser. Instead of guessing why errors happen, or asking users for screenshots and log dumps, LogRocket lets you replay the session to quickly understand what went wrong. It works perfectly with any app, regardless of framework, and has plugins to log additional context from Redux, Vuex, and @ngrx/store.</p>

<p>In addition to logging Redux actions and state, LogRocket records console logs, JavaScript errors, stacktraces, network requests/responses with headers + bodies, browser metadata, and custom logs. It also instruments the DOM to record the HTML and CSS on the page, recreating pixel-perfect videos of even the most complex single-page apps.</p>

<a class="signup" href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">Try it for free</a>.</div>
</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-19879" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/getting-started-with-typescript-generics/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/getting-started-with-typescript-generics/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-19879" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/getting-started-with-typescript-generics/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-19879" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/getting-started-with-typescript-generics/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><!-- AI CONTENT END 1 -->
                        <div class="clearfix"></div>
                                                <div class="clearfix"></div>
                    </article>
                            
                                             <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-lg-up"> 
                            <div class="col-md-2 col-xs-4"> 
                                <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/leonardomaldonado.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/leonardomaldonado.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/leonardomaldonado.jpg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                            </div>                                         
                            <div class="col-md-10 col-xs-8"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/leonardomaldonado/">
                                Leonardo Maldonado <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">Full Stack Developer. JavaScript, React, TypeScript, GraphQL.</span> 
                            </div>                                         
                        </div>
                                         
                    <div class="after-post-tags">
                                                    <ul class="post-categories">
	<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul>                                                                            <ul class="post-categories aretags">
                            <li><a href="https://blog.logrocket.com/tag/typescript/">#typescript</a></li>                             </ul>
                                            </div>
                    
                  
                    <div class="row mb-5 prevnextlinks justify-content-center align-items-center"> 
                       <div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/jsx-driven-components-crank-js/" rel="prev">JSX-driven components with Crank.js</a></div></div>
                       <div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"></div></div>
                    </div>
                    
                </div>
        
                    
         
        
        
    </div>                 
</div>             
          
<div class="hideshare"></div>

    <div class="graybg"> 
        <div class="container"> 
                <div class="row justify-content-center listrecent listrelated">
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/jsx-driven-components-crank-js/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/jsx-driven-components-crankjs.jpeg?fit=730%2C486&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/jsx-driven-components-crank-js/">JSX-driven components with Crank.js</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/nirmalyaghosh/">
                    <img alt src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/nirmalya-ghosh.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/nirmalya-ghosh.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/02/nirmalya-ghosh.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/nirmalyaghosh/">Nirmalya Ghosh</a></span><br>
                    <span class="post-date">Jun 5, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">5 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/jsx-driven-components-crank-js/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/10-tailwind-css-tips-to-boost-your-productivity/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/tailwind-css-logo.png?fit=730%2C412&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/10-tailwind-css-tips-to-boost-your-productivity/">10 Tailwind CSS tips to boost your productivity</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/rifkinada/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/01/author-photo_nada-rifki.png?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/01/author-photo_nada-rifki.png?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/01/author-photo_nada-rifki.png?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/rifkinada/">Nada Rifki</a></span><br>
                    <span class="post-date">Jun 5, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">4 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/10-tailwind-css-tips-to-boost-your-productivity/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/how-to-build-an-ecommerce-site-with-strapi-vue-js-and-flutterwave/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/flutterwavestrapivue.png?fit=730%2C411&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/how-to-build-an-ecommerce-site-with-strapi-vue-js-and-flutterwave/">How to build an ecommerce site with Strapi, Vue.js,&hellip;</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/peterekeneeze/">
                    <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/04/peterekeneeze.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/04/peterekeneeze.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/04/peterekeneeze.jpg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/peterekeneeze/">Peter Ekene Eze</a></span><br>
                    <span class="post-date">Jun 4, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">7 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/how-to-build-an-ecommerce-site-with-strapi-vue-js-and-flutterwave/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
            </div>
    <div class="clearfix"></div>
                
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/getting-started-with-typescript-generics/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=19879&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.6.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=7f890bf0e60624c4f5d0ff58cb4e7a7496c6383f#parent=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
</div>
</div>        </div>                 
    </div>

    <div class="alertbar"> 
        <div class="container text-center"> 
                    </div>
    </div>

</div><!-- /.site-content -->
        
        <div class="container">
            <footer class="footer"> 
                <div class="pull-left"> Does something seem off? Email <a>support@logrocket.com</a> </div> 
                <div class="pull-right"> <div class = "footerRight">			<div id="jetpack-search-filters-2-wrapper" >
		<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field"
placeholder="Search..."
value="" name="s"
title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>   
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div>  </div> 
                <div class="clearfix"></div>
                <a href="" class="back-to-top hidden-md-down"> 
                <i class="fa fa-angle-up"></i>
                </a>
            </footer>
        </div>
        <!--  -->
<script>window.onload = function() {
    if (window.jQuery) {
      jQuery(document).ready(function() {
        if(jQuery(('.text-capitalize').length) && (typeof heap !== 'undefined'))
        {
         var postLength = jQuery('.wordcount').text();
         var postAuthor = jQuery('.text-capitalize').first().text();
         var postAuthorclean = postAuthor.replace(' Follow','').replace('                                ','');
         heap.track('Post Author', {'Author': postAuthorclean});
         heap.track('Post Length', {'Length': postLength});
       }
       if (typeof hljs !== 'undefined')
       {
       document.querySelectorAll('pre').forEach((block) => {
         hljs.highlightBlock(block);
       });
       }
      });
    } else {
      return;
    }
}
</script>



<script>if (typeof jQuery !== 'undefined') {
    jQuery(function(){
      jQuery('a[href*="/signup/"]').each(function(){
            jQuery(this).addClass('signup-blog');
          });    });    }</script>

<script>jQuery(document).ready(function() {
        if(typeof heap !== 'undefined')
        {
          setTimeout(function(){
            heap.track('View Greater 30s', '> 30s');
          },30000);
             }
      });</script>	<div style="display:none">
	<div class="grofile-hash-map-543d9964f07575b1311232abf55edef7">
	</div>
	<div class="grofile-hash-map-de35efc14a82dd0fccb120555681c7cb">
	</div>
	<div class="grofile-hash-map-3981ed4d6ff3e21f338e01ce053ea6c3">
	</div>
	<div class="grofile-hash-map-97b8897f620c6dc18f4ea6a53e0e0796">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/getting-started-with-typescript-generics\/":19879};
	</script>
				<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.4.1/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/modules/widgets/search/js/search-widget.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.4.1/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=19879&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=7f890bf0e60624c4f5d0ff58cb4e7a7496c6383f#parent=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=19879&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=7f890bf0e60624c4f5d0ff58cb4e7a7496c6383f#parent=https%3A%2F%2Fblog.logrocket.com%2Fgetting-started-with-typescript-generics%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202023.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'161333275',post:'19879',tz:'-4',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '19879' ]);
</script>
<script>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</script>
            </body>     
</html>
<!--
	generated 244 seconds ago
	generated in 0.283 seconds
	served from batcache in 0.002 seconds
	expires in 56 seconds
-->
