<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />


<title>Build a task tracker with SolidJS and TypeScript - LogRocket Blog</title>
<meta name="description" content="Learn how to use SolidJS to build a web app. SolidJS makes global state management easier, uses JSX, and has a simple workflow." />
<link rel="canonical" href="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Build a task tracker with SolidJS and TypeScript - LogRocket Blog" />
<meta property="og:description" content="Learn how to use SolidJS to build a web app. SolidJS makes global state management easier, uses JSX, and has a simple workflow." />
<meta property="og:url" content="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2022-06-29T13:00:44+00:00" />
<meta property="article:modified_time" content="2022-06-28T19:30:36+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="487" />
<meta property="og:image:type" content="image/png" />
<meta name="author" content="Ebenezer Don" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@https://twitter.com/ebenezerdn" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Ebenezer Don" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="13 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://blog.logrocket.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blog.logrocket.com/build-task-tracker-solidjs-typescript/#primaryimage","url":"https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn.png","contentUrl":"https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn.png","width":730,"height":487,"caption":"Build a task tracker with SolidJS and TypeScript"},{"@type":"WebPage","@id":"https://blog.logrocket.com/build-task-tracker-solidjs-typescript/#webpage","url":"https://blog.logrocket.com/build-task-tracker-solidjs-typescript/","name":"Build a task tracker with SolidJS and TypeScript - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/build-task-tracker-solidjs-typescript/#primaryimage"},"datePublished":"2022-06-29T13:00:44+00:00","dateModified":"2022-06-28T19:30:36+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/b9cd3d8d6106b1b4aa55da389807b1cd"},"description":"Learn how to use SolidJS to build a web app. SolidJS makes global state management easier, uses JSX, and has a simple workflow.","breadcrumb":{"@id":"https://blog.logrocket.com/build-task-tracker-solidjs-typescript/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/build-task-tracker-solidjs-typescript/"]}]},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/build-task-tracker-solidjs-typescript/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://blog.logrocket.com/"},{"@type":"ListItem","position":2,"name":"Build a task tracker with SolidJS and TypeScript"}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/b9cd3d8d6106b1b4aa55da389807b1cd","name":"Ebenezer Don","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blog.logrocket.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/91337866b9e7a7c13894f52498020ebb?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/91337866b9e7a7c13894f52498020ebb?s=96&d=mm&r=g","caption":"Ebenezer Don"},"description":"Full-stack software engineer with a passion for building meaningful products that ease the lives of users.","sameAs":["https://www.ebenezerdon.com/","https://twitter.com/https://twitter.com/ebenezerdn"],"url":"https://blog.logrocket.com/author/ebenezerdon/"}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Build a task tracker with SolidJS and TypeScript Comments Feed" href="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.0' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/6.0.0-beta2/css/all.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=11.1-a.5' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.1-a.5' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/120511" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-vlJ' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<script src="//geoip-js.com/js/apis/geoip2/v2.1/geoip2.js" type="text/javascript"></script>

<script>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</script>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>
function setlrAdwinExpiry(lrAdwin, value, ttl) {
				var now = new Date()

				// `item` is an object which contains the original value
				// as well as the time when it's supposed to expire
				const item = {
					value: 'isSet',
					expiry: now.getTime() + 4665600000,
				}
				localStorage.setItem(lrAdwin, JSON.stringify(item))
				setTimeout(function(){
					analytics.track("lrAdwin", {
  active: "true"
});
    }, 1000);
			}

			function getWithExpiry(lrAdwin) {
				const itemStr = localStorage.getItem(lrAdwin)

				// if the item doesn't exist, return null
				if (!itemStr) {
					return null
				}

				const item = JSON.parse(itemStr)
				const now = new Date()

				// compare the expiry time of the item with the current time
				if (now.getTime() > item.expiry) {
					// If the item is expired, delete the item from storage
					// and return null
					localStorage.removeItem(lrAdwin)
					if (analytics) {					analytics.track("lrAdwin", {
  active: "false"
});}
					return null
				}
				return item.value
			}

			if (!localStorage.getItem('_lr_id_')){
				setlrAdwinExpiry();
			}
			getWithExpiry();
</script>
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://a39e555ed62c408792586c55bbb2ce3b@e.logrocket.com/9').install()
    </script>
<script type="text/javascript">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</script>
<script>

<!-- start vwo -->
      window._vwo_code = window._vwo_code || (function(){
        var account_id=338524,
        settings_tolerance=2000,
        library_tolerance=2500,
        use_existing_jquery=false,
        is_spa=1,
        hide_element='body',

        /* DO NOT EDIT BELOW THIS LINE */
        f=false,d=document,code={use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){
        settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b=hide_element?hide_element+'{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}':'',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&f='+(+is_spa)+'&r='+Math.random());return settings_timer; }};window._vwo_settings_timer = code.init(); return code; }());
<!-- Reddit Pixel -->
!function(w,d){if(!w.rdt){var p=w.rdt=function(){p.sendEvent?p.sendEvent.apply(p,arguments):p.callQueue.push(arguments)};p.callQueue=[];var t=d.createElement("script");t.src="https://www.redditstatic.com/ads/pixel.js",t.async=!0;var s=d.getElementsByTagName("script")[0];s.parentNode.insertBefore(t,s)}}(window,document);rdt('init','t2_3xdvtyx2');rdt('track', 'PageVisit');
<!-- DO NOT MODIFY -->
<!-- End Reddit Pixel -->
    </script><style>img#wpstats{display:none}</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=f9bf9daf84" /><style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-120511 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="navarea">
<div class="nav-left">
<a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>
<nav class="menu-container">
<div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a><li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">Podcast</a><li id="menu-item-72923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72923 nav-item"><a href="https://blog.logrocket.com/tech-meetups/" class="nav-link">Meetups</a></ul></div></nav>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Start monitoring for free</a></li>
</ul></div> </div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Build%20a%20task%20tracker%20with%20SolidJS%20and%20TypeScript&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn.png&amp;description=Build%20a%20task%20tracker%20with%20SolidJS%20and%20TypeScript">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript%2F&amp;title=Build%20a%20task%20tracker%20with%20SolidJS%20and%20TypeScript">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-120511 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-uncategorized tag-typescript" id="post-120511">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/ebenezerdon/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/10/ebenezer-don-2021-150x150.jpeg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/10/ebenezer-don-2021-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/10/ebenezer-don-2021-150x150.jpeg?crop=1' class='avatar avatar-72 photo' height='72' width='72'  /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/ebenezerdon/">
Ebenezer Don <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Full-stack software engineer with a passion for building meaningful products that ease the lives of users.</span>
</div>
</div>
<h1 class="posttitle">Build a task tracker with SolidJS and TypeScript</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
 June 29, 2022 </time></span>
<span class="dot"></span>
<span class="readingtime">10 min read</span>
<span class="wordcount">2919</span>
</p>
</div>
<img width="730" height="487" src="https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="Build a task tracker with SolidJS and TypeScript" data-attachment-id="121768" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/build-task-tracker-with-solidjs-typescript-nocdn/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn.png" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Build a task tracker with SolidJS and TypeScript" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn-300x200.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn-300x200.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/06/build-task-tracker-with-solidjs-typescript-nocdn.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> <article class="article-post">
<p>SolidJS is fast becoming the center of attention in the web development community. With its straightforward state management, fine-grained reactivity, and high performance, SolidJS has put itself on a pedestal for other JavaScript frameworks.</p>
<p>SolidJS is everything React developers have been asking for, and in this article, I’ll walk you through <a href="https://solid-task-tracker.netlify.app" target="_blank" rel="noopener">building a task tracker with SolidJS</a>. We’ll cover the following topics:</p>
<ul style="margin-bottom: 0px; padding-bottom: 0px;">
<li><a href="#why-solid-js">Why SolidJS?</a></li>
<li><a href="#setting-up-solidjs-app">Setting up a SolidJS app with TypeScript</a>
<ul style="margin-bottom: 0px; padding-bottom: 0px;">
<li><a href="#installing-bootstrap-style-solidjs">Installing Bootstrap to style our SolidJS app</a></li>
</ul>
</li>
<li><a href="#using-jsx-structure-task-tracker">Using JSX to structure our task tracker</a></li>
<li><a href="#creating-updating-state-solidjs">Creating and updating state in SolidJS</a>
<ul style="margin-bottom: 0px; padding-bottom: 0px;">
<li><a href="#adding-tasks-state">Adding tasks to our state</a></li>
</ul>
</li>
<li><a href="#control-flow-looping-data-solidjs">Control flow and looping through data in SolidJS</a></li>
<li><a href="#updating-tasks-nested-state">Updating tasks in our nested state</a></li>
<li><a href="#using-create-store-nested-reactivity">Using <code>createStore</code> for nested reactivity in SolidJS</a></li>
</ul>
<h3>Prerequisites</h3>
<p>To follow along with this tutorial, you’ll need knowledge of JavaScript and TypeScript, Node.js modules, and components in frontend frameworks.</p>
<h2 id="why-solid-js">Why SolidJS?</h2>
<p>If you’ve worked with React before, SolidJS will look very familiar. When React Hooks was first announced, I was so happy because I thought it would <a href="https://blog.logrocket.com/react-hooks-state-management/" target="_blank" rel="noopener">solve our state management crisis</a>. Hooks made local state management in components easier, but global state management remained complex.</p>
<p>It was still difficult for disconnected components to share data and numerous libraries showed up to try and solve the state management problem — which increased development fatigue and added unnecessary complexity to our codebase.</p>
<p>I’ve also seen the same problem happen in other frontend frameworks; it’s as if global state management is an afterthought, rather than something that was planned for from the beginning.</p>
<p>With SolidJS, things are different. Global state management is as easy as creating state and exporting it. There’s no need for any complex setup or third-party library.</p>
<p>SolidJS also uses JSX, the popular HTML-like syntax extension to JavaScript. This makes handling UI logic, events, and state changes straightforward. Coupled with that, SolidJS compiles to plain JavaScript, so there’s no need for a virtual DOM, making it relatively faster than frameworks like React and Angular.</p>
<p>SolidJS also has a simple workflow. Components only render once, just like in JavaScript, so it’s easier to predict the outcome of your code.</p>
<p>Another huge advantage of SolidJS is that it builds on the shoulders of other web frameworks, so it proudly emulates the good parts and improves the not-so-good parts.</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a target="_blank" id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br />No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img data-lazy-fallback="1" id="blog-personalized-demo-thumbnail" src="" /></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>
<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>
<p>Let’s go ahead and setup our SolidJS app to learn how to build a web app with SolidJS step-by-step.</p>
<h2 id="setting-up-solidjs-app">Setting up a SolidJS app with TypeScript</h2>
<p>To set up a SolidJS app on your local machine, you’ll need to install <a href="https://nodejs.org/en/" target="_blank" rel="noopener">Node.js</a>. If you already have it installed, running the following command on your terminal should return your current Node.js version:</p>
<pre class="language-bash hljs">node --version
</pre>
<p>Next, let’s create a new SolidJS app by running the following command on our terminal:</p>
<pre class="language-bash hljs">npx degit solidjs/templates/ts task-tracker
</pre>
<p>Using <code>solidjs/templates/ts</code> generates a Solid/TypeScript app. For JavaScript, you’ll have to change the command to <code>solidjs/templates/js</code>.</p>
<p>After running the command, you should see a success message that looks like this:</p>
<pre class="language-bash hljs">&gt; cloned solidjs/templates#HEAD to task-tracker
</pre>
<p>Now, go ahead and open the generated app in your code editor or IDE of choice. Here’s what the app structure should look like:</p>
<p><img data-attachment-id="120697" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/task-tracker-app-structure/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure.png" data-orig-size="730,397" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Task tracker app structure" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure-300x163.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure.png" class="aligncenter wp-image-120697 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure.png" alt="View of the generated app structure" width="730" height="397" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure-300x163.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="120697" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/task-tracker-app-structure/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure.png" data-orig-size="730,397" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Task tracker app structure" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure-300x163.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure.png" loading="lazy" class="aligncenter wp-image-120697 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure.png" alt="View of the generated app structure" width="730" height="397" srcset="https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/06/task-tracker-app-structure-300x163.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>Notice that our SolidJS app uses <a href="https://blog.logrocket.com/getting-started-with-vite/" target="_blank" rel="noopener">Vite</a> as its default build tool and <a href="https://blog.logrocket.com/javascript-package-managers-compared/" target="_blank" rel="noopener">pnpm</a> as the default package manager. These tools combined provide a great development experience for component rendering, app startup time, and package management.</p>
<p>Our app component currently lives inside of the <code>./src/App.tsx</code> file:</p>
<pre class="language-typescript hljs">import type { Component } from 'solid-js'
...
const App: Component = () =&gt; {
  return (
    &lt;div&gt;
      ...
    &lt;/div&gt;
  );
}

export default App
</pre>
<p>First, we import the <code>Component</code> type from <code>solid-js</code> which is then used as the type for our <code>App</code> component.</p>
<p>Components in SolidJS are JavaScript functions. They are reusable and can be customized using props, which are similar to function parameters/arguments.</p>
<p>Inside of the <code>./src/index.tsx</code> file, we render our <code>App</code> component:</p>
<pre class="language-typescript hljs">import { render } from 'solid-js/web'
import App from './App'

render(() =&gt; &lt;App /&gt;, document.getElementById('root') as HTMLElement)
</pre>
<p>The <code>render()</code> method from <code>solid-js/web</code> expects two arguments:</p>
<ol>
<li>A function that returns our <code>&lt;App /&gt;</code> component</li>
<li>An HTML element</li>
</ol>
<p>When you navigate to the <code>./index.html</code> file, you’ll see the root <code>div</code> and the use of our <code>./src/index.tsx</code> file via the <code>&lt;script /&gt;</code> tag:</p>
<pre class="language-html hljs">...
&lt;body&gt;
  &lt;noscript&gt;You need to enable JavaScript to run this app.&lt;/noscript&gt;
  &lt;div id="root"&gt;&lt;/div&gt;
  &lt;script src="/src/index.tsx" type="module"&gt;&lt;/script&gt;
&lt;/body&gt;
</pre>
<p>To run our SolidJS app, we’ll have to first install our packages by running the command <code>pnpm install</code> on our terminal, and then <code>pnpm dev</code> to start our application in development mode. You should see a success message that looks like this:</p>
<pre class="language-bash hljs"> vite v2.9.9 dev server running at:

 &gt; Local: http://localhost:3001/
 &gt; Network: use `--host` to expose

 ready in 378ms.
</pre>
<p>When you navigate to <code><a href="http://localhost:3001" rel="nofollow">http://localhost:3001</a></code> or the displayed URL on your terminal, you should see a page similar to this:</p>
<p><img data-attachment-id="120701" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/local-host-3001/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001.png" data-orig-size="730,392" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Run SolidJS app" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001-300x161.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001.png" class="aligncenter size-full wp-image-120701 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001.png" alt="Edit src/App.tsx and save to reload." width="730" height="392" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001-300x161.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="120701" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/local-host-3001/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001.png" data-orig-size="730,392" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Run SolidJS app" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001-300x161.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001.png" loading="lazy" class="aligncenter size-full wp-image-120701" src="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001.png" alt="Edit src/App.tsx and save to reload." width="730" height="392" srcset="https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/06/local-host-3001-300x161.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<h3 id="installing-bootstrap-style-solidjs">Installing Bootstrap to style our SolidJS app</h3>
<p>Now that we’ve successfully set up our SolidJS app, let’s install Bootstrap for styling so that we don’t have to bother about CSS.</p>
<p>To install Bootstrap, run the following command on your terminal:</p>
<pre class="language-bash hljs">pnpm install bootstrap
</pre>
<p>Next, we’ll use the following line of code to import Bootstrap in our <code>./src/index.tsx</code> file:</p>
<pre class="language-typescript hljs">import 'bootstrap/dist/css/bootstrap.min.css'
</pre>
<p>We can also remove the current <code>./index.css</code> import as we won’t be needing it. Our <code>index.tsx</code> file should now look like this:</p>
<pre class="language-typescript hljs">import { render } from 'solid-js/web'
import App from './App'
import 'bootstrap/dist/css/bootstrap.min.css'

render(() =&gt; &lt;App /&gt;, document.getElementById('root') as HTMLElement)
</pre>
<h2 id="using-jsx-structure-task-tracker">Using JSX to structure our task tracker</h2>
<p>Let’s use JSX to structure our task tracker. Inside the <code>./src/App.tsx</code> file, replace what you currently have with this:</p>
<pre class="language-typescript hljs">import type { Component } from 'solid-js'

const App: Component = () =&gt; {
  return (
    &lt;div class="container mt-5 text-center"&gt;
      &lt;h1 class="mb-4"&gt;Whattodo!&lt;/h1&gt;

      &lt;form class="mb-5 row row-cols-2 justify-content-center"&gt;
        &lt;input type="text" class="input-group-text p-1 w-25" placeholder="Add task here..." id="taskInput" required /&gt;

        &lt;button class="btn btn-primary ms-3 w-auto" type="submit"&gt;
          Add task
        &lt;/button&gt;
      &lt;/form&gt;

      &lt;div&gt;
        &lt;h4 class="text-muted mb-4"&gt;Tasks&lt;/h4&gt;
        &lt;div class="row row-cols-3 mb-3 justify-content-center"&gt;
          &lt;button class="btn btn-danger w-auto"&gt;X&lt;/button&gt;
          &lt;div class="bg-light p-2 mx-2"&gt;Push code to GitHub&lt;/div&gt;
          &lt;input type="checkbox" role="button" class="form-check-input h-auto px-3" /&gt;
        &lt;/div&gt;
      &lt;/div&gt;
    &lt;/div&gt;
  )
}
export default App
</pre>
<p>Our JSX code contains the form for inputting new tasks and the tasks section. For now, we’re using hard-coded data, but we’ll learn how we can make our app dynamic so that when a user inputs a new task in the form and clicks the <strong>Submit</strong> button, our SolidJS app updates with the new data.</p>
<p>When you go back to your browser, your page should now look like this:</p>
<p><img data-attachment-id="120703" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/solidjs-browser-example/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example.png" data-orig-size="730,341" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SolidJS app in browser" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example-300x140.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example.png" class="aligncenter size-full wp-image-120703 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example.png" alt="SolidJS App in browser" width="730" height="341" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example-300x140.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="120703" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/solidjs-browser-example/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example.png" data-orig-size="730,341" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SolidJS app in browser" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example-300x140.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example.png" loading="lazy" class="aligncenter size-full wp-image-120703" src="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example.png" alt="SolidJS App in browser" width="730" height="341" srcset="https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/06/solidjs-browser-example-300x140.png 300w" sizes="(max-width: 730px) 100vw, 730px"  /></noscript></p>
<p>Next, let’s learn how to create and manage state in SolidJS. We’ll do this by creating a <code>taskList</code> state and we’ll also create functions for adding new tasks to our state, removing them, and updating their completion status.</p>
<h2 id="creating-updating-state-solidjs">Creating and updating state in SolidJS</h2>
<p>SolidJS has a <code>createSignal</code> Hook to create state. As an example, let’s create a <code>taskList</code> state to house our tasks. Inside the <code>./src/App.tsx</code> file, we’ll start by creating a type for each task:</p>
<pre class="language-typescript hljs">const App: Component = () =&gt; {
  type Task = {
    text: string
    text: string
    completed: boolean
  }

  return (...)
}
</pre>
<p>Next, we’ll create our <code>taskList</code> state:</p>
<pre class="language-typescript hljs">import { Component, createSignal } from 'solid-js'

...
const [taskList, setTaskList] = createSignal([] as Task[])
...
</pre>
<p>The <code>createSignal()</code> Hook returns an array containing two variables, <code>taskList</code> and <code>setTaskList</code>. Unlike what you’ll <a href="https://blog.logrocket.com/react-hooks-cheat-sheet-unlock-solutions-to-common-problems-af4caf699e70/" target="_blank" rel="noopener">see with React Hooks</a>, both variables are functions. We call the <code>taskList()</code> function to access our task data, and the <code>setTaskList()</code> function to update our <code>taskList</code> state.</p>
<h3 id="adding-tasks-state">Adding tasks to our state</h3>
<p>Now that we’ve created our <code>taskList</code> state, let’s create a function for adding tasks to our state. We’ll name it <code>addTask</code>:</p>
<pre class="language-typescript hljs">const [taskList, setTaskList] = createSignal([] as Task[])

const addTask = (e: Event) =&gt; {
  e.preventDefault()

  const taskInput = document.querySelector('#taskInput') as HTMLInputElement

  const newTask: Task = {
    id: Math.random().toString(36).substring(2),
    text: taskInput.value,
    completed: false,
  }

  setTaskList([newTask, ...taskList()])
  taskInput.value = ''
}
</pre>
<p>Inside of our <code>addTask()</code> function, we’ve started by using the <code>e.preventDefault()</code> method to prevent the default reload behavior when we submit our form. We’re also getting our <code>taskInput</code> from the <code>&lt;input /&gt;</code> element with an ID of “taskInput”.</p>
<p>For each new task, we create an object named <code>newTask</code> with properties <code>id</code>, <code>text</code>, and <code>completed</code>. When a new task is created, our function will use the <code>Math.random()</code> method to generate a random string for our task ID and set the default <code>completed</code> value to <code>false</code>.</p>
<p>Finally, the <code>setTaskList()</code> function will be called with an array as its argument, appending the <code>newTask</code> with the current <code>taskList</code> state.</p>
<p>Let’s also create a function for deleting tasks:</p>
<pre class="language-typescript hljs">...
const deleteTask = (taskId: string) =&gt; {
  const newTaskList = taskList().filter((task) =&gt; task.id !== taskId)
  setTaskList(newTaskList)
}
</pre>
<p>When we call our <code>deleteTask()</code> function with the task ID as its argument, it will filter through our <code>taskList</code> state and return every task except the one with the ID we want to delete. Then, the <code>setTaskList()</code> method will be called with the new task list as its argument.</p>
<p>To put our <code>addTask()</code> function to use, we’ll add an <code>onSubmit</code> event listener to our <code>&lt;form /&gt;</code> tag in the JSX code, which will call our function whenever the submit button is clicked.</p>
<pre class="language-javascript hljs">...
return (
 &lt;div class="container mt-5 text-center"&gt;
    &lt;h1 class="mb-4"&gt;Whattodo!&lt;/h1&gt;
    &lt;form class="mb-5 row row-cols-2 justify-content-center" onSubmit={(e) =&gt; addTask(e)}&gt;
     ...
    &lt;/form&gt;
  &lt;/div&gt;
)
</pre>
<p>Next let’s see how we can show our <code>taskList</code> data in our app whenever a user adds a new task.</p>
<h2 id="control-flow-looping-data-solidjs">Control flow and looping through data in SolidJS</h2>
<p>SolidJS has a <code>&lt;For /&gt;</code> component for looping through data. While the JavaScript <code>Array.map()</code> method will work, our component will always map the <code>taskList</code> state when it’s updated. With the <code>&lt;For /&gt;</code> component, our app will only update the exact part of the DOM that needs updating.</p>
<p>Let’s replace what we currently have in the Tasks <code>div</code> with this:</p>
<pre class="language-javascript hljs">...
&lt;div&gt;
  &lt;h4 class="text-muted mb-4"&gt;Tasks&lt;/h4&gt;
  &lt;For each={taskList()}&gt;
    {(task: Task) =&gt; (
      &lt;div class="row row-cols-3 mb-3 justify-content-center"&gt;
        &lt;button class="btn btn-danger w-auto"&gt;X&lt;/button&gt;
        &lt;div class="bg-light p-2 mx-2"&gt;{task.text}&lt;/div&gt;
        &lt;input type="checkbox" checked={task.completed} role="button" class="form-check-input h-auto px-3" /&gt;
      &lt;/div&gt;
    )}
  &lt;/For&gt;
&lt;/div&gt;
...
</pre>
<p>Notice how we’re wrapping our <code>taskList</code> in the <code>&lt;For /&gt;</code> component. We’ve also updated the task text from “Push code to GitHub” to <code>task.text</code> from our <code>task</code> parameter.</p>
<p>We can now go ahead and use the <code>deleteTask()</code> method we created earlier. We’ll add an <code>onClick</code> event listener to the <strong>Delete</strong> button:</p>
<pre class="language-javascript hljs">...
&lt;button class="btn btn-danger w-auto" onclick={() =&gt; deleteTask(task.id)}&gt;
  X
&lt;/button&gt;
...
</pre>
<p>If we go over to our browser, our SolidJS app should now work like this:</p>
<p><img data-attachment-id="120735" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/typing-tasks-solidjs/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/typing-tasks-solidjs.gif" data-orig-size="710,357" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="typing-tasks-solidjs" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/typing-tasks-solidjs-300x151.gif" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/typing-tasks-solidjs.gif" class="aligncenter wp-image-120735 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/06/typing-tasks-solidjs.gif" alt="Adding tasks by typing in the task bar" width="710" height="357" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/06/typing-tasks-solidjs.gif?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="120735" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/typing-tasks-solidjs/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/typing-tasks-solidjs.gif" data-orig-size="710,357" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="typing-tasks-solidjs" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/typing-tasks-solidjs-300x151.gif" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/typing-tasks-solidjs.gif" loading="lazy" class="aligncenter wp-image-120735 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/06/typing-tasks-solidjs.gif" alt="Adding tasks by typing in the task bar" width="710" height="357"  /></noscript></p>
<h2 id="updating-tasks-status-nested-state">Updating tasks status in our nested state</h2>
<p>SolidJS has a <code>createStore()</code> Hook for creating and managing nested states. But before we talk about it, let’s see how we can make updates to pre-existing tasks in our <code>createSignal()</code> state. We’ll create a new function named <code>toggleStatus</code> just under the <code>deleteTask()</code> function:</p>
<pre class="language-typescript hljs">...
const toggleStatus = (taskId: string) =&gt; {
  const newTaskList = taskList().map((task) =&gt; {
    if (task.id === taskId) {
      return { ...task, completed: !task.completed }
    }
    return task
  })
  setTaskList(newTaskList)
}
</pre>
<p>Our <code>toggleStatus()</code> function expects a <code>taskId</code> argument, which we’ll use to get the particular task we want to mark as either completed or not-completed. We’re also using the <code>map()</code> method to loop through our <code>taskList</code> state, and if we find the task that has the same ID as the parameter <code>taskId</code>, we’ll change its <code>completed</code> property to the opposite of what’s currently there. So, if <code>true</code>, we’ll make it <code>false</code>, and if <code>false</code>, <code>true</code>.</p>
<p>Finally, we’re using the <code>setTaskList()</code> method to update the <code>taskList</code> state with our new <code>taskList</code> data.</p>
<p>Before we use our <code>toggleStatus()</code> function, let’s add a distinction between completed tasks and uncompleted tasks in our JSX code. We’ll add the Bootstrap class <em>&#8220;text-decoration-line-through text-success”</em> to the task text if its <code>completed</code> property is <code>true</code>. In our JSX code, just below the <strong>Delete</strong> button, let’s update the task text <code>div</code> to this:</p>
<pre class="language-javascript hljs">&lt;div class={`bg-light p-2 mx-2 ${task.completed &amp;&amp; 'text-decoration-line-through text-success'}`}&gt;
  {task.text}
&lt;/div&gt;
</pre>
<p>Next, we’ll add an <code>onClick</code> event listener to the checkbox input tag, where we’ll call the <code>toggleStatus()</code> method whenever it’s clicked:</p>
<pre class="language-javascript hljs">&lt;input
  type="checkbox"
  checked={task.completed}
  role="button"
  class="form-check-input h-auto px-3"
  onClick={() =&gt; {
    toggleStatus(task.id)
  }}
/&gt;
</pre>
<p>The JSX code that our <code>&lt;App /&gt;</code> component returns should now look like this:</p>
<pre class="language-html hljs">&lt;div class="container mt-5 text-center"&gt;
      &lt;h1 class="mb-4"&gt;Whattodo!&lt;/h1&gt;
      &lt;form class="mb-5 row row-cols-2 justify-content-center" onSubmit={(e) =&gt; addTask(e)}&gt;
        &lt;input type="text" class="input-group-text p-1 w-25" placeholder="Add task here..." id="taskInput" required /&gt;
        &lt;button class="btn btn-primary ms-3 w-auto" type="submit"&gt;
          Add task
        &lt;/button&gt;
      &lt;/form&gt;
      &lt;div&gt;
        &lt;h4 class="text-muted mb-4"&gt;Tasks&lt;/h4&gt;
        &lt;For each={taskList()}&gt;
          {(task: Task) =&gt; (
            &lt;div class="row row-cols-3 mb-3 justify-content-center"&gt;
              &lt;button class="btn btn-danger w-auto" onclick={() =&gt; deleteTask(task.id)}&gt;
                X
              &lt;/button&gt;
              &lt;div class={`bg-light p-2 mx-2 ${task.completed &amp;&amp; 'text-decoration-line-through text-success'}`}&gt;
                {task.text}
              &lt;/div&gt;
              &lt;input
                type="checkbox"
                checked={task.completed}
                role="button"
                class="form-check-input h-auto px-3"
                onClick={() =&gt; {
                  toggleStatus(task.id)
                }}
              /&gt;
            &lt;/div&gt;
          )}
        &lt;/For&gt;
      &lt;/div&gt;
    &lt;/div&gt;
</pre>
<p>When we go over to our browser, our SolidJS app should be able to work like this:</p>
<p><img data-attachment-id="120739" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/checking-boxes-deleting-tasks/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-deleting-tasks.gif" data-orig-size="710,357" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Web app checking tasks" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-deleting-tasks-300x151.gif" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-deleting-tasks.gif" class="aligncenter wp-image-120739 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-deleting-tasks.gif" alt="Adding tasks, checking them off, and deleting in web app" width="710" height="357" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-deleting-tasks.gif?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="120739" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/checking-boxes-deleting-tasks/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-deleting-tasks.gif" data-orig-size="710,357" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Web app checking tasks" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-deleting-tasks-300x151.gif" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-deleting-tasks.gif" loading="lazy" class="aligncenter wp-image-120739 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-deleting-tasks.gif" alt="Adding tasks, checking them off, and deleting in web app" width="710" height="357"  /></noscript></p>
<h2 id="using-create-store-nested-reactivity">Using <code>createStore</code> for nested reactivity in SolidJS</h2>
<p>Before we wrap up, let’s see how we can use the <code>createStore</code> Hook in SolidJS to create and update nested state. Instead of mapping through our state, creating a new task list, and replacing all of our state data with the new list, we can instead directly update the task that needs updating using its ID.</p>
<p>To use the <code>createStore</code> Hook, we’ll first import it from <code>solid-js/store</code>:</p>
<pre class="language-typescript hljs">import { createStore } from 'solid-js/store'
</pre>
<p>Notice that <code>createSignal</code> was imported from <code>solid-js</code>, while <code>createStore</code> is imported from <code>solid-js/store</code>.</p>
<p>Next, we’ll update our <code>taskList</code> state creation to this:</p>
<pre class="language-javascript hljs">const [taskList, setTaskList] = createStore([] as Task[])
</pre>
<p>The store we create with the <code>createStore()</code> Hook is not a function, unlike the one created with the <code>createSignal()</code> Hook. So, we’ll modify all instances of <code>taskList</code> in our code to just <code>taskList</code> instead of <code>taskList()</code>. The second variable, <code>setTaskList</code>, remains a function, and we’ll use it to update our store.</p>
<p>Let’s go ahead and use the <code>setTaskList()</code> method to modify the <code>toggleStatus()</code> function:</p>
<pre class="language-javascript hljs">const toggleStatus = (taskId: string) =&gt; {
  setTaskList(
    (task) =&gt; task.id === taskId,
    'completed',
    (completed) =&gt; !completed,
  )
}
</pre>
<p>In the <code>toggleStatus()</code> function, we pass three arguments to the <code>setTaskList()</code> method:</p>
<ol>
<li>A function to get the particular task we want to update. In our case we’re returning the task that has the same id as the <code>taskId</code> parameter</li>
<li>The property we want to modify — <code>completed</code></li>
<li>For the third argument, we’re passing another function that takes in the current value of our chosen property and returns a new value. Here, we’re returning the opposite of what it currently is</li>
</ol>
<p>When we go back to the browser, our app should still work as expected:</p>
<p><img data-attachment-id="120776" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/checking-boxes-still-working-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-still-working-1.gif" data-orig-size="710,357" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Task tracker app web browser" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-still-working-1-300x151.gif" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-still-working-1.gif" class="aligncenter wp-image-120776 size-full jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-still-working-1.gif" alt="Task tracker app is still working" width="710" height="357" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-still-working-1.gif?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="120776" data-permalink="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/attachment/checking-boxes-still-working-2/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-still-working-1.gif" data-orig-size="710,357" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Task tracker app web browser" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-still-working-1-300x151.gif" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-still-working-1.gif" loading="lazy" class="aligncenter wp-image-120776 size-full" src="https://blog.logrocket.com/wp-content/uploads/2022/06/checking-boxes-still-working-1.gif" alt="Task tracker app is still working" width="710" height="357"  /></noscript></p>
<h2 id="conclusion">Conclusion</h2>
<p>In this article, we’ve covered the basics of SolidJS by building a task tracker. Solid’s approach to building web applications is quite impressive and relatively straightforward when compared to other frontend frameworks like Angular and React. With direct compilation to real DOM nodes and without the need for a virtual DOM, web applications built with SolidJS have the uncommon advantage of being fast.</p>
<p>That said, SolidJS is still new, and its ecosystem and community are small compared to that of frameworks like React, Vue, and Angular, so there’s a good chance that you’ll be the first to encounter problems or be in need of specific functionalities, libraries, or integrations. But SolidJS is growing fast and lots of people have already started migrating existing apps to the framework. The SolidJS community is fairly responsive and you should not have any problem getting help when you need it.</p>
<p>You can find the <a href="https://github.com/ebenezerdon/solid-task-tracker" target="_blank" rel="noopener">repo for our task tracker</a> on my GitHub. I also have a <a href="https://youtu.be/WDodWU-B-aY" target="_blank" rel="noopener">SolidJS crash course</a> on my YouTube channel, which I’d love for you to check out. And if you want to keep in touch, consider following me on <a href="https://linkedin.com/in/ebenezerdon" target="_blank" rel="noopener">LinkedIn</a>. Keep building!</p><div class='code-block code-block-41' style='margin: 8px 0; clear: both;'>
<div class="blog-plug typescript-plug"><h2>Writing a lot of TypeScript? <a href="https://blog.logrocket.com/typescript-meetup-recap/?utm_source=social&utm_medium=organic&utm_campaign=21Q3_WB_TS-Tech-Meetup0930#utm_source=cro-blog&utm_medium=logrocket&utm_campaign=21Q3_WB_TS-Tech-Meetup0930">Watch the recording</a> of our recent TypeScript meetup to learn about writing more readable code.</h2><a class="signup" href="https://blog.logrocket.com/typescript-meetup-recap/?utm_source=social&utm_medium=organic&utm_campaign=21Q3_WB_TS-Tech-Meetup0930#utm_source=cro-blog&utm_medium=logrocket&utm_campaign=21Q3_WB_TS-Tech-Meetup0930" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2021/07/typescript-4-4-more-readable-code.png" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/07/typescript-4-4-more-readable-code.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" class="alignnone size-full wp-image-46" src="https://blog.logrocket.com/wp-content/uploads/2021/07/typescript-4-4-more-readable-code.png"  /></noscript></a><p style="margin-top: 15px;">TypeScript brings type safety to JavaScript. There can be a tension between type safety and readable code. Watch the recording for a deep dive on some new features of TypeScript 4.4.</p></div></div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-120511" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-120511" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-120511" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/build-task-tracker-solidjs-typescript/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/10/ebenezer-don-2021-150x150.jpeg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/10/ebenezer-don-2021-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/10/ebenezer-don-2021-150x150.jpeg?crop=1' class='avatar avatar-72 photo' height='72' width='72'  /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/ebenezerdon/">
Ebenezer Don <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Full-stack software engineer with a passion for building meaningful products that ease the lives of users.</span>
</div>
</div>
<div class="after-post-tags">
<ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/featured/" rel="category tag">Featured Posts</a></li>
<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/typescript/">#typescript</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/product-management/planning-poker-agile-estimation-scrum/" rel="prev">Planning poker: The agile way to do estimation for scrum teams</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/security-choices-multi-signature-wallets/" rel="next">Security choices and multi-signature wallets</a> &raquo;</div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
 <div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/security-choices-multi-signature-wallets/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/06/security-choices-multi-signature-wallets.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/security-choices-multi-signature-wallets/">Security choices and multi-signature wallets</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/oripomerantz/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/03/ori-pomerantz-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/03/ori-pomerantz-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/03/ori-pomerantz-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/oripomerantz/">Ori Pomerantz</a></span><br>
<span class="post-date">Jun 29, 2022</span>
<span class="dot"></span>
<span class="readingtime">11 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/security-choices-multi-signature-wallets/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/how-to-use-dateformatter-swift/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/06/how-to-use-dateformatter-swift-copy.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/how-to-use-dateformatter-swift/">How to use DateFormatter in Swift</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/matthewcroak/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/08/profile-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/08/profile-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/08/profile-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/matthewcroak/">Matthew Croak</a></span><br>
<span class="post-date">Jun 28, 2022</span>
<span class="dot"></span>
<span class="readingtime">4 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/how-to-use-dateformatter-swift/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/adding-gifs-ios-app-flanimatedimage-swiftui/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/06/adding-gifs-ios-app-flanimatedimage-swiftui-nocdn.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/adding-gifs-ios-app-flanimatedimage-swiftui/">Adding GIFs to your iOS app with FLAnimatedImage and&hellip;</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/rudrankriyam/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/03/rudrank-riyam-150x150.jpeg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/03/rudrank-riyam-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/03/rudrank-riyam-150x150.jpeg?crop=1' class='avatar avatar-40 photo' height='40' width='40'  /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/rudrankriyam/">Rudrank Riyam</a></span><br>
<span class="post-date">Jun 28, 2022</span>
<span class="dot"></span>
<span class="readingtime">8 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/adding-gifs-ios-app-flanimatedimage-swiftui/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/build-task-tracker-solidjs-typescript#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=120511&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;jetpack_comments_nonce=87999cba43&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=11.1-a.5&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=30ffaa076bc496a635b94b39a0a365bb07926d7f#parent=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="footerRight"><style>

	.footer .container{padding:20px 20px 10px 20px; color:white !important;}

	.footer .grid{
		display: grid;
		grid-template: auto auto auto / 150px auto;
		height:100%;
		grid-gap:20px;
		justify-items: left;
		align-items: center;
		font-family: 'PT Sans';
		padding:40px;
		background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/podrocket_slider_bg.png");
		background-position: center;
		background-repeat: no-repeat;
		background-size:cover;
		border-radius:30px;
		/* box-shadow: 0px 50px 120px 0px #2024734d; */
	}

	.footer .grid2{background-image: url('https://blog.logrocket.com/wp-content/uploads/2021/07/podrocket_slider_bg_v3.png');}

	.footer .epname{color:white !important; font-size: 24px;font-weight:700;}
	.footer .desc{color:white !important; font-size: 16px;align-self:start;}

	.footer .epname2{color:#202473 !important;}
	.footer .desc2{color:#383f4D !important;}

	.footer .info{
		font-weight:700;
		font-size: 13px;
		padding: 5px 10px 5px 10px;
		margin-bottom:10px;
		background-color: #ffffff;
		text-transform: uppercase;
		color:#202473;
		display:flex;
		width: 160px !important;
		border-radius:20px;
		letter-spacing: 1px;
	}

	.footer .info2{background-color:#202473; color:white;}

	.footer .a{grid-area: 1 / 1 / span 1 / span 1;}
	.footer .b{grid-area: 1 / 2 / span 1 / span 1;}
	.footer .cd{grid-area: 2 / 1 / span 1 / span 2;}
	.footer .ef{grid-area: 3 / 1 / span 1 / span 2; justify-self: start;}

	.footer .cta{
		font-weight: 700;
		font-size: 20px;
		text-transform: uppercase;
		padding: 15px 40px 15px 40px;
		background-color: white;
		color: #202473;
		letter-spacing: 1px;
		border: 0px;
		border-radius: 45px;
		transition: 400ms;
	}

	.footer .cta:hover{
		box-shadow: 0px 20px 40px 0px rgba(255,255,255,0.2);
		transition: 400ms;
	}

	.footer .cta2{background-color:#202473; color:white !important;}
	.footer .cta2:hover{box-shadow: 0px 20px 40px 0px #20247333;}

	.avatar1 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_rome.png");border-radius: 0px !important;}
	.avatar2 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_rocket-surgery.png");border-radius: 100%;}
	.avatar3 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_mark-erikson.png");border-radius: 100%;}
	.avatar4 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_continuing-education.png");border-radius: 100%;}

	.footer .avatar{
		width:150px;
		height:150px;
		
		background-position: center;
		background-repeat: no-repeat;
		background-size:cover;
		z-index: 99;
		/* box-shadow: 0px 36px 50px 0px rgba(32,36,115,0.75); */
	}

	.avatar_light{box-shadow: 0px 36px 50px 0px rgba(32,36,115,0.2);}

	.footer .owl-stage-outer a{
		text-decoration:none !important;
		color: #202473 !important;
	}

	@media only screen and (max-width: 900px){
		
		.footer .container{padding:10px;}

		.footer .grid{
			display: grid;
			grid-template: 150px auto auto auto / auto;
			padding:30px;
			border-radius:20px;
			grid-gap:14px;
		}

		.footer .a{grid-area: 1 / 1 / span 1 / span 1;}
		.footer .b{grid-area: 2 / 1 / span 1 / span 1;}
		.footer .cd{grid-area: 3 / 1 / span 1 / span 1;}
		.footer .ef{grid-area: 4 / 1 / span 1 / span 1; justify-self: start;}

		.footer .cta{font-size:16px; padding: 10px 20px 10px 20px;}
		.footer .epname{font-size: 20px;}
		.footer .desc{font-size: 14px;}
		
	}

</style>
<h2>Have you listened to our podcast? Check it out:</h2>
<div class='white' style='background:rgb(255, 255, 255); border:solid 0px #f0f0f0; border-radius:20px; padding:0px 0px 0px 0px;'>
<div id='sample_slider' class='owl-carousel sa_owl_theme owl-pagination-true' data-slider-id='sample_slider' style='visibility:hidden;'>
<div id='sample_slider_slide03' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid">
<div class="a"><div class="avatar avatar3"></div></div>
<div class="b">
<span class="info">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 26</span>
</span>
<span class="epname">Redux is alive and well with Mark Erikson</span>
</div>
<div class="cd desc">What is modern Redux? What is it with the obsession of declaring Redux dead? In this episode, Ben and Brian interview Mark Erikson to talk about all things Redux.</div>
<a href="https://podrocket.logrocket.com/redux" class="ef cta">Listen now</a>
</div>
</div></div>
<div id='sample_slider_slide04' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid grid2">
<div class="a"><div class="avatar avatar_light avatar4"></div></div>
<div class="b">
<span class="info info2">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 29</span>
</span>
<span class="epname epname2">Continuing education with Eve Porcello</span>
</div>
<div class="cd desc desc2">In this episode, we talk to Eve Porcello about her experience teaching web development and Moon Highway, a training and curriculum development company she runs.</div>
<a href="https://podrocket.logrocket.com/continuing-education" class="ef cta cta2" style="color: white !important;">Listen now</a>
</div>
</div></div>
<div id='sample_slider_slide01' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid">
<div class="a"><div class="avatar avatar1"></div></div>
<div class="b">
<span class="info">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 34</span>
</span>
<span class="epname">Rome and Rome Tools, Inc. with Sebastian McKenzie and Jamie Kyle</span>
</div>
<div class="cd desc">In this episode, Ben and Kaelan talk to Sebastian McKenzie and Jamie Kyle about Rome Tools, Inc., the roadmap for Rome, and the experience of getting funding as an open-source tool.</div>
<a href="https://podrocket.logrocket.com/rome" class="ef cta">Listen now</a>
</div>
</div></div>
<div id='sample_slider_slide02' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid grid2">
<div class="a"><div class="avatar avatar_light avatar2"></div></div>
<div class="b">
<span class="info info2">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 30</span>
</span>
<span class="epname epname2">Rocket Surgery: Kaelan and Chris Coyier compare notes</span>
</div>
<div class="cd desc desc2">Are you up to speed on all of this new CSS stuff? Chris Coyier and Kaelan compare notes on CSS and frontend development (they also discuss MDN plus).</div>
<a href="https://podrocket.logrocket.com/css" class="ef cta cta2" style="color: white !important;">Listen now</a>
</div>
</div></div>
</div>
</div>
<script type='text/javascript'>
	document.addEventListener('DOMContentLoaded', function() {
		jQuery('#sample_slider').owlCarousel({
			responsive:{
				0:{ items:1 },
				480:{ items:1 },
				768:{ items:2 },
				980:{ items:2 },
				1200:{ items:2 },
				1500:{ items:2 }
			},
			autoplay : false,
			autoplayHoverPause : false,
			smartSpeed : 300,
			fluidSpeed : 300,
			autoplaySpeed : 300,
			navSpeed : 300,
			dotsSpeed : 300,
			loop : true,
			nav : true,
			navText : ['Previous','Next'],
			dots : true,
			responsiveRefreshRate : 200,
			slideBy : 1,
			mergeFit : true,
			autoHeight : false,
			mouseDrag : false,
			touchDrag : true
		});
		jQuery('#sample_slider').css('visibility', 'visible');
		var owl_goto = jQuery('#sample_slider');
		jQuery('.sample_slider_goto1').click(function(event){
			owl_goto.trigger('to.owl.carousel', 0);
		});
		jQuery('.sample_slider_goto2').click(function(event){
			owl_goto.trigger('to.owl.carousel', 1);
		});
		jQuery('.sample_slider_goto3').click(function(event){
			owl_goto.trigger('to.owl.carousel', 2);
		});
		jQuery('.sample_slider_goto4').click(function(event){
			owl_goto.trigger('to.owl.carousel', 3);
		});
		var resize_59470 = jQuery('.owl-carousel');
		resize_59470.on('initialized.owl.carousel', function(e) {
			if (typeof(Event) === 'function') {
				window.dispatchEvent(new Event('resize'));
			} else {
				var evt = window.document.createEvent('UIEvents');
				evt.initUIEvent('resize', true, false, window, 0);
				window.dispatchEvent(evt);
			}
		});
	});
</script>
</div> <div class="clearfix"></div>
<a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202226'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text(),
	postAuthor: jQuery("meta[name='twitter:data1']").attr("content"),
	id: jQuery(".mainheading").closest(".col-md-8").attr("id").replace('post-','')
  });
}
jQuery(".aretags li a:contains('archive')").parent('li').hide();
jQuery(".aretags li a:contains('86919')").parent('li').hide();
jQuery(".aretags li a:contains('72293')").parent('li').hide();
};</script>
<script>
// fix for pagination position on wpblock query results page
jQuery(".wp-container-12").css({"position":"absolute","bottom":"-20px"});
</script> <div style="display:none">
<div class="grofile-hash-map-91337866b9e7a7c13894f52498020ebb">
</div>
<div class="grofile-hash-map-4b1ecd490d0ac296a80e152f8812a55b">
</div>
<div class="grofile-hash-map-4ede3c64a38f3218f91ea58afd594ba3">
</div>
<div class="grofile-hash-map-66aea9f5d4f707a913b69a665d36dc28">
</div>
</div>
<div id="jp-carousel-loading-overlay">
<div id="jp-carousel-loading-wrapper">
 <span id="jp-carousel-library-loading">&nbsp;</span>
</div>
</div>
<div class="jp-carousel-overlay" style="display: none;">
<div class="jp-carousel-container">

<div class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions" itemscope itemtype="https://schema.org/ImageGallery">
<div class="jp-carousel swiper-wrapper"></div>
<div class="jp-swiper-button-prev swiper-button-prev">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white" />
</mask>
<g mask="url(#maskPrev)">
<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
<div class="jp-swiper-button-next swiper-button-next">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white" />
</mask>
<g mask="url(#maskNext)">
<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
</div>

<div class="jp-carousel-close-hint">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white" />
</mask>
<g mask="url(#maskClose)">
<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>

<div class="jp-carousel-info">
<div class="jp-carousel-info-footer">
<div class="jp-carousel-pagination-container">
<div class="jp-swiper-pagination swiper-pagination"></div>
<div class="jp-carousel-pagination"></div>
</div>
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-caption"></h2>
</div>
<div class="jp-carousel-photo-icons-container">
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white" />
</mask>
<g mask="url(#maskInfo)">
<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</span>
</a>
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white" />
</mask>
<g mask="url(#maskComments)">
<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
</span>
</a>
</div>
</div>
<div class="jp-carousel-info-extra">
<div class="jp-carousel-info-content-wrapper">
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-title"></h2>
</div>
<div class="jp-carousel-comments-wrapper">
<div id="jp-carousel-comments-loading">
<span>Loading Comments...</span>
</div>
<div class="jp-carousel-comments"></div>
<div id="jp-carousel-comment-form-container">
<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
<div id="jp-carousel-comment-post-results"></div>
<form id="jp-carousel-comment-form">
<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
<textarea name="comment" class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea" id="jp-carousel-comment-form-comment-field" placeholder="Write a Comment..."></textarea>
<div id="jp-carousel-comment-form-submit-and-info-wrapper">
<div id="jp-carousel-comment-form-commenting-as">
<fieldset>
<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-url-field">Website</label>
<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
</fieldset>
</div>
<input type="submit" name="submit" class="jp-carousel-comment-form-button" id="jp-carousel-comment-form-button-submit" value="Post Comment" />
</div>
</form>
</div>
</div>
<div class="jp-carousel-image-meta">
<div class="jp-carousel-title-and-caption">
<div class="jp-carousel-photo-info">
<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
</div>
<div class="jp-carousel-photo-description"></div>
</div>
<ul class="jp-carousel-image-exif" style="display: none;"></ul>
<a class="jp-carousel-image-download" target="_blank" style="display: none;">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white" />
</mask>
<g mask="url(#mask0)">
<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-download-text"></span>
</a>
<div class="jp-carousel-image-map" style="display: none;"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/build-task-tracker-solidjs-typescript\/":120511};
	</script>
<link rel='stylesheet' id='owl_carousel_css-css' href='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/owl.carousel.css?ver=2.2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='owl_theme_css-css' href='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/sa-owl-theme.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='owl_animate_css-css' href='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/animate.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://blog.logrocket.com/wp-includes/css/dashicons.min.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='nf-display-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/display-opinions-light.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='nf-font-awesome-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/font-awesome.min.css?ver=6.0' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-before'>
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=6.0' id='comment-reply-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=83ec8aa758f883d6da14' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=54eb31dc971b63b49278' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/blog.logrocket.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"0be3323601","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=11.1-a.5' id='jetpack-carousel-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/owl.carousel.min.js?ver=2.2.1' id='owl_carousel_js-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/slide-anything/js/jquery.mousewheel.min.js?ver=3.1.13' id='mousewheel_js-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/backbone.min.js?ver=1.4.1' id='backbone-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end-deps.js?ver=3.6.12' id='nf-front-end-deps-js'></script>
<script type='text/javascript' id='nf-front-end-js-extra'>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</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end.js?ver=3.6.12' id='nf-front-end-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.1-a.5' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=120511&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=87999cba43&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.1-a.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=30ffaa076bc496a635b94b39a0a365bb07926d7f#parent=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=120511&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=87999cba43&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.1-a.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=30ffaa076bc496a635b94b39a0a365bb07926d7f#parent=https%3A%2F%2Fblog.logrocket.com%2Fbuild-task-tracker-solidjs-typescript";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202226.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.1-a.5',blog:'161333275',post:'120511',tz:'-4',srv:'blog.logrocket.com',hp:'atomic',ac:'2',amp:'0'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '120511' ]);
</script>
<script id="tmpl-nf-layout" type="text/template">
	<span id="nf-form-title-{{{ data.id }}}" class="nf-form-title">
		{{{ ( 1 == data.settings.show_title ) ? '<h3>' + data.settings.title + '</h3>' : '' }}}
	</span>
	<div class="nf-form-wrap ninja-forms-form-wrap">
		<div class="nf-response-msg"></div>
		<div class="nf-debug-msg"></div>
		<div class="nf-before-form"></div>
		<div class="nf-form-layout"></div>
		<div class="nf-after-form"></div>
	</div>
</script>
<script id="tmpl-nf-empty" type="text/template">

</script>
<script id="tmpl-nf-before-form" type="text/template">
	{{{ data.beforeForm }}}
</script><script id="tmpl-nf-after-form" type="text/template">
	{{{ data.afterForm }}}
</script><script id="tmpl-nf-before-fields" type="text/template">
    <div class="nf-form-fields-required">{{{ data.renderFieldsMarkedRequired() }}}</div>
    {{{ data.beforeFields }}}
</script><script id="tmpl-nf-after-fields" type="text/template">
    {{{ data.afterFields }}}
    <div id="nf-form-errors-{{{ data.id }}}" class="nf-form-errors" role="alert"></div>
    <div class="nf-form-hp"></div>
</script>
<script id="tmpl-nf-before-field" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-after-field" type="text/template">
    {{{ data.afterField }}}
</script><script id="tmpl-nf-form-layout" type="text/template">
	<form>
		<div>
			<div class="nf-before-form-content"></div>
			<div class="nf-form-content {{{ data.element_class }}}"></div>
			<div class="nf-after-form-content"></div>
		</div>
	</form>
</script><script id="tmpl-nf-form-hp" type="text/template">
	<label for="nf-field-hp-{{{ data.id }}}" aria-hidden="true">
		{{{ nfi18n.formHoneypot }}}
		<input id="nf-field-hp-{{{ data.id }}}" name="nf-field-hp" class="nf-element nf-field-hp" type="text" value=""/>
	</label>
</script>
<script id="tmpl-nf-field-layout" type="text/template">
    <div id="nf-field-{{{ data.id }}}-container" class="nf-field-container {{{ data.type }}}-container {{{ data.renderContainerClass() }}}">
        <div class="nf-before-field"></div>
        <div class="nf-field"></div>
        <div class="nf-after-field"></div>
    </div>
</script>
<script id="tmpl-nf-field-before" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-field-after" type="text/template">
    <#
    /*
     * Render our input limit section if that setting exists.
     */
    #>
    <div class="nf-input-limit"></div>
    <#
    /*
     * Render our error section if we have an error.
     */
    #>
    <div id="nf-error-{{{ data.id }}}" class="nf-error-wrap nf-error" role="alert"></div>
    <#
    /*
     * Render any custom HTML after our field.
     */
    #>
    {{{ data.afterField }}}
</script>
<script id="tmpl-nf-field-wrap" type="text/template">
	<div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
		<#
		/*
		 * This is our main field template. It's called for every field type.
		 * Note that must have ONE top-level, wrapping element. i.e. a div/span/etc that wraps all of the template.
		 */
        #>
		<#
		/*
		 * Render our label.
		 */
        #>
		{{{ data.renderLabel() }}}
		<#
		/*
		 * Render our field element. Uses the template for the field being rendered.
		 */
        #>
		<div class="nf-field-element">{{{ data.renderElement() }}}</div>
		<#
		/*
		 * Render our Description Text.
		 */
        #>
		{{{ data.renderDescText() }}}
	</div>
</script>
<script id="tmpl-nf-field-wrap-no-label" type="text/template">
    <div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
        <div class="nf-field-label"></div>
        <div class="nf-field-element">{{{ data.renderElement() }}}</div>
        <div class="nf-error-wrap"></div>
    </div>
</script>
<script id="tmpl-nf-field-wrap-no-container" type="text/template">

        {{{ data.renderElement() }}}

        <div class="nf-error-wrap"></div>
</script>
<script id="tmpl-nf-field-label" type="text/template">
	<div class="nf-field-label"><label for="nf-field-{{{ data.id }}}"
	                                   id="nf-label-field-{{{ data.id }}}"
	                                   class="{{{ data.renderLabelClasses() }}}">{{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}} {{{ ( 'undefined' != typeof data.required && 1 == data.required ) ? '<span class="ninja-forms-req-symbol">*</span>' : '' }}} {{{ data.maybeRenderHelp() }}}</label></div>
</script>
<script id="tmpl-nf-field-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-form-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-field-input-limit" type="text/template">
    {{{ data.currentCount() }}} {{{ nfi18n.of }}} {{{ data.input_limit }}} {{{ data.input_limit_msg }}}
</script><script id="tmpl-nf-field-null" type="text/template">
</script><script id="tmpl-nf-field-listcheckbox" type="text/template">
    <ul aria-describedby="nf-error-{{{ data.id }}}">
        {{{ data.renderOptions() }}}
    </ul>
</script>
<script id='tmpl-nf-field-listcheckbox-option' type='text/template'>
    <# if ( ! data.visible ) { return '' } #>
    <li>
        <input type="checkbox" id="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}" name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element {{{ ( data.isSelected ) ? ' nf-checked' : '' }}}" value="{{{ data.value }}}" {{{ ( data.isSelected ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
            <# if( data.required ) { #>
			required
			<# } #>
        >
        <label for="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               id="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               class="{{{ ( data.isSelected ) ? 'nf-checked-label' : '' }}}">{{{ data.label }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other' type='text/template'>
    <li {{{ ( ! data.visible ) ? 'style="display:none"' : '' }}}>
        <input type="checkbox"
               id="nf-field-{{{ data.fieldID }}}-other"
               name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element" value="nf-other" {{{ ( ! data.valueFound ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-other"
            <# if( data.required ) { #>
			required
			<# } #>
        >
         <label id="nf-label-field-{{{ data.fieldID }}}-other">Other
            {{{ data.renderOtherText() }}}
        </label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other-text' type='text/template'>
    <input type="text" name="nf-field-{{{ data.fieldID }}}" class="nf-element" value="{{{ data.currentValue }}}">
</script>
<script id='tmpl-nf-field-input' type='text/template'>
    <input id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" aria-invalid="false" aria-describedby="nf-error-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element" type="text" value="{{{ _.escape( data.value ) }}}" {{{ data.renderPlaceholder() }}} {{{ data.maybeDisabled() }}}
           aria-labelledby="nf-label-field-{{{ data.id }}}"

            {{{ data.maybeRequired() }}}
    >
</script>
<script id="tmpl-nf-field-email" type="text/template">
	<input
			type="email"
			value="{{{ _.escape( data.value ) }}}"
			class="{{{ data.renderClasses() }}} nf-element"

			id="nf-field-{{{ data.id }}}"
			<# if( ! data.disable_browser_autocompletes ){ #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id + '-' + data.type }}"
			autocomplete="email"
			<# } else { #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id }}"
			{{{ data.maybeDisableAutocomplete() }}}
			<# } #>
			{{{ data.renderPlaceholder() }}}
			{{{ data.maybeDisabled() }}}

			aria-invalid="false"
			aria-describedby="nf-error-{{{ data.id }}}"
			aria-labelledby="nf-label-field-{{{ data.id }}}"

			{{{ data.maybeRequired() }}}
	>
</script>
<script id="tmpl-nf-field-submit" type="text/template">
	<input id="nf-field-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element " type="button" value="{{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}}" {{{ ( data.disabled ) ? 'disabled' : '' }}}>
</script><script id='tmpl-nf-field-button' type='text/template'>
    <button id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" class="{{{ data.classes }}} nf-element">
        {{{ ( data.maybeFilterHTML() === 'true' ) ? _.escape( data.label ) : data.label }}}
    </button>
</script><script>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</script>
</body>
</html>

