<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Methods for deep cloning objects in JavaScript - LogRocket Blog</title>
	<meta name="description" content="There are several ways to shallow clone objects in JavaScript, but deep cloning objects is trickier. We highlight several methods to do so." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Methods for deep cloning objects in JavaScript - LogRocket Blog" />
	<meta property="og:description" content="There are several ways to shallow clone objects in JavaScript, but deep cloning objects is trickier. We highlight several methods to do so." />
	<meta property="og:url" content="https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/" />
	<meta property="og:site_name" content="LogRocket Blog" />
	<meta property="article:published_time" content="2020-10-01T13:00:39+00:00" />
	<meta property="article:modified_time" content="2020-09-29T21:20:08+00:00" />
	<meta property="og:image" content="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?fit=730%2C487&#038;ssl=1" />
	<meta property="og:image:width" content="730" />
	<meta property="og:image:height" content="487" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@https://twitter.com/alex_nnakwue" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?fit=730%2C487&ssl=1","width":730,"height":487,"caption":"Methods for Deep Cloning Objects in JavaScript"},{"@type":"WebPage","@id":"https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/#webpage","url":"https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/","name":"Methods for deep cloning objects in JavaScript - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/#primaryimage"},"datePublished":"2020-10-01T13:00:39+00:00","dateModified":"2020-09-29T21:20:08+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/4a06289456bed2a5b0241d68b6eabab3"},"description":"There are several ways to shallow clone objects in JavaScript, but deep cloning objects is trickier. We highlight several methods to do so.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/"]}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/4a06289456bed2a5b0241d68b6eabab3","name":"Alexander Nnakwue","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/8cef3b13cd11e184c6993c4b710b15fa?s=96&d=mm&r=g","caption":"Alexander Nnakwue"},"description":"Software Engineer. React, Node.js, Python, and other developer tools and libraries.","sameAs":["https://twitter.com/https://twitter.com/alex_nnakwue"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Methods for deep cloning objects in JavaScript Comments Feed" href="https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css'  href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css'  href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.9.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.9.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-3.5.1.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jquery-updater/js/jquery-migrate-3.3.0.min.js?ver=3.3.0' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/26142" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/paUW9B-6NE' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">

    <script>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</script>


    <script>
    window.Raven && window.Raven.config('https://98e0ea7c6f2e492d94439ad5aaea48dd@e.logrocket.com/4').install()
    </script>
    <script type="text/javascript">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</script>

<!-- Start VWO Async Smartcode -->
<script type='text/javascript'>
window._vwo_code = window._vwo_code || (function(){
var account_id=338524,
settings_tolerance=2000,
library_tolerance=2500,
use_existing_jquery=false,
is_spa=1,
hide_element='body',

/* DO NOT EDIT BELOW THIS LINE */
f=false,d=document,code={use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){
settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b=hide_element?hide_element+'{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}':'',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&f='+(+is_spa)+'&r='+Math.random());return settings_timer; }};window._vwo_settings_timer = code.init(); return code; }());
</script>
<!-- End VWO Async Smartcode -->

    <script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
    <script>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</script><style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196.png?fit=270%2C270&#038;ssl=1" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=96b7e078cf" />
		<style id="kirki-inline-styles">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</style></head>

<body class="post-template-default single single-post postid-26142 single-format-standard">

<style>
    </style>


<header class="navbar-light bg-white fixed-top mediumnavigation">

    <div class="container">



        <div class="navarea">

<div class="nav-left">

  <a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>

<nav class="menu-container">

        <div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a></ul></div></nav>

</div>

<div class="nav-right">

  <div class="menu-container">
    <div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Free Trial</a></li>
</ul></div>  </div>

</div>

        </div>

    </div>

</header>


        <!-- Begin site-content
		================================================== -->
        <div class="site-content">


<div class="container"> 
    <div class="row">         
        <div class=" col-md-2 ">           
            <div class="share">
                
                <div class="sidebarapplause">
                                </div>
                
                				<p class="sharecolour">
					Share				</p>
                
<ul class="shareitnow"><li>
        <a target="_blank" href="https://twitter.com/intent/tweet?text=Methods%20for%20deep%20cloning%20objects%20in%20JavaScript&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F">
        <i class="fa fa-twitter"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F">
        <i class="fa fa-facebook"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F">
        <i class="fa fa-google"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F&amp;media=https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?fit=730%2C487&ssl=1&amp;description=Methods%20for%20deep%20cloning%20objects%20in%20JavaScript">
        <i class="fa fa-pinterest"></i>
        </a>
    </li><li>
        <a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F&amp;title=Methods%20for%20deep%20cloning%20objects%20in%20JavaScript">
        <i class="fa fa-linkedin"></i>
        </a>
    </li></ul>                		        
                
                                <div class="sep"></div>
                <div class="hidden-xs-down">      

                    <p>
                        Reply                    </p>
                    <ul>
                        <li>
                        <a class="smoothscroll" href="#comments">0<br/>
                        <svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
                        </a>
                        </li>
                    </ul>
                </div>
                            </div>			                                
        </div>
        
                    			                <div class="col-md-8 flex-first flex-md-unordered post-26142 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-vanilla-javascript" id="post-26142"> 
                    <div class="mainheading">
                       
                                                <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-md-down"> 
                            <div class="col-md-2 col-xs-12"> 
                                <a href="https://blog.logrocket.com/author/alexandernnakwue/">
                                    <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/10/alexander-nnakwue.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/10/alexander-nnakwue.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/10/alexander-nnakwue.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                                </a>
                            </div>                                         
                            <div class="col-md-10 col-xs-12"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/alexandernnakwue/">
                                Alexander Nnakwue <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">Software Engineer. React, Node.js, Python, and other developer tools and libraries.</span> 
                            </div>                                         
                        </div>
                                                 
                                                
                        <h1 class="posttitle">Methods for deep cloning objects in JavaScript</h1>
					    <h2 class="post-subtitle"></h2>

                        <p>
                                                        <span class="post-date"><time class="post-date">
                            October 1, 2020                            </time></span>
                                                        
                                                        <span class="dot"></span>
                            <span class="readingtime">7 min read</span>
						    <span class="wordcount">2007</span>

                                                    </p> 
                    </div>
                    
                  <img width="730" height="487" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?fit=730%2C487&amp;ssl=1" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="Methods for Deep Cloning Objects in JavaScript" loading="lazy" data-attachment-id="26181" data-permalink="https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/deep-cloning-objects-javascript/" data-orig-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?fit=730%2C487&amp;ssl=1" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Methods for deep cloning objects in JavaScript" data-image-description="" data-medium-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?fit=300%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?fit=730%2C487&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?w=730&amp;ssl=1 730w, https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?resize=300%2C200&amp;ssl=1 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/deep-cloning-objects-javascript.png?fit=730%2C487&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    <article class="article-post">
                                                <h2>Introduction</h2>
<p>In JavaScript, objects are like a store or collection of key-value pairs. They are a kind of <a href="https://developer.mozilla.org/en-US/docs/Web/JavaScript/Data_structures">structural data type</a>, which can be seen as a collection of properties. These properties can either be values of other data types, including primitive types like <code>Boolean</code>, <code>Number</code>, <code>undefined</code>, etc., or even other objects. Therefore, with objects, we can build even more complex data structures.</p>
<p>Due to the nature of objects in JS, they are usually stored in memory and can only be copied by reference. This means that a variable does not store an object in itself, but rather an identifier, which represents an address or a reference to that particular object in memory. As such, objects cannot be treated in the same way as primitives.</p>
<p>With primitive data types, once variables are assigned, they cannot be copied over. Therefore, changing the value of the variable never changes the underlying primitive type. This means it is impossible to change the values of these types once they are assigned to a variable — a concept known as immutability. However, they can be combined together to derive new values.</p>
<p>Objects, on the other hand, are mutable data types. In this article, we will explore ways of modifying or mutating objects in JavaScript. This entails performing either shallow or deep cloning or copying with respect to general object behavior.</p>
<h2>Introducing object behavior</h2>
<p>To reiterate, objects are reference types, and as such, when we copy an object variable, we are indirectly creating one more reference to the same object stored somewhere else in the computer’s memory. Therefore, when an object variable is copied, only a reference to the object is copied — the actual object is not!</p>
<p>Let’s look at an example to understand this concept better:</p>
<pre>let user = { name: "Alexander" }

// this instead copies a reference to the previous object
let newUser = user</pre>
<p>In the above example, we have two variables, each making reference to the same object in memory. In this case, the variable <code>newUser</code> has a reference to the initially declared <code>user</code> variable in memory. Note that this is only possible for reference types like objects and arrays; for primitive types like a string or a Boolean, this is not the case.</p>
<blockquote><p><strong>Note</strong>: We can make use of the <code>Object.is()</code> method to determine whether the two values are actually the same value. Running <code>console.log(Object.is(user, newUser))</code> on the browser console should return the Boolean value <code>true</code>.</p></blockquote>
<h2>Object copying methods</h2>
<p>JavaScript offers many ways of copying objects, but they do not provide a deep copy. Performing shallow copies is the default behavior in most of the cases.</p>
<p>We should note that ES6 provides two shorter syntaxes for shallow copying objects in the language. They include <code><a href="https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Object/assign">Object.assign()</a></code> and the <a href="https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Operators/Spread_syntax">spread syntax</a>, which copies values of all <a href="https://developer.mozilla.org/en-US/docs/Web/JavaScript/Enumerability_and_ownership_of_properties">enumerable own properties</a>.) from one object to another.</p>
<blockquote><p><strong>Note</strong>: A shallow copy successfully copies <a href="https://flaviocopes.com/javascript-types/#primitive-types">primitive types</a> like numbers and strings, but any object reference will not be recursively copied, but instead the new, copied object will reference the same initial object.</p></blockquote>
<p>Let’s look at them one after the other:</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br/>No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>

<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>

<h3>Copying an object with the <code>Object.assign()</code> method</h3>
<p>Among the <a href="https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Object/assign#">object constructor methods</a>, <code>Object.assign()</code> is used to copy the values and properties from one or more source objects to a target object. It returns the target object, which has properties and values copied from the source object.</p>
<p>Since <code>Object.assign()</code> copies property values, it is unsuitable for deep cloning. Basically, we can use this method for shallow cloning an object and for merging two or more objects into one bigger object with the same properties.</p>
<ul>
<li><strong>Syntax:</strong>
<pre style="padding-left: 40px;">const copied = Object.assign(target, ...sources)</pre>
<blockquote><p><strong>Note</strong>: In using this method, if we have matching keys in both target and source objects, the matching keys in the second object would override the first one after cloning.</p></blockquote>
</li>
</ul>
<ul>
<li><strong>Parameters:</strong>
<ul>
<li><code>target</code> – target object to which values and properties are copied</li>
<li><code>sources</code> – source object from which values and properties are copied</li>
</ul>
</li>
<li><strong>Return value:</strong>
<ul>
<li>This method returns the target object.</li>
</ul>
</li>
</ul>
<p>Now, let&#8217;s look at a very simple example of using this method to merge two objects together:</p>
<pre>let objectA = {a: 1, b: 2}

let objectB = {c: 3, d: 4}

Object.assign(objectA, objectB)

console.log(objectA);
// → { a: 1, b: 2, c: 3, d: 4 }</pre>
<p>Here, the target object is <code>objectA</code>, while the source object is <code>objectB</code>. Using <code>object.assign()</code> is similar to using the lodash <code>clone</code> method for shallow copying objects. Let’s look at another example:</p>
<pre>const clone = require('lodash.clone')
var objA = { 
  a: 1,
  b: {
        c: 2,
        d: {
            e: 3
      }
  }
}
var objB = clone(objA)
objA.b.c = 30
console.log(objA)
// { a: 1, b: { c: 30, d: { e: 3 } } }
console.log(objB)
// { a: 1, b: { c: 30, d: { e: 3 } } }</pre>
<p>Being a shallow copy, values are cloned and object references are copied —not the objects themselves. So if we edit an object property in the original object, it is also modified in the copied object since the referenced inner object is the same in this case.</p>
<h3>Copying an object with the spread syntax</h3>
<p>The <a href="https://github.com/tc39/proposal-object-rest-spread">spread operator</a> is an ES2018 feature that adds <a href="https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Operators/Spread_operator">spread</a> properties to object literals. It provides a very convenient way to perform a shallow clone, equivalent to what <code>Object.assign()</code> does. With objects, the spread operator is used to create copies of existing objects with new or updated values.</p>
<p>It copies enumerable properties from a provided object onto a new object. Let’s see an example usage, as per the syntax:</p>
<pre>const copied = { ...original }</pre>
<p>Now let’s look at a real-world example:</p>
<pre>const objA = { 
    name: 'Alexander', 
    age: 26, 
}

const objB = { 
    Licensed: true, 
    location: "Ikeja" 
}

const mergedObj = {...objA, ...objB}
console.log(mergedObj) 

// { name: 'Alexander', age: 26, Licensed: true, location: 'Ikeja' }</pre>
<p>From the above, we can see that <code>mergedObj</code> is a copy of <code>objA</code> and <code>objB</code>. Actually, every enumerable property on the objects will be copied to the final <code>mergedObj</code> object. The spread operator is just a shorthand for the <code>Object.assign()</code> method, but there are some subtle differences between the two, including the fact that <code>Object.assign()</code> triggers <code><a href="https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Functions/set">setters</a></code>, whereas the spread operator does not.</p>
<blockquote><p><strong>Note</strong>: If an object references other objects when performing a shallow copy of the object, we copy the references to the external object. When performing a deep copy, those external objects are copied as well, so the new cloned object is completely independent from the old one.</p></blockquote>
<h3>Recommended method for deep cloning objects in JavaScript</h3>
<p>Most of the time, when we decide to copy objects in our program, our intent is to actually copy by reference, which is more or less making a shallow copy of the object. However, when it comes to deeply nested objects, the behavior of <code>Object.assign()</code> or <code>spread</code> is different.</p>
<p>In essence, there is no one consistent way of cloning or copying objects in the language, regardless of their structure, in terms of how the objects are constructed.</p>
<p>A question that arises here is copying deeply nested objects up to, say, two or three levels deep in such a way that if we make changes to the new object, it doesn’t affect the original object acting as our target. So how do we correctly deep clone an object?</p>
<p>To perform a deep copy, our best bet is to rely on a library that’s well tested, popular, and well maintained by the community: Lodash. Lodash offers both <code>clone</code> and <code>cloneDeep</code> functions to perform shallow and deep cloning, respectively.</p>
<p>For example, when deep copying objects in Node.js, we can make use of the <a href="https://lodash.com/docs/4.17.10#cloneDeep">Lodash</a> <code>cloneDeep()</code> method. An example is shown below:</p>
<pre>const cloneDeep = require('lodash.clonedeep')

let objA = {
    a: 1,
    b: {
        c: 2,
        d: {
            e: 3
        }
    }
}

// copy objA save as new variable objB
let objB = cloneDeep(objA)

// change the values in the original object objA
objA.a = 20
objA.b.c = 30
objA.b.d.e = 40

console.log(JSON.stringify(objA))
// → {"a":20,"b":{"c":30,"d":{"e":40}}}

// objB which is the cloned object is still the same
console.log(JSON.stringify(objB))
// → {"a":1,"b":{"c":2,"d":{"e":3}}}</pre>
<p>The Lodash <code>cloneDeep()</code> method is similar to <code>clone</code>, except that it recursively clones <code>value</code> while preserving object inheritance. The great thing about the library is that we can import each function individually — no need to import the entire library into our project. This can greatly reduce the size of our program dependencies.</p>
<p>In order to make use of Lodash clone methods in Node.js, we can install it by running <code>npm i lodash.clonedeep</code> for deep clone and <code>npm i lodash.clone</code> for shallow clone. We can use it like so:</p>
<pre>const clone = require('lodash.clone')
const cloneDeep = require('lodash.clonedeep')

const shallowCopy = clone(originalObject)
const deepCopy = clonedeep(originalObject)</pre>
<blockquote><p><strong>Note</strong>: Copying objects derived from built-in JavaScript objects will result in extra, unwanted properties.</p></blockquote>
<h3>Native deep cloning</h3>
<p>The HTML standard includes <a href="https://html.spec.whatwg.org/multipage/structured-data.html#safe-passing-of-structured-data"><strong>an internal structured cloning/serialization algorithm</strong></a> that can create deep clones of objects. Although still limited to certain built-in types, it can preserve references within the cloned data, allowing support for cyclical and recursive structures that would otherwise cause errors with JSON.</p>
<p>With support in Node.js still experimental, the <code>v8</code> module <a href="https://nodejs.org/api/all.html#v8_serialization_api">exposes the structured serialization API directly</a>. For example, cloning an object is as simple as:</p>
<pre>const v8 = require('v8');

const structuredClone = obj =&gt; {
  return v8.deserialize(v8.serialize(obj));
};</pre>
<p>More details can be found <a href="https://nodejs.org/api/all.html#v8_serialization_api">here</a>.</p>
<h3>Other object cloning methods</h3>
<h4>Iterating through each object property and copying it into a new empty object</h4>
<p>This involves iterating through a source object’s properties and copying all of them one after the other to a target object. The idea is to create a new object and replicate the structure of the existing one by iterating over its properties and copying them.</p>
<p>Let’s see an example:</p>
<pre>let user = {
  name: "Alexander",
  age: 26
};

let clone = {}; // the new empty object

// let's copy all user properties into it
for (let key in user) {
  if (user.hasOwnProperty(key)) {
  clone[key] = user[key];
 }
}

// now clone is a fully independent object with the same content
clone.name = "Chinedu"; // changed the data 

console.log(user.name); // still Alexander in the original object</pre>
<h4>Cloning Objects using JSON.parse/stringify</h4>
<p>This offers a very fast way of deep cloning objects. However, it is not very reliable and standard as it comes with some data loss along the way.</p>
<p>Using this method, the source object <em>must</em> be JSON-safe. If we do not use <code>Date</code>, <code>undefined</code>, <code>Infinity</code>, functions, regexps, maps, sets, or other complex types within our object, a very simple way to deep clone an object is by using:</p>
<pre>JSON.parse(JSON.stringify(object))</pre>
<p>Let’s look at an example:</p>
<pre>const a = {
  string: 'string',
  number: 123,
  bool: false,
  nul: null,
  date: new Date(),  // string
  undef: undefined,  // lost
  inf: Infinity,  // 'null'
  re: /.*/,  // lost
}

console.log(typeof a.date) // returns  object

const clone = JSON.parse(JSON.stringify(a))

console.log(typeof clone.date)  // returns string 

console.log(clone)
// 
{
  string: 'string',
  number: 123,
  bool: false,
  nul: null,
  date: '2020-09-28T15:47:23.734Z',
  inf: null,
  re: {}
}</pre>
<blockquote><p><strong>Note</strong>: This method needs some sort of exception handling to keep it safe in case the source object can not be converted to JSON.</p></blockquote>
<h2>Conclusion</h2>
<p>By default, JavaScript always passes by value, which means changing the value of the variable never changes the underlying primitive type. However, for non-primitive data types (arrays, functions, and objects), which are passed by reference, we can always mutate the data, causing a single object value to have different content at different times.</p>
<p>Cloning a JavaScript object is a task that is used mostly because we do not want to create the same object if it already exists. As we are now aware, objects are assigned and copied by reference. In other words, a variable stores not the object value, but a reference. Therefore, copying such a variable or passing it as a function argument copies that reference, not the object.</p>
<p>For simple objects that only store primitive types like numbers and strings, shallow copying methods discussed earlier will work. A shallow copy means the first level is copied, and deeper levels are referenced. However, if the object properties reference other nested objects, the actual object won’t be copied, as we would only be copying the reference.</p><div class='code-block code-block-29' style='margin: 8px 0; clear: both;'>
<div class="vanilla-javascript-cta"><h2><a class="signup" href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">LogRocket</a>: Debug JavaScript errors easier by understanding the context</h2>

<p>Debugging code is always a tedious task. But the more you understand your errors the easier it is to fix them.</p>

<p style="margin-bottom: 0px;"><a href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">LogRocket</a> allows you to understand these errors in new and unique ways. Our frontend monitoring solution tracks user engagement with your JavaScript frontends to give you the ability to find out exactly what the user did that led to an error.</p>
<a href="https://logrocket.com/signup/" class="signup" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/reproduce-javascript-errors.gif?ssl=1" alt="LogRocket Dashboard Free Trial Banner" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/reproduce-javascript-errors.gif?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/06/reproduce-javascript-errors.gif?ssl=1" alt="LogRocket Dashboard Free Trial Banner" data-recalc-dims="1" /></noscript></a>

<p style="margin-top:15px;">LogRocket records console logs, page load times, stacktraces, slow network requests/responses with headers + bodies, browser metadata, and custom logs. Understanding the impact of your JavaScript code will never be easier!</p>

<a class="signup" href="https://logrocket.com/signup/" target="_blank" rel="noopener noreferrer">Try it for free</a>.</div>
</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-26142" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-26142" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-26142" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/methods-for-deep-cloning-objects-in-javascript/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><!-- AI CONTENT END 1 -->
                        <div class="clearfix"></div>
                                                <div class="clearfix"></div>
                    </article>
                            
                                             <!-- Begin Author box -->                                     
                        <div class="row post-top-meta hidden-lg-up"> 
                            <div class="col-md-2 col-xs-4"> 
                                <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/10/alexander-nnakwue.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/10/alexander-nnakwue.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2019/10/alexander-nnakwue.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript>                            </div>                                         
                            <div class="col-md-10 col-xs-8"> 
                                <a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/alexandernnakwue/">
                                Alexander Nnakwue <span class="btn follow">Follow</span></a>
                                <span class="author-description d-block">Software Engineer. React, Node.js, Python, and other developer tools and libraries.</span> 
                            </div>                                         
                        </div>
                                         
                    <div class="after-post-tags">
                                                    <ul class="post-categories">
	<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul>                                                                            <ul class="post-categories aretags">
                            <li><a href="https://blog.logrocket.com/tag/vanilla-javascript/">#vanilla javascript</a></li>                             </ul>
                                            </div>
                    
                  
                    <div class="row mb-5 prevnextlinks justify-content-center align-items-center"> 
                       <div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/css-reference-guide-calc/" rel="prev">CSS Reference Guide: <code>calc()</code></a></div></div>
                       <div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/working-with-go-images/" rel="next">Working with Go images</a> &raquo;</div></div>
                    </div>
                    
                </div>
        
                    
         
        
        
    </div>                 
</div>             
          
<div class="hideshare"></div>

    <div class="graybg"> 
        <div class="container"> 
                <div class="row justify-content-center listrecent listrelated">
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/working-with-context-helpers-and-advanced-properties-in-nuxt-js/" style="background-image:url(https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/10/Nuxt.png?fit=730%2C412&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/working-with-context-helpers-and-advanced-properties-in-nuxt-js/">Working with context, helpers, and advanced properties in Nuxt.js</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/timi-omoyeni/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/timi.jpeg?resize=80%2C80&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/timi.jpeg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/08/timi.jpeg?resize=80%2C80&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/timi-omoyeni/">Timi Omoyeni</a></span><br>
                    <span class="post-date">Oct 1, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">6 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/working-with-context-helpers-and-advanced-properties-in-nuxt-js/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/working-with-go-images/" style="background-image:url(https://i1.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/workingwithgoimages.png?fit=730%2C412&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/working-with-go-images/">Working with Go images</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/okokomichaels/">
                    <img alt src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/michaelo.jpg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/michaelo.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i0.wp.com/blog.logrocket.com/wp-content/uploads/2020/07/michaelo.jpg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/okokomichaels/">Michael Okoko</a></span><br>
                    <span class="post-date">Oct 1, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">4 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/working-with-go-images/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
                <div class="col-lg-4 col-md-4 col-sm-4">
            
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/css-reference-guide-calc/" style="background-image:url(https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/09/lr-css-reference-guide-calc-nocdn.png?fit=730%2C487&ssl=1);"></a><div class="card-block">
    <h2 class="card-title">
        <a href="https://blog.logrocket.com/css-reference-guide-calc/">CSS Reference Guide: calc()</a>
    </h2>
            <div class="metafooter">
            <div class="wrapfooter">
                <span class="meta-footer-thumb">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">
                    <img alt src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://i2.wp.com/blog.logrocket.com/wp-content/uploads/2020/05/chidume-nnamdi.jpeg?resize=150%2C150&ssl=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript>                    </a>
                </span>
                <span class="author-meta">
                    <span class="post-name">
                    <a href="https://blog.logrocket.com/author/chidumennamdi/">Chidume Nnamdi</a></span><br>
                    <span class="post-date">Sep 30, 2020</span>
                    <span class="dot"></span>
                    <span class="readingtime">2 min read</span>
                </span>
                <span class="post-read-more">
                    <a href="https://blog.logrocket.com/css-reference-guide-calc/" title="">
                    <svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
                        <path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
                    </svg>
                    </a>
                </span>            </div>
        </div>
    </div>
</div>
        </div>
            </div>
    <div class="clearfix"></div>
                
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/methods-for-deep-cloning-objects-in-javascript/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=26142&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.9.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=72816137a5635ebf9f81f003c6215dacb1525ffb#parent=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
</div>
</div>        </div>                 
    </div>

    <div class="alertbar"> 
        <div class="container text-center"> 
                    </div>
    </div>

</div><!-- /.site-content -->
        
        <div class="container">
            <footer class="footer"> 
                <div class="pull-left"> Does something seem off? Email <a>support@logrocket.com</a> </div> 
                <div class="pull-right"> <div class = "footerRight">			<div id="jetpack-search-filters-2-wrapper" >
		<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field"
placeholder="Search..."
value="" name="s"
title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>   
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div>  </div> 
                <div class="clearfix"></div>
                <a href="" class="back-to-top hidden-md-down"> 
                <i class="fa fa-angle-up"></i>
                </a>
            </footer>
        </div>
        
<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
};
var current_url = location.pathname;
if (current_url == "/") {
jQuery( "#post-20374 span.readingtime" ).replaceWith( "<span class='readingtime'>12 min read</span>" );
};
</script>	<div style="display:none">
	<div class="grofile-hash-map-8cef3b13cd11e184c6993c4b710b15fa">
	</div>
	<div class="grofile-hash-map-0ee6efeea8cdc9985fef8b8a5342d863">
	</div>
	<div class="grofile-hash-map-a64fbe74173fca211ef3ef037a621f41">
	</div>
	<div class="grofile-hash-map-dbafebf712fa816299231d2763fd292e">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/methods-for-deep-cloning-objects-in-javascript\/":26142};
	</script>
				<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blog.logrocket.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.5.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.9.1/modules/widgets/search/js/search-widget.js' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://c0.wp.com/c/5.5.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=26142&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=72816137a5635ebf9f81f003c6215dacb1525ffb#parent=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=26142&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=72816137a5635ebf9f81f003c6215dacb1525ffb#parent=https%3A%2F%2Fblog.logrocket.com%2Fmethods-for-deep-cloning-objects-in-javascript%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202040.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'161333275',post:'26142',tz:'-4',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '26142' ]);
</script>
<script>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</script>
            </body>     
</html>
<!--
	generated in 0.321 seconds
	144700 bytes batcached for 300 seconds
-->
