<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />


<title>How and when to force a Flutter widget rebuild - LogRocket Blog</title>
<meta name="description" content="Sometimes, a Flutter widget requires manual rebuilding in order to update. Learn why this is the case (and how to implement it) here." />
<link rel="canonical" href="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How and when to force a Flutter widget rebuild - LogRocket Blog" />
<meta property="og:description" content="Sometimes, a Flutter widget requires manual rebuilding in order to update. Learn why this is the case (and how to implement it) here." />
<meta property="og:url" content="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2022-04-29T14:30:53+00:00" />
<meta property="article:modified_time" content="2022-04-22T16:27:35+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="487" />
<meta property="og:image:type" content="image/png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@https://twitter.com/checkpoint_ke" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Rose Chege" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="10 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://blog.logrocket.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/#primaryimage","inLanguage":"en-US","url":"https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild.png","contentUrl":"https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild.png","width":730,"height":487},{"@type":"WebPage","@id":"https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/#webpage","url":"https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/","name":"How and when to force a Flutter widget rebuild - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/#primaryimage"},"datePublished":"2022-04-29T14:30:53+00:00","dateModified":"2022-04-22T16:27:35+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/8a61a7cd8b19d91ae868a7bd219181c3"},"description":"Sometimes, a Flutter widget requires manual rebuilding in order to update. Learn why this is the case (and how to implement it) here.","breadcrumb":{"@id":"https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/"]}]},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://blog.logrocket.com/"},{"@type":"ListItem","position":2,"name":"How and when to force a Flutter widget rebuild"}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/8a61a7cd8b19d91ae868a7bd219181c3","name":"Rose Chege","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ec2f423afc74a9aa66ca8c25fafc2361?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/ec2f423afc74a9aa66ca8c25fafc2361?s=96&d=mm&r=g","caption":"Rose Chege"},"description":"Rose is a lover of technology and an upright individual who is not afraid to get out of her comfort zone and try out new programming paradigms.","sameAs":["https://twitter.com/https://twitter.com/checkpoint_ke"],"url":"https://blog.logrocket.com/author/rosechege/"}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; How and when to force a Flutter widget rebuild Comments Feed" href="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code>code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group:where(.has-background){padding:1.25em 2.375em}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://blog.logrocket.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/6.0.0-beta2/css/all.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.9-beta2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.9-beta2' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/105242" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-rns' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<script src="//geoip-js.com/js/apis/geoip2/v2.1/geoip2.js" type="text/javascript"></script>

<script>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</script>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>
function setlrAdwinExpiry(lrAdwin, value, ttl) {
				var now = new Date()

				// `item` is an object which contains the original value
				// as well as the time when it's supposed to expire
				const item = {
					value: 'isSet',
					expiry: now.getTime() + 4665600000,
				}
				localStorage.setItem(lrAdwin, JSON.stringify(item))
				setTimeout(function(){
					analytics.track("lrAdwin", {
  active: "true"
});
    }, 1000);
			}

			function getWithExpiry(lrAdwin) {
				const itemStr = localStorage.getItem(lrAdwin)

				// if the item doesn't exist, return null
				if (!itemStr) {
					return null
				}

				const item = JSON.parse(itemStr)
				const now = new Date()

				// compare the expiry time of the item with the current time
				if (now.getTime() > item.expiry) {
					// If the item is expired, delete the item from storage
					// and return null
					localStorage.removeItem(lrAdwin)
					if (analytics) {					analytics.track("lrAdwin", {
  active: "false"
});}
					return null
				}
				return item.value
			}

			if (!localStorage.getItem('_lr_id_')){
				setlrAdwinExpiry();
			}
			getWithExpiry();
</script>
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://a39e555ed62c408792586c55bbb2ce3b@e.logrocket.com/9').install()
    </script>
<script type="text/javascript">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</script>
<script>

<!-- start vwo -->
      window._vwo_code = window._vwo_code || (function(){
        var account_id=338524,
        settings_tolerance=2000,
        library_tolerance=2500,
        use_existing_jquery=false,
        is_spa=1,
        hide_element='body',

        /* DO NOT EDIT BELOW THIS LINE */
        f=false,d=document,code={use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){
        settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b=hide_element?hide_element+'{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}':'',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&f='+(+is_spa)+'&r='+Math.random());return settings_timer; }};window._vwo_settings_timer = code.init(); return code; }());
<!-- Reddit Pixel -->
!function(w,d){if(!w.rdt){var p=w.rdt=function(){p.sendEvent?p.sendEvent.apply(p,arguments):p.callQueue.push(arguments)};p.callQueue=[];var t=d.createElement("script");t.src="https://www.redditstatic.com/ads/pixel.js",t.async=!0;var s=d.getElementsByTagName("script")[0];s.parentNode.insertBefore(t,s)}}(window,document);rdt('init','t2_3xdvtyx2');rdt('track', 'PageVisit');
<!-- DO NOT MODIFY -->
<!-- End Reddit Pixel -->
    </script><style type='text/css'>img#wpstats{display:none}</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=f9bf9daf84" /><style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-105242 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="navarea">
<div class="nav-left">
<a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>
<nav class="menu-container">
<div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a><li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">Podcast</a><li id="menu-item-72923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72923 nav-item"><a href="https://blog.logrocket.com/tech-meetups/" class="nav-link">Meetups</a></ul></div></nav>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Start monitoring for free</a></li>
</ul></div> </div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=How%20and%20when%20to%20force%20a%20Flutter%20widget%20rebuild&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild.png&amp;description=How%20and%20when%20to%20force%20a%20Flutter%20widget%20rebuild">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F&amp;title=How%20and%20when%20to%20force%20a%20Flutter%20widget%20rebuild">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-105242 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-flutter tag-mobile" id="post-105242">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/rosechege/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/01/avatar_huced40cffbafaf781b8f514e964ab8f66_26941_400x0_resize_q75_box-150x150.jpg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/01/avatar_huced40cffbafaf781b8f514e964ab8f66_26941_400x0_resize_q75_box-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/01/avatar_huced40cffbafaf781b8f514e964ab8f66_26941_400x0_resize_q75_box-150x150.jpg?crop=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/rosechege/">
Rose Chege <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Rose is a lover of technology and an upright individual who is not afraid to get out of her comfort zone and try out new programming paradigms.</span>
</div>
</div>
<h1 class="posttitle">How and when to force a Flutter widget rebuild</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
April 29, 2022 </time></span>
<span class="dot"></span>
<span class="readingtime">7 min read</span>
<span class="wordcount">2012</span>
</p>
</div>
<img width="730" height="487" src="https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="" data-attachment-id="105287" data-permalink="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/how-when-force-flutter-widget-rebuild/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild.png" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="How-when-force-flutter-widget-rebuild" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild-300x200.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild.png 730w, https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild-300x200.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/04/How-when-force-flutter-widget-rebuild.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> <article class="article-post">
<p>In Flutter, states are used to describe the behavior of an application at any given point in time. The concept of state management allows you to share data between screens and widgets within your application, and Flutter describes everything as a widget organized in a tree structure.</p>
<p>The main thing you need to understand is how you can inject data into the Flutter tree. In this case, Flutter checks and compares the current state of a widget with other widgets within the tree. If it identifies any data change, it will rebuild its widgets, and set the new data to the current widget tree.</p>
<p>This way, Flutter will redraw its UI and display the current state of your application. Changing a state in the Flutter will always cause the UI to rebuild itself.</p>
<p>However, this case is not always one hundred percent effective. Flutter may fail to display this state to the current widget tree. This means Flutter won&#8217;t redraw itself, and the current widget won&#8217;t be rebuilt at the appropriate moment. As a result, you need to force that specific widget to rebuild.</p>
<p>In this article, we will look into how and when to force a Flutter widget to rebuild. We will create a simple orders application to guide us in such instances.</p>
<h3>Contents</h3>
<ul>
<li><a href="#setting-up-application">Setting up the application</a>
<ul style="margin-bottom: 0px; padding-bottom: 0px;">
<li><a href="#implementing-listview-orders">Implementing a list view of orders</a></li>
<li><a href="#updating-orders">Updating the orders</a></li>
</ul>
</li>
<li><a href="#using-setstate-rebuild-widgets">Using <code>setState</code> to rebuild widgets</a></li>
<li><a href="#using-keys-force-widget-rebuild">Using keys to force widget rebuild</a>
<ul style="margin-bottom: 0px; padding-bottom: 0px;">
<li><a href="#using-unique-key">Unique keys</a></li>
<li><a href="#using-value-key">Value keys</a></li>
<li><a href="#using-object-key">Object keys</a></li>
</ul>
</li>
<li><a href="#force-flutter-rebuild-redraw-all-widgets">How to force Flutter to rebuild or redraw all widgets</a></li>
</ul>
<h2 id="setting-up-application">Setting up the application</h2>
<p>Open the terminal in your working directory and run the following command to initialize the application:</p>
<pre class="language-shell hljs">Flutter create orders_app
</pre>
<p>After the installation process is complete, navigate to the newly created directory:</p>
<pre class="language-shell hljs">cd orders_app
</pre>
<p>Start the development server by running:</p>
<pre class="language-shell hljs">Flutter run
</pre>
<p>Your application should be launched successfully from your emulator or phone device.</p>
<p><img data-attachment-id="105277" data-permalink="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/blank-flutter-demo-app/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app.jpeg" data-orig-size="720,1412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Blank flutter demo app" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app-153x300.jpeg" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app-522x1024.jpeg" loading="lazy" class="size-full wp-image-105277 aligncenter jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app.jpeg" alt="Blank flutter demo app" width="720" height="1412" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app.jpeg 720w, https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app-153x300.jpeg 153w, https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app-522x1024.jpeg 522w" data-lazy-sizes="(max-width: 720px) 100vw, 720px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="105277" data-permalink="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/blank-flutter-demo-app/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app.jpeg" data-orig-size="720,1412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Blank flutter demo app" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app-153x300.jpeg" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app-522x1024.jpeg" loading="lazy" class="size-full wp-image-105277 aligncenter" src="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app.jpeg" alt="Blank flutter demo app" width="720" height="1412" srcset="https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app.jpeg 720w, https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app-153x300.jpeg 153w, https://blog.logrocket.com/wp-content/uploads/2022/04/Blank-flutter-demo-app-522x1024.jpeg 522w" sizes="(max-width: 720px) 100vw, 720px" /></noscript></p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br />No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>
<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>
<h3 id="implementing-listview-orders">Implementing a list view of orders</h3>
<p>Let&#8217;s start by changing the application name. Navigate to the <code>lib/main.dart</code> file, and inside the <code>MyApp</code> class, edit the <code>MaterialApp</code> widget like so:</p>
<pre class="language-dart hljs">MaterialApp(
    title: 'Orders',
    theme: ThemeData(
        primarySwatch: Colors.blue,
    ),
    debugShowCheckedModeBanner: false,
    // remove the debug banner
    home: const MyHomePage(title: 'Orders'),
);
</pre>
<p>Next, create an <code>Order</code> class to define the structure of an order:</p>
<pre class="language-dart hljs">class Order {
  Order(this.id, this.name, this.price, this.quantity, this.date);
  int id;
  String name;
  int quantity;
  double price;
  DateTime date;
}
</pre>
<p>Inside the <code>_MyHomePageState</code> class, create a list of dummy orders:</p>
<pre class="language-dart hljs">final List&lt;Order&gt; _orders = [
  Order(1, 'Coffee', 20.00, 1, DateTime(2020, 1, 1)),
  Order(2, 'Tea', 10.00, 1, DateTime(2020, 1, 2)),
  Order(3, 'Cake', 50.00, 1, DateTime(2020, 1, 3)),
  Order(4, 'Pizza', 100.00, 1, DateTime(2020, 1, 4)),
];
</pre>
<p>Then, remove the current child widgets for the <code>Column</code> widget, and render an <code>Expanded</code> widget to display the orders using the <code>ListView</code> widget:</p>
<pre class="language-dart hljs">Expanded(
    child: ListView.builder(
    itemCount: _orders.length,
    itemBuilder: (context, index) {
        final order = _orders[index];
        return ListTile(
        title: Text(order.name),
        subtitle: Text('USD ${order.price}'),
        trailing: Row(
            mainAxisSize: MainAxisSize.min,
            children: &lt;Widget&gt;[
            const IconButton(
                onPressed: null,
                icon: Icon(Icons.remove)),
            const SizedBox(width: 15),
            Text('${order.quantity}'),
            const SizedBox(width: 15),
            const IconButton(
                onPressed: null,
                icon: Icon(Icons.add)),
            ],
        ),);
    },),
)
</pre>
<p>Reload your development server by pressing <code>R</code> on your terminal. Your application should now render the orders like in the image below.</p>
<p><img data-attachment-id="105279" data-permalink="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/order-list-in-flutter-app/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app.jpeg" data-orig-size="720,1412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Order list in Flutter app" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app-153x300.jpeg" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app-522x1024.jpeg" loading="lazy" class="size-full wp-image-105279 aligncenter jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app.jpeg" alt="Order list in Flutter app" width="720" height="1412" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app.jpeg 720w, https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app-153x300.jpeg 153w, https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app-522x1024.jpeg 522w" data-lazy-sizes="(max-width: 720px) 100vw, 720px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="105279" data-permalink="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/order-list-in-flutter-app/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app.jpeg" data-orig-size="720,1412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Order list in Flutter app" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app-153x300.jpeg" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app-522x1024.jpeg" loading="lazy" class="size-full wp-image-105279 aligncenter" src="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app.jpeg" alt="Order list in Flutter app" width="720" height="1412" srcset="https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app.jpeg 720w, https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app-153x300.jpeg 153w, https://blog.logrocket.com/wp-content/uploads/2022/04/Order-list-in-Flutter-app-522x1024.jpeg 522w" sizes="(max-width: 720px) 100vw, 720px" /></noscript></p>
<h3 id="updating-orders">Updating the orders</h3>
<p>To update an order, we will be updating an order&#8217;s quantity, which will also update its price. There will be two instances here: increment and decrement.</p>
<p>Inside the rendering class, create a <code>void</code> function that increments the quantity of order:</p>
<pre class="language-dart hljs">void incrementQuantity(Order order) {
  double initialPrice = order.price / order.quantity;
  // the original price
  order.quantity++;
  // increment the quantity
  order.price = initialPrice * order.quantity;
  // change the price.
}
</pre>
<p>Similarly, create a <code>void</code> function that decrements the quantity of order:</p>
<pre class="language-dart hljs">void decrementQuantity(Order order) {
  if (order.quantity &gt; 1) {
    // Check if the quantity is greater than one
    double initialPrice = order.price / order.quantity;
    // orginal price
    order.quantity--;
    // decrement the quantity
    order.price = initialPrice * order.quantity;
    // change the price
  }
}
</pre>
<p>Append the function to the <code>onPressed</code> event handler respectively:</p>
<pre class="language-dart hljs">return ListTile(
    title: Text(order.name),
    subtitle: Text('USD ${order.price}'),
    trailing: Row(
        mainAxisSize: MainAxisSize.min,
        children: &lt;Widget&gt;[
        IconButton(
            onPressed: () =&gt; decrementQuantity(order),
            icon: const Icon(Icons.remove)),
        const SizedBox(width: 15),
        Text('${order.quantity}'),
        const SizedBox(width: 15),
        IconButton(
            onPressed: () =&gt; incrementQuantity(order),
            icon: const Icon(Icons.add)),
        ],
    ),
);
</pre>
<p>Reload your development server and test out the functionality.</p>
<p>On pressing the <strong>+</strong> and <strong>&#8211;</strong> icons, you will notice that the quantity does not change, nor does the price. This is because we are not updating the current state of the application that is holding the data.</p>
<p>Updating the state will force a <code>ListTile</code> widget to rebuild and display the new quantity and price.</p>
<h2 id="using-setstate-rebuild-widgets">Using <code>setState</code> to rebuild widgets</h2>
<p>Flutter gives you access to <code>setState()</code>. In this case, we have to ensure <code>setState()</code> has the new values. When <code>setState()</code> is called, Flutter will know to get these new values and mark the widget that needs to be rebuilt.</p>
<p>To ensure we are updating the state, we will make the following changes to the increment and the decrement functions:</p>
<pre class="language-dart hljs">void incrementQuantity(Order order) {
  double initialPrice = order.price / order.quantity;
  setState(() {
    // updating the state
    order.quantity++;
    order.price = initialPrice * order.quantity;
  });
}

void decrementQuantity(Order order) {
  if (order.quantity &gt; 1) {
    double initialPrice = order.price / order.quantity;
    setState(() {
      // updating the state
      order.quantity--;
      order.price = initialPrice * order.quantity;
    });
  }
}
</pre>
<p>This ensures that everything inside the <code>setState()</code> method is going to be compared against the older values. Flutter will see some values have changed and then display them to the respective widget.</p>
<p>To test this, reload the development server and give it a test. This time, when you press the <strong>+</strong> and <strong>&#8211;</strong> icons, the quantity and the price will be updated accordingly.</p>
<p><img data-attachment-id="105282" data-permalink="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/orders-with-updated-quanitities/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities.jpeg" data-orig-size="720,1412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Orders with updated quanitities" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities-153x300.jpeg" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities-522x1024.jpeg" loading="lazy" class="size-full wp-image-105282 aligncenter jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities.jpeg" alt="Orders with updated quanitities" width="720" height="1412" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities.jpeg 720w, https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities-153x300.jpeg 153w, https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities-522x1024.jpeg 522w" data-lazy-sizes="(max-width: 720px) 100vw, 720px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="105282" data-permalink="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/orders-with-updated-quanitities/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities.jpeg" data-orig-size="720,1412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Orders with updated quanitities" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities-153x300.jpeg" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities-522x1024.jpeg" loading="lazy" class="size-full wp-image-105282 aligncenter" src="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities.jpeg" alt="Orders with updated quanitities" width="720" height="1412" srcset="https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities.jpeg 720w, https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities-153x300.jpeg 153w, https://blog.logrocket.com/wp-content/uploads/2022/04/Orders-with-updated-quanitities-522x1024.jpeg 522w" sizes="(max-width: 720px) 100vw, 720px" /></noscript></p>
<h2 id="using-keys-force-widget-rebuild">Using keys to force widget rebuild</h2>
<p>Let&#8217;s set a stateful widget and see how we can use keys to rebuild a widget. At times, Flutter <code>setState()</code> can be called, but will fail to display the changes on the screen. In this case, the internal state of a widget is already changed.</p>
<p>This means the new state is preserved and can be accessed. The state of a Flutter widget is stateful. When a new value is generated, a new widget is generated within the widget tree. This way, every newly generated widget generates a new key. Because its state is already preserved, we can use a key to access the new widget and force a rebuild to display the new state on the screen.</p>
<p>Flutter UI uses different keys such as unique key, value key, and object key. Let&#8217;s see how we can use them in Flutter and force a widget to rebuild.</p>
<p>We will need to do the following modifications to use keys on our existing application. Separate the existing <code>ListTile</code> widget that is rendering every order to be a stateful widget like so:</p>
<pre class="language-dart hljs">class OrderCard extends StatefulWidget {
  final Order order;
  // Order
  final Key orderKey;
  // key
  const OrderCard(this.order, this.orderKey) : super(key: orderKey);

  @override
  State&lt;OrderCard&gt; createState() =&gt; OrderCardState();
}

class OrderCardState extends State&lt;OrderCard&gt; {
  late Order order;
  @override
  void initState() {
    super.initState();
    order = widget.order;
    // Get the order
  }

  void incrementQuantity(Order order) {
    double initialPrice = order.price / order.quantity;
    setState(() {
      order.quantity++;
      order.price = initialPrice * order.quantity;
    });
  }

  void decrementQuantity(Order order) {
    if (order.quantity &gt; 1) {
      double initialPrice = order.price / order.quantity;
      setState(() {
        order.quantity--;
        order.price = initialPrice * order.quantity;
      });
    }
  }

  @override
  Widget build(BuildContext context) {
    return ListTile(
      title: Text(order.name),
      subtitle: Text('USD ${order.price}'),
      trailing: Row(mainAxisSize: MainAxisSize.min, children: &lt;Widget&gt;[
        Row(mainAxisSize: MainAxisSize.min, children: &lt;Widget&gt;[
          IconButton(
              onPressed: () =&gt; decrementQuantity(order),
              icon: const Icon(Icons.remove)),
          const SizedBox(width: 15),
          Text('${order.quantity}'),
          const SizedBox(width: 15),
          IconButton(
              onPressed: () =&gt; incrementQuantity(order),
              icon: const Icon(Icons.add)),
        ])
      ]),
    );
  }
}
</pre>
<p>When you want to pass data from the parent to the child widget, set up a build method to compare the previous (parent) and new widget (child) being returned. An important part here is how we update these new quantity and price values.</p>
<p>When you run the application, the <code>setState()</code> will fail to rebuild the widget. In this example, the <code>initState()</code> is called only once. This means the results of clicking <strong>+</strong> or <strong>&#8211;</strong> icons won&#8217;t get displayed on the screen.</p>
<p>However, this clicking will always execute the <code>setState()</code> and pass the new value to the widget tree. The results are not displayed, but calling <code>setState()</code> has already triggered the change. The new state is preserved and can be accessed with the key that every new widget generates.</p>
<h3 id="using-unique-key">Using a unique key</h3>
<p>Update the <code>_orders</code> on the parent widget to be a list of widgets like so:</p>
<pre class="language-dart hljs">final List&lt;Widget&gt; _orders = [
  OrderCard(Order(1, 'Coffee', 20.00, 1, DateTime(2020, 1, 1)), UniqueKey()),
  OrderCard(Order(2, 'Tea', 10.00, 1, DateTime(2020, 1, 2)), UniqueKey()),
  OrderCard(Order(3, 'Cake', 50.00, 1, DateTime(2020, 1, 3)), UniqueKey()),
  OrderCard(Order(4, 'Pizza', 100.00, 1, DateTime(2020, 1, 4)), UniqueKey()),
];
</pre>
<p>For the above case, we are passing a <code>UniqueKey</code> as the key prop. This will update the new state being returned.</p>
<p>Now, change how the <code>orders</code> are rendered on the build function:</p>
<pre class="language-dart hljs">body: Center(
    child: Column(
      mainAxisAlignment: MainAxisAlignment.start,
      children: _orders,
    ),
)
</pre>
<p>In the code above, we are not using a <code>ListView Builder</code> because we already have a list of widgets.</p>
<p>Reload your development server to load your application. Your application should be as responsive to the new changes. Every time you click the icons, Flutter will refresh the keys and force the widget to rebuild.</p>
<h3 id="using-value-key">Using a value key</h3>
<p>To change from a value key to a unique key, update the <code>_orders</code> list of widgets as follows:</p>
<pre class="language-dart hljs">final List&lt;Widget&gt; _orders = [
  OrderCard(Order(1, 'Coffee', 20.00, 1, DateTime(2020, 1, 1)),
      const ValueKey('coffee')),
  OrderCard(
      Order(2, 'Tea', 10.00, 1, DateTime(2020, 1, 2)), const ValueKey('Tea')),
  OrderCard(
      Order(3, 'Cake', 50.00, 1, DateTime(2020, 1, 3)), const ValueKey('Cake')),
  OrderCard(Order(4, 'Pizza', 100.00, 1, DateTime(2020, 1, 4)),
      const ValueKey('Pizza')),
];
</pre>
<p>From above, we supply a specific value to the <code>ValueKey</code> constructor that identifies that order.<br />
Reload your application to reflect the change. The experience should be similar to the prior one.</p>
<h3 id="using-object-key">Using an object key</h3>
<p>To use an object key in place of a value key, change the <code>ValueKey</code> constructor to <code>ObjectKey</code> as follows:</p>
<pre class="language-dart hljs">final List&lt;Widget&gt; _orders = [
  OrderCard(Order(1, 'Coffee', 20.00, 1, DateTime(2020, 1, 1)),
      const ObjectKey('Coffee')),
  OrderCard(
      Order(2, 'Tea', 10.00, 1, DateTime(2020, 1, 2)), const ObjectKey('Tea')),
  OrderCard(Order(3, 'Cake', 50.00, 1, DateTime(2020, 1, 3)),
      const ObjectKey('Cake')),
  OrderCard(Order(4, 'Pizza', 100.00, 1, DateTime(2020, 1, 4)),
      const ObjectKey('Pizza')),
];
</pre>
<p>In the code above, we are supplying the <code>ObjectKey</code> with a unique identifier of the item.</p>
<p>Refresh the development server to test it. The behavior should be similar to the prior instances, i.e., using a unique and value key.</p>
<h2 id="force-flutter-rebuild-redraw-all-widgets">How to force Flutter to rebuild or redraw all widgets</h2>
<p>In some instances, you may require your application to redraw all widgets. This mainly applies when setting up an application with local or theme settings. Let&#8217;s use the theme case and see how Flutter rebuilds all widgets.</p>
<p>In the <code>MyApp</code> class, add the following theme properties to the <code>MaterialApp</code> widget being returned:</p>
<pre class="language-dart hljs">return MaterialApp(
    title: 'Orders',
    theme: ThemeData(brightness: Brightness.light), 
    // light theme
    darkTheme: ThemeData(brightness: Brightness.dark), 
    //dark theme
    debugShowCheckedModeBanner: false,
    home: const MyHomePage(title: 'Orders'),
);
</pre>
<p>Above, we are targeting the brightness level of <code>light theme</code> and <code>dark theme</code>.</p>
<p>To show either of the two themes, add the <code>themeMode</code> property to the <code>MaterialApp</code> widget:</p>
<pre class="language-dart hljs">return MaterialApp(
    title: 'Orders',
    theme: ThemeData(brightness: Brightness.light),
    // light theme
    darkTheme: ThemeData(brightness: Brightness.dark),
    // dark theme
    themeMode: ThemeMode.dark,
    // dark mode
    debugShowCheckedModeBanner: false,
    home: const MyHomePage(title: 'Orders'),
);
</pre>
<p>Reload your development server and observe the change.</p>
<p><img data-attachment-id="105284" data-permalink="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/flutter-orders-app-dark-mode/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode.jpeg" data-orig-size="720,1412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Flutter orders app dark mode" data-image-description data-image-caption data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode-153x300.jpeg" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode-522x1024.jpeg" loading="lazy" class="size-full wp-image-105284 aligncenter jetpack-lazy-image" src="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode.jpeg" alt="Flutter orders app dark mode" width="720" height="1412" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode.jpeg 720w, https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode-153x300.jpeg 153w, https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode-522x1024.jpeg 522w" data-lazy-sizes="(max-width: 720px) 100vw, 720px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="105284" data-permalink="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/flutter-orders-app-dark-mode/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode.jpeg" data-orig-size="720,1412" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Flutter orders app dark mode" data-image-description="" data-image-caption="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode-153x300.jpeg" data-large-file="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode-522x1024.jpeg" loading="lazy" class="size-full wp-image-105284 aligncenter" src="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode.jpeg" alt="Flutter orders app dark mode" width="720" height="1412" srcset="https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode.jpeg 720w, https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode-153x300.jpeg 153w, https://blog.logrocket.com/wp-content/uploads/2022/04/Flutter-orders-app-dark-mode-522x1024.jpeg 522w" sizes="(max-width: 720px) 100vw, 720px" /></noscript></p>
<p>The <code>themeMode</code> property will cause a full rebuild of the application to conform with the specified theme as seen above.</p>
<h2>Conclusion</h2>
<p>Congratulations! You can now rebuild a widget even when Flutter fails to do so.</p>
<p>Flutter uses <code>setState()</code> to reference the state object and identify any change to the state. This way, you can track these changes and rebuild your application. In case this fails, keys will play an important role in forcing a rebuild of any preserved state.</p>
<p>When it comes to preserving state across widget trees, keys are ideal. This use case is commonly applied when updating a group of identical widgets, on a list, for example. And we have demonstrated using the order list to achieve the desired goal.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-105242" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-105242" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-105242" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/how-when-force-flutter-widget-rebuild/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/01/avatar_huced40cffbafaf781b8f514e964ab8f66_26941_400x0_resize_q75_box-150x150.jpg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/01/avatar_huced40cffbafaf781b8f514e964ab8f66_26941_400x0_resize_q75_box-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/01/avatar_huced40cffbafaf781b8f514e964ab8f66_26941_400x0_resize_q75_box-150x150.jpg?crop=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/rosechege/">
Rose Chege <span class="btn follow">Follow</span></a>
<span class="author-description d-block">Rose is a lover of technology and an upright individual who is not afraid to get out of her comfort zone and try out new programming paradigms.</span>
</div>
</div>
<div class="after-post-tags">
<ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/flutter/">#flutter</a></li> <li><a href="https://blog.logrocket.com/tag/mobile/">#mobile</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/exploring-react-natives-new-architecture/" rel="prev">Exploring React Native&#8217;s new architecture</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/comparing-kotlin-scope-functions/" rel="next">Comparing Kotlin scope functions</a> &raquo;</div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/comparing-kotlin-scope-functions/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/04/kotlin-scoping-functions.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/comparing-kotlin-scope-functions/">Comparing Kotlin scope functions</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/peteraideloje/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2022/01/unnamed-1-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2022/01/unnamed-1-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2022/01/unnamed-1-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/peteraideloje/">Peter Aideloje</a></span><br>
<span class="post-date">Apr 29, 2022</span>
<span class="dot"></span>
<span class="readingtime">6 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/comparing-kotlin-scope-functions/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/exploring-react-natives-new-architecture/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/04/exploring-react-native-new-architecture.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/exploring-react-natives-new-architecture/">Exploring React Native&#8217;s new architecture</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/davidekanem/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/11/david-ekanem-150x150.jpeg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/11/david-ekanem-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/11/david-ekanem-150x150.jpeg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/davidekanem/">David Ekanem</a></span><br>
<span class="post-date">Apr 29, 2022</span>
<span class="dot"></span>
<span class="readingtime">5 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/exploring-react-natives-new-architecture/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/build-erc-20-exchange-platform/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2022/04/How-to-create-ERC20-exchange-platform.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/build-erc-20-exchange-platform/">How to build an ERC-20 exchange platform</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/atharvadeosthale/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/06/1618236709098-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/06/1618236709098-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/06/1618236709098-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/atharvadeosthale/">Atharva Deosthale</a></span><br>
<span class="post-date">Apr 28, 2022</span>
<span class="dot"></span>
<span class="readingtime">10 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/build-erc-20-exchange-platform/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-when-force-flutter-widget-rebuild/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=105242&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;jetpack_comments_nonce=ecf439f476&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.9-beta2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=540185bf9a814f7ad0fa7c94de6178f5e038b3fd#parent=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="footerRight"><style>

	.footer .container{padding:20px 20px 10px 20px; color:white !important;}

	.footer .grid{
		display: grid;
		grid-template: auto auto auto / 150px auto;
		height:100%;
		grid-gap:20px;
		justify-items: left;
		align-items: center;
		font-family: 'PT Sans';
		padding:40px;
		background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/podrocket_slider_bg.png");
		background-position: center;
		background-repeat: no-repeat;
		background-size:cover;
		border-radius:30px;
		/* box-shadow: 0px 50px 120px 0px #2024734d; */
	}

	.footer .grid2{background-image: url('https://blog.logrocket.com/wp-content/uploads/2021/07/podrocket_slider_bg_v3.png');}

	.footer .epname{color:white !important; font-size: 24px;font-weight:700;}
	.footer .desc{color:white !important; font-size: 16px;align-self:start;}

	.footer .epname2{color:#202473 !important;}
	.footer .desc2{color:#383f4D !important;}

	.footer .info{
		font-weight:700;
		font-size: 13px;
		padding: 5px 10px 5px 10px;
		margin-bottom:10px;
		background-color: #ffffff;
		text-transform: uppercase;
		color:#202473;
		display:flex;
		width: 160px !important;
		border-radius:20px;
		letter-spacing: 1px;
	}

	.footer .info2{background-color:#202473; color:white;}

	.footer .a{grid-area: 1 / 1 / span 1 / span 1;}
	.footer .b{grid-area: 1 / 2 / span 1 / span 1;}
	.footer .cd{grid-area: 2 / 1 / span 1 / span 2;}
	.footer .ef{grid-area: 3 / 1 / span 1 / span 2; justify-self: start;}

	.footer .cta{
		font-weight: 700;
		font-size: 20px;
		text-transform: uppercase;
		padding: 15px 40px 15px 40px;
		background-color: white;
		color: #202473;
		letter-spacing: 1px;
		border: 0px;
		border-radius: 45px;
		transition: 400ms;
	}

	.footer .cta:hover{
		box-shadow: 0px 20px 40px 0px rgba(255,255,255,0.2);
		transition: 400ms;
	}

	.footer .cta2{background-color:#202473; color:white !important;}
	.footer .cta2:hover{box-shadow: 0px 20px 40px 0px #20247333;}

	.avatar1 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_rome.png");border-radius: 0px !important;}
	.avatar2 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_rocket-surgery.png");border-radius: 100%;}
	.avatar3 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_mark-erikson.png");border-radius: 100%;}
	.avatar4 {background-image: url("https://blog.logrocket.com/wp-content/uploads/2021/07/avatar_continuing-education.png");border-radius: 100%;}

	.footer .avatar{
		width:150px;
		height:150px;
		
		background-position: center;
		background-repeat: no-repeat;
		background-size:cover;
		z-index: 99;
		/* box-shadow: 0px 36px 50px 0px rgba(32,36,115,0.75); */
	}

	.avatar_light{box-shadow: 0px 36px 50px 0px rgba(32,36,115,0.2);}

	.footer .owl-stage-outer a{
		text-decoration:none !important;
		color: #202473 !important;
	}

	@media only screen and (max-width: 900px){
		
		.footer .container{padding:10px;}

		.footer .grid{
			display: grid;
			grid-template: 150px auto auto auto / auto;
			padding:30px;
			border-radius:20px;
			grid-gap:14px;
		}

		.footer .a{grid-area: 1 / 1 / span 1 / span 1;}
		.footer .b{grid-area: 2 / 1 / span 1 / span 1;}
		.footer .cd{grid-area: 3 / 1 / span 1 / span 1;}
		.footer .ef{grid-area: 4 / 1 / span 1 / span 1; justify-self: start;}

		.footer .cta{font-size:16px; padding: 10px 20px 10px 20px;}
		.footer .epname{font-size: 20px;}
		.footer .desc{font-size: 14px;}
		
	}

</style>
<h2>Have you listened to our podcast? Check it out:</h2>
<div class='white' style='background:rgb(255, 255, 255); border:solid 0px #f0f0f0; border-radius:20px; padding:0px 0px 0px 0px;'>
<div id='sample_slider' class='owl-carousel sa_owl_theme owl-pagination-true' data-slider-id='sample_slider' style='visibility:hidden;'>
<div id='sample_slider_slide04' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid grid2">
<div class="a"><div class="avatar avatar_light avatar4"></div></div>
<div class="b">
<span class="info info2">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 29</span>
</span>
<span class="epname epname2">Continuing education with Eve Porcello</span>
</div>
<div class="cd desc desc2">In this episode, we talk to Eve Porcello about her experience teaching web development and Moon Highway, a training and curriculum development company she runs.</div>
<a href="https://podrocket.logrocket.com/continuing-education" class="ef cta cta2" style="color: white !important;">Listen now</a>
</div>
</div></div>
<div id='sample_slider_slide03' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid">
<div class="a"><div class="avatar avatar3"></div></div>
<div class="b">
<span class="info">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 26</span>
</span>
<span class="epname">Redux is alive and well with Mark Erikson</span>
</div>
<div class="cd desc">What is modern Redux? What is it with the obsession of declaring Redux dead? In this episode, Ben and Brian interview Mark Erikson to talk about all things Redux.</div>
<a href="https://podrocket.logrocket.com/redux" class="ef cta">Listen now</a>
</div>
</div></div>
<div id='sample_slider_slide01' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid">
<div class="a"><div class="avatar avatar1"></div></div>
<div class="b">
<span class="info">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 34</span>
</span>
<span class="epname">Rome and Rome Tools, Inc. with Sebastian McKenzie and Jamie Kyle</span>
</div>
<div class="cd desc">In this episode, Ben and Kaelan talk to Sebastian McKenzie and Jamie Kyle about Rome Tools, Inc., the roadmap for Rome, and the experience of getting funding as an open-source tool.</div>
<a href="https://podrocket.logrocket.com/rome" class="ef cta">Listen now</a>
</div>
</div></div>
<div id='sample_slider_slide02' class='sa_hover_container' style='padding:0% 0%; margin:0px 0%; min-height:400px; '><div style="text-align: left;" class="container">
<div class="grid grid2">
<div class="a"><div class="avatar avatar_light avatar2"></div></div>
<div class="b">
<span class="info info2">
<span>PodRocket</span><span style="opacity:40%; margin: 0 5px 0 5px;">|</span><span>Ep. 30</span>
</span>
<span class="epname epname2">Rocket Surgery: Kaelan and Chris Coyier compare notes</span>
</div>
<div class="cd desc desc2">Are you up to speed on all of this new CSS stuff? Chris Coyier and Kaelan compare notes on CSS and frontend development (they also discuss MDN plus).</div>
<a href="https://podrocket.logrocket.com/css" class="ef cta cta2" style="color: white !important;">Listen now</a>
</div>
</div></div>
</div>
</div>
<script type='text/javascript'>
	document.addEventListener('DOMContentLoaded', function() {
		jQuery('#sample_slider').owlCarousel({
			responsive:{
				0:{ items:1 },
				480:{ items:1 },
				768:{ items:2 },
				980:{ items:2 },
				1200:{ items:2 },
				1500:{ items:2 }
			},
			autoplay : false,
			autoplayHoverPause : false,
			smartSpeed : 300,
			fluidSpeed : 300,
			autoplaySpeed : 300,
			navSpeed : 300,
			dotsSpeed : 300,
			loop : true,
			nav : true,
			navText : ['Previous','Next'],
			dots : true,
			responsiveRefreshRate : 200,
			slideBy : 1,
			mergeFit : true,
			autoHeight : false,
			mouseDrag : false,
			touchDrag : true
		});
		jQuery('#sample_slider').css('visibility', 'visible');
		var owl_goto = jQuery('#sample_slider');
		jQuery('.sample_slider_goto1').click(function(event){
			owl_goto.trigger('to.owl.carousel', 0);
		});
		jQuery('.sample_slider_goto2').click(function(event){
			owl_goto.trigger('to.owl.carousel', 1);
		});
		jQuery('.sample_slider_goto3').click(function(event){
			owl_goto.trigger('to.owl.carousel', 2);
		});
		jQuery('.sample_slider_goto4').click(function(event){
			owl_goto.trigger('to.owl.carousel', 3);
		});
		var resize_59470 = jQuery('.owl-carousel');
		resize_59470.on('initialized.owl.carousel', function(e) {
			if (typeof(Event) === 'function') {
				window.dispatchEvent(new Event('resize'));
			} else {
				var evt = window.document.createEvent('UIEvents');
				evt.initUIEvent('resize', true, false, window, 0);
				window.dispatchEvent(evt);
			}
		});
	});
</script>
</div><div class="footerRight"> <div id="jetpack-search-filters-2-wrapper">
<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div> <div class="clearfix"></div>
<a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202217'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text(),
	postAuthor: jQuery("meta[name='twitter:data1']").attr("content"),
	id: jQuery(".mainheading").closest(".col-md-8").attr("id").replace('post-','')
  });
}
jQuery(".aretags li a:contains('archive')").parent('li').hide();
jQuery(".aretags li a:contains('86919')").parent('li').hide();
jQuery(".aretags li a:contains('72293')").parent('li').hide();
};</script> <div style="display:none">
<div class="grofile-hash-map-ec2f423afc74a9aa66ca8c25fafc2361">
</div>
<div class="grofile-hash-map-1ce2af1bcf15cb76d3332d152afb3560">
</div>
<div class="grofile-hash-map-78baff0bcb7c0217b16721286e3460b6">
</div>
<div class="grofile-hash-map-0c566c76a8c53eeb261588c6d9db1621">
</div>
</div>
<div id="jp-carousel-loading-overlay">
<div id="jp-carousel-loading-wrapper">
<span id="jp-carousel-library-loading">&nbsp;</span>
</div>
</div>
<div class="jp-carousel-overlay" style="display: none;">
<div class="jp-carousel-container">

<div class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions" itemscope itemtype="https://schema.org/ImageGallery">
<div class="jp-carousel swiper-wrapper"></div>
<div class="jp-swiper-button-prev swiper-button-prev">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white" />
</mask>
<g mask="url(#maskPrev)">
<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
<div class="jp-swiper-button-next swiper-button-next">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white" />
</mask>
<g mask="url(#maskNext)">
<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
</div>

<div class="jp-carousel-close-hint">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white" />
</mask>
<g mask="url(#maskClose)">
<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>

<div class="jp-carousel-info">
<div class="jp-carousel-info-footer">
<div class="jp-carousel-pagination-container">
<div class="jp-swiper-pagination swiper-pagination"></div>
<div class="jp-carousel-pagination"></div>
</div>
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-caption"></h2>
</div>
<div class="jp-carousel-photo-icons-container">
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white" />
</mask>
<g mask="url(#maskInfo)">
<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</span>
</a>
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white" />
</mask>
<g mask="url(#maskComments)">
<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
</span>
</a>
</div>
</div>
<div class="jp-carousel-info-extra">
<div class="jp-carousel-info-content-wrapper">
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-title"></h2>
</div>
<div class="jp-carousel-comments-wrapper">
<div id="jp-carousel-comments-loading">
<span>Loading Comments...</span>
</div>
<div class="jp-carousel-comments"></div>
<div id="jp-carousel-comment-form-container">
<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
<div id="jp-carousel-comment-post-results"></div>
<form id="jp-carousel-comment-form">
<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
<textarea name="comment" class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea" id="jp-carousel-comment-form-comment-field" placeholder="Write a Comment..."></textarea>
<div id="jp-carousel-comment-form-submit-and-info-wrapper">
<div id="jp-carousel-comment-form-commenting-as">
<fieldset>
<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
</fieldset>
<fieldset>
<label for="jp-carousel-comment-form-url-field">Website</label>
<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
</fieldset>
</div>
<input type="submit" name="submit" class="jp-carousel-comment-form-button" id="jp-carousel-comment-form-button-submit" value="Post Comment" />
</div>
</form>
</div>
</div>
<div class="jp-carousel-image-meta">
<div class="jp-carousel-title-and-caption">
<div class="jp-carousel-photo-info">
<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
</div>
<div class="jp-carousel-photo-description"></div>
</div>
<ul class="jp-carousel-image-exif" style="display: none;"></ul>
<a class="jp-carousel-image-download" target="_blank" style="display: none;">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white" />
</mask>
<g mask="url(#mask0)">
<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-download-text"></span>
</a>
<div class="jp-carousel-image-map" style="display: none;"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/how-when-force-flutter-widget-rebuild\/":105242};
	</script>
<link rel='stylesheet' id='owl_carousel_css-css' href='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/owl.carousel.css?ver=2.2.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='owl_theme_css-css' href='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/sa-owl-theme.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='owl_animate_css-css' href='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/animate.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://blog.logrocket.com/wp-includes/css/dashicons.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='nf-display-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/display-opinions-light.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='nf-font-awesome-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/font-awesome.min.css?ver=5.9.3' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-before'>
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/dist/hooks.min.js?ver=1e58c8c5a32b2e97491080c5b10dc71c' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/dist/i18n.min.js?ver=30fcecb428a0e8383d3776bcdd3a7834' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='jetpack-search-widget-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "jetpack-search-pkg", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-search/src/widgets/js/search-widget.js?minify=false&#038;ver=1645029952' id='jetpack-search-widget-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=b5fe079abfcad78b7237774a0b3115aa' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=567470f2f8d6d97f1a9cb9b77b0e503c' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/blog.logrocket.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/blog.logrocket.com\/wp-admin\/admin-ajax.php","nonce":"53f91eb0ef","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/blog.logrocket.com\/wp-login.php?redirect_to=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=10.9-beta2' id='jetpack-carousel-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/slide-anything/owl-carousel/owl.carousel.min.js?ver=2.2.1' id='owl_carousel_js-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/slide-anything/js/jquery.mousewheel.min.js?ver=3.1.13' id='mousewheel_js-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/backbone.min.js?ver=1.4.0' id='backbone-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end-deps.js?ver=3.6.9' id='nf-front-end-deps-js'></script>
<script type='text/javascript' id='nf-front-end-js-extra'>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</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end.js?ver=3.6.9' id='nf-front-end-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.9-beta2' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=105242&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=ecf439f476&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.9-beta2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=540185bf9a814f7ad0fa7c94de6178f5e038b3fd#parent=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=105242&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&jetpack_comments_nonce=ecf439f476&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.9-beta2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=540185bf9a814f7ad0fa7c94de6178f5e038b3fd#parent=https%3A%2F%2Fblog.logrocket.com%2Fhow-when-force-flutter-widget-rebuild%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202217.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9-beta2',blog:'161333275',post:'105242',tz:'-4',srv:'blog.logrocket.com',hp:'atomic',ac:'2',amp:'0'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '105242' ]);
</script>
<script id="tmpl-nf-layout" type="text/template">
	<span id="nf-form-title-{{{ data.id }}}" class="nf-form-title">
		{{{ ( 1 == data.settings.show_title ) ? '<h3>' + data.settings.title + '</h3>' : '' }}}
	</span>
	<div class="nf-form-wrap ninja-forms-form-wrap">
		<div class="nf-response-msg"></div>
		<div class="nf-debug-msg"></div>
		<div class="nf-before-form"></div>
		<div class="nf-form-layout"></div>
		<div class="nf-after-form"></div>
	</div>
</script>
<script id="tmpl-nf-empty" type="text/template">

</script>
<script id="tmpl-nf-before-form" type="text/template">
	{{{ data.beforeForm }}}
</script><script id="tmpl-nf-after-form" type="text/template">
	{{{ data.afterForm }}}
</script><script id="tmpl-nf-before-fields" type="text/template">
    <div class="nf-form-fields-required">{{{ data.renderFieldsMarkedRequired() }}}</div>
    {{{ data.beforeFields }}}
</script><script id="tmpl-nf-after-fields" type="text/template">
    {{{ data.afterFields }}}
    <div id="nf-form-errors-{{{ data.id }}}" class="nf-form-errors" role="alert"></div>
    <div class="nf-form-hp"></div>
</script>
<script id="tmpl-nf-before-field" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-after-field" type="text/template">
    {{{ data.afterField }}}
</script><script id="tmpl-nf-form-layout" type="text/template">
	<form>
		<div>
			<div class="nf-before-form-content"></div>
			<div class="nf-form-content {{{ data.element_class }}}"></div>
			<div class="nf-after-form-content"></div>
		</div>
	</form>
</script><script id="tmpl-nf-form-hp" type="text/template">
	<label for="nf-field-hp-{{{ data.id }}}" aria-hidden="true">
		{{{ nfi18n.formHoneypot }}}
		<input id="nf-field-hp-{{{ data.id }}}" name="nf-field-hp" class="nf-element nf-field-hp" type="text" value=""/>
	</label>
</script>
<script id="tmpl-nf-field-layout" type="text/template">
    <div id="nf-field-{{{ data.id }}}-container" class="nf-field-container {{{ data.type }}}-container {{{ data.renderContainerClass() }}}">
        <div class="nf-before-field"></div>
        <div class="nf-field"></div>
        <div class="nf-after-field"></div>
    </div>
</script>
<script id="tmpl-nf-field-before" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-field-after" type="text/template">
    <#
    /*
     * Render our input limit section if that setting exists.
     */
    #>
    <div class="nf-input-limit"></div>
    <#
    /*
     * Render our error section if we have an error.
     */
    #>
    <div id="nf-error-{{{ data.id }}}" class="nf-error-wrap nf-error" role="alert"></div>
    <#
    /*
     * Render any custom HTML after our field.
     */
    #>
    {{{ data.afterField }}}
</script>
<script id="tmpl-nf-field-wrap" type="text/template">
	<div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
		<#
		/*
		 * This is our main field template. It's called for every field type.
		 * Note that must have ONE top-level, wrapping element. i.e. a div/span/etc that wraps all of the template.
		 */
        #>
		<#
		/*
		 * Render our label.
		 */
        #>
		{{{ data.renderLabel() }}}
		<#
		/*
		 * Render our field element. Uses the template for the field being rendered.
		 */
        #>
		<div class="nf-field-element">{{{ data.renderElement() }}}</div>
		<#
		/*
		 * Render our Description Text.
		 */
        #>
		{{{ data.renderDescText() }}}
	</div>
</script>
<script id="tmpl-nf-field-wrap-no-label" type="text/template">
    <div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
        <div class="nf-field-label"></div>
        <div class="nf-field-element">{{{ data.renderElement() }}}</div>
        <div class="nf-error-wrap"></div>
    </div>
</script>
<script id="tmpl-nf-field-wrap-no-container" type="text/template">

        {{{ data.renderElement() }}}

        <div class="nf-error-wrap"></div>
</script>
<script id="tmpl-nf-field-label" type="text/template">
	<div class="nf-field-label"><label for="nf-field-{{{ data.id }}}"
	                                   id="nf-label-field-{{{ data.id }}}"
	                                   class="{{{ data.renderLabelClasses() }}}">{{{ data.label }}} {{{ ( 'undefined' != typeof data.required && 1 == data.required ) ? '<span class="ninja-forms-req-symbol">*</span>' : '' }}} {{{ data.maybeRenderHelp() }}}</label></div>
</script>
<script id="tmpl-nf-field-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-form-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-field-input-limit" type="text/template">
    {{{ data.currentCount() }}} {{{ nfi18n.of }}} {{{ data.input_limit }}} {{{ data.input_limit_msg }}}
</script><script id="tmpl-nf-field-null" type="text/template">
</script><script id="tmpl-nf-field-listcheckbox" type="text/template">
    <ul aria-describedby="nf-error-{{{ data.id }}}">
        {{{ data.renderOptions() }}}
    </ul>
</script>
<script id='tmpl-nf-field-listcheckbox-option' type='text/template'>
    <# if ( ! data.visible ) { return '' } #>
    <li>
        <input type="checkbox" id="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}" name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element {{{ ( data.isSelected ) ? ' nf-checked' : '' }}}" value="{{{ data.value }}}" {{{ ( data.isSelected ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
            <# if( data.required ) { #>
			required
			<# } #>
        >
        <label for="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               id="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               class="{{{ ( data.isSelected ) ? 'nf-checked-label' : '' }}}">{{{ data.label }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other' type='text/template'>
    <li {{{ ( ! data.visible ) ? 'style="display:none"' : '' }}}>
        <input type="checkbox"
               id="nf-field-{{{ data.fieldID }}}-other"
               name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element" value="nf-other" {{{ ( ! data.valueFound ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-other"
            <# if( data.required ) { #>
			required
			<# } #>
        >
         <label id="nf-label-field-{{{ data.fieldID }}}-other">Other
            {{{ data.renderOtherText() }}}
        </label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other-text' type='text/template'>
    <input type="text" name="nf-field-{{{ data.fieldID }}}" class="nf-element" value="{{{ data.currentValue }}}">
</script>
<script id='tmpl-nf-field-input' type='text/template'>
    <input id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" aria-invalid="false" aria-describedby="nf-error-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element" type="text" value="{{{ data.value }}}" {{{ data.renderPlaceholder() }}} {{{ data.maybeDisabled() }}}
           aria-labelledby="nf-label-field-{{{ data.id }}}"

            {{{ data.maybeRequired() }}}
    >
</script>
<script id="tmpl-nf-field-email" type="text/template">
	<input
			type="email"
			value="{{{ data.value }}}"
			class="{{{ data.renderClasses() }}} nf-element"

			id="nf-field-{{{ data.id }}}"
			<# if( ! data.disable_browser_autocompletes ){ #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id + '-' + data.type }}"
			autocomplete="email"
			<# } else { #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id }}"
			{{{ data.maybeDisableAutocomplete() }}}
			<# } #>
			{{{ data.renderPlaceholder() }}}
			{{{ data.maybeDisabled() }}}

			aria-invalid="false"
			aria-describedby="nf-error-{{{ data.id }}}"
			aria-labelledby="nf-label-field-{{{ data.id }}}"

			{{{ data.maybeRequired() }}}
	>
</script>
<script id="tmpl-nf-field-submit" type="text/template">
	<input id="nf-field-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element " type="button" value="{{{ data.label }}}" {{{ ( data.disabled ) ? 'disabled' : '' }}}>
</script><script id='tmpl-nf-field-button' type='text/template'>
    <button id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" class="{{{ data.classes }}} nf-element">
        {{{ data.label }}}
    </button>
</script><script>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</script>
</body>
</html>

