<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="pingback" href="https://blog.logrocket.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />


<title>Handling side effects in an Angular + Redux application - LogRocket Blog</title>
<meta name="description" content="Learn how you can manage side effects to the Redux state tree in an Angular framework with the @ngrx/effects library." />
<link rel="canonical" href="https://blog.logrocket.com/handling-side-effects-angular-redux-application/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Handling side effects in an Angular + Redux application - LogRocket Blog" />
<meta property="og:description" content="Learn how you can manage side effects to the Redux state tree in an Angular framework with the @ngrx/effects library." />
<meta property="og:url" content="https://blog.logrocket.com/handling-side-effects-angular-redux-application/" />
<meta property="og:site_name" content="LogRocket Blog" />
<meta property="article:published_time" content="2021-06-07T13:00:05+00:00" />
<meta property="article:modified_time" content="2021-06-04T19:24:38+00:00" />
<meta property="og:image" content="https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application.png" />
<meta property="og:image:width" content="730" />
<meta property="og:image:height" content="487" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Emmanuel John">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="7 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://blog.logrocket.com/#website","url":"https://blog.logrocket.com/","name":"LogRocket Blog","description":"For Frontend Developers and Web App Engineers","potentialAction":[{"@type":"SearchAction","target":"https://blog.logrocket.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blog.logrocket.com/handling-side-effects-angular-redux-application/#primaryimage","inLanguage":"en-US","url":"https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application.png","contentUrl":"https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application.png","width":730,"height":487,"caption":"Handling Side Effects in a Redux and Angular Application"},{"@type":"WebPage","@id":"https://blog.logrocket.com/handling-side-effects-angular-redux-application/#webpage","url":"https://blog.logrocket.com/handling-side-effects-angular-redux-application/","name":"Handling side effects in an Angular + Redux application - LogRocket Blog","isPartOf":{"@id":"https://blog.logrocket.com/#website"},"primaryImageOfPage":{"@id":"https://blog.logrocket.com/handling-side-effects-angular-redux-application/#primaryimage"},"datePublished":"2021-06-07T13:00:05+00:00","dateModified":"2021-06-04T19:24:38+00:00","author":{"@id":"https://blog.logrocket.com/#/schema/person/ca5994596160a3b5257ebe3a205bd4e8"},"description":"Learn how you can manage side effects to the Redux state tree in an Angular framework with the @ngrx/effects library.","breadcrumb":{"@id":"https://blog.logrocket.com/handling-side-effects-angular-redux-application/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blog.logrocket.com/handling-side-effects-angular-redux-application/"]}]},{"@type":"BreadcrumbList","@id":"https://blog.logrocket.com/handling-side-effects-angular-redux-application/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://blog.logrocket.com/","url":"https://blog.logrocket.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://blog.logrocket.com/handling-side-effects-angular-redux-application/#webpage"}}]},{"@type":"Person","@id":"https://blog.logrocket.com/#/schema/person/ca5994596160a3b5257ebe3a205bd4e8","name":"Emmanuel John","image":{"@type":"ImageObject","@id":"https://blog.logrocket.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/633d353d709f2e4be765695fa17853dd?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/633d353d709f2e4be765695fa17853dd?s=96&d=mm&r=g","caption":"Emmanuel John"},"description":"I'm a fullstack software developer, mentor, and writer. I am an open source enthusiast. In my spare time, I enjoy watching sci-fi movies and cheering for Arsenal FC."}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Feed" href="https://blog.logrocket.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Comments Feed" href="https://blog.logrocket.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LogRocket Blog &raquo; Handling side effects in an Angular + Redux application Comments Feed" href="https://blog.logrocket.com/handling-side-effects-angular-redux-application/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blog.logrocket.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://blog.logrocket.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='github-embed-css' href='https://blog.logrocket.com/wp-content/plugins/github-embed/css/github-embed.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap4-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/assets/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediumish-style-css' href='https://blog.logrocket.com/wp-content/themes/mediumish/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=9.8' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://blog.logrocket.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.8' type='text/css' media='all' />
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/highlight.min.js' id='hljs1-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/languages/javascript.min.js' id='hljs2-js'></script>
<link rel="https://api.w.org/" href="https://blog.logrocket.com/wp-json/" /><link rel="alternate" type="application/json" href="https://blog.logrocket.com/wp-json/wp/v2/posts/52702" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blog.logrocket.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blog.logrocket.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://wp.me/paUW9B-dI2' />
<link rel="alternate" type="application/json+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blog.logrocket.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F&#038;format=xml" />
<meta name="theme-color" content="#764abc" />
<script src="//geoip-js.com/js/apis/geoip2/v2.1/geoip2.js" type="text/javascript"></script>

<script>
var processEpsilonData = function(textResponseData) {
  // --- Decode Response ---
  if (!textResponseData) {
    // If the response is blank, stop processing
    return;
  }
  var jData = JSON.parse(textResponseData);
  // --- End Decode Response ---
  // --- Push Company and segment Details to segment ---

  // -- start personalization
  setTimeout(function() {
    if (jData.company.domain && window.location.pathname != "/") {
		
		  window.analytics && window.analytics.track('6sense domain', {
    domain: jData.company.domain
  });
      var demoButton = document.getElementById("blog-personalized-demo-link");
      var personalizeImage = document.getElementById("blog-personalized-demo-thumbnail");
      var companyName = document.getElementById("personalized-company-account-name");
      var perUrl = "https://us-central1-logrocket-com.cloudfunctions.net/findPersonalization?targetDomain=" + jData.company.domain;
      fetch(perUrl)
        .then(response => {
          return response.json()
        })
        .then(data => {
          var imageReturn = data.image_url;
          var linkReturn = data.link_url;
          if (imageReturn.includes("not-found") || linkReturn.includes("not-found")) {
            return "not-found";
          } else {
            personalizeImage.src = imageReturn;
            demoButton.href = linkReturn;
            companyName.innerHTML = jData.company.name;
            var intersectionOptions = {
              root: null, // use the viewport
              rootMargin: '-240px',
              threshold: 1.0
            }

            function intersectionCallback(entries, observer) {
              entries.forEach(entry => {
                if (entry.intersectionRatio >= 1) {
                  jQuery('.inline-demo').slideDown(1500);
                  //  jQuery('.crp-list-item-image img').delay(550).fadeIn(1000);
                  observer.unobserve(target);
                } else {}
              });
            }
            var observer = new IntersectionObserver(intersectionCallback, intersectionOptions);
            var target = document.querySelector('.code-block-28');
            observer.observe(target);

            analytics.track('Personalization-deployed-blog', {
              'Domain': jData.company.domain
            });
            LogRocket.track('post-personalized-blog');
          }
        })
        .catch(err => {
          analytics.track("personalization-failed");
          throw err;
        })
    };
    // end personalization

    //start segmetns & intercom
    if (jData.segments.names) {
      window.sixSegments = jData.segments.names;
      window.analytics && window.analytics.track('6sense segments', {
        segments: jData.segments.names.join(',')
      });
      const sixTargetSegments = ['intent-3rd-party-core-sessionreplay', 'intent-3rd-party-competitive-quantum-metric', 'intent-3rd-party-competitive-fullstory-activetargets', 'intent-3rd-party-core-RUM', 'intent-3rd-party-competitive-sentry',
        'intent-3rd-party-core-productanalytics', 'intent-3rd-party-core-frontend-monitoring', 'intent-3rd-party-react', 'intent-3rd-party-conversion-rate', 'intent-3rd-party-web-vitals', 'intent-3rd-party-competitive-smartlook',
        'intent-3rd-party-competitive-dynatrace'
      ]
      const sixResult = sixTargetSegments.find((item) => sixSegments.includes(item));
      jQuery('.intercom-lightweight-app').css('display','block');
      window.intercomSettings = {
        app_id: 'zcgg0wlq',
        utm_content: sixResult
      }
    }
    // end intercom

  }, 2000);
};
const setup6Sense = () => {
  window._6si = window._6si || [];
  window.dataLayer = window.dataLayer || [];
  window._6si.push(['enableEventTracking', true]);
  window._6si.push(['setToken', 'd5fbd2e5f08cba3d3d417f7a67cd8d1f']);
  window._6si.push(["setEndpoint", "b.6sc.co"]);
  var epsilonName = 'enableCompanyDetails';
  var enabled = true; // set to true to enable API
  var callback = processEpsilonData; // optional callback
  var version = 3; // 3 for v3
  window._6si.push([epsilonName, enabled, callback, version]);
  window._6si.push(['setEpsilonKey', 'a2d1a28025c555de9af13fd94f96f9044dbb8331']);
  var gd = document.createElement('script');
  gd.type = 'text/javascript';
  gd.async = true;
  gd.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'j.6sc.co/6si.min.js';
  var s = document.getElementsByTagName('script')[0];
  s.parentNode.insertBefore(gd, s);
}
geoip2.country(
  function(response) {
    if (response.country.iso_code == "US") {
      setup6Sense();
    }
  }
);
</script>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/highlight.js/9.12.0/styles/tomorrow.min.css" media="none" onload="if(media!='all')media='all'">
<script>
function setlrAdwinExpiry(lrAdwin, value, ttl) {
				var now = new Date()

				// `item` is an object which contains the original value
				// as well as the time when it's supposed to expire
				const item = {
					value: 'isSet',
					expiry: now.getTime() + 4665600000,
				}
				localStorage.setItem(lrAdwin, JSON.stringify(item))
				setTimeout(function(){
					analytics.track("lrAdwin", {
  active: "true"
});
    }, 1000);
			}

			function getWithExpiry(lrAdwin) {
				const itemStr = localStorage.getItem(lrAdwin)

				// if the item doesn't exist, return null
				if (!itemStr) {
					return null
				}

				const item = JSON.parse(itemStr)
				const now = new Date()

				// compare the expiry time of the item with the current time
				if (now.getTime() > item.expiry) {
					// If the item is expired, delete the item from storage
					// and return null
					localStorage.removeItem(lrAdwin)
					if (analytics) {					analytics.track("lrAdwin", {
  active: "false"
});}
					return null
				}
				return item.value
			}

			if (!localStorage.getItem('_lr_id_')){
				setlrAdwinExpiry();
			}
			getWithExpiry();
</script>
<script>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</script>
<script>
    window.Raven && window.Raven.config('https://a39e555ed62c408792586c55bbb2ce3b@e.logrocket.com/9').install()
    </script>
<script type="text/javascript">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</script>
<script src="https://cdn.lr-ingest.io/LogRocket.min.js"></script>
<script>
        if (window.LogRocket) {
            window.LogRocket.init('apphub/logrocket-website',{
                dashboardHost: "https://staging.lr-ingest.io",
                serverURL: "https://staging-i.lr-ingest.io/i",
                mergeIframes: true,
                rootHostname: "logrocket.com",
            });
        }

<!-- start vwo -->
      window._vwo_code = window._vwo_code || (function(){
        var account_id=338524,
        settings_tolerance=2000,
        library_tolerance=2500,
        use_existing_jquery=false,
        is_spa=1,
        hide_element='body',

        /* DO NOT EDIT BELOW THIS LINE */
        f=false,d=document,code={use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){
        settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);var a=d.createElement('style'),b=hide_element?hide_element+'{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}':'',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&f='+(+is_spa)+'&r='+Math.random());return settings_timer; }};window._vwo_settings_timer = code.init(); return code; }());
<!-- Reddit Pixel -->
!function(w,d){if(!w.rdt){var p=w.rdt=function(){p.sendEvent?p.sendEvent.apply(p,arguments):p.callQueue.push(arguments)};p.callQueue=[];var t=d.createElement("script");t.src="https://www.redditstatic.com/ads/pixel.js",t.async=!0;var s=d.getElementsByTagName("script")[0];s.parentNode.insertBefore(t,s)}}(window,document);rdt('init','t2_3xdvtyx2');rdt('track', 'PageVisit');
<!-- DO NOT MODIFY -->
<!-- End Reddit Pixel -->
    </script><style type='text/css'>img#wpstats{display:none}</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<link rel="preload" as="style" href="https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/prettify.css" /><link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-32x32.png" sizes="32x32" />
<link rel="icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-180x180.png" />
<meta name="msapplication-TileImage" content="https://blog.logrocket.com/wp-content/uploads/2019/06/cropped-cropped-favicon-196x196-270x270.png" />
<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://blog.logrocket.com/?custom-css=bb61364259" />
<style id="kirki-inline-styles">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</style></head>
<body class="post-template-default single single-post postid-52702 single-format-standard">
<style>
    </style>
<header class="navbar-light bg-white fixed-top mediumnavigation">
<div class="container">
<div class="navarea">
<div class="nav-left">
<a class="blog-logo" href="https://logrocket.com" rel='home'><img class="lozad" src='https://blog.logrocket.com/wp-content/uploads/2020/01/logrocket-blog-logo.png' alt='LogRocket Blog'></a>
<nav class="menu-container">
<div class="menu-primary-container"><ul id="menu-primary" class=""><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6 nav-item"><a href="/" class="nav-link">Blog</a><li id="menu-item-32492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32492 nav-item"><a href="https://podrocket.logrocket.com" class="nav-link">PodRocket</a></ul></div></nav>
</div>
<div class="nav-right">
<div class="menu-container">
<div id="right-hand-nav" class="menu-right-hand-menu-container"><ul id="menu-right-hand-menu" class=""><li id="menu-item-877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-877"><a href="https://app.logrocket.com">Sign In</a></li>
<li id="menu-item-878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-878"><a href="https://logrocket.com/signup/">Start your self-service trial</a></li>
</ul></div> </div>
</div>
</div>
</div>
</header>

<div class="site-content">
<div class="container">
<div class="row">
<div class=" col-md-2 ">
<div class="share">
<div class="sidebarapplause">
</div>
<p class="sharecolour">
Share </p>
<ul class="shareitnow"><li>
<a target="_blank" href="https://twitter.com/intent/tweet?text=Handling%20side%20effects%20in%20an%20Angular%20+%20Redux%20application&amp;url=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F">
<i class="fa fa-twitter"></i>
</a>
</li><li>
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F">
<i class="fa fa-facebook"></i>
</a>
</li><li>
<a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F">
<i class="fa fa-google"></i>
</a>
</li><li>
<a target="_blank" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F&amp;media=https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application.png&amp;description=Handling%20side%20effects%20in%20an%20Angular%20+%20Redux%20application">
<i class="fa fa-pinterest"></i>
</a>
</li><li>
<a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F&amp;title=Handling%20side%20effects%20in%20an%20Angular%20+%20Redux%20application">
<i class="fa fa-linkedin"></i>
</a>
</li></ul>
<div class="sep"></div>
<div class="hidden-xs-down">
<p>
Reply </p>
<ul>
<li>
<a class="smoothscroll" href="#comments">0<br />
<svg class="svgIcon-use" width="29" height="29" viewBox="0 0 29 29"><path d="M21.27 20.058c1.89-1.826 2.754-4.17 2.754-6.674C24.024 8.21 19.67 4 14.1 4 8.53 4 4 8.21 4 13.384c0 5.175 4.53 9.385 10.1 9.385 1.007 0 2-.14 2.95-.41.285.25.592.49.918.7 1.306.87 2.716 1.31 4.19 1.31.276-.01.494-.14.6-.36a.625.625 0 0 0-.052-.65c-.61-.84-1.042-1.71-1.282-2.58a5.417 5.417 0 0 1-.154-.75zm-3.85 1.324l-.083-.28-.388.12a9.72 9.72 0 0 1-2.85.424c-4.96 0-8.99-3.706-8.99-8.262 0-4.556 4.03-8.263 8.99-8.263 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32c0 .07 0 .19.02.37.03.29.1.6.19.92.19.7.49 1.4.89 2.08-.93-.14-1.83-.49-2.67-1.06-.34-.22-.88-.48-1.16-.74z"></path></svg>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="col-md-8 flex-first flex-md-unordered post-52702 post type-post status-publish format-standard has-post-thumbnail hentry category-uncategorized tag-angular tag-redux" id="post-52702">
<div class="mainheading">

<div class="row post-top-meta hidden-md-down">
<div class="col-md-2 col-xs-12">
<a href="https://blog.logrocket.com/author/emmanueljohn/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/01/AirBrush_20210107121828-150x150.jpg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/01/AirBrush_20210107121828-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/01/AirBrush_20210107121828-150x150.jpg?crop=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </a>
</div>
<div class="col-md-10 col-xs-12">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/emmanueljohn/">
Emmanuel John <span class="btn follow">Follow</span></a>
<span class="author-description d-block">I'm a fullstack software developer, mentor, and writer. I am an open source enthusiast. In my spare time, I enjoy watching sci-fi movies and cheering for Arsenal FC.</span>
</div>
</div>
<h1 class="posttitle">Handling side effects in an Angular + Redux application</h1>
<h2 class="post-subtitle"></h2>
<p>
<span class="post-date"><time class="post-date">
June 7, 2021 </time></span>
 <span class="dot"></span>
<span class="readingtime">5 min read</span>
<span class="wordcount">1545</span>
</p>
</div>
<img width="730" height="487" src="https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application.png" class="featured-image img-fluid wp-post-image jetpack-lazy-image" alt="Handling Side Effects in a Redux and Angular Application" loading="lazy" data-attachment-id="52710" data-permalink="https://blog.logrocket.com/handling-side-effects-angular-redux-application/handling-side-effects-redux-angular-application/" data-orig-file="https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application.png" data-orig-size="730,487" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="handling-side-effects-redux-angular-application" data-image-description="" data-medium-file="https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application-300x200.png" data-large-file="https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application.png" data-lazy-srcset="https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application.png 730w, https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application-300x200.png 300w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/06/handling-side-effects-redux-angular-application.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> <article class="article-post">
<h2>Introduction</h2>
<p>With Redux gaining widespread popularity within the frontend ecosystem, Angular and other leading frontend frameworks have embraced it as one of their reliable state management libraries.</p>
<p>But unfortunately, the Redux architecture doesn’t provide any built-in functionality for handling asynchronous data changes (also known as side effects) to the Redux state tree. As a result, when these asynchronous actions are done, the Redux state tree will be affected.</p>
<p>This article will introduce the @ngrx/effects library, a special package for handling side effects in NgRx applications, and how it can be used to handle side effects in NgRx applications.</p>
<h3>Prerequisites</h3>
<ol>
<li>Knowledge of Angular</li>
<li>Knowledge of NgRx</li>
<li>Knowledge of TypeScript</li>
</ol>
<h2>What are side effects?</h2>
<p>Side effects are operations such as fetching data from a remote server, accessing local storage, recording analytics events, and accessing files that usually finish sometime in the future.</p>
<p>Knowing what side effects are, let’s say we want to make a request to an API endpoint to fetch a list of users in our app. Considering the fact that such an operation will be asynchronous, the following cases will be accounted for:</p>
<ol>
<li><code>FETCHING_USERS</code></li>
<li><code>USERS_FETCH_SUCCESSFUL</code></li>
<li><code>ERROR_FETCHING_USERS</code></li>
</ol>
<p>Let’s get our hands dirty by doing some practice.</p>
<h2>Environment setup</h2>
<p>Create a new Angular project with the following command:</p>
<pre>ng new side-effects
</pre>
<p>Run the following command to install the required dependencies for this exercise:</p>
<pre>npm install --save @ngrx/effects @ngrx/store rxjs
</pre>
<p>Next, we will run the following command to create a feature module for users:</p>
<pre>ng generate module user
</pre>
<p>Then, we will create a <code>constants.ts</code> file to hold <code>FETCHING USERS</code>, <code>USERS FETCH SUCCESSFUL</code>, and <code>ERROR FETCHING USERS</code> as follows:</p><div class='code-block code-block-28' style='margin: 8px 0; clear: both;'>
<a id="blog-personalized-demo-link" href="">
<div class="inline-demo">
<h2 style="color: #ffffff;">We made a custom demo for <span id="personalized-company-account-name"></span>.<br />No really. <span style="text-decoration:underline">Click here to check it out</span>.</h2>
<img id="blog-personalized-demo-thumbnail" src><noscript><img id="blog-personalized-demo-thumbnail" src=""/></noscript>
<button class="personalize-button">Click here to see the full demo with network requests</button>
</div></a>
<style>.inline-demo {width: 100%; max-width:700px;display:none;margin-bottom: 2rem;transition: filter 0.5s ease;padding: 1.5rem;border-radius: 5px;filter: drop-shadow(5px 0px 15px #afafaf); 	background: linear-gradient(-45deg, #764abc, #7a49a5, #4974a5,#4A4A4A);
	background-size: 400% 400%;
	animation: gradient 10s ease infinite;} .inline-demo:hover{filter:drop-shadow(1px 0px 5px #d7d7d7) !important;}@keyframes gradient {
	0% {
		background-position: 0% 50%;
	}
	50% {
		background-position: 100% 50%;
	}
	100% {
		background-position: 0% 50%;
	}
}#blog-personalized-demo-link:hover{text-decoration:none;}
.personalize-button {background: #4ABC76;
    width: 35%;
    border-radius: 25px;
    text-decoration: none;
    color: #fff;
    line-height: 18px;
    display: block;
    margin: 20px auto 5px auto;
    border:0px;
    padding: 20px;
    letter-spacing: 0.1px;
    box-shadow: 0px 0px 50px 10px rgba(0,0,0,0.3);
    transition: all 0.25s linear;}
  .personalize-button:hover{
  color: #4ABC76;
  background: #fff !important;
  cursor:pointer;
}@media all and (max-width: 600px){.personalize-button{width: 80%;}}</style>
</div>
<pre>//src/app/user/user.constants.ts
export const FETCHING_USERS = "FETCHING_USERS";
export const USERS_FETCH_SUCCESSFUL = "USERS_FETCH_SUCCESSFUL";
export const ERROR_FETCHING_USERS = "ERROR_FETCHING_USERS";
</pre>
<h2>Action creators</h2>
<p>Action creators are helper functions that create and return actions. Knowing that, let’s create one as follows:</p>
<pre>//src/app/user/user.actions.ts
import {
    USERS_FETCH_SUCCESSFUL,
    ERROR_FETCHING_USERS,
    FETCHING_USERS
} from "./user.constants";
export const usersFetchSuccessful = users =&gt; ({
    type: USERS_FETCH_SUCCESSFUL,
    payload: users
});
export const fetchError = error =&gt; ({
    type: ERROR_FETCHING_USERS,
    payload: error
});

export const fetchingUsers = () =&gt; ({ type: FETCHING_USERS });
</pre>
<p>Here we export <code>usersFetchSuccessful</code>, <code>fetchError</code>, and <code>fetchingUsers</code>, which will be needed in the components to interact with the NgRx store.</p>
<p>The <code>fetchError()</code> action creator will be invoked if an error occurs, the <code>usersFetchSuccessful()</code> action creator will be invoked once the data is returned successfully from an endpoint, and the <code>fetchingUsers()</code> action creator will be invoked once the API request is initiated.</p>
<h2>Creating the reducer</h2>
<p>Reducers are pure functions that don&#8217;t mutate the state. Instead, they produce a new state. A reducer specifies how the application&#8217;s state changes in response to the actions triggered.</p>
<p>Let&#8217;s create our reducer as follows:</p>
<pre>//src/app/user/user.reducers.ts
import {
    USERS_FETCH_SUCCESSFUL,
    ERROR_FETCHING_USERS,
    FETCHING_USERS
} from "./user.constants";
import { User } from "./user.model";
import { ActionReducerMap } from "@ngrx/store/src/models";
const initialState = {
    loading: false,
    list: [],
    error: void 0
};
export interface UserState {
    loading: boolean;
    list: Array&lt;User&gt;;
    error: string;
}
export interface FeatureUsers {
    users: UserState;
}
export const UserReducers: ActionReducerMap&lt;FeatureUsers&gt; = {
    users: UserReducer
};
export function userReducer(state = initialState, action) {
    switch (action.type) {
        case USERS_FETCH_SUCCESSFUL:
            return { ...state, list: action.payload, loading: false };
        case ERROR_FETCHING_USERS:
            return { ...state, error: action.payload, loading: false };
        case FETCHING_USERS:
            return { ...state, loading: true };
        default:
            return state;
    }
}
</pre>
<p>Each time an action is dispatched from any component that is connected to the store, the reducer receives the action and tests the type property of the action for each of these cases. If the test does not meet any of these cases, it will return the current state.</p>
<h2>Creating the effect</h2>
<p>Effects allow us to carry out a specified task, then dispatch an action once the task is done.</p>
<p>Knowing that, let’s create our effect that will handle the entire process of sending a request, receiving a request, and also receiving the error response when the request fails:</p>
<pre>//src/app/user/user.effect.ts
import { Actions, Effect, ofType } from "@ngrx/effects";
import { HttpClient } from "@angular/common/http";
import { FETCHING_USERS } from "./product.constants";
import { Injectable } from "@angular/core";
import { Observable } from "rxjs/Observable";
import { delay, map, catchError, switchMap } from "rxjs/operators";
import { usersFetchSuccessful, fetchError } from "./user.actions";
import { Action } from "@ngrx/store";
import { of } from "rxjs/observable/of";
@Injectable()
export class UserEffects {
    @Effect()
    users$: Observable&lt;Action&gt; = this.actions$.pipe(
        ofType(FETCHING_USERS),
        switchMap(action =&gt;
            this.http
                .get("https://jsonplaceholder.typicode.com/users")
                .pipe(
                    delay(3000),
                    map(usersFetchSuccessful),
                    catchError(err =&gt; of(fetchError(err)))
                )
         )
    );
    constructor(private actions$: Actions&lt;Action&gt;, private http: HttpClient) {
        console.log("user effects initialized");
    }
}
</pre>
<p>Here, the <code>@Injectable</code> decorator is used to decorate the <code>Effect</code> class.</p>
<p>The <code>ofType()</code> method allows us to listen to a specific dispatched action, and in our case, <code>FETCHING_USERS</code> while triggering the <code>switchMap()</code> method allows us to convert our current observable to an AJAX service. The <code>delay()</code> method allows us to show the loading indicator for some time. The <code>map()</code> method allows us to dispatch an action if the AJAX response is successful.</p>
<h2>Registering the effect</h2>
<p>There are two ways of registering effects. We can do so in the root module or in the feature module. The former approach makes the effect accessible globally across the entire application while the latter restricts its accessibility to a specific module. For the sake of code reusability, the latter is preferred.</p>
<pre>//src/app/user/user.module.ts
import { NgModule } from "@angular/core";
import { UserComponent } from "./user.component";
import { BrowserModule } from "@angular/platform-browser";
import { UserEffects } from "./user.effect";
import { EffectsModule } from "@ngrx/effects";
import { StoreModule, Action } from "@ngrx/store";
import { UserReducers } from "./user.reducers";
import { HttpClientModule } from "@angular/common/http";

@NgModule({
    imports: [
        BrowserModule,
        StoreModule.forFeature("featureUsers", UserReducers),
        EffectsModule.forFeature([UserEffects]),
        HttpClientModule
    ],
    exports: [UserComponent],
    declarations: [UserComponent],
    providers: []
})
export class UserModule {}
</pre>
<p>For a feature module, we would use the <code>forFeature()</code> method on the <code>EffectsModule</code>.</p>
<p>Now that we are done with creating and registering the effect, let’s access the effect from our component.</p>
<h2>Creating selectors</h2>
<p>If you have used Vuex before, you’ll be familiar with getters, which are similar to <a href="https://blog.logrocket.com/angular-state-management-made-simple-with-ngrx/">NgRx</a> <a href="https://blog.logrocket.com/angular-state-management-made-simple-with-ngrx/">s</a><a href="https://blog.logrocket.com/angular-state-management-made-simple-with-ngrx/">electors</a>. Selectors are used to derive computed information from the store state. We can call getters multiple times in our actions and in our components.</p>
<p>Knowing this, let’s create our selectors:</p>
<pre>//src/app/user/user.selector.ts
import { AppState } from "../app-state";
export const getList = (state: AppState) =&gt; state.featureUsers.users.list;
export const getError = (state: AppState) =&gt;
    state.featureUsers.users.error;
export const isLoading = (state: AppState) =&gt;
    state.featureUsers.users.loading;
</pre>
<p>We’ll need a component to display a loading indicator while we’re waiting for the AJAX request to finish. The component will display our data if the request is successful or display an error message if it isn’t.</p>
<h2>Creating components</h2>
<p>Let’s create a component to display our data, as well as a loading indicator, while our AJAX request is pending:</p>
<pre>//src/app/user/user.component.ts
import { Component, OnInit } from "@angular/core";
import { AppState } from "../app-state";
import { Store } from "@ngrx/store";
import { fetchingUsers } from "./user.actions";
import { getList, isLoading, getError } from "./user.selector";
@Component({
    selector: "users",
    template: `
        Users:
        &lt;div *ngFor="let user of users$ | async"&gt;
            {{ user.email }}
        &lt;/div&gt;
        &lt;div *ngIf="loading$ | async; let loading"&gt;
            &lt;div *ngIf="loading"&gt;
            fetching users...
            &lt;/div&gt;
        &lt;/div&gt;
        &lt;div *ngIf="error$ | async; let error" &gt;
            &lt;div *ngIf="error"&gt;{{ error }}&lt;/div&gt;
        &lt;/div&gt;
`
})
export class UserComponent implements OnInit {
    users$;
    loading$;
    error$;
    constructor(private store: Store&lt;AppState&gt;) {
        this.users$ = this.store.select(getList);
        this.loading$ = this.store.select(isLoading);
        this.error$ = this.store.select(getError);
    }
    ngOnInit() {
        this.store.dispatch(fetchingUsers());
    }
}
</pre>
<p>Here the store is injected through the constructor, so we can access the properties of the state object from the store through the store’s <code>select()</code> method. The store’s <code>select</code> method returns an observable that is rendered in the template using the async pipe.</p>
<p>With this, let’s update <code>AppState</code>:</p>
<pre>//src/app/app-state.ts
import { FeatureUsers } from "./user/user.reducer";
export interface AppState {
    featureUsers: FeatureUsers;
}
</pre>
<p>Because <code>AppState</code> now knows the structure of the resulting user object, our component is able to trigger the <code>store.select()</code> method.</p>
<p>Also, let’s update <code>appModule</code>:</p>
<pre>import { BrowserModule } from "@angular/platform-browser";
import { NgModule } from "@angular/core";
import { EffectsModule } from "@ngrx/effects";
import { AppComponent } from "./app.component";
import { StoreModule } from "@ngrx/store";
import { UserModule } from "./user/user.module";
@NgModule({
    declarations: [AppComponent],
    imports: [
        BrowserModule,
        EffectsModule,
        StoreModule.forRoot({}),
        EffectsModule.forRoot([]),
        UserModule
    ],
    providers: [],
    bootstrap: [AppComponent]
})
export class AppModule {}
</pre>
<p>Let’s see what we have been building so far on our browser with the following command:</p>
<pre>npm start
</pre>
<h2>Conclusion</h2>
<p>In this article, we demonstrated how to handle side effects in our NgRx applications using the <code>@ngrx/effects</code> library while building on some <a href="https://blog.logrocket.com/8-definitive-rules-building-apps-redux/">R</a><a href="https://blog.logrocket.com/8-definitive-rules-building-apps-redux/">edux concepts</a> like actions, reducers, and constants. Also, we were able to create effects for handling pending requests, errors in AJAX requests, and successful AJAX requests.</p>
<p>For more information on NgRx, you can <a href="https://ngrx.io/docs">check out NgRx’s official documentation here</a>. And here is the <a href="https://github.com/emmanuelhashy/ngrx-effect">GitHub repo</a> for this tutorial.</p>
<p>Reach out in the comment section below if you have any questions or suggestions.</p><div class='code-block code-block-6' style='margin: 8px 0; clear: both;'>
<div class="blog-plug inline-plug angular-plug"><h2>Experience your Angular apps exactly how a user does</h2> Debugging Angular applications can be difficult, especially when users experience issues that are difficult to reproduce. If you’re interested in monitoring and tracking Angular state and actions for all of your users in production, <a href="https://www2.logrocket.com/angular-performance-monitoring">try LogRocket</a>. <a class="signup" href="https://www2.logrocket.com/angular-performance-monitoring" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-46 jetpack-lazy-image" src="https://files.readme.io/610d6a7-687474703a2f2f692e696d6775722e636f6d2f696147547837412e706e67.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" data-lazy-src="https://files.readme.io/610d6a7-687474703a2f2f692e696d6775722e636f6d2f696147547837412e706e67.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignnone size-full wp-image-46" src="https://files.readme.io/610d6a7-687474703a2f2f692e696d6775722e636f6d2f696147547837412e706e67.png" alt="LogRocket Dashboard Free Trial Banner" width="1200" height="677" /></noscript></a><a href="https://www2.logrocket.com/angular-performance-monitoring" target="_blank" rel="noopener noreferrer">https://logrocket.com/signup/</a><p style="margin-top: 15px;"><a href="https://www2.logrocket.com/angular-performance-monitoring" target="_blank" rel="noopener noreferrer">LogRocket</a> is like a DVR for web apps, recording literally everything that happens on your site including network requests, JavaScript errors, and much more. Instead of guessing why problems happen, you can aggregate and report on what state your application was in when an issue occurred.</p><p>The LogRocket NgRx plugin logs Angular state and actions to the LogRocket console, giving you context around what led to an error, and what state the application was in when an issue occurred.</p><p>Modernize how you debug your Angular apps - <a class="signup" href="https://www2.logrocket.com/angular-performance-monitoring" target="_blank" rel="noopener noreferrer">Start monitoring for free</a>.</p></div>
<style>
.plug-poll {margin-bottom: 2rem;}
.code-block-6 .fadeIn {
    opacity:1 !important;
    height:auto !important;
}

.code-block-6 .fadeOut {
    opacity:0 !important;
}

.code-block-6 .wpcf7-email {margin: 15px 0;}

#plug-survey-errors, #plug-survey-help, #plug-survey-email  {opacity:0; height:1px; transition: all 1s;overflow:hidden; width: 100%;}

</style>
<script>
  jQuery("#plug-survey-framework input").click(function() {
  analytics.track('footer-poll', {
      'footer-poll-framework': jQuery(this).val()
    });
    jQuery('#plug-survey-framework').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-errors').delay(800).addClass('fadeIn');
  });
    jQuery("#plug-survey-errors input").click(function() {
    jQuery('#plug-survey-errors').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-help').delay(800).addClass('fadeIn');
  });
  
      jQuery("#plug-survey-help input").click(function() {
        analytics.track('footer-poll', {
      'footer-poll-help': jQuery(this).val()
    });
    jQuery('#plug-survey-help').delay(200).addClass('fadeout').delay(200).css('display', 'none');
    jQuery('#plug-survey-email').delay(800).addClass('fadeIn');
  });
  
  </script>
</div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-52702" class="share-twitter sd-button share-icon" href="https://blog.logrocket.com/handling-side-effects-angular-redux-application/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blog.logrocket.com/handling-side-effects-angular-redux-application/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-52702" class="share-linkedin sd-button share-icon" href="https://blog.logrocket.com/handling-side-effects-angular-redux-application/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-52702" class="share-facebook sd-button share-icon" href="https://blog.logrocket.com/handling-side-effects-angular-redux-application/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="clearfix"></div>
<div class="clearfix"></div>
</article>

<div class="row post-top-meta hidden-lg-up">
<div class="col-md-2 col-xs-4">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/01/AirBrush_20210107121828-150x150.jpg?crop=1" class="avatar avatar-72 photo jetpack-lazy-image" height="72" width="72" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/01/AirBrush_20210107121828-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/01/AirBrush_20210107121828-150x150.jpg?crop=1' class='avatar avatar-72 photo' height='72' width='72' /></noscript> </div>
<div class="col-md-10 col-xs-8">
<a class="text-capitalize link-dark" href="https://blog.logrocket.com/author/emmanueljohn/">
Emmanuel John <span class="btn follow">Follow</span></a>
<span class="author-description d-block">I'm a fullstack software developer, mentor, and writer. I am an open source enthusiast. In my spare time, I enjoy watching sci-fi movies and cheering for Arsenal FC.</span>
</div>
</div>
<div class="after-post-tags">
<ul class="post-categories">
<li><a href="https://blog.logrocket.com/category/uncategorized/" rel="category tag">Uncategorized</a></li></ul> <ul class="post-categories aretags">
<li><a href="https://blog.logrocket.com/tag/angular/">#angular</a></li> <li><a href="https://blog.logrocket.com/tag/redux/">#redux</a></li> </ul>
</div>
<div class="row mb-5 prevnextlinks justify-content-center align-items-center">
<div class="col-md-6 col-xs-12 rightborder pl-0"><div class="thepostlink">&laquo; <a href="https://blog.logrocket.com/firebase-and-fauna-comparing-database-tools-for-frontend-devs/" rel="prev">Firebase and Fauna: Comparing database tools for frontend devs</a></div></div>
<div class="col-md-6 col-xs-12 text-right pr-0"><div class="thepostlink"><a href="https://blog.logrocket.com/crafting-product-tours-in-vue-js/" rel="next">Crafting product tours in Vue.js</a> &raquo;</div></div>
</div>
</div>
</div>
</div>
<div class="hideshare"></div>
<div class="graybg">
<div class="container">
<div class="row justify-content-center listrecent listrelated">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/laravel-dusk-browser-testing-and-automation/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/06/Laravel-Dusk-browser-testing-automation.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/laravel-dusk-browser-testing-and-automation/">Laravel Dusk browser testing and automation</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/samson-omojola/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/04/samson-512x512-1-150x150.jpg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/04/samson-512x512-1-150x150.jpg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/04/samson-512x512-1-150x150.jpg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/samson-omojola/">Samson Omojola</a></span><br>
<span class="post-date">Jun 7, 2021</span>
<span class="dot"></span>
<span class="readingtime">6 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/laravel-dusk-browser-testing-and-automation/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/a-deep-dive-into-css-modules/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/06/Css-module-deep-dive.png);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/a-deep-dive-into-css-modules/">A deep dive into CSS Module</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/lawrenceoputa/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2020/08/lawrenceo-150x150.jpg" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2020/08/lawrenceo-150x150.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2020/08/lawrenceo-150x150.jpg' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/lawrenceoputa/">Lawrence Eagles</a></span><br>
<span class="post-date">Jun 7, 2021</span>
<span class="dot"></span>
<span class="readingtime">5 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/a-deep-dive-into-css-modules/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="card post height262">
<a class="thumbimage" href="https://blog.logrocket.com/crafting-product-tours-in-vue-js/" style="background-image:url(https://blog.logrocket.com/wp-content/uploads/2021/06/crafting-product-tours-vuejs.jpg);"></a><div class="card-block">
<h2 class="card-title">
<a href="https://blog.logrocket.com/crafting-product-tours-in-vue-js/">Crafting product tours in Vue.js</a>
</h2>
<div class="metafooter">
<div class="wrapfooter">
<span class="meta-footer-thumb">
<a href="https://blog.logrocket.com/author/iniubongobonguko/">
<img alt src="https://blog.logrocket.com/wp-content/uploads/2021/04/iniubong-obonguko-150x150.jpeg?crop=1" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-src="https://blog.logrocket.com/wp-content/uploads/2021/04/iniubong-obonguko-150x150.jpeg?crop=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://blog.logrocket.com/wp-content/uploads/2021/04/iniubong-obonguko-150x150.jpeg?crop=1' class='avatar avatar-40 photo' height='40' width='40' /></noscript> </a>
</span>
<span class="author-meta">
<span class="post-name">
<a href="https://blog.logrocket.com/author/iniubongobonguko/">Iniubong Obonguko</a></span><br>
<span class="post-date">Jun 7, 2021</span>
<span class="dot"></span>
<span class="readingtime">6 min read</span>
</span>
<span class="post-read-more">
<a href="https://blog.logrocket.com/crafting-product-tours-in-vue-js/" title="">
<svg class="svgIcon-use" width="25" height="25" viewBox="0 0 25 25">
<path d="M19 6c0-1.1-.9-2-2-2H8c-1.1 0-2 .9-2 2v14.66h.012c.01.103.045.204.12.285a.5.5 0 0 0 .706.03L12.5 16.85l5.662 4.126a.508.508 0 0 0 .708-.03.5.5 0 0 0 .118-.285H19V6zm-6.838 9.97L7 19.636V6c0-.55.45-1 1-1h9c.55 0 1 .45 1 1v13.637l-5.162-3.668a.49.49 0 0 0-.676 0z" fill-rule="evenodd"></path>
</svg>
</a>
</span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="row justify-content-center">
<div class="col-md-8">
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/handling-side-effects-angular-redux-application/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&#038;postid=52702&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.8&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=12c6f5ade0a86af9979f67856e51be3ff11ca12e#parent=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
</div> </div>
</div>
<div class="alertbar">
<div class="container text-center">
</div>
</div>
</div>
<div class="container">
<footer class="footer">
<div class="pull-left"> Does something seem off? Email <a><span class="__cf_email__" data-cfemail="6615131616091412260a09011409050d03124805090b">[email&#160;protected]</span></a> </div>
<div class="pull-right"> <div class="footerRight"> <div id="jetpack-search-filters-2-wrapper">
<div class="jetpack-search-form"><form role="search" method="get" class="search-form" action="https://blog.logrocket.com/">
<input type="hidden" name="post_type" value="post">
<input type="search" class="search-field" placeholder="Search..." value="" name="s" title="Search for:" />
<button type="submit" class="search-submit">
<i class="fa fa-search"></i>
</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /><input type="hidden" name="post_type" value="post" /></form></div></div></div> </div>
<div class="clearfix"></div>
 <a href="" class="back-to-top hidden-md-down">
<i class="fa fa-angle-up"></i>
</a>
</footer>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202123'></script>
<script>window.onload = function() {
  if (typeof hljs !== 'undefined')
  {
  document.querySelectorAll('pre').forEach((block) => {
    hljs.highlightBlock(block);
  });
  }
if (jQuery(".type-post").length) {
  var localDate = new Date(document.getElementsByTagName('time')[0].innerText);
  var pubDate = new Date(Date.UTC(localDate.getFullYear(), localDate.getMonth(), localDate.getDate()));
  analytics.track('post-info', {
    url: window.location.href.split('?')[0],
    wordCount: jQuery('.wordcount').text(),
    publishDate: pubDate,
    blogtag: jQuery('.aretags li a').text(),
	postAuthor: jQuery("meta[name='twitter:data1']").attr("content"),
	id: jQuery(".mainheading").closest(".col-md-8").attr("id").replace('post-','')
  });
}
};</script> <div style="display:none">
<div class="grofile-hash-map-633d353d709f2e4be765695fa17853dd">
</div>
<div class="grofile-hash-map-17470bbacdac47fbcf08098db8e7fc96">
</div>
<div class="grofile-hash-map-37e15aae62c51e948e2d56b2820c49a7">
</div>
<div class="grofile-hash-map-1e0e0e1d21650a27b525078452f8109b">
</div>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blog.logrocket.com\/handling-side-effects-angular-redux-application\/":52702};
	</script>
<link rel='stylesheet' id='dashicons-css' href='https://blog.logrocket.com/wp-includes/css/dashicons.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='nf-display-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/display-opinions-light.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='nf-font-awesome-css' href='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/css/font-awesome.min.css?ver=5.7.2' type='text/css' media='all' />
<script type='text/javascript' id='code-prettify-js-extra'>
/* <![CDATA[ */
var codePrettifyLoaderBaseUrl = "https:\/\/blog.logrocket.com\/wp-content\/plugins\/code-prettify\/prettify";
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/code-prettify/prettify/run_prettify.js?ver=1.4.0' id='code-prettify-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/tether/1.4.0/js/tether.min.js' id='tether-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/bootstrap.min.js' id='bootstrap4-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/ie10-viewport-bug-workaround.js' id='mediumish-ieviewportbugworkaround-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/masonry.pkgd.min.js' id='mediumish-masonrypkgd-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/themes/mediumish/assets/js/mediumish.js' id='mediumish-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/modules/widgets/search/js/search-widget.js?ver=9.8' id='jetpack-search-widget-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script async="async" type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-includes/js/backbone.min.js?ver=1.4.0' id='backbone-js'></script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end-deps.js?ver=3.5.4' id='nf-front-end-deps-js'></script>
<script type='text/javascript' id='nf-front-end-js-extra'>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</script>
<script type='text/javascript' src='https://blog.logrocket.com/wp-content/plugins/ninja-forms/assets/js/min/front-end.js?ver=3.5.4' id='nf-front-end-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' async='async' src='https://blog.logrocket.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.8' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=52702&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.8&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=12c6f5ade0a86af9979f67856e51be3ff11ca12e#parent=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=161333275&postid=52702&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.8&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=12c6f5ade0a86af9979f67856e51be3ff11ca12e#parent=https%3A%2F%2Fblog.logrocket.com%2Fhandling-side-effects-angular-redux-application%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script src='https://stats.wp.com/e-202123.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.8',blog:'161333275',post:'52702',tz:'-4',srv:'blog.logrocket.com'} ]);
	_stq.push([ 'clickTrackerInit', '161333275', '52702' ]);
</script>
<script id="tmpl-nf-layout" type="text/template">
	<span id="nf-form-title-{{{ data.id }}}" class="nf-form-title">
		{{{ ( 1 == data.settings.show_title ) ? '<h3>' + data.settings.title + '</h3>' : '' }}}
	</span>
	<div class="nf-form-wrap ninja-forms-form-wrap">
		<div class="nf-response-msg"></div>
		<div class="nf-debug-msg"></div>
		<div class="nf-before-form"></div>
		<div class="nf-form-layout"></div>
		<div class="nf-after-form"></div>
	</div>
</script>
<script id="tmpl-nf-empty" type="text/template">

</script>
<script id="tmpl-nf-before-form" type="text/template">
	{{{ data.beforeForm }}}
</script><script id="tmpl-nf-after-form" type="text/template">
	{{{ data.afterForm }}}
</script><script id="tmpl-nf-before-fields" type="text/template">
    <div class="nf-form-fields-required">{{{ data.renderFieldsMarkedRequired() }}}</div>
    {{{ data.beforeFields }}}
</script><script id="tmpl-nf-after-fields" type="text/template">
    {{{ data.afterFields }}}
    <div id="nf-form-errors-{{{ data.id }}}" class="nf-form-errors" role="alert"></div>
    <div class="nf-form-hp"></div>
</script>
<script id="tmpl-nf-before-field" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-after-field" type="text/template">
    {{{ data.afterField }}}
</script><script id="tmpl-nf-form-layout" type="text/template">
	<form>
		<div>
			<div class="nf-before-form-content"></div>
			<div class="nf-form-content {{{ data.element_class }}}"></div>
			<div class="nf-after-form-content"></div>
		</div>
	</form>
</script><script id="tmpl-nf-form-hp" type="text/template">
	<label for="nf-field-hp-{{{ data.id }}}" aria-hidden="true">
		{{{ nfi18n.formHoneypot }}}
		<input id="nf-field-hp-{{{ data.id }}}" name="nf-field-hp" class="nf-element nf-field-hp" type="text" value=""/>
	</label>
</script>
<script id="tmpl-nf-field-layout" type="text/template">
    <div id="nf-field-{{{ data.id }}}-container" class="nf-field-container {{{ data.type }}}-container {{{ data.renderContainerClass() }}}">
        <div class="nf-before-field"></div>
        <div class="nf-field"></div>
        <div class="nf-after-field"></div>
    </div>
</script>
<script id="tmpl-nf-field-before" type="text/template">
    {{{ data.beforeField }}}
</script><script id="tmpl-nf-field-after" type="text/template">
    <#
    /*
     * Render our input limit section if that setting exists.
     */
    #>
    <div class="nf-input-limit"></div>
    <#
    /*
     * Render our error section if we have an error.
     */
    #>
    <div id="nf-error-{{{ data.id }}}" class="nf-error-wrap nf-error" role="alert"></div>
    <#
    /*
     * Render any custom HTML after our field.
     */
    #>
    {{{ data.afterField }}}
</script>
<script id="tmpl-nf-field-wrap" type="text/template">
	<div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
		<#
		/*
		 * This is our main field template. It's called for every field type.
		 * Note that must have ONE top-level, wrapping element. i.e. a div/span/etc that wraps all of the template.
		 */
        #>
		<#
		/*
		 * Render our label.
		 */
        #>
		{{{ data.renderLabel() }}}
		<#
		/*
		 * Render our field element. Uses the template for the field being rendered.
		 */
        #>
		<div class="nf-field-element">{{{ data.renderElement() }}}</div>
		<#
		/*
		 * Render our Description Text.
		 */
        #>
		{{{ data.renderDescText() }}}
	</div>
</script>
<script id="tmpl-nf-field-wrap-no-label" type="text/template">
    <div id="nf-field-{{{ data.id }}}-wrap" class="{{{ data.renderWrapClass() }}}" data-field-id="{{{ data.id }}}">
        <div class="nf-field-label"></div>
        <div class="nf-field-element">{{{ data.renderElement() }}}</div>
        <div class="nf-error-wrap"></div>
    </div>
</script>
<script id="tmpl-nf-field-wrap-no-container" type="text/template">

        {{{ data.renderElement() }}}

        <div class="nf-error-wrap"></div>
</script>
<script id="tmpl-nf-field-label" type="text/template">
	<div class="nf-field-label"><label for="nf-field-{{{ data.id }}}"
	                                   id="nf-label-field-{{{ data.id }}}"
	                                   class="{{{ data.renderLabelClasses() }}}">{{{ data.label }}} {{{ ( 'undefined' != typeof data.required && 1 == data.required ) ? '<span class="ninja-forms-req-symbol">*</span>' : '' }}} {{{ data.maybeRenderHelp() }}}</label></div>
</script>
<script id="tmpl-nf-field-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-form-error" type="text/template">
	<div class="nf-error-msg nf-error-{{{ data.id }}}">{{{ data.msg }}}</div>
</script><script id="tmpl-nf-field-input-limit" type="text/template">
    {{{ data.currentCount() }}} {{{ nfi18n.of }}} {{{ data.input_limit }}} {{{ data.input_limit_msg }}}
</script><script id="tmpl-nf-field-null" type="text/template">
</script><script id="tmpl-nf-field-listcheckbox" type="text/template">
    <ul aria-describedby="nf-error-{{{ data.id }}}">
        {{{ data.renderOptions() }}}
    </ul>
</script>
<script id='tmpl-nf-field-listcheckbox-option' type='text/template'>
    <# if ( ! data.visible ) { return '' } #>
    <li>
        <input type="checkbox" id="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}" name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element {{{ ( data.isSelected ) ? ' nf-checked' : '' }}}" value="{{{ data.value }}}" {{{ ( data.isSelected ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
            <# if( data.required ) { #>
			required
			<# } #>
        >
        <label for="nf-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               id="nf-label-field-{{{ data.fieldID }}}-{{{ data.index }}}"
               class="{{{ ( data.isSelected ) ? 'nf-checked-label' : '' }}}">{{{ data.label }}}</label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other' type='text/template'>
    <li {{{ ( ! data.visible ) ? 'style="display:none"' : '' }}}>
        <input type="checkbox"
               id="nf-field-{{{ data.fieldID }}}-other"
               name="nf-field-{{{ data.fieldID }}}" class="{{{ data.classes }}} nf-element" value="nf-other" {{{ ( ! data.valueFound ) ? 'checked="checked"' : '' }}}
            aria-labelledby="nf-label-field-{{{ data.fieldID }}}-other"
            <# if( data.required ) { #>
			required
			<# } #>
        >
         <label id="nf-label-field-{{{ data.fieldID }}}-other">Other
            {{{ data.renderOtherText() }}}
        </label>
    </li>
</script>
<script id='tmpl-nf-field-listcheckbox-other-text' type='text/template'>
    <input type="text" name="nf-field-{{{ data.fieldID }}}" class="nf-element" value="{{{ data.currentValue }}}">
</script>
<script id='tmpl-nf-field-input' type='text/template'>
    <input id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" aria-invalid="false" aria-describedby="nf-error-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element" type="text" value="{{{ data.value }}}" {{{ data.renderPlaceholder() }}} {{{ data.maybeDisabled() }}}
           aria-labelledby="nf-label-field-{{{ data.id }}}"

            {{{ data.maybeRequired() }}}
    >
</script>
<script id="tmpl-nf-field-email" type="text/template">
	<input
			type="email"
			value="{{{ data.value }}}"
			class="{{{ data.renderClasses() }}} nf-element"

			id="nf-field-{{{ data.id }}}"
			<# if( ! data.disable_browser_autocompletes ){ #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id + '-' + data.type }}"
			autocomplete="email"
			<# } else { #>
			name="{{ data.custom_name_attribute || 'nf-field-' + data.id }}"
			{{{ data.maybeDisableAutocomplete() }}}
			<# } #>
			{{{ data.renderPlaceholder() }}}
			{{{ data.maybeDisabled() }}}

			aria-invalid="false"
			aria-describedby="nf-error-{{{ data.id }}}"
			aria-labelledby="nf-label-field-{{{ data.id }}}"

			{{{ data.maybeRequired() }}}
	>
</script>
<script id="tmpl-nf-field-submit" type="text/template">
	<input id="nf-field-{{{ data.id }}}" class="{{{ data.renderClasses() }}} nf-element " type="button" value="{{{ data.label }}}" {{{ ( data.disabled ) ? 'disabled' : '' }}}>
</script><script id='tmpl-nf-field-button' type='text/template'>
    <button id="nf-field-{{{ data.id }}}" name="nf-field-{{{ data.id }}}" class="{{{ data.classes }}} nf-element">
        {{{ data.label }}}
    </button>
</script><script>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</script>
</body>
</html>
